Subject: [Speechsc] draft-ietf-speechsc-mrcpv2-00: multiple media sessions

From: "Reifenrath, Klaus" <[email-masked]>
Date: Wed, 8 Oct 2003 08:54:01 -0400

According to Chapter 3.8 of draft-ieft-speechsc-reqts-04 MRCPv2 MUST allow a
1:N mapping between session and RTP channels. But the spec
(draft-ietf-speechsc-mrcpv2-00 chapter 2 last paragraph and chapter 3.3)
says that the media pipes MUST be shared by all media processing resources
under that SIP session. Why this restriction?

How would a sample for the 1:N use case look like? Especially how does the
client know which RTP stream is used for ASR and which for SV/SI (if it does
not have this info it has to send all audio data of every utterance to ASR
and SV/SI, even if only ASR or SV/SI is activated at the same time)? The
"i=" field (of the SDP session description) could be used to label the
different media streams. 

Is the following sequence of messages MRCPv2 compliant?
C->S: 
           INVITE sip:[email-masked] SIP/2.0 
           Max-Forwards: 70 
           To: MediaServer <sip:[email-masked]> 
           From: sarvi <sip:[email-masked]>;tag=1928301774 
           Call-ID: a84b4c76e66710 
           CSeq: 314163 INVITE 
           Contact: <sip: [email-masked]> 
           Content-Type: application/sdp 
           Content-Length: 142 
  
           v=0 
           o=sarvi 2890844526 2890842809 IN IP4 126.16.64.4 
           s=SDP Seminar 
           i=A session for processing media 
           c=IN IP4 224.2.17.12/127 
           m=control 0 mrcp 01 
           m=control 0 mrcp 02 
           m=control 0 mrcp 04
           m=audio 49170 RTP/AVP 0 96 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=fmtp:96 0-15 
           a=sendrecv 
     
 S->C: 
           SIP/2.0 200 OK 
           To: MediaServer <sip:[email-masked]> 
           From: sarvi <sip:[email-masked]>;tag=1928301774 
           Call-ID: a84b4c76e66710 
           CSeq: 314163 INVITE 
           Contact: <sip: [email-masked]> 
           Content-Type: application/sdp 
           Content-Length: 131 
            
           v=0 
           o=sarvi 2890844526 2890842809 IN IP4 126.16.64.4 
           s=SDP Seminar 
           i=A session for processing media 
           c=IN IP4 224.2.17.12/127 
           m=control 32416 mrcp 32AECB23433801 
           m=control 32416 mrcp 32AECB23433802 
           m=control 32416 mrcp 32AECB23433804 
           m=audio 48260 RTP/AVP 0 96
           i=ASR
           c=IN IP4 224.2.17.13/127 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=fmtp:96 0-15 
           a=recvonly 
           m=audio 48260 RTP/AVP 0 96
           i=TTS
           c=IN IP4 224.2.17.14/127 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=sendonly 
           m=audio 48260 RTP/AVP 0 96
           i=SV
           c=IN IP4 224.2.17.15/127 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=fmtp:96 0-15 
           a=recvonly 
     
    C->S: 
           ACK sip:[email-masked] SIP/2.0 
           Max-Forwards: 70 
           To: MediaServer <sip:[email-masked]>;tag=a6c85cf 
           From: Sarvi <sip:[email-masked]>;tag=1928301774 
           Call-ID: a84b4c76e66710 
           CSeq: 314164 ACK 
           Content-Length: 0 

And what about the following message sequence?

C->S: 
           INVITE sip:[email-masked] SIP/2.0 
           Max-Forwards: 70 
           To: MediaServer <sip:[email-masked]> 
           From: sarvi <sip:[email-masked]>;tag=1928301774 
           Call-ID: a84b4c76e66710 
           CSeq: 314163 INVITE 
           Contact: <sip: [email-masked]> 
           Content-Type: application/sdp 
           Content-Length: 142 
  
           v=0 
           o=sarvi 2890844526 2890842809 IN IP4 126.16.64.4 
           s=SDP Seminar 
           i=A session for processing media 
           c=IN IP4 224.2.17.12/127 
           m=control 0 mrcp 01 
           m=control 0 mrcp 02 
           m=control 0 mrcp 04
           m=audio 49170 RTP/AVP 0 96 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=fmtp:96 0-15 
           a=sendrecv 
     
 S->C: 
           SIP/2.0 200 OK 
           To: MediaServer <sip:[email-masked]> 
           From: sarvi <sip:[email-masked]>;tag=1928301774 
           Call-ID: a84b4c76e66710 
           CSeq: 314163 INVITE 
           Contact: <sip: [email-masked]> 
           Content-Type: application/sdp 
           Content-Length: 131 
            
           v=0 
           o=sarvi 2890844526 2890842809 IN IP4 126.16.64.4 
           s=SDP Seminar 
           i=A session for processing media 
           m=control 32416 mrcp 32AECB23433801 
           c=IN IP4 224.2.17.13/127 
           m=control 32416 mrcp 32AECB23433802 
           c=IN IP4 224.2.17.14/127 
           m=control 32416 mrcp 32AECB23433804 
           c=IN IP4 224.2.17.15/127 
           m=audio 48260 RTP/AVP 0 96
           i=ASR
           c=IN IP4 224.2.17.13/127 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=fmtp:96 0-15 
           a=recvonly 
           m=audio 48260 RTP/AVP 0 96
           i=TTS 
           c=IN IP4 224.2.17.14/127 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=sendonly 
           m=audio 48260 RTP/AVP 0 96
           i=SV 
           c=IN IP4 224.2.17.15/127 
           a=rtpmap:0 pcmu/8000 
           a=rtpmap:96 telephone-event/8000 
           a=fmtp:96 0-15 
           a=recvonly 
     
    C->S: 
           ACK sip:[email-masked] SIP/2.0 
           Max-Forwards: 70 
           To: MediaServer <sip:[email-masked]>;tag=a6c85cf 
           From: Sarvi <sip:[email-masked]>;tag=1928301774 
           Call-ID: a84b4c76e66710 
           CSeq: 314164 ACK 
           Content-Length: 0 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 08 Oct 2003 09:15:22 -0400

Hmmm, I think KLaus has a good point here. There may be very good reasons 
to send separate RTP streams to different media resources for the same 
logical session. Given that we do not want to create extra SIP dialogs and 
have multiple MRCP sessions as a side effect of that I think that some 
explicit matching of RTP streams and MRCP control sessions is needed.

I think fid probably fills the bill here. I'd prefer to not introduce 
convention hacks like "i=" to do the matching.

Dave.

--On Wednesday, October 08, 2003 8:54 AM -0400 "Reifenrath, Klaus" 
<[email-masked]> wrote:

> According to Chapter 3.8 of draft-ieft-speechsc-reqts-04 MRCPv2 MUST
> allow a 1:N mapping between session and RTP channels. But the spec
> client know which RTP stream is used for ASR and which for SV/SI (if it
> does not have this info it has to send all audio data of every utterance
> to ASR and SV/SI, even if only ASR or SV/SI is activated at the same
> time)? The "i=" field (of the SDP session description) could be used to
> label the different media streams.
>

------------------------
David R. Oran
Cisco Systems
7 Ladyslipper Lane
Acton, MA 01720
Office: +1 978 264 2048
VoIP: +1 408 571 4576
Email: [email-masked]