Subject: Re: [Speechsc] mrcpv2-01: Media Streams (S. 3.3)

From: Sarvi Shanmugham <[email-masked]>
Date: Mon, 02 Feb 2004 22:59:00 -0800

Eric Burger wrote:

>Section 3.3 talks about the behavior and suggested directionality for media streams when one hooks up players and recognizers.
>
>What happens when someone gets it wrong?  For example, what if I set up a player with sendonly (remembering that we're talking about directionality from the client)?  Do I accept the client's SDP, figuring they know what they're doing, and will not be surprised when they never receive audio?  Or do I reject the offer with some sort of SIP 'bad SIP' response?
>
I think a bad SIP response would be order.

What happens if the codec proposed in SIP offer is not satisfiable or 
the media type not supported for some reason by an endpoint. I believe 
this should be treated similarly.

Sarvi

>
>Opinions?
>
>
>_______________________________________________
>Speechsc mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/speechsc
>
>  
>

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Eric Burger" <[email-masked]>
Date: Wed, 4 Feb 2004 20:46:51 -0500

Agreed.

> -----Original Message-----
> From: Sarvi Shanmugham [mailto:[email-masked]]
> Sent: Tuesday, February 03, 2004 1:59 AM
> To: Eric Burger
> Cc: IETF SPEECHSC (E-mail)
> Subject: Re: [Speechsc] mrcpv2-01: Media Streams (S. 3.3)
> 
> 
> 
> 
> Eric Burger wrote:
> 
> >Section 3.3 talks about the behavior and suggested 
> directionality for media streams when one hooks up players 
> and recognizers.
> >
> >What happens when someone gets it wrong?  For example, what 
> if I set up a player with sendonly (remembering that we're 
> talking about directionality from the client)?  Do I accept 
> the client's SDP, figuring they know what they're doing, and 
> will not be surprised when they never receive audio?  Or do I 
> reject the offer with some sort of SIP 'bad SIP' response?
> >