Subject: RE: [Speechsc] PRELIMINARY IETF agenda

From: "Eric Burger" <[email-masked]>
Date: Mon, 9 Feb 2004 16:30:28 -0500

Korea time, of course :-)
 
1700 Korea time on 3/2 is 3am 3/2 ET, midnight 3/1-2 PT (sorry!), 8am 3/2 London, 9am 3/2 Paris.

-----Original Message-----
From: Jeff Kusnitz [mailto:[email-masked]]
Sent: Friday, February 06, 2004 8:08 PM
To: Eric Burger
Cc: IETF SPEECHSC (E-mail)
Subject: Re: [Speechsc] PRELIMINARY IETF agenda

What time zone (for those of us who will be on the other side of the world, should we want to join somehow :-) 

Thanks, 
Jeff 

"Eric Burger" <[email-masked]> 
Sent by: [email-masked] 

02/06/2004 12:06 PM 

To
"IETF SPEECHSC (E-mail)" <[email-masked]> 

cc

Subject
[Speechsc] PRELIMINARY IETF agenda

This schedule is preliminary and is always likely to change without notice.  At this time, we do have a multicast session.

TUESDAY, March 2, 2004

1700-1800 Afternoon Sessions IV
APP   iea      Internationalizing Email Address BOF
GEN   newtrk   New IETF Standards Track BOF
INT   ipv6     IP Version 6 WG *
OPS   hubmib   Ethernet Interfaces and Hub MIB WG
TSV   rmt      Reliable Multicast Transport WG 
TSV   speechsc Speech Services Control WG *

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Jeff Kusnitz <[email-masked]>
Date: Wed, 11 Feb 2004 14:48:45 -0800

If a client attempts to define a grammar, and for some reason the 
compilation fails, say the grammar is French but the recognizer is 
English, how is this information conveyed to the client?  Should it come 
back through the using the completion-cause header like this:

      C->S:MRCP/2.0 334 DEFINE-GRAMMAR 543258 
           Channel-Identifier: 32AECB23433801@speechrecog 
           Content-Type: application/grammar+xml 
           Content-Id: [email-masked] 
           Content-Length: 104 
 
           <?xml version="1.0"?> 
 
           <grammar xml:lang="fr-FR" version="1.0"> 
 
           <rule id="request"> 
               Je suis perdu
           </rule> 
 
      S->C:MRCP/2.0 73 543258 407 COMPLETE 
           Channel-Identifier: 32AECB23433801@speechrecog 
           Completion-Cause: 005 xxxxxxx

What should be used for "xxxxxx" above?  Ideally, it would be something 
that indicated the cause of the failure, but the BNF for completion-cause 
doesn't seem to allow for much creativity - it excludes spaces.  A 
vendor-specific-parameter might be useful as well, but that's not allowed 
on a define-grammar request/response.

Thanks,
Jeff

---

From: Jeff Kusnitz <[email-masked]>
Date: Thu, 12 Feb 2004 08:38:30 -0800

Yesterday, I wrote:

> What should be used for "xxxxxx" above?  Ideally, it would be 
> something that indicated the cause of the failure, but the BNF for 
> completion-cause doesn't seem to allow for much creativity - it 
> excludes spaces.  A vendor-specific-parameter might be useful as 
> well, but that's not allowed on a define-grammar request/response. 

To make things just that much more entertaining, the BNF for the 
completion cause includes 1*ALPHA, which RFC2234 says is A-Z and a-z, but 
does not include hyphens, which the Cause-Name values do include.

Thanks,
Jeff