Subject: RE: [Speechsc] define-grammar and text/uri-list

From: "Eric Burger" <[email-masked]>
Date: Mon, 9 Feb 2004 16:27:43 -0500

I would vote for one-at-a-time, as it makes error handling infinitely easer.  In addition, I would expect grammar compilation to be an up-front thing (is this a true assertion?).  Thus the added round-trip burden is not so bad as one probably is not in the middle of a real-time call.

> -----Original Message-----
> From: Jeff Kusnitz [mailto:[email-masked]]
> Sent: Thursday, February 05, 2004 3:02 PM
> To: IETF SPEECHSC (E-mail)
> Subject: [Speechsc] define-grammar and text/uri-list
> 
> 
> In reading the section 8.5 on "Recognizer Grammar Data", it 
> would seem 
> that the define-grammar method allows one to define multiple 
> grammars on a 
> single request - either via a text/uri-list, or multipart/mixed, with 
> embedded grammars and lists.  But the description of the 
> define-grammar 
> method itself implies that only a single grammar is used at a 
> time (e.g. "
> The DEFINE-GRAMMAR method, from the client to the server, 
> provides **a** 
> grammar and tells the server to define, download if needed 
> and compile the 
> grammar.").
> 
> It seems a bit odd to define more than one grammar at a time 
> - how does 
> one handle failures, for example (should multiple failing URIs be 
> returned, if one fails are any others that compiled undefined, etc).
> 
> Perhaps the define-grammar method can be clarified to 
> indicate that it 
> only allows a single grammar, either inline, or via a text/uri-list?
> 
> Thanks,
> Jeff
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc
> 
> 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 10 Feb 2004 08:06:50 -0500

Most - if not all - DEFINE-GRAMMAR will be during a real-time call. This is
obviously true for RECOGNIZE where we face the same problem. Therefore
performance is an issue. But I agree that we need to improve error handling.

The defined error codes are very high-level. An optional field error-text
would enable the client to display a more precise error message. Example:
completion-cause : 005 grm-load-failure
error-text : http://www.grammar-server.com/myGrammar.xml, line 42: syntax
error 

-----Original Message-----
From: Eric Burger [mailto:[email-masked]]
Sent: Montag, 9. Februar 2004 22:28
To: IETF SPEECHSC (E-mail)
Subject: RE: [Speechsc] define-grammar and text/uri-list

I would vote for one-at-a-time, as it makes error handling infinitely easer.
In addition, I would expect grammar compilation to be an up-front thing (is
this a true assertion?).  Thus the added round-trip burden is not so bad as
one probably is not in the middle of a real-time call.