Subject: RE: [Speechsc] Media Server or Media Resource

From: "Roy, Radhika R, ALABS" <[email-masked]>
Date: Wed, 19 May 2004 10:17:43 -0400

Eric, Klaus, and Sarvi:
 
Let me try to provide the definition of media servers:
 
"Media servers (MSs) typically operate with application servers (ASs) to handle and terminate media streams, and provide services such as announcement, media bridging, media transcoding, interactive voice response (IVR) messages (with or without VocieXML), speech-to-text (STT) conversion, text-to-speech (TTS) conversion, and others."
 
Cheers!
 
Radhika R. Roy
AT&T
732 420 1580

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Reifenrath, Klaus
Sent: Wednesday, May 19, 2004 5:07 AM
To: 'Sarvi Shanmugham'; Eric Burger
Cc: [email-masked]
Subject: RE: [Speechsc] Media Server or Media Resource

Hi Eric and Sarvi,
 
after some internal discussions I prefer to stay with the term "media server"!
 
In draft-burger-sipping-msuri-01.txt (expired IETF internet draft, that was referenced in the speechsc requirements document) the following definition of a media server can be found (section 3 on page 3):
"Media servers are devices that perform media processing on real-time packet media."
According to this definition the MRCP server is a media server (and not the platform that uses MRCP servers for media processing, which becomes a media proxy).  
In a network architecture that includes MRCP servers there might be other media servers.
 
Could someone point me to the documents of the IETF, 3GPP, ... where I can find their definition of a media server. The term "media server" is used fairly often (especially in product brochures), but it seems to be difficult to find precise definitions.
 
Thanks,
Klaus

-----Original Message-----
From: Sarvi Shanmugham [mailto:[email-masked]]
Sent: Mittwoch, 19. Mai 2004 01:49
To: Garland Sharratt
Cc: Eric Burger; [email-masked]
Subject: Re: [Speechsc] Media Server or Media Resource

This is fine by me. And I haven't heard any opposition so far. 
 I will make the necessary edits.

Sarvi
Garland Sharratt wrote: 

Eric, I concur.  Using the term "media server" for MRCPv2 muddies the

waters, I think, and implies the two things are the same whereas they are

not.

Garland

-----Original Message-----

From:  [email-masked] [ mailto:[email-masked]]On Behalf

Of Jeff Haynie

Sent: Monday, May 17, 2004 08:10

To: Eric Burger

Cc:  [email-masked]

Subject: Re: [Speechsc] Media Server or Media Resource

That's funny - I myself have struggled with the same term and would be

much more in favor of "media resource".

Jeff

Eric Burger wrote:

<ChairHat state="off">

I have a form issue, not necessarily a substance issue.

Throughout the MRCPv2 document, the "thing that is a server controlled by

the MRCPv2 protocol" is called a "Media Server".

A Media Server is a device that has a well-defined meaning, in the IETF,

3GPP (MRF), SIP Forum, IPCC, etc.

That definition, IMHO, does not really match with "the thing that is a

server controlled by the MRCPv2 protocol."  In fact, the thing that

embodies

the accepted version of a Media Server is often a *client* to the MRCPv2

protocol.

Would anyone be really put out if we did a 1,$:s/media server/media

resource/g throughout the document?

Rationale: The document describes the Media RESOURCE Control Protocol, not

the Media SERVER Control Protocol.

</ChairHat>

Thoughts?  Comments?

_______________________________________________

Speechsc mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________

Speechsc mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________

Speechsc mailing list

[email-masked]

https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Garland Sharratt" <[email-masked]>
Date: Wed, 19 May 2004 17:02:19 -0700

To Radhika's list I would also add recording and playback, as well as video
announcements, video recording and playback, and video bridging.

"Media server" is a generic term in NGN for a multi-purpose slave media
processing engine controlled by a call agent or application server.  All NGN
architectures have a media server component, often by another name; in 3GPP,
for instance, it's called an Media Resource Function Processor (MRFP).
Media server control interfaces in NGN architectures are MGCP, H.248, and
SIP.

Garland

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Roy, Radhika R, ALABS
Sent: Wednesday, May 19, 2004 07:18
To: Reifenrath, Klaus; Sarvi Shanmugham; Eric Burger
Cc: [email-masked]
Subject: RE: [Speechsc] Media Server or Media Resource

Eric, Klaus, and Sarvi:

"Media servers (MSs) typically operate with application servers (ASs) to
handle and terminate media streams, and provide services such as
announcement, media bridging, media transcoding, interactive voice response
(IVR) messages (with or without VocieXML), speech-to-text (STT) conversion,
text-to-speech (TTS) conversion, and others."

Cheers!

Radhika R. Roy
AT&T
732 420 1580
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Reifenrath, Klaus
  Sent: Wednesday, May 19, 2004 5:07 AM
  To: 'Sarvi Shanmugham'; Eric Burger
  Cc: [email-masked]
  Subject: RE: [Speechsc] Media Server or Media Resource

  Hi Eric and Sarvi,

  after some internal discussions I prefer to stay with the term "media
server"!

  In draft-burger-sipping-msuri-01.txt (expired IETF internet draft, that
was referenced in the speechsc requirements document) the following
definition of a media server can be found (section 3 on page 3):
  "Media servers are devices that perform media processing on real-time
packet media."
  According to this definition the MRCP server is a media server (and not
the platform that uses MRCP servers for media processing, which becomes a
media proxy).
  In a network architecture that includes MRCP servers there might be other
media servers.

  Could someone point me to the documents of the IETF, 3GPP, ... where I can
find their definition of a media server. The term "media server" is used
fairly often (especially in product brochures), but it seems to be difficult
to find precise definitions.

  Thanks,
  Klaus

    -----Original Message-----
    From: Sarvi Shanmugham [mailto:[email-masked]]
    Sent: Mittwoch, 19. Mai 2004 01:49
    To: Garland Sharratt
    Cc: Eric Burger; [email-masked]
    Subject: Re: [Speechsc] Media Server or Media Resource

    Sarvi
    Garland Sharratt wrote:

Garland

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Jeff Haynie
Sent: Monday, May 17, 2004 08:10
To: Eric Burger
Cc: [email-masked]
Subject: Re: [Speechsc] Media Server or Media Resource

Jeff

Eric Burger wrote:

  <ChairHat state="off">

</ChairHat>

Thoughts?  Comments?

---

From: Jeff Haynie <[email-masked]>
Date: Wed, 19 May 2004 20:56:53 -0400

Both you and Radhika seem to highlight exactly what MRCP is NOT and 
re-enforce Eric's original request, no?  Of course, I'm not implying 
that media servers can't also support the MRCP protocol as a fact of 
implementation - that's something that's completely within reason.

Jeff

Garland Sharratt wrote:

> To Radhika's list I would also add recording and playback, as well as 
> video announcements, video recording and playback, and video bridging.
>  
> "Media server" is a generic term in NGN for a multi-purpose slave 
> media processing engine controlled by a call agent or application 
> server.  All NGN architectures have a media server component, often by 
> another name; in 3GPP, for instance, it's called an Media Resource 
> Function Processor (MRFP).  Media server control interfaces in NGN 
> architectures are MGCP, H.248, and SIP.
>  
> Garland
>  
> *From:* [email-masked] [mailto:[email-masked]]*On 
> Behalf Of *Roy, Radhika R, ALABS
> *Sent:* Wednesday, May 19, 2004 07:18
> *To:* Reifenrath, Klaus; Sarvi Shanmugham; Eric Burger
> *Cc:* [email-masked]
> *Subject:* RE: [Speechsc] Media Server or Media Resource
>
> Eric, Klaus, and Sarvi:
>  
> "Media servers (MSs) typically operate with application servers (ASs) 
> to handle and terminate media streams, and provide services such as 
> announcement, media bridging, media transcoding, interactive voice 
> response (IVR) messages (with or without VocieXML), speech-to-text 
> (STT) conversion, text-to-speech (TTS) conversion, and others."
>  
> Cheers!
>  
> Radhika R. Roy
> AT&T
> 732 420 1580
>
>     *From:* [email-masked]
>     [mailto:[email-masked]]*On Behalf Of *Reifenrath, Klaus
>     *Sent:* Wednesday, May 19, 2004 5:07 AM
>     *To:* 'Sarvi Shanmugham'; Eric Burger
>     *Cc:* [email-masked]
>     *Subject:* RE: [Speechsc] Media Server or Media Resource
>
>     Hi Eric and Sarvi,
>      
>     In draft-burger-sipping-msuri-01.txt (expired IETF internet draft,
>     that was referenced in the speechsc requirements document) the
>     following definition of a media server can be found (section 3 on
>     page 3):
>     According to this definition the MRCP server is a media server
>     (and not the platform that uses MRCP servers for media processing,
>     which becomes a media proxy). 
>     Could someone point me to the documents of the IETF, 3GPP, ...
>     where I can find their definition of a media server. The term
>     "media server" is used fairly often (especially in product
>     brochures), but it seems to be difficult to find precise definitions.
>      
>     Thanks,
>     Klaus
>      
>      
>
>         *From:* Sarvi Shanmugham [mailto:[email-masked]]
>         *Sent:* Mittwoch, 19. Mai 2004 01:49
>         *To:* Garland Sharratt
>         *Cc:* Eric Burger; [email-masked]
>         *Subject:* Re: [Speechsc] Media Server or Media Resource
>