Subject: RE: [Speechsc] Media Server or Media Resource

From: "Roy, Radhika R, ALABS" <[email-masked]>
Date: Fri, 21 May 2004 08:27:42 -0400

Burk's proposal is also a viable solution, but the word "MCRCv2" itself seems to be very "odd."

What is the opinion of others?

-----Original Message-----
From: Dave Burke [mailto:[email-masked]]
Sent: Friday, May 21, 2004 5:02 AM
To: Roy, Radhika R, ALABS; Tim Melanchuk; Sarvi Shanmugham
Cc: Jeff Haynie; Garland Sharratt; [email-masked]
Subject: Re: [Speechsc] Media Server or Media Resource

I like simplicity and I think the readers of the MRCPv2 specification will
appreciate this also.

We are seeking some sort of general term for discussing entities controlled
by MRCPv2. At first glance "Media Server" appears to be an appropriate
general term but unfortunately it carries with it definition out of scope of
MRCPv2.

What I like about Eric's original suggestion is that the phrase "Media
Server" does not appear at all in the MRCPv2 specification. Building on
this, why not just:

"Media Resource":
    An entity to be controlled by MRCPv2

"MRCPv2 Server":
    Aggregate of one or more "Media Resource", exposed by MRCPv2. ("Server"
for short)

"MRCPv2 Client":
    The entity controlling one or more "Media Resource" via MRCPv2.
("Client" for short).

This avoids confusion and leaves the media server vendors to decide if they
want their product to be an MRCPv2 Client (probably the usual case), or an
MRCPv2 Server (possible but perhaps not so common), or even an MRCPv2 Client
and Server (ref my facetious remark earlier about a "Media B2BUA").

- Dave

----- Original Message -----
From: "Roy, Radhika R, ALABS" <[email-masked]>
To: "Tim Melanchuk" <[email-masked]>; "Sarvi Shanmugham"
<[email-masked]>
Cc: "Jeff Haynie" <[email-masked]>; "Garland Sharratt"
<[email-masked]>; <[email-masked]>
Sent: Friday, May 21, 2004 5:07 AM
Subject: RE: [Speechsc] Media Server or Media Resource

All:

Seeing all definitions, it appears that we can safely conclude what
Sarvi has proposed:

1. "MRCP server" or "MRCP Media server" - (a media server that contains
only MRCP media resources)

2. "MRCP resource" or  "MRCP media resource" - (self explanatory)

3. "MRCP resources on the Media Server" - (a media server that contains
MRCP resources in addition to other media resources)

4. "Media Server" - (a media server that contains MRCP plus other media
resources in the context of our works)

Items 3 and 4 are the same in the context of our works.

Radhika

-----Original Message-----
From: Tim Melanchuk [mailto:[email-masked]]
Sent: Thursday, May 20, 2004 5:49 PM
To: Sarvi Shanmugham
Cc: Roy, Radhika R, ALABS; Jeff Haynie; Garland Sharratt;
[email-masked]
Subject: Re: [Speechsc] Media Server or Media Resource

this approach sounds reasonable. "media server" is somewhat of
generic term that is used for slightly different things in different
contexts. for example, rtsp uses the term media server extensively
and defines it as:

         Media server: The server providing playback services for one or
              more media streams. Different media streams within a
              presentation may originate from different media servers. A
              media server may reside on the same or a different host as
              the web server the presentation is invoked from.

Sarvi Shanmugham wrote:

> Well from what I am hearing so far, a Media server is an entity that
may
> support multiple media resources on it.  But, the resources may not
all
> be controlled by single protocol.
>
> So it would be a misnomer to call the whole box an "MRCP server" or
> "MRCP media server".
> But  from the definitions flying around, it looks like people do agree

> that the box as a whole can be called/classified as a "Media server"
> without any protocol implications.
>
> So here is a suggestion, I propose we change all occurances of "MRCP
> server" or "MRCP Media server".
> I will instead use one of the following terms/phrases depending on the

> context.
>     To refer to individual resources I will use "MRCP resource" or
> "MRCP media resource".
>     To refer to the whole box that may have multiple media
> resources(MRCP or otherwise) I will use the phrase  "Media Server" or
> "MRCP resources on the Media Server" as appropriate.
>
> Any thoughts.
>
> Sarvi
>
> Roy, Radhika R, ALABS wrote:
>
>>Jeff:
>>
>>OK, let us go back to analyze these terms: Media Resources and Media
Server.
>>
>>That is, MRCP is used to control (many, if not all) "media resources"
of a media server.
>>
>>Radhika
>>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]]On
Behalf
>>Of Jeff Haynie
>>Sent: Wednesday, May 19, 2004 9:48 PM
>>To: Roy, Radhika R, ALABS
>>Cc: Garland Sharratt; [email-masked]
>>Subject: Re: [Speechsc] Media Server or Media Resource
>>
>>
>>OK, sorry, I'm confused.  Do you support using the term "media server"

>>or "media resource"?  I can't tell from your response.  Garland
>>suggested in the original post that he favored the term "media
resource"
>>too.
>>
>>Jeff
>>
>>Roy, Radhika R, ALABS wrote:
>>
>>
>>
>>>Jeff:
>>>
>>>Garland and I have been saying exactly what a media server is. A
media server will be using many protocols, and MRCP is only of them.
>>>
>>>In this sense, MRCP is one of the protocols that is used for its
media resources control.
>>>
>>>Who knows MRCP may NOT enough to control all the media resources of a
Media Server.
>>>
>>>Let us see the big picture of a media server.
>>>
>>>Radhika
>>>
>>>-----Original Message-----
>>>From: [email-masked] [mailto:[email-masked]]On
Behalf
>>>Of Jeff Haynie
>>>Sent: Wednesday, May 19, 2004 8:57 PM
>>>To: Garland Sharratt
>>>Cc: [email-masked]
>>>Subject: Re: [Speechsc] Media Server or Media Resource
>>>
>>>
>>>Both you and Radhika seem to highlight exactly what MRCP is NOT and
>>>re-enforce Eric's original request, no?  Of course, I'm not implying
>>>that media servers can't also support the MRCP protocol as a fact of
>>>implementation - that's something that's completely within reason.
>>>
>>>Jeff
>>>
>>>Garland Sharratt wrote:
>>>
>>>
>>>
>>>
>>>
>>>>To Radhika's list I would also add recording and playback, as well
as
>>>>video announcements, video recording and playback, and video
bridging.
>>>>
>>>>"Media server" is a generic term in NGN for a multi-purpose slave
>>>>media processing engine controlled by a call agent or application
>>>>server.  All NGN architectures have a media server component, often
by
>>>>another name; in 3GPP, for instance, it's called an Media Resource
>>>>Function Processor (MRFP).  Media server control interfaces in NGN
>>>>architectures are MGCP, H.248, and SIP.
>>>>
>>>>Garland
>>>>
>>>>-----Original Message-----
>>>>*From:* [email-masked] [mailto:[email-masked]]*On
>>>>Behalf Of *Roy, Radhika R, ALABS
>>>>*Sent:* Wednesday, May 19, 2004 07:18
>>>>*To:* Reifenrath, Klaus; Sarvi Shanmugham; Eric Burger
>>>>*Cc:* [email-masked]
>>>>*Subject:* RE: [Speechsc] Media Server or Media Resource
>>>>
>>>>Eric, Klaus, and Sarvi:
>>>>
>>>>Let me try to provide the definition of media servers:
>>>>
>>>>"Media servers (MSs) typically operate with application servers
(ASs)
>>>>to handle and terminate media streams, and provide services such as
>>>>announcement, media bridging, media transcoding, interactive voice
>>>>response (IVR) messages (with or without VocieXML), speech-to-text
>>>>(STT) conversion, text-to-speech (TTS) conversion, and others."
>>>>
>>>>Cheers!
>>>>
>>>>Radhika R. Roy
>>>>AT&T
>>>>732 420 1580
>>>>
>>>>   -----Original Message-----
>>>>   *From:* [email-masked]
>>>>   [mailto:[email-masked]]*On Behalf Of *Reifenrath, Klaus
>>>>   *Sent:* Wednesday, May 19, 2004 5:07 AM
>>>>   *To:* 'Sarvi Shanmugham'; Eric Burger
>>>>   *Cc:* [email-masked]
>>>>   *Subject:* RE: [Speechsc] Media Server or Media Resource
>>>>
>>>>   Hi Eric and Sarvi,
>>>>
>>>>   after some internal discussions I prefer to stay with the term
>>>>   "media server"!
>>>>
>>>>   In draft-burger-sipping-msuri-01.txt (expired IETF internet
draft,
>>>>   that was referenced in the speechsc requirements document) the
>>>>   following definition of a media server can be found (section 3 on
>>>>   page 3):
>>>>   "Media servers are devices that perform media processing on
>>>>   real-time packet media."
>>>>   According to this definition the MRCP server is a media server
>>>>   (and not the platform that uses MRCP servers for media
processing,
>>>>   which becomes a media proxy).
>>>>   In a network architecture that includes MRCP servers there might
>>>>   be other media servers.
>>>>
>>>>   Could someone point me to the documents of the IETF, 3GPP, ...
>>>>   where I can find their definition of a media server. The term
>>>>   "media server" is used fairly often (especially in product
>>>>   brochures), but it seems to be difficult to find precise
definitions.
>>>>
>>>>   Thanks,
>>>>   Klaus
>>>>
>>>>
>>>>
>>>>       -----Original Message-----
>>>>       *From:* Sarvi Shanmugham [mailto:[email-masked]]
>>>>       *Sent:* Mittwoch, 19. Mai 2004 01:49
>>>>       *To:* Garland Sharratt
>>>>       *Cc:* Eric Burger; [email-masked]
>>>>       *Subject:* Re: [Speechsc] Media Server or Media Resource
>>>>
>>>>       This is fine by me. And I haven't heard any opposition so
far.
>>>>        I will make the necessary edits.
>>>>
>>>>       Sarvi
>>>>       Garland Sharratt wrote:
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>>Eric, I concur.  Using the term "media server" for MRCPv2 muddies
the
>>>>>waters, I think, and implies the two things are the same whereas
they are
>>>>>not.
>>>>>
>>>>>Garland
>>>>>
>>>>>-----Original Message-----
>>>>>From: [email-masked] [mailto:[email-masked]]On
Behalf
>>>>>Of Jeff Haynie
>>>>>Sent: Monday, May 17, 2004 08:10
>>>>>To: Eric Burger
>>>>>Cc: [email-masked]
>>>>>Subject: Re: [Speechsc] Media Server or Media Resource
>>>>>
>>>>>
>>>>>That's funny - I myself have struggled with the same term and would
be
>>>>>much more in favor of "media resource".
>>>>>
>>>>>Jeff
>>>>>
>>>>>Eric Burger wrote:
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>><ChairHat state="off">
>>>>>>I have a form issue, not necessarily a substance issue.
>>>>>>
>>>>>>Throughout the MRCPv2 document, the "thing that is a server
controlled by
>>>>>>the MRCPv2 protocol" is called a "Media Server".
>>>>>>
>>>>>>A Media Server is a device that has a well-defined meaning, in the
IETF,
>>>>>>3GPP (MRF), SIP Forum, IPCC, etc.
>>>>>>
>>>>>>That definition, IMHO, does not really match with "the thing that
is a
>>>>>>server controlled by the MRCPv2 protocol."  In fact, the thing
that
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>embodies
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>>the accepted version of a Media Server is often a *client* to the
MRCPv2
>>>>>>protocol.
>>>>>>
>>>>>>Would anyone be really put out if we did a 1,$:s/media
server/media
>>>>>>resource/g throughout the document?
>>>>>>
>>>>>>Rationale: The document describes the Media RESOURCE Control
Protocol, not
>>>>>>the Media SERVER Control Protocol.
>>>>>>
>>>>>></ChairHat>
>>>>>>
>>>>>>Thoughts?  Comments?
>>>>>>
>>>>>>_______________________________________________
>>>>>>Speechsc mailing list
>>>>>>[email-masked]
>>>>>>https://www1.ietf.org/mailman/listinfo/speechsc
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>_______________________________________________
>>>>>Speechsc mailing list
>>>>>[email-masked]
>>>>>https://www1.ietf.org/mailman/listinfo/speechsc
>>>>>
>>>>>
>>>>>_______________________________________________
>>>>>Speechsc mailing list
>>>>>[email-masked]
>>>>>https://www1.ietf.org/mailman/listinfo/speechsc
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>_______________________________________________
>>>Speechsc mailing list
>>>[email-masked]
>>>https://www1.ietf.org/mailman/listinfo/speechsc
>>>
>>>
>>>
>>>
>>
>>
>>_______________________________________________
>>Speechsc mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/speechsc
>>
>>_______________________________________________
>>Speechsc mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/speechsc
>>
>>
>>
>

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Garland Sharratt" <[email-masked]>
Date: Fri, 21 May 2004 07:16:55 -0700

How about:

   "Media Resource"

   "MRCP Server"

   "MRCP Client"

with Dave's meanings.

-----Original Message-----
From: Roy, Radhika R, ALABS [mailto:[email-masked]]
Sent: Friday, May 21, 2004 05:28
To: Dave Burke; Tim Melanchuk; Sarvi Shanmugham
Cc: Jeff Haynie; Garland Sharratt; [email-masked]
Subject: RE: [Speechsc] Media Server or Media Resource

Burk's proposal is also a viable solution, but the word "MCRCv2" itself
seems to be very "odd."

-----Original Message-----
From: Dave Burke [mailto:[email-masked]]
Sent: Friday, May 21, 2004 5:02 AM
To: Roy, Radhika R, ALABS; Tim Melanchuk; Sarvi Shanmugham
Cc: Jeff Haynie; Garland Sharratt; [email-masked]
Subject: Re: [Speechsc] Media Server or Media Resource

"Media Resource":

"MRCPv2 Server":

"MRCPv2 Client":

- Dave

----- Original Message -----
From: "Roy, Radhika R, ALABS" <[email-masked]>
To: "Tim Melanchuk" <[email-masked]>; "Sarvi Shanmugham"
<[email-masked]>

All:

Radhika

-----Original Message-----
From: Tim Melanchuk [mailto:[email-masked]]
Sent: Thursday, May 20, 2004 5:49 PM
To: Sarvi Shanmugham
Cc: Roy, Radhika R, ALABS; Jeff Haynie; Garland Sharratt;
[email-masked]

may
all

Server.
of a media server.
Behalf

resource"
media resources control.
Media Server.
Behalf
as
bridging.
by
(ASs)
draft,
processing,
definitions.
far.
the
they are
Behalf
be
controlled by
IETF,
is a
that
MRCPv2
server/media
Protocol, not