Subject: RE: [Speechsc] XML schema for verification result

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 5 Oct 2004 13:27:29 -0400

Hi group,

aside from the discussion which schema we should use, I like to resolve the
open issues concerning the verification result elements:
According to the current spec the <verification-score> element is mandatory
also for training results. What is the meaning of a verification score in
the context of training (see 4))?
What is your opinion on 2) and 3)? 

Regards,
Klaus
   
-----Original Message-----
From: Reifenrath, Klaus [mailto:[email-masked]]
Sent: Mittwoch, 21. Juli 2004 18:11
To: 'Sarvi Shanmugham'; Daniel Burnett
Cc: [email-masked]
Subject: [Speechsc] XML schema for verification result

Hi Sarvi and Dan,

I created a XML schema for the verification result. Like the RelaxNG schema
of Dan it can be improved. I also adapted the sample results of Dan.

Compared to Dan's proposal I changed the following:
1) Because of XML Schema limitations I need to distinguish between
verification and training results. 
2) The <num-frames> element is no longer child element of the <voice-print>
element, because in case of multi-verification, the value of num-frames is
the same for all voiceprints.
3) The <adapted> and <need-more-data> are child elements of the
<voice-print> element.
4) For training results the <verification-score> is now optional. I also
added a new optional parameter for training results: consistent.
5) The <voice-print> element has 2 mandatory attributes: repository-uri and
identifier
6) Currently I included the <result> element of NLSML, to allow validation
of sample results with validation tools. But I still do not see the benefit
of using NLSML for verification results, because a speaker verification
engine is not a semantic interpretation component.

Suggestions for improvement are welcome!

Klaus
 <<ver.xsd>>  <<mrcpver20040721example.xml>> 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Pierre Forgues" <[email-masked]>
Date: Fri, 8 Oct 2004 14:54:37 -0400

Klaus,

We do not use <verification-score> in the context of training and would
therefore not have an issue with this being optional.

Also, we are OK for items 2 and 3 below.

Pierre

-----Original Message-----
From: Reifenrath, Klaus [mailto:[email-masked]] 
Sent: Tuesday, October 05, 2004 1:27 PM
To: [email-masked]
Cc: 'Sarvi Shanmugham'; Pierre Forgues; [email-masked]'
Subject: RE: [Speechsc] XML schema for verification result

Hi group,

aside from the discussion which schema we should use, I like to resolve
the
open issues concerning the verification result elements:
According to the current spec the <verification-score> element is
mandatory
also for training results. What is the meaning of a verification score
in
the context of training (see 4))?
What is your opinion on 2) and 3)? 

Regards,
Klaus
   
-----Original Message-----
From: Reifenrath, Klaus [mailto:[email-masked]]
Sent: Mittwoch, 21. Juli 2004 18:11
To: 'Sarvi Shanmugham'; Daniel Burnett
Cc: [email-masked]
Subject: [Speechsc] XML schema for verification result

Hi Sarvi and Dan,

I created a XML schema for the verification result. Like the RelaxNG
schema
of Dan it can be improved. I also adapted the sample results of Dan.

Compared to Dan's proposal I changed the following:
1) Because of XML Schema limitations I need to distinguish between
verification and training results. 
2) The <num-frames> element is no longer child element of the
<voice-print>
element, because in case of multi-verification, the value of num-frames
is
the same for all voiceprints.
3) The <adapted> and <need-more-data> are child elements of the
<voice-print> element.
4) For training results the <verification-score> is now optional. I also
added a new optional parameter for training results: consistent.
5) The <voice-print> element has 2 mandatory attributes: repository-uri
and
identifier
6) Currently I included the <result> element of NLSML, to allow
validation
of sample results with validation tools. But I still do not see the
benefit
of using NLSML for verification results, because a speaker verification
engine is not a semantic interpretation component.

Klaus