Subject: [Speechsc] Regarding SDP negotiation during session establishment

From: jakki sasidhar <[email-masked]>
Date: Mon, 08 Jan 2007 11:49:19 +0530

Hi,
    In the draft-ietf-speechsc-mrcpv2-11(pg. 15), following is the SDP
negotiation during the session establishment.
 
INVITE
          v=0
          o=sarvi 2890844526 2890842808 IN IP4 126.16.64.4
          s=-
          c=IN IP4 224.2.17.12
          m=application 9 TCP/MRCPv2
          a=setup:active
          a=connection:new
          a=resource:speechsynth
          a=cmid:1
          m=audio 49170 RTP/AVP 0 96
          a=rtpmap:0 pcmu/8000
          a=recvonly
          a=mid:1
 
200 OK
          v=0
          o=- 2890844526 2890842808 IN IP4 126.16.64.4
          s=-
          c=IN IP4 224.2.17.12
          m=application 32416 TCP/MRCPv2
          a=setup:passive
          a=connection:new
          a=channel:32AECB234338@speechsynth
          a=cmid:1
          m=audio 48260 RTP/AVP 00 96
          a=rtpmap:0 pcmu/8000
          a=sendonly
          a=mid:1
 
The following is an example from rfc4145.
 
client
           m=image 54111 TCP t38
           c=IN IP4 192.0.2.2
           a=setup:passive
           a=connection:new
server
           m=image 9 TCP t38
           c=IN IP4 192.0.2.1
           a=setup:active
           a=connection:new
 
1. Here multicast address is used in the connection field, but as we use
TCP(unicast) how does this actually work? In the example of rfc4145, it uses
unicast addresses of client and server.
2. The SDP in 200 has the same connection address, but how will the client
be able to connect to the server without knowing its IP address and only
using the port specified in the m-line.
3. Is there ordering that needs to be followed in the control and rtp
m-lines? I guess this may be significant when the MRCP client is not the
originator of the media.
 
please clarify these..
 
with regards,
Sasidhar

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Mon, 8 Jan 2007 09:41:11 -0000

Hi Sasidhar,

Quick comments below with DB>. 

Dave
  ----- Original Message ----- 
  From: jakki sasidhar 
  To: [email-masked] ; [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, January 08, 2007 6:19 AM
  Subject: [Speechsc] Regarding SDP negotiation during session establishment

  Hi,
      In the draft-ietf-speechsc-mrcpv2-11(pg. 15), following is the SDP negotiation during the session establishment.

  INVITE
            v=0

  200 OK
            v=0

  client
             m=image 54111 TCP t38
             c=IN IP4 192.0.2.2
             a=setup:passive
             a=connection:new
  server
             m=image 9 TCP t38
             c=IN IP4 192.0.2.1
             a=setup:active
             a=connection:new

  1. Here multicast address is used in the connection field, but as we use TCP(unicast) how does this actually work? In the example of rfc4145, it uses unicast addresses of client and server.

  DB> Good catch - the intent is of course a unicast address for the control channel so I believe this is just an editorial error in the example.

  2. The SDP in 200 has the same connection address, but how will the client be able to connect to the server without knowing its IP address and only using the port specified in the m-line.

  DB> This would typically be a different unicast address for the server.

  3. Is there ordering that needs to be followed in the control and rtp m-lines? I guess this may be significant when the MRCP client is not the originator of the media.

  DB> Order for media m-lines follows the usual offer/answer model (RFC 3264) rules - i.e. order in the offer dictates preference. No such ordering is defined or indeed necessary for the application m-line associated with the MRCP control channel. 

  please clarify these..

  with regards,
  Sasidhar

------------------------------------------------------------------------------