Subject: [Speechsc] a problem with mrcpv2:how can I establish a media control channel

From: "lala lala" <[email-masked]>
Date: Thu, 08 Feb 2007 07:05:05 +0000

hi.
    I wanna make a mrcpv2 server myself,But I have a problem with the 
sip.First I have got a client for mrcpv2 form the web.Then I use this 
client to send SIP message to my server with TCP.like this:

INVITE sip:mresources@localhost:4900 SIP/2.0
Via: SIP/2.0/TCP;branch=z9hG4bK09a7a775a4f24e1b
Max-Forwards: 6
To: MediaServer <sip:mresources@localhost:4900>
From: clien_user <sip:[email-masked]:3050>;tag=a0ac26c8
Contact: <sip:[email-masked]>
Call-Id: 1cb629ac592a712c
Cseq: 665931353 INVITE
Content-Type: application/sdp
Content-Length: 317

v=0
o=client_user 2890844526 2890842808 IN IP4 zhujin.sinovoice.com
s=SomeSIPsession
m=application 9 TCP/MRCPv2
c=IN IP4 10.0.0.79
a=setup:active
a=connection:new
a=resource:speechsynth
a=cmid:1
m=audio 37774 RTP/AVP 0 96
c=IN IP4 10.0.0.79
a=rtpmap:0 pcmu/8000
a=rtpmap:96 l16/8000
a=recvonly
a=mid:1

    Then I pharse the message and send the SIP 200 Ok ,and I give the 
client a listen port:6000,at this time my server listen this port for mrcp 
connection.like this:

SIP/2.0 200 OK
Via: SIP/2.0/TCP;branch=z9hG4bK09a7a775a4f24e1b;received=10.0.0.79
To: MediaServer <sip:[email-masked]:4900>
From: clien_user <sip:[email-masked]:3050>;tag=a0ac26c8
Contact:<sip:[email-masked];transport=TCP>
Call-Id: 1cb629ac592a712c
Cseq: 665931353 INVITE
Content-Type: application/sdp
Content-Length: 310

v=0
o=client_user 2890844526 2890842808 IN IP4 10.0.0.79
s=SomeSIPsession
m=application 6000 TCP/MRCPv2
c=IN IP4 10.0.0.79
a=setup:passive
a=connection:new
a=channel:1@speechsynth
a=cmid:1
m=audio 7774 RTP/AVP 0 96
c=IN IP4 10.0.0.79
a=rtpmap:0 pcmu/8000
a=rtpmap:96 l16/8000
a=sendonly
a=mid:1

    Then the client send me the ACK,like this:

ACK sip:[email-masked]:4900 SIP/2.0
Via: SIP/2.0/TCP;branch=z9hG4bKfbb398e28bc5ca41
Max-Forwards: 60
To: MediaServer <sip:mresources@localhost:4900>;tag=
From: clien_user <sip:[email-masked]:3050>;tag=a0ac26c8
Contact: <sip:[email-masked]>
Call-ID: 1cb629ac592a712c
CSeq: 665931353 ACK
Content-Length: 0

   But then I can not get the mrcp message from the port 6000.I don't know 
if I haven't understand the mrcpv2 protocal yet.I see the client log,It has 
make the mrcp message just like "MRCP/2.0 486 SPEAK",but it said that "The 
connection is not exists for Channel-Id\=1@speechsynth".So it can not send 
the message to my server,I wonder if this time the client should send the 
mrcp message to my 6000 port.My server should do what after I send the  
SIP/2.0 200 OK.How can I establish the media control channel by the 
SIP.Thanks very much!

_________________________________________________________________
享用世界上最大的电子邮件系统― MSN Hotmail。  http://www.hotmail.com  

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: prasanna 70008 <[email-masked]>
Date: Fri, 09 Feb 2007 09:49:00 +0800

Hi,
Did you check if the client opened a TCP connection with the server @ 6000 port?
Cheers,
Prasanna
******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

----- Original Message -----
From: lala lala <[email-masked]>
Date: Thursday, February 8, 2007 3:05 pm
Subject: [Speechsc] a problem with mrcpv2:how can I establish a media	control channel

> List-Unsubscribe: <https://www1.ietf.org/mailman/listinfo/speechsc>,
> 	<[email-masked]?subject=unsubscribe>
> List-Help: <[email-masked]?subject=help>
> List-Id: Speech Services Control Working Group <speechsc.ietf.org>
> X-OriginalArrivalTime: 08 Feb 2007 07:05:09.0493 (UTC)
> 	FILETIME=[783A3A50:01C74B4F]
> 
> hi.
> From: clien_user 
> <sip:[email-masked]:3050>;tag=a0ac26c8Contact: 
> <sip:[email-masked]>Call-Id: 1cb629ac592a712c
> Cseq: 665931353 INVITE
> From: clien_user 
> <sip:[email-masked]:3050>;tag=a0ac26c8Contact:<sip:[email-masked];transport=TCP>
> From: clien_user 
> <sip:[email-masked]:3050>;tag=a0ac26c8Contact: 
> <sip:[email-masked]>Call-ID: 1cb629ac592a712c
> CSeq: 665931353 ACK
> Content-Length: 0
> 
> ??????????????? MSN Hotmail?  http://www.hotmail.com  
> 
>

---

From: prasanna 70008 <[email-masked]>
Date: Mon, 12 Feb 2007 10:09:25 +0800

Hi,
A silly query... did you check if your server has bound to 6000 port and listening on it?
Cheers,
Prasanna

----- Original Message -----
From: lala lala <[email-masked]>
Date: Friday, February 9, 2007 10:01 am
Subject: Re: [Speechsc] a problem with mrcpv2:how can I establish a media control channel

> I use the software"Active Ports" and find the client dose not 
> create a 
> connection with the 6000 port but also gives me a ACK?If a ACK be 
> gived to 
> me means that the connection has been established.
> 
> And who can give me another client for mrcpv2 and the client 
> source 
> code.Thanks very much!
> 
> 
> >From: prasanna 70008 <[email-masked]>
> >To: lala lala <[email-masked]>
> >CC: [email-masked]
> >Subject: Re: [Speechsc] a problem with mrcpv2:how can I establish 
> a media 
> control channel
> >Date: Fri, 09 Feb 2007 09:49:00 +0800
> >
> >Hi,
> >Did you check if the client opened a TCP connection with the 
> server @ 6000 
> port?
> >Cheers,
> >Prasanna
> >  This email and its attachments contain confidential information 
> from 
> HUAWEI, which is intended only for the person or entity whose 
> address is 
> listed above. Any use of the information contained herein in any 
> way 
> (including, but not limited to, total or partial disclosure, 
> reproduction, 
> or dissemination) by persons other than the intended recipient(s) 
> is 
> prohibited. If you receive this e-mail in error, please notify the 
> sender 
> by phone or email immediately and delete it!
> >  
> > > List-Unsubscribe: 
> <https://www1.ietf.org/mailman/listinfo/speechsc>,> > 	<speechsc-
> [email-masked]?subject=unsubscribe>> > List-Help: <speechsc-
> [email-masked]?subject=help>> > List-Id: Speech Services Control 
> Working Group <speechsc.ietf.org>
> ?????????????? MSN Messenger:  http://messenger.msn.com/cn  
> 
>