Subject: [Status] Proposed Charter

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Fri, 6 Sep 2013 06:48:16 +0000

All,

here follows a proposal for the charter.

Thanks.
s.

-------------------------------------------------------------------
Name: SEGROUTE (or SR, or whatever else)
Charter:

Introduction
------------
The following use cases:
. Path computation based on awareness of utilization or performance 
  data, within both centralized and distributed environments,
. Multi-topology (dual planes, disjoint trees),
. Simplification and reduction of signaling components (scaling),
. Combined application and network layer path specification,
. Full coverage LFA-FRR,
. Topology Aware OAM,
. etc. 

have triggered work on the definition of new architecture and protocol 
extensions allowing to combine well known shortest path based routing 
paradigms with source/explicit routing methods. Some of these 
extensions have been implemented already.

Objective
---------
Define an architecture where a node can steer a packet through a 
controlled set of instructions, called segments while maintaining 
per-explicit path state only at the ingress node.

The instruction associated to a segment can be derived based on
arbitrary mechanisms which may include:

. Shortest path routing or explicit/source routing paradigms
. Intra and inter domain path computation
. Network or application layer
. Network virtualization
. Centralized or distributed path computation
. Unicast or Multicast schemes
. Others.

The SEGROUTE architecture will support:

. Tunnel and non-tunnel based paradigms
. Multiple data-planes: MPLS and IPv6. The SEGROUTE control plane 
  should be independent (agnostic) to the data-planes.

The WG will work on the definition of the architecture and protocol 
extensions. No new protocol specification is expected within this WG. 
No MPLS data-plane changes are expected either.

Instead the standardization work should consist in extensions in well 
established protocols (ISIS, OSPF, BGP, PCEP, ...).

It is expected that the SEGROUTE WG will help in the orchestration 
of protocol extensions specification with the existing IETF Working 
Groups (ISIS, OSPF, IDR, PCE, 6MAN, MPLS, ...).
 
Documents
---------
The WG will produce the following documents:
. Problem Statement
. Requirements
. Use Cases
. Architecture 
. Interoperability Report

The protocol extensions and data-plane instantiations will be handled 
in their respective WGs.

---

From: <[email-masked]>
Date: Fri, 6 Sep 2013 08:51:21 +0200

Hi Stefano,

thanks and ok.

Regards,

Ruediger

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stefano Previdi (sprevidi)
Sent: Friday, September 06, 2013 8:48 AM
To: [email-masked]
Cc: Clarence Filsfils (cfilsfil)
Subject: [Status] Proposed Charter

All,

Thanks.
s.

Introduction
------------
The following use cases:

Objective
---------

Documents
---------

The protocol extensions and data-plane instantiations will be handled
in their respective WGs.
_______________________________________________
status mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/status

---

From: <[email-masked]>
Date: Fri, 6 Sep 2013 11:00:26 +0200

Agree on this charter proposal, just need to add security aspects.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Stefano Previdi (sprevidi)
Envoyé : vendredi 6 septembre 2013 08:48
À : [email-masked]
Cc : Clarence Filsfils (cfilsfil)
Objet : [Status] Proposed Charter

All,

Thanks.
s.

Introduction
------------
The following use cases:
. Path computation based on awareness of utilization or performance
  data, within both centralized and distributed environments, . Multi-topology (dual planes, disjoint trees), . Simplification and reduction of signaling components (scaling), . Combined application and network layer path specification, . Full coverage LFA-FRR, . Topology Aware OAM, . etc. 

have triggered work on the definition of new architecture and protocol extensions allowing to combine well known shortest path based routing paradigms with source/explicit routing methods. Some of these extensions have been implemented already.

Objective
---------
Define an architecture where a node can steer a packet through a controlled set of instructions, called segments while maintaining per-explicit path state only at the ingress node.

The instruction associated to a segment can be derived based on arbitrary mechanisms which may include:

. Shortest path routing or explicit/source routing paradigms . Intra and inter domain path computation . Network or application layer . Network virtualization . Centralized or distributed path computation . Unicast or Multicast schemes . Others.

The WG will work on the definition of the architecture and protocol extensions. No new protocol specification is expected within this WG. 
No MPLS data-plane changes are expected either.

Instead the standardization work should consist in extensions in well established protocols (ISIS, OSPF, BGP, PCEP, ...).

It is expected that the SEGROUTE WG will help in the orchestration of protocol extensions specification with the existing IETF Working Groups (ISIS, OSPF, IDR, PCE, 6MAN, MPLS, ...).
 
Documents
---------

The protocol extensions and data-plane instantiations will be handled in their respective WGs.
_______________________________________________
status mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/status

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Mon, 9 Sep 2013 08:53:00 +0200

Stefano,

I support the draft agenda as suggested below.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von Stefano Previdi (sprevidi)
Gesendet: Freitag, 6. September 2013 08:48
An: [email-masked]
Cc: Clarence Filsfils (cfilsfil)
Betreff: [Status] Proposed Charter

All,

Thanks.
s.

Introduction
------------
The following use cases:

Objective
---------

Documents
---------

---

From: Jeff Tantsura <[email-masked]>
Date: Mon, 9 Sep 2013 06:56:32 +0000

Hi,

Support, looks rather reasonable.

Cheers,
Jeff

>  data, within both centralized and distributed environments, .
>Multi-topology (dual planes, disjoint trees), . Simplification and
>reduction of signaling components (scaling), . Combined application and
>network layer path specification, . Full coverage LFA-FRR, . Topology
>Aware OAM, . etc.
>
>paradigms with source/explicit routing methods. Some of these extensions
>have been implemented already.
>
>Objective
>---------
>. Shortest path routing or explicit/source routing paradigms . Intra and
>inter domain path computation . Network or application layer . Network
>virtualization . Centralized or distributed path computation . Unicast or
>Multicast schemes . Others.
>
>It is expected that the SEGROUTE WG will help in the orchestration of
>protocol extensions specification with the existing IETF Working Groups
>(ISIS, OSPF, IDR, PCE, 6MAN, MPLS, ...).
>
>Documents
>---------