Subject: RE: [Syslog-sec] Naming Style for SD-PARAMs

From: "Rainer Gerhards" <[email-masked]>
Date: Fri, 14 Jan 2005 10:41:10 +0100

Sharon,

I agree to your comment. I will change it consistently to all-lowercase
in the draft, but I will not include any requirement to do so. Hopefully
the consistent lowercase will be guidiance enough to implementors ;)

Rainer 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> Sharon Chisholm
> Sent: Tuesday, January 11, 2005 10:13 PM
> To: [email-masked]
> Subject: [Syslog-sec] Naming Style for SD-PARAMs
> 
> hi
> 
> I was looking through version 8 of the protocol specification 
> to see what
> sort of naming style was being used for SD-PARAMs and it 
> seems all over the
> map. Should set a best practice and use it consistently throughout the
> document? I don't think we want an actual requirement though 
> as it would
> turn into a CLR (crappy little rule)
> 
> 1. Upper Camel
> 
> EventSource, EventID
> 
> 2. Lower Camel
> 
> enterpriseID
> 
> 3. all lower case
> 
> tzknown, issynced, issynced
> 
> 4. Hyphenated
> 
> sw-version
> 
> Sharon Chisholm
> Nortel Networks
> Ottawa, Ontario
> Canada
> _______________________________________________
> Syslog-sec mailing list
> [email-masked]
> http://www.employees.org/mailman/listinfo/syslog-sec
> 
_______________________________________________
Syslog-sec mailing list
[email-masked]
http://www.employees.org/mailman/listinfo/syslog-sec

---

From: "David B Harrington" <[email-masked]>
Date: Fri, 14 Jan 2005 16:36:35 -0500

Hi,

The case-consistency was overlooked by the WG. It will be easy to
overlook by others.
I suggest we add a guideline to implementers suggesting the use of
lower camel for consistency.

dbh 

> Rainer Gerhards
> Sent: Friday, January 14, 2005 4:41 AM
> To: Sharon Chisholm; [email-masked]
> Subject: RE: [Syslog-sec] Naming Style for SD-PARAMs
> 
> Sharon,
>