Subject: [Syslog-sec] Naming Style for SD-PARAMs

From: "Sharon Chisholm" <[email-masked]>
Date: Tue, 11 Jan 2005 16:13:29 -0500

hi

I was looking through version 8 of the protocol specification to see what
sort of naming style was being used for SD-PARAMs and it seems all over the
map. Should set a best practice and use it consistently throughout the
document? I don't think we want an actual requirement though as it would
turn into a CLR (crappy little rule)

1. Upper Camel

EventSource, EventID

2. Lower Camel

enterpriseID

3. all lower case

tzknown, issynced, issynced

4. Hyphenated

sw-version

Sharon Chisholm
Nortel Networks
Ottawa, Ontario
Canada
_______________________________________________
Syslog-sec mailing list
[email-masked]
http://www.employees.org/mailman/listinfo/syslog-sec

---

From: "Sharon Chisholm" <[email-masked]>
Date: Fri, 14 Jan 2005 09:47:06 -0500

hi

All lower case might the most difficult to read of the four choices. Might I
suggest lower camel? 

Sharon

-----Original Message-----
From: Rainer Gerhards [mailto:[email-masked]] 
Sent: Friday, January 14, 2005 4:41 AM
To: Chisholm, Sharon [CAR:5K50:EXCH]; [email-masked]
Subject: RE: [Syslog-sec] Naming Style for SD-PARAMs

Sharon,

I agree to your comment. I will change it consistently to all-lowercase in
the draft, but I will not include any requirement to do so. Hopefully the
consistent lowercase will be guidiance enough to implementors ;)

Rainer 

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of 
> Sharon Chisholm
> Sent: Tuesday, January 11, 2005 10:13 PM
> To: [email-masked]
> Subject: [Syslog-sec] Naming Style for SD-PARAMs
> 
> hi
>

---

From: "Rainer Gerhards" <[email-masked]>
Date: Fri, 14 Jan 2005 16:47:59 +0100

Sharon,

I have no specific preferrence and your reasoning is good ;) I change it
to lower camel.

Rainer 

> Sent: Friday, January 14, 2005 3:47 PM

---

From: "Rainer Gerhards" <[email-masked]>
Date: Mon, 17 Jan 2005 09:24:18 +0100

David,

I've been hesitant to put a specific recommendation in because we had so
many discussions about the paper being to precise. And if someone
implements -protocol but does not use consistent case for his SD-IDs
.... nothing is broken at all... 

Based on your suggestion, however, I think it would be worth putting a
note into the non-normative "implementors notes" appendix. 

What does the WG say?

Rainer 

> From: David B Harrington [mailto:[email-masked]] 
> Sent: Friday, January 14, 2005 10:37 PM
> To: Rainer Gerhards; 'Sharon Chisholm'; [email-masked]
> Hi,
> The case-consistency was overlooked by the WG. It will be easy to
> overlook by others.
> I suggest we add a guideline to implementers suggesting the use of
> lower camel for consistency.
> 
> dbh 
> 
> > Rainer Gerhards
> > To: Sharon Chisholm; [email-masked]
> > I agree to your comment. I will change it consistently to 
> > all-lowercase
> > in the draft, but I will not include any requirement to do 
> > so. Hopefully
> > the consistent lowercase will be guidiance enough to implementors ;)
> > 
> > Rainer 
> >

---

From: "Sharon Chisholm" <[email-masked]>
Date: Mon, 17 Jan 2005 07:43:40 -0500

hi

We do want to be careful not to over proscribe, but a note suggesting lower
camel where ever it seems most appropriate in the draft will actually help
prevent things breaking as swstuff, sw-stuff, swStuff and SwStuff do not
interoperate. People can still manage to create duplicate tags, but
consistent naming patterns make this more detectable and therefore
preventable.

Sharon

-----Original Message-----
From: Rainer Gerhards [mailto:[email-masked]] 
Sent: Monday, January 17, 2005 3:24 AM
To: [email-masked]; Sharon Chisholm; [email-masked]
Subject: RE: [Syslog-sec] Naming Style for SD-PARAMs

David,

I've been hesitant to put a specific recommendation in because we had so
many discussions about the paper being to precise. And if someone implements
-protocol but does not use consistent case for his SD-IDs .... nothing is
broken at all... 

Based on your suggestion, however, I think it would be worth putting a note
into the non-normative "implementors notes" appendix. 

What does the WG say?

Rainer 

> overlook by others. I suggest we add a guideline to implementers 
> suggesting the use of lower camel for consistency.
> 
> dbh
>