Subject: RE: [Syslog] Sec 6.1: Truncation

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Fri, 20 Jan 2006 10:39:01 -0500

I think the suggestion from me and Tom (if I interpret his email correctly) is to state that messages can be truncated at the end at an arbitrary point.  We also make a note that this may result in invalid UTF character encoding, or a change in UTF character.  

I don't think it even warrants a SHOULD for truncation to preserve UTF character in full. Valid characters when you only get some of them after truncation may result in a wrong language word, anyway. 

Anton.  

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Darren Reed
> Sent: Friday, January 20, 2006 8:57 AM
> To: Tom Petch
> Cc: [email-masked]
> Subject: Re: [Syslog] Sec 6.1: Truncation
> 
> 
> Is the truncation of a message on a UTF-8 boundary rather 
> than within an extended character something that syslog 
> daemons SHOULD do rather than MUST do ?  (To use the RFC words.)
> 
> Darren
> 
> _______________________________________________
> Syslog mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/syslog
> 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Tom Petch" <[email-masked]>
Date: Fri, 20 Jan 2006 20:59:23 +0100

I don't have a strong view on SHOULD v MUST v neither, happy with any of them.
My point was that this is UTF-8 which I see as an unfamiliar technology for
some, perhaps for many, so while the idea that truncating a message can change
its meaning I would expect to be obvious to all, the idea of truncation leading
to a change within a character (from base + diacritic mark to base) or to an
illegal string (UTF-8 says three octets follow and there are none) to be less
familiar and so worth pointing out.

So, if we truncate any UTF-8 string, then I would like to see a warning of what
the consequences might be. I think it unrealistic to ask for truncation at the
boundary of a
composite character, I suspect it unrealistic to ask for more than a SHOULD to
truncate at an UTF-8 boundary and perhaps even a SHOULD is too much, but as I
said, I don't have a strong view on that aspect on truncation.

Tom Petch

----- Original Message -----
From: "Anton Okmianski (aokmians)" <[email-masked]>
To: "Darren Reed" <[email-masked]>; "Tom Petch"
<[email-masked]>
Cc: <[email-masked]>
Sent: Friday, January 20, 2006 4:39 PM
Subject: RE: [Syslog] Sec 6.1: Truncation

I think the suggestion from me and Tom (if I interpret his email correctly) is
to state that messages can be truncated at the end at an arbitrary point.  We
also make a note that this may result in invalid UTF character encoding, or a
change in UTF character.

I don't think it even warrants a SHOULD for truncation to preserve UTF character
in full. Valid characters when you only get some of them after truncation may
result in a wrong language word, anyway.

Anton.