Subject: RE: [Syslog] Charter comments from IESG Review

From: "Rainer Gerhards" <[email-masked]>
Date: Mon, 9 Jan 2006 09:14:43 +0100

Tom,

> > If so, yes, both S/MIME and OpenPGP support this model.  
> However I'll
> > point oun that it is not a requirement that syslog work 
> that way; for
> > example RFC 3195 certainly has connections.
> >
> I'll look at those, thanks.  I agree syslog could be, perhaps 
> should be for
> meaningful security, but often at present is not, so I wanted 
> to see what
> security was
> possible with just one way communication

They use pre-shared secrets.

It's probably best if you look at syslog-sign, which provides the
necessary mechanisms for syslog. Please note that it still transmits
data in clear-text (which I consider a requirement to remain
backwards-compatible).

Rainer

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: Sam Hartman <[email-masked]>
Date: Mon, 09 Jan 2006 07:07:34 -0500

>>>>> "Rainer" == Rainer Gerhards <[email-masked]> writes:

    Rainer> Tom,
    >> However I'll > point oun that it is not a requirement that
    >> syslog work that way; for > example RFC 3195 certainly has
    >> connections.
    >> >
    >> should be for meaningful security, but often at present is not,
    >> so I wanted to see what security was possible with just one way
    >> communication

    Rainer> They use pre-shared secrets.

Not typically.
They typically use public keys.