Subject: [Syslog] SD-ELEMENT names

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Thu, 12 Jan 2006 15:40:34 -0500

Rainer and all:

I'd like to propose a slight terminology change for syslog protocol for structured data. I think there is confusion even in this group about current terminology.  For example, we (me included) keep referring to "structured data element", when we mean "structured data parameter".  It is hard to remember the difference.  

I think easier vocabulary can help a standard - inside and outside this group.  Here is my proposal:

Structured Data => Tags
Structured Data Element => Tag Group
Structured Data ID => Tag Group ID
Structured Data Parameter => Tag
Structured Data Parameter Name => Tag Name
Structured Data Parameter Value => Tag Value

This is much less verbose and easier IMO. 

Thanks,
Anton. 

_______________________________________________
Syslog mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/syslog

---

From: "Rainer Gerhards" <[email-masked]>
Date: Fri, 13 Jan 2006 09:01:40 +0100

Anton,

I see your point, but I am not yet convinced the proposed terminology is
actually better. I have some concerns on "Tag Group" vs. "Tag". If I
think about tags, I typically think about something that has a name and
a value (good description for param-name and param-value). However, I
associate a tag-group with something loosely coupled. In
STRUCTURED-DATA, however, each name/value pair is strongly associated
with the ID. It is the ID that describes what the whole thing is about,
the name/value pairs "just" convey some specifics.

Any more comments?

Rainer

> -----Original Message-----
> From: Anton Okmianski (aokmians) [mailto:[email-masked]] 
> Sent: Thursday, January 12, 2006 9:41 PM
> To: Rainer Gerhards
> Cc: [email-masked]
> Subject: SD-ELEMENT names
> 
> Rainer and all:
> 
> I'd like to propose a slight terminology change for syslog 
> protocol for structured data. I think there is confusion even 
> in this group about current terminology.  For example, we (me 
> included) keep referring to "structured data element", when 
> we mean "structured data parameter".  It is hard to remember 
> the difference.  
>

---

From: "Anton Okmianski \(aokmians\)" <[email-masked]>
Date: Fri, 13 Jan 2006 11:15:16 -0500

Well, that's why the Tag Group has a Tag Group ID. It is not called a Tag Set or Tag Array.  Maybe there is a better word than Group here. Cluster? I agree it is not ideal, but I don't believe "Structured Data Element" is any more intuitive. It sounds like one element, while in fact it contains multiple parameters and the ID. 

At least, we agree that Tag is better than Structured Data Parameter. This is the one I am really after. 

Thanks,
Anton. 

> From: Rainer Gerhards [mailto:[email-masked]] 
> Sent: Friday, January 13, 2006 3:02 AM
> To: Anton Okmianski (aokmians)
> Cc: [email-masked]
> Subject: RE: SD-ELEMENT names
> 
> Anton,
> 
> I see your point, but I am not yet convinced the proposed 
> terminology is actually better. I have some concerns on "Tag 
> Group" vs. "Tag". If I think about tags, I typically think 
> about something that has a name and a value (good description 
> for param-name and param-value). However, I associate a 
> tag-group with something loosely coupled. In STRUCTURED-DATA, 
> however, each name/value pair is strongly associated with the 
> ID. It is the ID that describes what the whole thing is 
> about, the name/value pairs "just" convey some specifics.
> 
> Any more comments?
> 
> Rainer
> 
> > I'd like to propose a slight terminology change for syslog protocol 
> > for structured data. I think there is confusion even in this group 
> > about current terminology.  For example, we (me
> > included) keep referring to "structured data element", when we mean 
> > "structured data parameter".  It is hard to remember the difference.
> > 
> > Structured Data Parameter Name => Tag Name Structured Data 
> Parameter 
> > Value => Tag Value
> >