Subject: [tcpm] WG consensus sought (deadline 5 May): abort timeout negotiation

From: Ted Faber <[email-masked]>
Date: Wed, 28 Apr 2004 10:37:08 -0700

Hi, all.

A few days ago Lars Eggert posted a draft to the group describing a way
to negotiate TCP abort timeouts at connection establishment,
draft-eggert-tcpm-tcp-abort-timeout-option-00.txt .  Those concerned
about process (which should be everyone) note that despite the presence
of the string "tcpm" in the draft name, it is not a working group item,
but an individual submission targeted to tcpm.  My black helicopter is
in the shop.

Before we try to get consensus on the draft itself, Mark and I are
seeking consensus on the topic.  The draft itself does a good job of
describing the issue and is a good place to start if you want to
understand it (it's not a very complex issue).  The short form is that
mobile or intermittently connected hosts may want to request that
endpoints wait a long time before tearing down an idle TCP connection,
and that there's currently no way to do that.

The question before the group is "do we want to address negotiating the
abort timeout in TCP?"  If we reach a positive consensus on that, we'll
talk about adopting Lars's draft.

We need to hear from folks who have opinions either way.  I propose that
we close discussion and come to a resolution by Wed 5 May.  If you have
opinions you want considered, at least get a placeholder out to the tcpm
mailing list by then.

-- 
Ted Faber
http://www.isi.edu/~faber           PGP: http://www.isi.edu/~faber/pubkeys.asc
Unexpected attachment on this mail? See http://www.isi.edu/~faber/FAQ.html#SIG

---

From: [email-masked]
Date: Wed, 28 Apr 2004 13:02:16 -0700

I will say the discussion should belong inside the WG.

(time to get on the soapbox)
I would like to say however (for those people that DO see Black Helicopters and wear there AFBs on a regular
bassis...

The use of ietf-draft-name-wg-foo-00.txt as an individual submission is a well honored practice when the work
belongs within the charter of a working group.  It is much easier as a WG chair to get a new work item put into
the WG charter when there is a draft to base it off of.

Now it is up to the WG chairs to go off and find out if it indeed belongs in the WG as a charter item, and if
so instruct the new editor to change the name of the updated draft to reflect it (or to continue down the
Individual Submission path if it is decided not to become a WG item)

I am slightly more concerned with the tcp security draft that went out, but there were reasons for doing it the
way that it was done, and I am happy with the results (OK - I wish I had been included in the secret audience
before it was announced - don't we all <G>).  Even then there is no requirement that I am aware of that drafts
be exposed outside the authors before initial submission (or that internal discussions among the editors be
disclosed outside of summary - here are the decisions that we have made, to the Working Group), so I don't
think any process has been violated.

These are my opinions only (stepping off of my soapbox now)

Bill
> -------- Original Message --------
> Subject: [tcpm] WG consensus sought (deadline 5 May): abort timeout
> negotiation
> From: "Ted Faber" <[email-masked]>
> Date: Wed, April 28, 2004 10:37 am
> To: [email-masked]
>
> Hi, all.
>

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Tom Petch" <[email-masked]>
Date: Thu, 29 Apr 2004 11:34:59 +0100

-----Original Message-----
From: Ted Faber <[email-masked]>
To: [email-masked] <[email-masked]>
Date: 28 April 2004 18:57
Subject: [tcpm] WG consensus sought (deadline 5 May): abort timeout
negotiation
<snip>
>talk about adopting Lars's draft.

The current charter has a number of specific work items on it and from what
I see on this list, we will miss the milestone date for each and every one
of them.  So while this may be a worthwhile activity, I would like to see
progress on what we are meant to be doing before considering other  items
ie defer the question until we have something with the IESG.

Tom Petch