Subject: [tcpm] Re: [e2e] Open the floodgate

From: "Michael Welzl" <[email-masked]>
Date: Fri, 23 Apr 2004 18:54:11 +0200

> > > Still, my question remains: why don't we have these 
> > separate checksums 
> > > as a TCP option? It strikes me as a rather simple method for links 
> > > where erroneous data are actually handed over, and I 
> > believe that it's 
> > > about time we transferred these things from the world of 
> > research into 
> > > the IETF.
> > 
> > When you have erroneous packets (for whatever reaso other 
> > than congestion), who will inform about that? Maybe the 
> > addresses themselves are erroneous. Besides, some packets 
> > just get completely junked ... Special headers will not solve 
> > the problem.
> 
> Another reason may be due to deployability issue, if you add checksum in
> TCP options, you have to modify both sending and receiving TCP stack. Is
> it? That is not easy to deploy in real network.

Not easy, but possible, in an incremental fashion.

This is not a reason to abandon it IMO. It wasn't a reason
to abandon ECN either.

Cheers,
Michael

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Fu Cheng Peng, Franklin" <[email-masked]>
Date: Fri, 23 Apr 2004 21:41:18 +0800

> 
> On Fri, 23 Apr 2004, Michael Welzl wrote:
> 

-Franlkin

====================================
Dr. Fu Cheng Peng, Franklin
Asst Professor 
School of Computer Engineering
Nanyang Technological University, Singapore 639798
Tel: (65) 6790-4287 Fax: (65) 6792-6559 
====================================