Subject: RE: [tcpm] draft-ietf-tcpm-tcpsecure-00.txt

From: "sanjay kaniyar" <[email-masked]>
Date: Tue, 20 Apr 2004 23:26:57 -0700

Section [4.2]:

   An additional input check should be added to any incoming segment.
   The ACK value should be acceptable only if it is in the range of
   ((SND.UNA - MAX.SND.WND) <= SEG.ACK < SND.NXT).

The right edge of the acceptable ACK range should be SND.MAX actually. 
During the course of a retransmission, SND.NXT moves back and making that 
the right edge of the range would result in potentially dropping a lot of 
valid acknowledgements.

Thanks,
Sanjay

_________________________________________________________________
From must-see cities to the best beaches, plan a getaway with the Spring 
Travel Guide! http://special.msn.com/local/springtravel.armx

_______________________________________________
tcpm mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tcpm

---

From: "Randall Stewart (cisco)" <[email-masked]>
Date: Wed, 21 Apr 2004 10:19:32 -0500

Sanjay:

Good point I will add that to the next pass.

I am also going to attempt to use the draft tracker
Mark pointed to earlier :->

R

sanjay kaniyar wrote:

> During the course of a retransmission, SND.NXT moves back and making 
> that the right edge of the range would result in potentially dropping 
> a lot of valid acknowledgements.
>
> Thanks,
> Sanjay
>

-- 
Randall R. Stewart
ITD - Transport Technologies
815-477-2127(o) or 815-342-5222(c)