Subject: [tcpm] Fwd: New Version Notification for draft-touch-tcpm-experimental-options-00.txt

From: Joe Touch <[email-masked]>
Date: Mon, 24 Oct 2011 14:57:51 -0700

Hi, all,

The following document describes an informal proposal I made on the list 
a while back. Hopefully we can discuss it in Taiwan.

Joe

-------- Original Message --------
Subject: New Version Notification for 
draft-touch-tcpm-experimental-options-00.txt
Date: Mon, 24 Oct 2011 14:53:10 -0700
From: [email-masked]
To: [email-masked]
CC: [email-masked]

A new version of I-D, draft-touch-tcpm-experimental-options-00.txt has 
been successfully submitted by Joe Touch and posted to the IETF repository.

Filename:	 draft-touch-tcpm-experimental-options
Revision:	 00
Title:		 Shared Use of Experimental TCP Options
Creation date:	 2011-10-24
WG ID:		 Individual Submission
Number of pages: 6

Abstract:
    This document describes how TCP option codepoints can support
    concurrent experiments. The suggested mechanism avoids the need for
    a coordinated registry, and is backward-compatible with currently
    known uses.

The IETF Secretariat

---

From: Yuchung Cheng <[email-masked]>
Date: Sat, 29 Oct 2011 13:15:01 -0700

Hi Joe,

Kinda obvious but I assume the option "length" field now includes the
nonce?

Yuchung

On Mon, Oct 24, 2011 at 2:57 PM, Joe Touch <[email-masked]> wrote:

> Hi, all,
>
> The following document describes an informal proposal I made on the list a
> while back. Hopefully we can discuss it in Taiwan.
>
> Joe
>
> Subject: New Version Notification for draft-touch-tcpm-experimental-**
> options-00.txt
> A new version of I-D, draft-touch-tcpm-experimental-**options-00.txt has
> Filename:        draft-touch-tcpm-experimental-**options
> Revision:        00
> ______________________________**_________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/tcpm<https://www.ietf.org/mailman/listinfo/tcpm>
>

---

From: Joe Touch <[email-masked]>
Date: Sun, 30 Oct 2011 23:40:51 -0700

Hi, Yuchung,

Yes, the length field includes the size of the entire option, including the KIND, LENGTH, and NONCE fields. This will be made clear in the next version.

Joe

On Oct 29, 2011, at 1:15 PM, Yuchung Cheng wrote:

> Hi Joe,
> 
> Kinda obvious but I assume the option "length" field now includes the nonce? 
> 
> Yuchung
> 
> The following document describes an informal proposal I made on the list a while back. Hopefully we can discuss it in Taiwan.
> 
> Joe
> 
> Subject: New Version Notification for draft-touch-tcpm-experimental-options-00.txt
> A new version of I-D, draft-touch-tcpm-experimental-options-00.txt has been successfully submitted by Joe Touch and posted to the IETF repository.
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm
>