Subject: [tcpm] rtorestart applicable for SCTP ?

From: <[email-masked]>
Date: Tue, 25 Sep 2012 10:01:53 +0300

Hi,

This comment is related to draft-hurtig-tcpm-rtorestart-02.

The work seems to assume that SCTP T3 handling is as in TCP, which it is not.
By prescription SCTP should already implement "almost" the mechanism described in the draft as indeed
it is prescribed to:

Section 6.3.2:

   R3)  Whenever a SACK is received that acknowledges the DATA chunk

        with the earliest outstanding TSN for that address, restart the

        T3-rtx timer for that address with its current RTO (if there is

        still outstanding data on that address).

The difference in between the Rtorestart draft and existing SCTP prescription then seems to be that SCTP does it always not
only under special circumstances - ?

The latter perhaps then should be questioned - in particular if STCP, as TCP, is to start using larger initial CWNDs.

BR, Karen

PS:  I have not followed discussions on the work,
draft-hurtig-tcpm-rtorestart-02, in the past, so my comment
may already have been discussed. If so than I apologize in advance !

*****************************************************************************************
Karen Egede Nielsen
Software Architect, Ph.D.

Tieto Denmark A/S
IP Solutions, R&D Services
Åhave Parkvej 27, 2nd, 8260 Viby J, DK-Denmark
Direct Phone / Mobile +45 25134336
E-mail: [email-masked]
*****************************************************************************************
www.tieto.com

Please note: The information contained in this message may be legally privileged and confidential and protected from disclosure. If the reader of this message is not the intended recipient, you are hereby notified that any unauthorised use, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify us immediately by replying to the message and deleting it from your computer. Thank You.

---

From: <[email-masked]>
Date: Tue, 25 Sep 2012 18:55:04 +0300

Hi,

Please disregard the email below.
TCP and SCTP indeed do share the issue.

BR, Karen

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 25. september 2012 09:02
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [tcpm] rtorestart applicable for SCTP ?

Hi,

Section 6.3.2:

BR, Karen

Tieto Denmark A/S