Subject: Re: [tcpm] WGLC for Proportional Rate Reduction

From: Pasi Sarolahti <[email-masked]>
Date: Mon, 3 Sep 2012 08:54:01 +0200

Hi,

We need to move forward with the Proportional Rate Reduction draft. There have been a couple of comments supporting its publication as Proposed Standard rather than Experimental, but on the hand, Matt made some points for keeping with the current status. Therefore, after discussing with my co-chairs, we think the most appropriate path is to continue as planned, and proceed towards publishing the document as Experimental.

There were also some other comments made in response to the WGLC, so the authors should do a revision based on those before we request publication of the draft.

Thanks for your input!

- Pasi

On Aug 27, 2012, at 9:16 PM, Matt Mathis wrote:

> Sorry for the long radio silence here.
> 
> The only reason to bother with standards track is if there is a need
> to compel reluctant manufacturers to implement and deploy it.
> Customers can then write in their requests for quotes specifications
> such as "must support SACK (RFC 2018), and then suddenly the lack of
> SACK support becomes a high priority issue for some large manufacture
> who shall remain nameless.
> 
> Back in the old days (before 1990) RFC meant "request for comments"
> and there was no such concept as "standards track". We wrote down our
> ideas, and if they were valuable, they became part of the installed
> base.   For PRR this has already come to pass for the installed base
> that is most important to me.
> 
> If management at Apple or Microsoft think PRR isn't worth the effort,
> then making PRR a standard will permit their customers to influence
> their priorities.   Given the extent to which PRR is an across the
> board win, I really don't think this is required.  (However, I could
> change my mind if a TCP engineer at one of the above companies
> indicate that they are getting pushback from their management.)
> 
> Finally there are some details in PRR that are effected by Laminar.  I
> would rather not go to the effort of fixing the current draft to make
> it a proper normative PS, but not totally correct.  (Hint: Yoshifumi
> Nishida's "off by one" comment reflects the difference between pipe
> and total_pipe).
> 
> So here is what I was planning to do:  Push out the current document
> as experimental, and then after Laminar is further along, generate a
> normative respecification using Laminar state variables (probably as
> one section of a larger doc, but that remains TBD).
> 
> Does that make sense?
> 
> Thanks,
> --MM--
> The best way to predict the future is to create it.  - Alan Kay
> 
> 
> On Mon, Aug 27, 2012 at 7:43 AM, Mark Allman <[email-masked]> wrote:
>> 
>>> I wonder about the process issues related to changing the status at
>>> this point.
>> 
>> The process is that y'all say someone has suggested the status should be
>> standards track and you want to know what the WG thinks of that.  This
>> document has not left the WG.  I have not seen any declaration that it
>> passed WGLC.  It is within this WG's purview to consider this question.
>> 
>> allman
>> 
>> 
>> 
>> 
>> _______________________________________________
>> tcpm mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/tcpm
>>

---

From: Matt Mathis <[email-masked]>
Date: Mon, 3 Sep 2012 20:41:21 -0700

Thanks!

I will make the requested revisions.

Thanks,
--MM--