Subject: [tcpm] I-D Action: draft-ietf-tcpm-rtorestart-00.txt

From: [email-masked]
Date: Mon, 18 Feb 2013 01:48:51 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TCP Maintenance and Minor Extensions Working Group of the IETF.

	Title           : TCP and SCTP RTO Restart
	Author(s)       : Per Hurtig
                          Anna Brunstrom
                          Andreas Petlund
                          Michael Welzl
	Filename        : draft-ietf-tcpm-rtorestart-00.txt
	Pages           : 10
	Date            : 2013-02-18

Abstract:
   This document describes a modified algorithm for managing the TCP and
   SCTP retransmission timers that provides faster loss recovery when a
   connection's amount of outstanding data is small.  The modification
   allows the transport to restart its retransmission timer more
   aggressively in situations where fast retransmit cannot be used.
   This enables faster loss detection and recovery for connections that
   are short-lived or application-limited.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tcpm-rtorestart

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tcpm-rtorestart-00

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Anna Brunstrom <[email-masked]>
Date: Wed, 20 Feb 2013 23:57:18 +0100

Hi all,

A kernel patch for the Linux 3.7 kernel that implements the RTO restart 
draft is available from 
http://riteproject.eu/projects/wp1-end-systems-and-applications/rto-restart/. 
Please try it out and see how it works in your context.

Comments on the draft itself are of course also welcome.

Best Regards,
Anna

On 2013-02-18 10:48, [email-masked] wrote:
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Tue, 26 Feb 2013 17:48:03 +0100

Anna,

Thanks a lot for sharing this patch!

Is there already some report of experiments with that patch (e. g., a paper)?

I'd be interested in that (as individual contributor).

Thanks

Michael

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Anna Brunstrom
> Sent: Wednesday, February 20, 2013 11:57 PM
> To: [email-masked]
> Subject: Re: [tcpm] I-D Action: draft-ietf-tcpm-rtorestart-00.txt
> 
> Hi all,
> 
> A kernel patch for the Linux 3.7 kernel that implements the 
> RTO restart draft is available from 
> >   This draft is a work item of the TCP Maintenance and 
> Minor Extensions Working Group of the IETF.
> >