Subject: Re: [tcpm] Updated Section 3 of draft-ietf-tcpm-1323bis

From: Pasi Sarolahti <[email-masked]>
Date: Fri, 17 May 2013 12:47:50 +0300

On May 15, 2013, at 10:06 PM, "Scheffenegger, Richard" <[email-masked]> wrote:

> Appendix G.  RTO calculation modification
> 
>   This document RECOMMENDS that the standard RTO calculation

RECOMMENDS is not a RFC 2119 keyword. "RECOMMENDED" would be, but my preference would rather be just not to recommend anything, nor have RFC 2119 keywords in Appendix. Just state the fact that taking multiple samples in RTT would shorten the window of history calculated in RFC 6298, and the below algorithm aims to maintain similar window than originally intended by RFC 6298.

- Pasi

>   ([RFC6298]) is modified in the following way.  We roughly know how
>   many samples a congestion window worth of data will yield, not
>   accounting for ACK compression, and ACK losses.  Such events will
>   result in more history of the path being reflected in the final value
>   for RTO, and are uncritical.  This modification will approximate the
>   RTO estimator described in [RFC6298], regardless how many samples are
>   taken per window:
> 
>      ExpectedSamples = ceiling(FlightSize / (SMSS * 2))
> 
>      alpha' = alpha / ExpectedSamples
> 
>      beta' = beta / ExpectedSamples
> 
>   Note that the factor 2 in ExpectedSamples is due to "Delayed ACKs".
> 
>   Instead of using alpha and beta in the algorithm of [RFC6298], use
>   alpha' and beta' instead:
> 
>      RTTVAR <- (1 - beta') * RTTVAR + beta' * |SRTT - R'|
> 
>      SRTT <- (1 - alpha') * SRTT + alpha' * R'
> 
>      (for each sample R') 
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Fri, 17 May 2013 18:54:22 +0000

Hi Pasi,

I've taken your text donation and updated the appendix as follows:

   Taking multiple RTT samples per window would shorten the history
   calculated by the RTO mechanism in [RFC6298], and the below algorithm
   aims to maintain a similar history as originally intended by
   [RFC6298].

   We roughly know how many samples a congestion window worth of data
   will yield, not accounting for ACK compression, and ACK losses.  Such
   events will result in more history of the path being reflected in the
   final value for RTO, and are uncritical.  This modification will
   approximate the RTO estimator described in [RFC6298], regardless how
   many samples are taken per window:

      (for each sample R')

Richard Scheffenegger

> -----Original Message-----
> From: Pasi Sarolahti [mailto:[email-masked]]
> Sent: Freitag, 17. Mai 2013 11:48
> To: Scheffenegger, Richard
> Cc: [email-masked]; tcpm ([email-masked]); David Borman
> ([email-masked])
> Subject: Re: [tcpm] Updated Section 3 of draft-ietf-tcpm-1323bis
> 
> RECOMMENDS is not a RFC 2119 keyword. "RECOMMENDED" would be, but my
> preference would rather be just not to recommend anything, nor have RFC
> 2119 keywords in Appendix. Just state the fact that taking multiple
> samples in RTT would shorten the window of history calculated in RFC 6298,
> and the below algorithm aims to maintain similar window than originally
> intended by RFC 6298.
> 
> - Pasi
> 
>

---

From: Michael Welzl <[email-masked]>
Date: Fri, 17 May 2013 22:28:20 +0200

Hi,

>   many samples are taken per window:

Sorry, but I disagree with "will approximate the RTO estimator described in…"
=> I haven't seen any strong indication that this is really valid to say, and Mark has made it clear (in my understanding) that he never said this.

I suggest: "This modification will ensure that a similar amount of time is taken into account for the RTO estimation, regardless of how many samples are taken per window:"

Cheers,
Michael

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Sat, 18 May 2013 16:44:57 +0000

Thanks Michael,

I've also updated the auxiliary stuff (changes section), and submitted a new version.

http://tools.ietf.org//rfcdiff?url1=http://tools.ietf.org/id/draft-ietf-tcpm-1323bis-11.txt&url2=http://tools.ietf.org/id/draft-ietf-tcpm-1323bis-13.txt

Richard Scheffenegger

> From: Michael Welzl [mailto:[email-masked]]
> Sent: Freitag, 17. Mai 2013 22:28
> Cc: Pasi Sarolahti; tcpm ([email-masked]); David Borman
> ([email-masked]); [email-masked]
> Sorry, but I disagree with "will approximate the RTO estimator described
> in..."
> => I haven't seen any strong indication that this is really valid to say,
> and Mark has made it clear (in my understanding) that he never said this.
> 
> I suggest: "This modification will ensure that a similar amount of time is
> taken into account for the RTO estimation, regardless of how many samples
> are taken per window:"
> 
> Cheers,
> Michael