Subject: Re: [tcpm] httpbis chromium data

From: Pasi Sarolahti <[email-masked]>
Date: Fri, 2 Aug 2013 17:22:41 +0200

On 2.8.2013, at 16.26, "Scheffenegger, Richard" <[email-masked]> wrote:

> One of the interesting facts from that was a spike/peak at large window sizes (200 packets IIRC). It would be interesting, how these large windows came to be…
>  
> Provided that these data  points are not invalid for some data collection issue somewhere, this should only be true for very long latencies (like browsing from Japan via Europe on a West-Coast Server), very high bandwidths (google deploys gigabit-to-the-home in places, right), or potentially when the tcp session is application limited but constantly stays below the bottleneck bandwidth, while the OS continues to increase the cwnd over many RTTs by 1 (congestion avoidance flaw in app-limited streams in some OS).

There is another possible reason that I find more likely explanation: excess buffering in the network.

- Pasi

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Fri, 2 Aug 2013 18:17:22 +0000

Hi pasi,

That should show up as excessive path latency - as i said it would be interesting to know which of the three is responsible in what fraction!

Best regards,
   Richard

Von meinem iPhone gesendet

Am 02.08.2013 um 17:23 schrieb "Pasi Sarolahti" <[email-masked]<mailto:[email-masked]>>:

On 2.8.2013, at 16.26, "Scheffenegger, Richard" <[email-masked]<mailto:[email-masked]>> wrote:

- Pasi