Subject: Re: [tcpm] proposal to update & obsolete RFC 793

From: Hagen Paul Pfeifer <[email-masked]>
Date: Tue, 22 Oct 2013 08:40:51 +0200

Makes draft-eddy-rfc793bis draft-ietf-tcpm-tcp-rfc4614bis in parts or at whole unnecessary? There are so many TCP documents published - TCP Babylon. In the end we should provide one or two consolidated RFCs, referencing the relevant RFCs. When two, the user should get an idea what is the difference between both documents. The current situation is worse and I highly appreciate this effort!

Hagen

-- 
http://protocollabs.com

Wesley Eddy <[email-masked]> schrieb:

>After some prior threads mentioning that at least a few people
>think it would be desirable to have an updated and somewhat more
>consolidated TCP specification, Andre Oppermann and I have been
>outlining what we think this might look like and what would need
>to be included.
>
>As the draft submission cutoff approached, we aren't as far as
>hoped for, but a sketch of what we are thinking is at:
>http://www.ietf.org/id/draft-eddy-rfc793bis-00.txt
>
>I would like to start talking about this on the list and at the
>meeting in Vancouver to understand if people would be supportive
>of this, and whether the proposed scoping of what to include or
>not include sounds sane.
>
>-- 
>Wes Eddy
>MTI Systems
>_______________________________________________
>tcpm mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/tcpm
>

---

From: Wesley Eddy <[email-masked]>
Date: Tue, 22 Oct 2013 09:19:37 -0400

> Makes draft-eddy-rfc793bis draft-ietf-tcpm-tcp-rfc4614bis in parts or at whole unnecessary? There are so many TCP documents published - TCP Babylon. In the end we should provide one or two consolid…

Since the goal of 793bis is incorporating standards track changes,
errata, etc., and the scope of 4614bis is much wider (including
historical documents, experimental extensions, etc.), I think both
have a place and the relation will not be confusing.

793bis is a consolidation of the "core specification".

4614bis is a handbook to the current fragmented core specification,
plus a slew of other related things.  It will (hopefully!) also be
done far sooner than 793bis :).

-- 
Wes Eddy
MTI Systems

---

From: "Duke, Martin" <[email-masked]>
Date: Wed, 23 Oct 2013 14:54:38 +0000

So is your intent to have 793 focus on the minimum interoperable spec, or incorporate widely deployed-yet-optional features like SACK?

I think the intent of 4614(bis) is to familiarize the reader with the universe of possible things he/she will experience in the open internet's various TCP implementations, with a guide to how prevalent and "standard" they are. It would certainly be valuable to consolidate the 4 or 5 RFCs that comprise the core spec into a single document.

It seems like congestion control is both evolving and not strictly relevant to interoperability, so perhaps it's best to exclude it with references to existing RFCs/drafts/papers and statement of a vague requirement for Reno friendliness.

Martin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Wesley Eddy
Sent: Tuesday, October 22, 2013 6:20 AM
To: Hagen Paul Pfeifer
Cc: [email-masked]
Subject: Re: [tcpm] proposal to update & obsolete RFC 793

> Makes draft-eddy-rfc793bis draft-ietf-tcpm-tcp-rfc4614bis in parts or at whole unnecessary? There are so many TCP documents published - TCP Babylon. In the end we should provide one or two consolid…

Since the goal of 793bis is incorporating standards track changes, errata, etc., and the scope of 4614bis is much wider (including historical documents, experimental extensions, etc.), I think both have a place and the relation will not be confusing.

4614bis is a handbook to the current fragmented core specification, plus a slew of other related things.  It will (hopefully!) also be done far sooner than 793bis :).

---

From: Wesley Eddy <[email-masked]>
Date: Wed, 23 Oct 2013 13:22:17 -0400

On 10/23/2013 10:54 AM, Duke, Martin wrote:
> So is your intent to have 793 focus on the minimum interoperable
> spec, or incorporate widely deployed-yet-optional features like
> SACK?

The changes I was able to brainstorm that should be made from 793
(as noted in the internet-draft) are:

   1.   incorporate the accepted errata
   2.   incorporate 1122 additions
   3.   point to major additional docs like 1323bis and 5681
   4.   incorporate relevant parts of 3168 (ECN)
   5.   incorporate 6093 (urgent pointer)
   6.   incorporate 6528 (sequence number)
   7.   incorporate Fernando's new number-checking fixes (if past the
        IESG in time)
   8.   point to PMTUD?
   9.   point to 5461 (soft errors)
   10.  mention 5961 state machine option
   11.  mention 6161 (reducing TIME-WAIT)
   12.  incorporate 6429 (ZWP/persist)
   13.  incorporate 6691 (MSS)

Note that I marked some things as "incorporate", while others
are only "point to" or "mention".

-- 
Wes Eddy
MTI Systems

---

From: Hagen Paul Pfeifer <[email-masked]>
Date: Thu, 24 Oct 2013 23:43:04 +0200

>   7.   incorporate Fernando's new number-checking fixes (if past the

Yes

>   13.  incorporate 6691 (MSS)

What about 3390 and 6928?