Subject: [tcpm] Congestion Window Validation

From: Martin Winbjörk <[email-masked]>
Date: Fri, 31 Jan 2014 09:54:03 +0000

Hello

My name is Martin Winbjörk and I am a student at Luleå University of Technology. I am currently writing my master thesis "TCP Optimized for Wireless Access" at Ericsson in Sweden, Luleå. In the thesis I am evaluating different TCP enhancements and Congestion Window Validation is one of them.

I have a question regarding section 4.4 on page 9 where it is stated "A cwnd-limited sender uses the standard TCP method to increase cwnd (i.e. a TCP sender that fully utilises the cwnd is permitted to increase cwnd each received ACK)." I don't fully understand when this scenario can occur in the non-validated phase?

On the same page I found what appears to be two typos.
"reducing the cwnd as defined in section 4.3.1" should be "reducing the cwnd as defined in section 4.4.1"?
"The resulting reduction of cwnd described in section 4.3.2 is appropriate, since any accumulated path history is considered unreliable" should be "The resulting reduction of cwnd described in section 4.4.2 is appropriate, since any accumulated path history is considered unreliable"?

I also have a request regarding an equation on page 11.
May "cwnd = max(1/2*cwnd, IW)" have parentheses added around 1 / 2 for added clarity?

Regards
Martin Winbjörk

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 31 Jan 2014 06:20:44 -0500

I contacted Martin, who confirmed he is referring to version 04 of the 
document:
     http://datatracker.ietf.org/doc/draft-ietf-tcpm-newcwv/

Comments inline:

On 1/31/14, 4:54 AM, Martin Winbjörk wrote:
>
> Hello
>
> My name is Martin Winbjörk and I am a student at Luleå University of 
> Technology. I am currently writing my master thesis "TCP Optimized for 
> Wireless Access" at Ericsson in Sweden, Luleå. In the thesis I am 
> evaluating different TCP enhancements and Congestion Window Validation 
> is one of them.
>
> I have a question regarding section 4.4 on page 9 where it is stated 
> "A cwnd-limited sender uses the standard TCP method to increase cwnd 
> (i.e. a TCP sender that fully utilises the cwnd is permitted to 
> increase cwnd each received ACK)." I don't fully understand when this 
> scenario can occur in the non-validated phase?
>
> "The resulting reduction of cwnd described in section 4.3.2 is 
> appropriate, since any accumulated path history is considered 
> unreliable" should be "The resulting reduction of cwnd described in 
> section 4.4.2 is appropriate, since any accumulated path history is 
> considered unreliable"?
>
I agree with Martin, it appears the sections were altered between 
draft-02 and draft-03 but the changes were not passed through the entire 
document.

Additionally, at the bottom of Page 12 has a similar mention to section 
4.3.2 which should be changed to 4.4.2

> May "cwnd = max(1/2*cwnd, IW)" have parentheses added around 1 / 2 for 

I agree with his comments on the parentheses added around (1/2) in 
section 4.4.3, as this seems to be done elsewhere in the document as such.

> Regards
>
> Martin Winbjörk
>
>
>
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm