Subject: [tcpm] Draft agenda for London

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Thu, 13 Feb 2014 09:23:51 +0000

Hi all,

Please find below the first draft for the TCPM agenda in London. Since we received a request for an exceptionally long presentation, we decided to ask for a second TCPM time slot. We plan to discuss the WG drafts in the Thursday slot, while spending the Monday slot on individual submissions. Note that this is a tentative agenda and changes are still possible.

Please let the chairs know if you have any suggestions or if we missed something.

Thanks

Michael, Pasi, Yoshifumi

****** Draft Agenda ******

TCPM meeting, IETF-89, London, UK

Session 1: Monday, 0900-1130
============================

Individual Drafts
-----------------

* Making TCP more Robust to Packet Reordering
  draft-zimmermann-tcpm-reordering-detection
  draft-zimmermann-tcpm-reordering-reaction
  Alexander Zimmermann
  30 min

* Simpler and reordering resilient loss recovery
  (no draft)
  Yuchung Cheng
  20 min

* tcpcrypt: the case for ubiquitous transport-level encryption
  draft-bittau-tcp-crypt
  Andrea Bittau
  60 min

Session 2: Thursday, 1300-1500
==============================

WG Status
---------

* TCPM status
  Chairs
  10 min

Working Group Items
-------------------

* TCP Roadmap
  draft-ietf-tcpm-tcp-rfc4614bis
  Alexander Zimmermann
  10 min

* Updating TCP to support Rate-Limited Traffic
  draft-ietf-tcpm-newcwv-05
  Gorry Fairhurst
  20 min 
  
* TCP and SCTP RTO Restart
  draft-ietf-tcpm-rtorestart-01
  Per Hurtig
  15 min
  
* Problem Statement and Requirements for a More Accurate ECN Feedback
  draft-ietf-tcpm-accecn-reqs-05
  Mirja Kuehlewind
  5 min

Individual Drafts
-----------------

* More Accurate ECN Feedback Solutions
  draft-kuehlewind-tcpm-accurate-ecn
  draft-kuehlewind-tcpm-accurate-ecn-option
  Richard Scheffenegger
  10 min

* Timestamp negotiation and Clock exposure
  draft-trammell-tcpm-timestamp-interval
  draft-scheffenegger-tcpm-timestamp-negotiation
  Richard Scheffenegger
  15 min

---

From: Yuchung Cheng <[email-masked]>
Date: Thu, 13 Feb 2014 15:32:53 -0800

On Feb 13, 2014 1:24 AM, "Scharf, Michael (Michael)" <
[email-masked]> wrote:
>
> Hi all,
>
> Please find below the first draft for the TCPM agenda in London. Since we
received a request for an exceptionally long presentation, we decided to
ask for a second TCPM time slot. We plan to discuss the WG drafts in the
Thursday slot, while spending the Monday slot on individual submissions.
Note that this is a tentative agenda and changes are still possible.
> Session 1: Monday, 0900-1130
This draft was presented in Prague and Vancouver. Is this an update based
on the feedbacks from prior meetings?

> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: [email-masked]
Date: Fri, 14 Feb 2014 07:38:37 -0000

I think it would be good to understand why there is a 60 minute talk on
something where the text has not changed at all since the last meeting.

Gorry

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 14 Feb 2014 08:27:08 +0000

Very valid question. I was told that the draft will be updated.

Some background: Given some interest in MPTCP, we thought that a technical discussion on tcpcrypt could make sense. However, due to additional WG conflicts, we realized that for this we actually need a second (very short) TCPM slot. Surprisingly, we then ended up with a much longer slot than what we asked for. As a result, and as noted earlier on this list, we actually have plenty of meeting time in London - more than we asked for. Now, since there was no shortage of time, we finally decided to approve the author's request of 60 min even if it significantly exceeds what TCPM is used to grant. So far, we also approved all other presentation requests with at least the requested time. Within the usual single TCPM slot, a 60 min request would not have been approved.

Having said this, the agenda is tentative, and feedback is welcome.

Michael

________________________________________
Von: [email-masked] [[email-masked]]
Gesendet: Freitag, 14. Februar 2014 08:38
Bis: Yuchung Cheng
Cc: Scharf, Michael (Michael); [email-masked]; [email-masked] Extensions
Betreff: Re: [tcpm] Draft agenda for London

Gorry

---

From: <[email-masked]>
Date: Fri, 14 Feb 2014 10:45:40 +0100

Hi all,
If that sounds like "we have time left for other discussion" I may propose to spend some time on the very recent and partially controversial opinion exchange on the host_id/NAT header modification issue described in draft-williams-exp-tcp-host-id-opt-01.txt - just to quote the most recent ML contribution to be found here: http://www.ietf.org/mail-archive/web/tcpm/current/msg08568.html. 
I am interested in the topic also because of other activities such as HIAPS https://www.ietf.org/mailman/listinfo/hiaps 

What do you think?
Or have I missed something?
My 2 cents
Best regards
Dirk

-----Original Message-----
From: tcpm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Michael)
Sent: Freitag, 14. Februar 2014 09:27
To: [email-masked]; Yuchung Cheng
Cc: [email-masked]; [email-masked] Extensions
Subject: Re: [tcpm] Draft agenda for London

Michael

I think it would be good to understand why there is a 60 minute talk on something where the text has not changed at all since the last meeting.

Gorry

> received a request for an exceptionally long presentation, we decided 
> to ask for a second TCPM time slot. We plan to discuss the WG drafts 
> in the Thursday slot, while spending the Monday slot on individual submissions.
>> Please let the chairs know if you have any suggestions or if we 
>> missed
> something.
>>
>> Thanks
>>
>> Michael, Pasi, Yoshifumi
>>
>>
>>
> This draft was presented in Prague and Vancouver. Is this an update 
> based on the feedbacks from prior meetings?
>
>
>>
>>

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 14 Feb 2014 10:38:36 +0000

Hi Dirk,

Does Deutsche Telekom plan to deploy this option in their network? If so, could you perhaps provide details on the deployment and its use to the TCPM community (on the mailinglist)?

The TCPM community has asked explicitly which vendors and network operators would indeed use this option in products, and, for what. Without further details, I do not understand what benefit a face-to-face discussion would have.

Thanks

Michael

________________________________________
Von: [email-masked] [[email-masked]]
Gesendet: Freitag, 14. Februar 2014 10:45
Bis: Scharf, Michael (Michael); [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [tcpm] Draft agenda for London

Hi all,

What do you think?

-----Original Message-----
From: tcpm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Michael)
Sent: Freitag, 14. Februar 2014 09:27
To: [email-masked]; Yuchung Cheng
Cc: [email-masked]; [email-masked] Extensions
Subject: Re: [tcpm] Draft agenda for London

Michael

Gorry

---

From: Joe Touch <[email-masked]>
Date: Fri, 14 Feb 2014 03:41:04 -0800

FWIW, given this has already been presented *twice* before, and there is 
no current indication of a significant change in the approach, there is 
absolutely no justification for a full hour's time - regardless of how 
much has been given to TCPM.

Time slots not only consume a WG's meeting time, but they prevent 
attendees from participating in other WGs (even if not 'conflicting' as 
far as the authors or WG chairs are concerned), or using valuable 
face-to-face time in other ways.

Joe

---

From: <[email-masked]>
Date: Fri, 14 Feb 2014 14:28:30 +0100

Hi Michael,
Thanks for the question: As far as I know my company does not have such plans - my interest is more an academic one being from research entity T-Labs.
In that sense I am eager to discuss aspects of 'reality check' for deployment of protocols making use of host_id or similar features which may help to improve a service (e.g. emergency caller location) while bearing danger of misuse (observation, tracking) and how to prevent that ...
Sorry for having raised unintended expectations potentially ;-(

Best regards
Dirk

-----Original Message-----
From: Scharf, Michael (Michael) [mailto:[email-masked]] 
Sent: Freitag, 14. Februar 2014 11:39
To: von Hugo, Dirk; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [tcpm] Draft agenda for London

Hi Dirk,

Thanks

Michael

Hi all,

What do you think?

-----Original Message-----
From: tcpm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Michael)
Sent: Freitag, 14. Februar 2014 09:27
To: [email-masked]; Yuchung Cheng
Cc: [email-masked]; [email-masked] Extensions
Subject: Re: [tcpm] Draft agenda for London

Michael

Gorry

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 14 Feb 2014 13:52:18 +0000

Hi Dirk,

TCPM is an I*E*TF working group. As such, we we wonder whether there is an engineering need for TCPM standardization of an option, e.g., instead of an individual document.

One (potential) motivation for spending TCPM cycles would be a clear need for interoperability between different entities (e.g., products from multiple vendors), combined with the willingness to contribute to TCPM standardization and a high likelyhood of (commercial/Internet-scale) adoption of a TCPM standard, e.g., as replacement of existing proprietary solutions.

Thanks

Michael

________________________________________
Von: [email-masked] [[email-masked]]
Gesendet: Freitag, 14. Februar 2014 14:28
An: Scharf, Michael (Michael); [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [tcpm] Draft agenda for London

Hi Michael,

Best regards
Dirk

-----Original Message-----
From: Scharf, Michael (Michael) [mailto:[email-masked]]
Sent: Freitag, 14. Februar 2014 11:39
To: von Hugo, Dirk; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [tcpm] Draft agenda for London

Hi Dirk,

Thanks

Michael

Hi all,

What do you think?

-----Original Message-----
From: tcpm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Michael)
Sent: Freitag, 14. Februar 2014 09:27
To: [email-masked]; Yuchung Cheng
Cc: [email-masked]; [email-masked] Extensions
Subject: Re: [tcpm] Draft agenda for London

Michael

Gorry

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Fri, 14 Feb 2014 14:38:00 +0000

Hi Joe,

Point taken.

Regarding your concern on waste of time: I explicitly scheduled this presentation at the end of one of the TCPM slots - and before lunch. For instance, TCPM contributors can leave the room and attend other sessions after the first talks, if they prefer to do so (not that I want to recommend this). And, on purpose, we do not discuss any WG items in this slot; as a side note, the other slot is more friendly to remote participants in North America, since we typically have some participants there. In addition, please note that we have not reduced any other time slot request.

I really tried to come up with a scheduling that is reasonable and fulfills all external constraints I had to deal with. In some sense, the only persons who *have* to attend this session the TCPM chairs ;)

But, again, point taken, it is a draft agenda, and I share it as early as possible to enable agenda bashing.

Michael

________________________________________
Von: Joe Touch [[email-masked]]
Gesendet: Freitag, 14. Februar 2014 12:41
An: Scharf, Michael (Michael); [email-masked]; Yuchung Cheng
Cc: [email-masked]; [email-masked] Extensions
Betreff: Re: [tcpm] Draft agenda for London

Joe

---

From: "Eggert, Lars" <[email-masked]>
Date: Mon, 17 Feb 2014 15:36:41 +0000

Hi,

> * Simpler and reordering resilient loss recovery

is there *any* material available that we could look at, in order to get some insight before the meeting?

Lars

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Mon, 17 Feb 2014 15:53:27 +0000

For what it is worth: I have already asked all presenters scheduled for Monday to provide their slides until Wednesday Feb. 26, in order to allow upload to the meeting material page and thus early review by the TCPM community.

For this specific talk the presenter has provided an abstract that seemed of interest to the TCPM community.

Michael

> From: Eggert, Lars [mailto:[email-masked]]
> Sent: Monday, February 17, 2014 4:37 PM
> To: Scharf, Michael (Michael)
> Cc: [email-masked]; [email-masked]
> On 2014-2-13, at 10:23, Scharf, Michael (Michael)
> <[email-masked]> wrote:

---

From: Brandon Williams <[email-masked]>
Date: Tue, 18 Feb 2014 12:25:01 -0500

Hi Michael,

I can see that the schedules for both sessions are already quite full. 
That said, if there is any flexibility in the schedule for Monday's 
"Individual Drafts" session and if people on the list think that it 
would be a reasonable use of the time, we would be happy to prepare a 
short presentation focused on use-cases and vendor interoperability for 
the HOST_ID option. Our goal would be to facilitate discussion on 
whether or not it makes sense for us to pursue tcpm adoption of the 
I.D., as opposed to publishing the draft under individual contributor 
guidelines. If we give such a presentation, I think it would be about 20 
minutes worth of discussion.

If the time isn't available or attendees don't think that the time would 
be well spent, then I'll continue with my current plan of trying to get 
a bit of between-meeting facetime with the handful of people who have 
contributed the most to this discussion on the list.

Thanks,
--Brandon

-- 
Brandon Williams; Senior Principal Software Engineer
Emerging Products Engineering; Akamai Technologies Inc.

---

From: "Scharf, Michael (Michael)" <[email-masked]>
Date: Tue, 18 Feb 2014 19:41:03 +0000

Hi Brandon,

Our agenda is pretty full. Given the list discussion so far, I believe that an informal side meeting would make more sense (if somebody strongly disagrees with this, please speak up!). I guess nobody will prevent you from posting time and place on this list, if you wish that.

I'd be interested in attending a side meeting in order to better understand the use cases and vendor interoperability needs.

Thanks

Michael

> From: Brandon Williams [mailto:[email-masked]]
> Sent: Tuesday, February 18, 2014 6:25 PM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; Dan Wing;
> [email-masked]
> > TCPM is an I*E*TF working group. As such, we we wonder whether there
> is an engineering need for TCPM standardization of an option, e.g.,
> instead of an individual document.
> >
> > One (potential) motivation for spending TCPM cycles would be a clear
> need for interoperability between different entities (e.g., products
> from multiple vendors), combined with the willingness to contribute to
> TCPM standardization and a high likelyhood of (commercial/Internet-
> scale) adoption of a TCPM standard, e.g., as replacement of existing
> proprietary solutions.
> >
> > Thanks
> >
> > Michael
> >
> > Thanks for the question: As far as I know my company does not have
> such plans - my interest is more an academic one being from research
> entity T-Labs.
> > In that sense I am eager to discuss aspects of 'reality check' for
> deployment of protocols making use of host_id or similar features which
> may help to improve a service (e.g. emergency caller location) while
> bearing danger of misuse (observation, tracking) and how to prevent
> that ...
> > Does Deutsche Telekom plan to deploy this option in their network? If
> so, could you perhaps provide details on the deployment and its use to
> the TCPM community (on the mailinglist)?
> >
> > The TCPM community has asked explicitly which vendors and network
> operators would indeed use this option in products, and, for what.
> Without further details, I do not understand what benefit a face-to-
> face discussion would have.
> >
> > Thanks
> >
> > Michael
> >
> >
> > If that sounds like "we have time left for other discussion" I may
> propose to spend some time on the very recent and partially
> controversial opinion exchange on the host_id/NAT header modification
> issue described in draft-williams-exp-tcp-host-id-opt-01.txt - just to
> quote the most recent ML contribution to be found here:
> http://www.ietf.org/mail-archive/web/tcpm/current/msg08568.html.
> > I am interested in the topic also because of other activities such as
> HIAPS https://www.ietf.org/mailman/listinfo/hiaps
> >
> > What do you think?
> > Some background: Given some interest in MPTCP, we thought that a
> technical discussion on tcpcrypt could make sense. However, due to
> additional WG conflicts, we realized that for this we actually need a
> second (very short) TCPM slot. Surprisingly, we then ended up with a
> much longer slot than what we asked for. As a result, and as noted
> earlier on this list, we actually have plenty of meeting time in London
> - more than we asked for. Now, since there was no shortage of time, we
> finally decided to approve the author's request of 60 min even if it
> significantly exceeds what TCPM is used to grant. So far, we also
> approved all other presentation requests with at least the requested
> time. Within the usual single TCPM slot, a 60 min request would not
> have been approved.
> >
> > I think it would be good to understand why there is a 60 minute talk
> on something where the text has not changed at all since the last
> meeting.
> >
> > Gorry
> >