Subject: [tcpm] TCP Tail Loss Probe

From: Martin Winbjörk <[email-masked]>
Date: Fri, 28 Feb 2014 14:25:56 +0000

Hi

I have a question regarding the draft for Tail Loss Probe found on the following link
http://tools.ietf.org/html/draft-dukkipati-tcpm-tcp-loss-probe-01

What is the status of the draft? It has expired on August 29 2013. Is it still relevant and updated or has it been abandoned or continued elsewhere?

Regards
Martin Winbjörk

---

From: "Scheffenegger, Richard" <[email-masked]>
Date: Fri, 28 Feb 2014 18:04:47 +0000

Hi Martin,

I hope that work hasn't been abandoned.

For one, I would like this work being formally adopted as a TCPM item and discussed, as this mechanism would address some of the problems that I wanted addressed, which can be summarized as TCP HOL blocking latency.

Now that 1323bis is asymptotically nearing publication, I also want to revive some work that got me started with Timestamps. That work was also related to loss-related latency in TCP, but dealing with lost retransmissions (and the non-ambiguous detection that a retransmission was lost).

If time permits, I want to give a short overview of that work, even though the current (expired) drafts don't include things learned during the discussions of 1323bis:

http://tools.ietf.org/html/draft-scheffenegger-tcpm-timestamp-negotiation-05
http://tools.ietf.org/html/draft-trammell-tcpm-timestamp-interval-01

And ideally also the way Linux currently recovers from lost retransmissions (even though the scheme making use of a modified TS sematic does not incur unnecessary latency, or fails at the end-of-stream).

Best regards,

Richard Scheffenegger

From: tcpm [mailto:[email-masked]] On Behalf Of Martin Winbjörk
Sent: Freitag, 28. Februar 2014 15:26
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: Ingemar Johansson S
Subject: [tcpm] TCP Tail Loss Probe

Hi

Regards
Martin Winbjörk

---

From: Yuchung Cheng <[email-masked]>
Date: Fri, 28 Feb 2014 10:35:00 -0800

On Fri, Feb 28, 2014 at 6:25 AM, Martin Winbjörk
<[email-masked]> wrote:
> What is the status of the draft? It has expired on August 29 2013. Is it
> still relevant and updated or has it been abandoned or continued elsewhere?
Hi Martin,

The feedback on tcpm after several meetings was although it is solving
an important problem, 1) it is fairly complicated and 2) it relies on
FACK which is not standardized.

Therefore I and the other co-authors are working on a simpler solution
with much wider scope: a new framework to encompass a dozen of
heuristics developed in the last two decades: RFC3517, FACK, TLP,
F-RTO, traditional RTO, lost retransmit, dynamic dupthresh for
reordering, early retransmit etc. The underlying idea is to replace
packet counter notion (e.g. 3 dupacks) with time. Allow fast timeout &
recovery if network is still responsive, and only reset cwnd to 1
under extended silence. I was originally going to talk about this idea
in this tcpm but have to cancel the trip  in the last minute.

Anyways, we are hopeful to come up a newer draft that subsumes TLP
(and many other heuristics) and an implementation all together latter
this year.