Subject: [tcpm] new tcpcrypt draft available

From: Andrea Bittau <[email-masked]>
Date: Sun, 16 Feb 2014 14:47:52 -0800

Hi,

For those interested, we posted a revised version of the tcpcrypt
draft (opportunistic TCP encryption):

http://www.ietf.org/id/draft-bittau-tcp-crypt-04.txt

This will be discussed on Monday morning in tcpm, at the end of
Session 1 (09:00--11:30).

All comments are welcome, including any points that you'd like us to
address in our presentation.

thanks!

---

From: Joe Touch <[email-masked]>
Date: Sun, 16 Feb 2014 18:12:28 -0800

It would be useful to post a summary of changes to this list. 

> On Feb 16, 2014, at 2:47 PM, Andrea Bittau <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> tcpm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tcpm

---

From: Andrea Bittau <[email-masked]>
Date: Mon, 17 Feb 2014 21:46:32 -0800

Main changes, in no particular order:

1.  Support key agreement (ECDHE) as opposed to only key transport (RSA).
2.  Express the symmetric crypto in terms of authenticated encryption.
3.  Rationale for various design decisions.
4.  Define crypto requirements specific to TCP setting.
5.  IANA considerations for option number assignment, and TCP registry.
6.  Security considerations.
7.  A bunch of edits and clarifications as per some reviews we have received.

---

From: Joe Touch <[email-masked]>
Date: Tue, 18 Feb 2014 10:19:01 -0800

So basically you've ignored input since the last presentation at the IETF.

Joe