Subject: Re: [Tools-discuss] draft-hixie-thewebsocketprotocol-100.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 02 Feb 2010 15:00:20 +1300

Version 73 has appeared. The current prediction for version 100
is still June 2010.

Regards
   Brian Carpenter

On 2009-12-05 08:45, Brian E Carpenter wrote:
> The current rate for this draft is one version per 4.4 days,
> so it looks like version 100 will appear around June 2010.
> 
> Version 00 appeared in January 2009, so extrapolating from
> then, we won't see version 100 until August 2010. But the
> rate appears to be accelerating...
> 
>     Brian
> 
>> -------- Original Message --------
>> Subject: I-D Action:draft-hixie-thewebsocketprotocol-60.txt
>> Date: Fri,  4 Dec 2009 03:45:02 -0800 (PST)
>> From: [email-masked]
>> Reply-To: [email-masked]
>> To: [email-masked]
>>
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>>
>> 	Title           : The Web Socket protocol
>> 	Author(s)       : I. Hickson
>> 	Filename        : draft-hixie-thewebsocketprotocol-60.txt
>> 	Pages           : 38
>> 	Date            : 2009-12-04
> 
> 
> Regards
>    Brian Carpenter
> 
> 
> 
> 
> On 2009-10-23 00:33, Spencer Dawkins wrote:
>> I'm thinking that we should NOT fix the tools to accommodate three-digit
>> draft numbers, because if this happens even once, there are things that
>> are more broken than the tools...
>>
>> bernard pointed me to the excellent web page
>> http://www.arkko.com/tools/lifecycle/extremes.html a couple of days ago.
>> Words fail me.
>>
>> Spencer
>>
>>>> So, half way to the interesting case of someone trying to submit
>>>> a -100.txt draft. How many tools will that break, I wonder?
>>> It looks like the ID submission tool does check that revision
>>> is <= 99. And the database field for this has type 'CHAR(2)' anyway :-)
>>>
>>> (However, I think there are places that would break if someone
>>> managed to submit -99; so the check should be "<= 98"). 
>>
> 
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 02 Feb 2010 22:23:28 +0100

Hi Brian,

> Version 73 has appeared. The current prediction for version 100

Humm.

The easy workaround once we hit -99 is to submit a replacement draft
draft-hixie-thewebsocketprotocol-1-00.txt and carry on ...

But this prompted something else:

Curious as to what drives the draft to pass so swiftly through the
revisions, I started to look at the side-by-side diffs, and soon got
fed up with manually moving from one diff to another.  Accordingly
I added backwards and forwards links to the side-by-side diffs.  The
links are pretty simpleminded; they're added to the diff page whether
the next and previous revisions are available or not; still, I hope
they will be of some use:

  http://tools.ietf.org/rfcdiff?url2=draft-hixie-thewebsocketprotocol-73.txt

Best,

	Henrik

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 2 Feb 2010 15:39:32 -0600

Hi, Henrik,

Speaking as a Gen-ART reviewer, I find this addition very helpful - it's not 
uncommon for a draft to be revved multiple times between the IETF Last Call 
version (which Gen-ART looks at) and the version on an IESG telechat (which 
Gen-ART also looks at).

It's trivial enough for us to do a diff that shows us what we need to see 
(the diff between -08 and -11), but what you've added is simple enough to 
use that it invites reviewers to look at intermediate changes as well - and 
that's often useful when we're trying to understand what the community has 
been talking about during the review cycle.

Thanks,

Spencer

---

From: Tony Hansen <[email-masked]>
Date: Tue, 02 Feb 2010 16:56:49 -0500

nice addition!

---

From: Julian Reschke <[email-masked]>
Date: Tue, 02 Feb 2010 23:34:29 +0100

Henrik Levkowetz wrote:
> ...

The author submits *every single change* as Internet Draft.

Best regards, Julian

---

From: SM <[email-masked]>
Date: Tue, 02 Feb 2010 14:28:19 -0800

Hi Henrik,
>revisions, I started to look at the side-by-side diffs, and soon got

The author of that I-D has a commit script that uploads any changes 
to the draft to tools.ietf.org.

Regards,
-sm

---

From: Joe Touch <[email-masked]>
Date: Tue, 02 Feb 2010 15:03:53 -0800

SM wrote:
> The author of that I-D has a commit script that uploads any changes to
> the draft to tools.ietf.org.

It might be useful to ask him to have the script upload commits only
periodically (once a month?) or when explicitly asked, rather than for
every commit.

Joe

---

From: Julian Reschke <[email-masked]>
Date: Wed, 03 Feb 2010 00:18:44 +0100

> periodically (once a month?) or when explicitly asked, rather than for

Been there, done that. Try yourself. Good luck with that.

---

From: SM <[email-masked]>
Date: Tue, 02 Feb 2010 17:35:16 -0800

Hi Joe,
>periodically (once a month?) or when explicitly asked, rather than for

Several persons on the mailing list pointed out that it was not a 
good idea to submit a new version of the I-D every few days.  That 
was before the commit script was mentioned.  The author replied that 
he was just following a "release early release often" policy.

Regards,
-sm

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 2 Feb 2010 23:16:59 -0600

I do feel sorry for the ADs who might be trying to watch this, and I wish it 
wasn't a distraction for Henrik, but for the rest of us...

Without trying to be TOO snotty, it is helpful to have authors self-identify 
as people whose draft revisions you can safely ignore, because you're sure 
that another revision will come along in, oh, let's say 4 days :D

"release early release often" is brilliant when you have an automated test 
procedure catching the output. If it's just humans downstream, I'd say 
"semi-brilliant".

Spencer

> Several persons on the mailing list pointed out that it was not a good 
> idea to submit a new version of the I-D every few days.  That was before 
> the commit script was mentioned.  The author replied that he was just 
> following a "release early release often" policy.