Subject: Re: [Tools-discuss] Datatracker improvements for testing

From: <[email-masked]>
Date: Mon, 8 Feb 2010 12:40:55 +0100

Thanks for your comments!

I don't think we can get down to one view any time soon, but yes, the 
plan is to replace several current URLs with redirects. This includes 
at least these URLs on datatracker:

http://datatracker.ietf.org/drafts/draft-ietf-pce-pcep/
http://datatracker.ietf.org/drafts/draft-ietf-pce-pcep/related/
http://datatracker.ietf.org/idtracker/draft-ietf-pce-pcep/
http://datatracker.ietf.org/idtracker/ballot/2762/
(IESG only) https://datatracker.ietf.org/cgi-bin/idtracker.cgi?command=view_id&dTag=14049
(IESG only) https://datatracker.ietf.org/cgi-bin/idtracker.cgi?command=open_ballot&id_document_tag=14049

On www.ietf.org, I think we don't have anything except the plain text
(e.g. http://www.ietf.org/id/draft-ietf-6lowpan-hc-06.txt); that will
stay as-is.

Tools.ietf.org is a separate system, and I think Henrik wants to
continue maintaining it separately for the time being:

http://tools.ietf.org/wg/pce/draft-ietf-pce-pcep/
http://tools.ietf.org/html/draft-ietf-pce-pcep-19

Best regards,
Pasi

> -----Original Message-----
> From: [email-masked] [mailto:tools-discuss-
> [email-masked]] On Behalf Of ext Mark Nottingham
> Sent: 31 January, 2010 01:32
> To: Eronen Pasi (Nokia-NRC/Helsinki)
> Cc: [email-masked]
> Subject: Re: [Tools-discuss] Datatracker improvements for testing
> 
> These look fantastic.
> 
> My only feedback is that once these are deemed "live" (now?), the
> various other I-D URLs hosted on tools, datatracker and ietf.org should
> 301 redirect to them, so there's ONE view of this information, not
> (seemingly, sometimes) fifteen.
> 
> Cheers,
> 
> 
> On 27/01/2010, at 6:17 AM, <[email-masked]>
> <[email-masked]> wrote:
> 
> > Hi everyone,
> >
> > I'd like to invite everyone on the tools-discuss list to test the
> > upcoming datatracker improvements that Russ referred to recently:
> >
> > http://www.ietf.org/mail-archive/web/ietf-
> announce/current/msg06907.html
> >
> > Two starting points:
> >
> > o  The new search page (try searching for "nsis" for a good overview
> >   of new features):
> >   http://datatracker.ietf.org/doc/
> >
> >   This page will eventually replace at least three separate search
> >   interfaces in the current datatracker: /idtracker/, /drafts/, and
> >   the IESG tracker search page.
> >
> > o  New per-draft page:
> >   http://datatracker.ietf.org/doc/draft-ietf-csi-sndp-prob/
> >
> >   Here the goal is again to simplify the system, and replace at
> >   least three separate per-draft pages (one under /idtracker/,
> >   another under /drafts/, and third in the IESG tracker) with one
> >   page that shows all the information previously found on those
> >   separate pages (and has "edit" buttons if you're logged in
> >   as area director).
> >
> > As Russ noted, this code is developed by volunteers, so please send
> > bug reports, enhancement ideas, and other comments to this list, not
> > the IETF secretariat.
> >
> > (Note that if you have used this interface earlier, it might be
> > necessary to click "Reload" to clear old data from the cache.)
> >
> > Best regards,
> > Pasi
> > _______________________________________________
> > Tools-discuss mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> 
> --
> Mark Nottingham     http://www.mnot.net/
> 
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Feb 2010 23:18:38 +1100

OK. Would it be possible to also have

  http://datatracker.ietf.org/id/...

redirect to it? That way, if I'm on a www.ietf.org-hosted draft, I only need to replace 'www' with 'datatracker'...

Cheers,

---

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 8 Feb 2010 07:21:53 -0600

I don't want to put words in Mark's mouth, so he might not agree with this,
but I agree with my understanding of Mark's comment, which is,

"gee, no matter where *I* go, I want to have pretty much the same
capabilities as I have using the tools system".

As a Gen-ART reviewer, I usually want to know all kinds of things about a
draft that I'm reviewing - IESG evaluation record, shepherd writeup
(usually, but not automatically, cut-and-pasted into the ID tracker), e-mail
addresses to contact everyone who needs to see the review - we had that
conversation last week - links to previous versions and to diffs from
previous versions...

I'm really spoiled by the tools capability - so much so that when I click on
a URL that brings up bare ASCII text with no links, and that I can't even
get to the previous version(s) by editing the version number in the URL,
because that version has expired, I just sigh.

So ... having as many links as possible redirect, would be awesome :D

Thanks,

Spencer

> redirect to it? That way, if I'm on a www.ietf.org-hosted draft, I only
> need to replace 'www' with 'datatracker'...
>
> Cheers,
>
>
>> (IESG only)
>> https://datatracker.ietf.org/cgi-bin/idtracker.cgi?command=view_id&dTag=14049
>> (IESG only)
>> https://datatracker.ietf.org/cgi-bin/idtracker.cgi?command=open_ballot&id_document_tag=14049
>>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 9 Feb 2010 23:38:10 +1100

Agreed.

One other thing - it would be wonderful if the print CSS for the page would remove the navigation elements, and place page breaks appropriately. I know that the CSS for page breaks isn't terribly well-supported, but it would be nice to try...

(I can help with the CSS if needed)

Cheers,

---

From: Julian Reschke <[email-masked]>
Date: Tue, 09 Feb 2010 14:28:47 +0100

Mark Nottingham wrote:
> ...

I think forced page breaks work across UAs, and Henrik's 
http://tools.ietf.org/tools/rfcmarkup/ already does the right thing, so 
just steal from it's output.

Best regards, Julian