Subject: [Tools-discuss] searching for BCPs.

From: "David Harrington" <[email-masked]>
Date: Wed, 18 Aug 2010 21:20:10 -0400

Hi,

http://datatracker.ietf.org/doc/ gives me no options for searching for
BCPs.
http://www.rfc-editor.org/cgi-bin/rfcsearch.pl did allow this.

Can we add BCP and STD and FYI to the advanced search capabilities?
(I find that I often search for BCPs, when I want to see the
recommended way to do something.
I almost never search for STDs or FYIs)

dbh

---

From: Richard Barnes <[email-masked]>
Date: Wed, 18 Aug 2010 21:29:19 -0400

At least for BCPs, you can use the tools site,e.g.:
<http://tools.IETF.org/html/bcp38>

As for STDs, wasn't there consensus at the last IETF to get rid of those
numbers?  :)

On Aug 18, 2010 9:20 PM, "David Harrington" <[email-masked]> wrote:

Hi,

dbh

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "David Harrington" <[email-masked]>
Date: Thu, 19 Aug 2010 16:15:01 -0400

Hi,
 
There was discussion. I don't know if or when that will happen.
 
dbh

  _____  

From: Richard Barnes [mailto:[email-masked]] 
Sent: Wednesday, August 18, 2010 9:29 PM
To: David Harrington
Cc: [email-masked]; [email-masked]
Subject: Re: [Tools-discuss] searching for BCPs.

As for STDs, wasn't there consensus at the last IETF to get rid of
those numbers?  :)

On Aug 18, 2010 9:20 PM, "David Harrington" <[email-masked]>
wrote:

Hi,

dbh

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Aug 2010 06:42:36 -0500

Not speaking as anything except Russ's note-taker for the Wednesday night plenary, but "not at the plenary where *I* was taking notes".

What I was hearing in hallway discussions is that STDs that don't get assigned until you're at the third level of the current three-level maturity set might be worth getting rid of, but if you assign STD numbers at the first level (of any maturity set), that's a lot less obvious. If we had more protocols that qualified for STD numbers, we might very well use them more. So I didn't think they've been voted off the island yet.

I'm assuming that FYIs would come along for free, if you had BCPs and STDs already, without looking at the code for this. If that's not true, the most recent FYI was published in April 2001, which might account for the low usage rate by IETF participants who are not also archeologists ...

Spencer
  ----- Original Message ----- 
  From: David Harrington 
  To: 'Richard Barnes' 
  Cc: [email-masked] ; [email-masked] 
  Sent: Thursday, August 19, 2010 3:15 PM
  Subject: Re: [Tools-discuss] searching for BCPs.

  Hi,

  dbh

----------------------------------------------------------------------------
    From: Richard Barnes [mailto:[email-masked]] 
    Sent: Wednesday, August 18, 2010 9:29 PM
    To: David Harrington
    Cc: [email-masked]; [email-masked]
    Subject: Re: [Tools-discuss] searching for BCPs.
    As for STDs, wasn't there consensus at the last IETF to get rid of those numbers?  :)

---

From: Alice Hagens <[email-masked]>
Date: Mon, 30 Aug 2010 12:36:24 -0400

David,

> http://www.rfc-editor.org/cgi-bin/rfcsearch.pl did allow this.

The RFC Editor search engine (http://www.rfc-editor.org/rfcsearch.html a.k.a. http://www.rfc-editor.org/cgi-bin/rfcsearch.pl) does allow this. 

The default is to search all RFCs (including the sub-series STDs, BCPs, and FYIs).  In addition to searching by document number (e.g., BCP 9), you can search by title, keyword, and author name. Also, you can limit the search to a sub-series by selecting a button on the right.

Please let us know if a specific search of BCPs on http://www.rfc-editor.org/rfcsearch.html wasn't yielding the expected results.

Thank you.

RFC Editor/ah