Subject: [Tools-discuss] idnits error?

From: "Prakash Venkatesen, ERS-HCLTech" <[email-masked]>
Date: Fri, 22 Oct 2010 19:49:10 +0530

Hi,
I noticed an error in idnits found at http://tools.ietf.org/tools/idnits/.

When I did an idnits check for the attached file draft-ietf-storm-ifcpmib-06.txt, I got the error
  Checking references for intended status: Proposed Standard
  ----------------------------------------------------------------------------

     (See RFCs 3967 and 4897 for information about using normative references
     to lower-maturity documents in RFCs)

  ** Downref: Normative reference to an Informational RFC: RFC 3410

When I did the check with draft-ietf-storm-ifcpmib-07.txt, I did not get the error.

The difference between these 2 files is that I added the following line at the start of the last page:
   [OneRef]  One more reference to prevent the error
              XXXXX

The idnits error seems to be that if the section "Informative References" comes at the start of a page, idnits ignores it and treats the following references as normative references. The work around is to make sure that this section does not come at the start of the page - possibly by adding a dummy reference.

Can you please look into this?

regards
Prakash

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only. 
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates. 
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have 
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 25 Oct 2010 01:02:32 +0200

Hi Prakash

On 2010-10-22 16:19 Prakash Venkatesen, ERS-HCLTech said the following:

> The idnits error seems to be that if the section "Informative
> References" comes at the start of a page, idnits ignores it and
> treats the following references as normative references. The work
> around is to make sure that this section does not come at the start
> of the page - possibly by adding a dummy reference.

Your observations are correct, but your guess at the reason for the error
partially incorrect...  During the processing, in order to handle some
cases correctly, idnits strips out the page headers and footers, and re-
connects broken paragraphs.  One of the cases which needs this is the
identification of boilerplate text (but there are others).  Since your
text at the end of the previous page (your comments starting flush left
with '--') end without terminating punctuation, idnits guesses that this
is an incomplete paragraph, and connects it up with the first blank-line
delimited text on the next page.

All you need to avoid the problem is to terminate your instructions
to the RFC editor with a period sign.

(A more common formatting of the note to the RFC Editor would be
something like the following; but that's just FYI; it's not related
to the problem at hand...

...

   (Note to the RFC Editor: please replace yyyy with the RFC number
   assigned to draft-ietf-storm-ifcp-ipn133-updates, replace mmyy
   with the RFC month and year assigned to
   draft-ietf-storm-ifcp-ipn133-updates & remove this note.)

...
)

> Can you please look into this?

Certainly.  See above :-)

	Henrik