Subject: [Tools-discuss] idnits 2.12.05 vs. pre5378Trust200902

From: =JeffH <[email-masked]>
Date: Fri, 08 Oct 2010 10:36:07 -0700

idnits 2.12.05 says the following about draft-ietf-httpstate-cookie-14..

   == You're using the IETF Trust Provisions' Section 6.b License Notice from
      12 Sep 2009 rather than the newer Notice from 28 Dec 2009.  (See
      http://trustee.ietf.org/license-info/)

though, Julian Reschke <[email-masked]> said on Thu, 01 Apr 2010 
17:33:41 +0200:
 >
 > On 01.04.2010 17:07, Paul Hoffman wrote:
 >> At 4:54 PM +0200 4/1/10, Julian Reschke wrote:
 >>> Clarifying: there are no new values for the @ipr attribute, both xml2rfc
 >>> and rfc2629.xslt just pick the right boilerplate based on the document's
 >>> publication date.
 >>>
 >>> See
 >>> <http://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#attribute-ipr>.
 >>
 >> For quite some time, the common advice has been "if your doc might have 
some text from before 2008-11-10,  just use 'pre5378Trust200902' as the @ipr 
attribute value". How does the new version change the processing of drafts with 
this value?
 >
 > It doesn't; the "pre5378" escape clause is generated just like before,
 > but now according to TLP 4.0, not TLP 3.0 or 2.0.

So is what's in the draft correct, and idnits is just being needlessly picky?

thanks,

=JeffH

---

From: Julian Reschke <[email-masked]>
Date: Fri, 08 Oct 2010 19:55:58 +0200

Hi,

I just chatted with Jeff, and checked what went wrong.

Apparently, the XML source is correct, but the TXT version was generated 
with an outdated version of xml2rfc (the latest is 1.35, but 1.34 
probably would have been good enough as well).

Best regards, Julian

On 08.10.2010 19:36, =JeffH wrote:
>  >> For quite some time, the common advice has been "if your doc might
> have some text from before 2008-11-10, just use 'pre5378Trust200902' as
> the @ipr attribute value". How does the new version change the
> processing of drafts with this value?
>  >
> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>