Subject: Re: [Tools-discuss] Gitlab?

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Tue, 15 Sep 2015 20:50:15 +0000

On 2015-09-07T20:28Z, Brian E Carpenter wrote:

> On 08/09/2015 08:00, Carsten Bormann wrote:
> > Again, there is some rebellion among the CoRE authors about us using an
> > SVN-based repo for WG work.
> >
> > Of course, github is great, but it means that issue tracking and the
> > discussion threads on these issues are kept outside the control of the IETF.

> If you're running a repo for IETF work, I think you need to cite the IETF Note Well
> in the readme. I included the following line:
> This repository is for an IETF effort and falls under IETF rules: 
> see http://www.ietf.org/about/note-well.html

On GitHub, one of the best places to put this is in a CONTRIBUTING.md file.  A link to that file will be shown whenever you send a pull request or file an issue.

https://github.com/blog/1184-contributing-guidelines

I'm checking with my GitHub contacts to see if there's a way to enforce acknowledgement of the guidelines.

> > Has there been any endeavor to set up a Gitlab instance for the IETF?
> > Many enlightened organizations in the German academics space now have
> > one. (And, no, you don't have to use the for-money version; the
> > "community edition" is just right.)

> Agreed, that would be helpful.

I'm not convinced.  If the main thing we need is Note Well protection, we can see if there's a better way to accomplish that.  If we need to do integration so that mailers get notified when issues are filed, that's no more difficult on GitHub than it would be in Gitlab.

Having yet another complicated server to keep up to date and secure sounds expensive in the medium term, and I want to make sure we justify the need adequately.

-- 
Joe Hildebrand

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 Sep 2015 10:39:40 -0700

> Having yet another complicated server to keep up to date and secure sounds expensive in the medium term, and I want to make sure we justify the need adequately.

I'm going to take a stronger position than Joe.  Running your own
server is wasteful.  You don't need that here; a distributed version
control system means that you aren't truly beholden to github, because
the service they provide is largely limited to convenience.

There is one exception to that: issues.  I have a tool that downloads
them, but they aren't especially accessible in the form that that
produces.

Joe, I think that your contacts might be better pressed into
converting issues into a git repository/branch.  Then we will have a
proper distributed store of all the critical information.  I've looked
several times, but I couldn't find where to register the request.

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Fri, 25 Sep 2015 18:12:54 +0000

I assume you want each issue to be stored as a directory, with a file for the issue and a file for each comment, on a gh-issues branch?

gh-issues/
  issue-0/
    issue.md
    comment-0/
      comment.md
        comment-1/
          Comment.md

Etc. (note the nested comments)

-- 
Joe Hildebrand

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Sep 2015 20:13:26 +0200

> the service they provide is largely limited to convenience.

Elephant in the room: I'd like to understand how the subpoena process
works in a distributed system like this.

Grüße, Carsten

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 Sep 2015 12:18:10 -0700

I don't think that we need to prescribe a specific design, but something
like that might work.
On Sep 25, 2015 11:12 AM, "Joe Hildebrand (jhildebr)" <[email-masked]>
wrote:

> I assume you want each issue to be stored as a directory, with a file for
> the issue and a file for each comment, on a gh-issues branch?
>
> gh-issues/
>   issue-0/
>     issue.md
>     comment-0/
>       comment.md
>         comment-1/
>           Comment.md
>
> >> Having yet another complicated server to keep up to date and secure
> sounds expensive in the medium term, and I want to make sure we justify the
> need adequately.
> >

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Fri, 25 Sep 2015 19:19:58 +0000

Understood.  I wanted to have a way to describe our requirements in concrete terms.  Also, we may be able to prototype this using their webhooks API.

-- 
Joe Hildebrand

On 9/25/15, 3:18 PM, "Martin Thomson" <[email-masked]> wrote:

>I don't think that we need to prescribe a specific design, but something like that might work.
>On Sep 25, 2015 11:12 AM, "Joe Hildebrand (jhildebr)" <[email-masked]> wrote:
>
>    issue.md <http://issue.md>
>    comment-0/
>      comment.md <http://comment.md>
>        comment-1/
>          Comment.md
>

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 Sep 2015 12:23:16 -0700

> works in a distributed system like this.

If you think that that is an important use case to support, it is trivial
to create a copy for the purposes of being a subpoena target. Much easier
than maintaining a copy that is required to support the whole experience.

Also, as I think more about this, installing a dedicated server would have
more negative consequences than mere waste. You also lose access to the
Github community, which would be a big loss in my experience.

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 Sep 2015 12:24:14 -0700

I didn't think of that, it is an interesting idea.
On Sep 25, 2015 12:19 PM, "Joe Hildebrand (jhildebr)" <[email-masked]>
wrote:

> Understood.  I wanted to have a way to describe our requirements in
> concrete terms.  Also, we may be able to prototype this using their
> webhooks API.
>
> --
> Joe Hildebrand
>
>
>
>
>
>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 25 Sep 2015 18:48:12 -0400

> them, but they aren't especially accessible in the form that that

Have you taken a look at Joey Hess's github-backup ?

 https://github.com/joeyh/github-backup

 --dkg

---

From: Martin Thomson <[email-masked]>
Date: Fri, 25 Sep 2015 15:56:41 -0700

>  https://github.com/joeyh/github-backup

I have now.  It looks like exactly what was requested.