Subject: [Tools-discuss] Gitlab?

From: Carsten Bormann <[email-masked]>
Date: Mon, 07 Sep 2015 22:00:36 +0200

Again, there is some rebellion among the CoRE authors about us using an
SVN-based repo for WG work.

Of course, github is great, but it means that issue tracking and the
discussion threads on these issues are kept outside the control of the IETF.

Has there been any endeavor to set up a Gitlab instance for the IETF?
Many enlightened organizations in the German academics space now have
one.  (And, no, you don't have to use the for-money version; the
"community edition" is just right.)

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 8 Sep 2015 08:28:51 +1200

> discussion threads on these issues are kept outside the control of the IETF.

If you're running a repo for IETF work, I think you need to cite the IETF Note Well
in the readme. I included the following line:
This repository is for an IETF effort and falls under IETF rules: see http://www.ietf.org/about/note-well.html

> "community edition" is just right.)

Agreed, that would be helpful.

    Brian