Subject: [Tools-discuss] idnits 2.16.03

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Mar 2020 12:59:06 +0100

I see that there is an idnits 2.16.03, and it seems to work for me (better than 2.16.02, which complains about corrupt reference info everywhere).

However, I can’t find any release notes — where do I look for them?

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 5 Mar 2020 14:34:27 +0100

> However, I can’t find any release notes — where do I look for them?

In the release note, of course and here: 

  https://tools.ietf.org/tools/idnits/changelog

Regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Mar 2020 15:31:12 +0100

Hi Henrik,

On 2020-03-05, at 14:34, Henrik Levkowetz <[email-masked]> wrote:
> 
> In the release note, of course

Where do these go?

> and here: 

Hidden in plain sight :-)  Thank you!

(I submitted an update request to the homebrew entry for idnits:
https://github.com/Homebrew/homebrew-core/pull/51155
.)

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 5 Mar 2020 15:45:33 +0100

Hi Carsten,

>> In the release note, of course

Hmm.  Currently only to AMS people who might want to update server
installations.  I could easily expand the recipient list.  Suggestions?

> https://github.com/Homebrew/homebrew-core/pull/51155

Ack.  FWIW, once we're past IETF 107, I hope to complete the rewrite
to python, and make that available on PyPi.

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Mar 2020 15:53:35 +0100

> installations.  I could easily expand the recipient list.  Suggestions?

Authors use idnits a lot, so a CC to rfc-markdown (as you do for xml2rfc) would work from my point of view.
I’m not sure there is a specific announcement list for all I-D authors, though.

> to python,

Oh, I never looked into the sources.  Heroic :-)

> and make that available on PyPi.

Looking forward to this!

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 5 Mar 2020 18:12:40 +0100

Hi Carsten,

On 2020-03-05 15:53, Carsten Bormann wrote:
> Authors use idnits a lot, so a CC to rfc-markdown (as you do for
> xml2rfc) would work from my point of view. I’m not sure there is a
> specific announcement list for all I-D authors, though.

Ok.  Cc: to [email-masked] added.

>> and make that available on PyPi.

:-)

	Henrik