Subject: [Tools-discuss] Datatracker version borks

From: Brian Rosen <[email-masked]>
Date: Mon, 9 Mar 2020 15:03:03 -0400

I tried to submit draft-ietf-ecrit-data-only-22.  Datatracker (and tools draft repository) have -21.  Submission complained about metadata, and said version should be -19.

Then I tried manual adjust, and it won’t let me manually submit -22!

I changed the form to -19 and alerted the secretariat

So two bugs: Submission insists on wrong version, and manual adjust won’t allow you to say, no, tool is wrong, this is the correct version

Brian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 9 Mar 2020 20:09:48 +0100

(That has happened with another draft.  Henrik was able to manually intervene and fix the database, which might have been disturbed in the recent failed server migration event.)

Grüße, Carsten

> On 2020-03-09, at 20:03, Brian Rosen <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 9 Mar 2020 20:25:29 +0100

Hi Brian, Carsten,

Yes, that's right.  I've corrected the rev number to 21; you should be
able to proceed with submission.

Best regards,

	Henrik

---

From: Brian Rosen <[email-masked]>
Date: Mon, 9 Mar 2020 17:09:07 -0400

Thanks, that worked and I submitted successfully.

Will you put the “can’t override the tool when manually submitting” on a bug list somewhere?

Brian

> On Mar 9, 2020, at 3:25 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Brian, Carsten,
>

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 9 Mar 2020 22:13:59 +0100

> Will you put the “can’t override the tool when manually submitting” on a bug list somewhere?

That is not the bug.  Not determining the right next number is the bug.
I don’t think the tool should allow selecting a random version number (even though it would have helped with TLS :-)

Grüße, Carsten

---

From: Brian Rosen <[email-masked]>
Date: Mon, 9 Mar 2020 17:17:00 -0400

If tools never made mistakes, manual submission wouldn’t be required.  But tools make mistakes.  Manual submission fixes that, but you have to ask for the right thing, so having an override when you manually submit: which might show up as red text to the secretariat, seems to make sense to me.

Brian

> On Mar 9, 2020, at 5:13 PM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 9 Mar 2020 22:43:07 +0100

Hi Brian,

On 2020-03-09 22:17, Brian Rosen wrote:
> If tools never made mistakes, manual submission wouldn’t be required.
> But tools make mistakes. Manual submission fixes that, but you have
> to ask for the right thing, so having an override when you manually
> submit: which might show up as red text to the secretariat, seems to
> make sense to me.

This was an exceptional case, and much better handled manually than by
writing code to override it.  I think the right thing happened here.

Best regards,

	Henrik