Subject: [Tools-discuss] bug in XML2RFC

From: Tim Wicinski <[email-masked]>
Date: Fri, 20 Mar 2020 17:31:28 -0400

It appears that xml2rfc has an issue if a new sentence starts with a
reference.

Please see
https://tools.ietf.org/html/draft-kucherawy-dmarc-dmarcbis-00#page-17

The XML submitted contains

<section anchor="dmarc-uris"><name>DMARC URIs</name>
<t><xref target="RFC3986"></xref> defines a generic syntax for identifying
a resource.

tim

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 20 Mar 2020 19:44:32 -0400

Apologies, I was incorrect. The HTML version is correct:

https://www.ietf.org/id/draft-kucherawy-dmarc-dmarcbis-00.html

The "HTMLized" version contains some of the correct bits but fails to wrap
the reference inside
a <span> </span>

https://tools.ietf.org/html/draft-kucherawy-dmarc-dmarcbis-00

[<a name="ref-RFC3986" id="ref-RFC3986">RFC3986</a>]

I'm not sure where this bug falls actually.

tim

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 20 Mar 2020 19:57:34 -0400

Since the HTMLized versions are known to have issues and won’t be fixed, I think it’s time to deprecate the HTMLized versions when a HTML native version is available.

Let’s just not generate HTMLized in this case.

Tom

> On Mar 20, 2020, at 7:44 PM, Tim Wicinski <[email-masked]> wrote:
> 
> https://www.ietf.org/id/draft-kucherawy-dmarc-dmarcbis-00.html <https://www.ietf.org/id/draft-kucherawy-dmarc-dmarcbis-00.html>
> 
> The "HTMLized" version contains some of the correct bits but fails to wrap the reference inside
> a <span> </span> 
> 
> https://tools.ietf.org/html/draft-kucherawy-dmarc-dmarcbis-00 <https://tools.ietf.org/html/draft-kucherawy-dmarc-dmarcbis-00>
> 
> On Fri, Mar 20, 2020 at 5:31 PM Tim Wicinski <[email-masked] <mailto:[email-masked]>> wrote:
> 
> It appears that xml2rfc has an issue if a new sentence starts with a reference. 
> 
> Please see https://tools.ietf.org/html/draft-kucherawy-dmarc-dmarcbis-00#page-17 <https://tools.ietf.org/html/draft-kucherawy-dmarc-dmarcbis-00#page-17>
> 
> <t><xref target="RFC3986"></xref> defines a generic syntax for identifying a resource.
> 
> tim
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 21 Mar 2020 08:13:26 +0100

> Let’s just not generate HTMLized in this case.

I still rely on the HTMLized version, and I think a lot of people do.

Of course, the direct-to-HTML version should be the advertised one, if it exists.

Grüße, Carsten

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 23 Mar 2020 11:18:32 +1100

> I still rely on the HTMLized version, and I think a lot of people do.

It's a useful baseline. Also, I find the new HTML borderline unreadable.  Mostly that comes down to line length.

I do prefer HTML, but I am happier with things like https://quicwg.org/base-drafts/draft-ietf-quic-transport.html or https://httpwg.org/http-extensions/draft-ietf-httpbis-header-structure.html or https://mnot.github.io/I-D/how-did-that-get-into-the-repo/

---

From: Tom Pusateri <[email-masked]>
Date: Sun, 22 Mar 2020 21:33:27 -0400

> On Mar 22, 2020, at 8:18 PM, Martin Thomson <[email-masked]> wrote:
> 

It appears that it is going to be difficult to get general agreement on a new HTML native version.

I do like the QUIC example you list except for the font choice. I find the San Francisco from Apple, Roboto from Google, and then a simple Helvetica provide less eye strain than the multiple font families used in the QUIC example (cabincondensed, lora, oxygenmono).

Another minor issue with the QUIC example is how the Figure labels are too close to the next paragraph.

But I’ve also been frustrated for years with bugs in the HTMLized versions and just want them to go away. This is no criticism of Henrik and any other authors. It’s an impossible task to parse the TXT version and generate HTML.

Tom

---

From: Russ Housley <[email-masked]>
Date: Sun, 22 Mar 2020 22:32:08 -0400

That is not a tools topic.  Please discuss formatting preferences on rfc-interest.

Russ