Subject: [Tools-discuss] "artset" element and I-D submission

From: Yaron Sheffer <[email-masked]>
Date: Sun, 08 Mar 2020 23:21:27 +0200

We’ve been using the “artset” xml2rfc element, with which you can specify two diagrams, one will be included in the txt version of the draft and one (typically a more fancy SVG) in the HTML version. This works wonderfully in xml2rfc 2.32.0 on my laptop, and fails when I try to submit the draft (submit the XML version). It appears that “artset” is not part of the RFC 7991 vocabulary.

Is there another way to achieve the same result?
Is there a plan to update the xml2rfc processor on the submission tool to the version I am using?

Thanks,

                Yaron

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 8 Mar 2020 22:40:59 +0100

And while we are at that:
How are the tools going to work with the multi-file documents artset needs?

Grüße, Carsten

> On 2020-03-08, at 22:21, Yaron Sheffer <[email-masked]> wrote:
> 
> 	• Is there another way to achieve the same result?
> 	• Is there a plan to update the xml2rfc processor on the submission tool to the version I am using?
>  
> Thanks,
>                 Yaron
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 9 Mar 2020 13:03:26 +0100

Hi Yaron,

On 2020-03-08 22:21, Yaron Sheffer wrote:
> We’ve been using the “artset” xml2rfc element, with which you can
> specify two diagrams, one will be included in the txt version of the
> draft and one (typically a more fancy SVG) in the HTML version. This
> works wonderfully in xml2rfc 2.32.0 on my laptop, and fails when I
> try to submit the draft (submit the XML version). It appears that
> “artset” is not part of the RFC 7991 vocabulary.

The submission tool is using the latest xml2rfc version, so this is
a bug.  Could you send me the XML file which showed this problem, please?

> Is there another way to achieve the same result?

You can try to upload both xml and txt, that may help, but since the
failure is a bug, not intended behaviour, I'd still need to see the XML
file and debug this.

> tool to the version I am using?

As said above, the version used by the datatracker is the latest release
(2.40.1).

Best regards,

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 9 Mar 2020 13:08:15 +0100

Hi Carsten,

> How are the tools going to work with the multi-file documents artset needs?

'the tools' is a wide descriptor.  Answering this for the datatracker:

At this time, you'll have to submit all content assembled in a single XML
file.  Using xml2rfc with the --expand option should give you this, if you
have multiple files in your workflow.

Regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 9 Mar 2020 13:11:08 +0100

> have multiple files in your workflow.

Thank you!

Grüße, Carsten