Subject: [Tools-discuss] Non-WG lists list

From: Carsten Bormann <[email-masked]>
Date: Thu, 19 Nov 2020 07:34:50 +0100

I think the list at

https://datatracker.ietf.org/list/nonwg

might benefit from an indication of how much mold has grown over a list (and maybe filter for active ones).

Not sure it really needs to start with 101-newcomers…

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 19 Nov 2020 06:07:49 -0500

> Not sure it really needs to start with 101-newcomers…

I suggest that any list without a posting in the last 365 days gets moved to
a section at the bottom of the page.  When/how/if to delete them is above my
pay grade.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 19 Nov 2020 12:11:21 +0100

On 2020-11-19, at 12:07, Michael Richardson <[email-masked]> wrote:
> a section at the bottom of the page.  

Sounds good,

> When/how/if to delete them is above my
> pay grade.

“Deleting” would be wrong (we need the archive).
Even “closing” would be questionable — recently, the ROHC list turned out to be useful after two years of silence.  There was a bit of a hiccup when IAB decided to close some lists...

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 19 Nov 2020 18:20:21 +0100

Each list should have:

a) A visible "owner" of the list. Whatever that is (IESG, IAB, any other "org", individual)

b) A history of the description of the list with who and when the description was changed.

That would allow for anyone getting to what looks like a stale list to do a bit more of an
educated guess whats going on with the list.

>From then on out, we could determine if therer should be

c) a trigger to the owner to update the list after some type of event, such as:
c.1) There was no mail to the list for 1 year
c.2) The description was not changed for 5 years.

Cheers
    Toerless

On Thu, Nov 19, 2020 at 12:11:21PM +0100, Carsten Bormann wrote:
> >> Not sure it really needs to start with 101-newcomers???
> > 
> ???Deleting??? would be wrong (we need the archive).
> Even ???closing??? would be questionable ??? recently, the ROHC list turned out to be useful after two years of silence.  There was a bit of a hiccup when IAB decided to close some lists...
> 
> Grüße, Carsten
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

-- 
---
[email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Thu, 19 Nov 2020 10:48:36 -0800

> Even “closing” would be questionable — recently, the ROHC list turned out to be useful after two years of silence.  There was a bit of a hiccup when IAB decided to close some lists…

Perhaps move them to an inactive page, I agree important to keep the archive.   Might also be good to put them in moderated mode to make it hard to spam people.

Bob

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 19 Nov 2020 20:16:25 +0100

Bob: Not sure if inventing new dedicated groups / status ("inactive") is going to be very helpfull.

We already have descriptions for groups, and thats why i was sugggesting that simply updating the statuses of groups is IMHO most flexible - in many cases you want to redirect new trafic to othrer groups for example. How ? Just write it into the group description...

Cheers
    toerless

On Thu, Nov 19, 2020 at 10:48:36AM -0800, Bob Hinden wrote:
> > Even ???closing??? would be questionable ??? recently, the ROHC list turned out to be useful after two years of silence.  There was a bit of a hiccup when IAB decided to close some lists???
> 

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 19 Nov 2020 20:46:20 +0100

> c.2) The description was not changed for 5 years.

I wasn’t asking for more process, just for a better display of the list.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 19 Nov 2020 20:49:50 +0100

Understood.

IMHO, what i was asking for is also primarily better visibility.
Owner of list could be entered informally into the description, and
changelog shuold be standard IMHO on stuff like this

On Thu, Nov 19, 2020 at 08:46:20PM +0100, Carsten Bormann wrote:
> I wasn???t asking for more process, just for a better display of the list.
> 
> Grüße, Carsten

-- 
---
[email-masked]