Subject: [Tools-discuss] Idnits confused about draft version numbers in the datatracker

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 20 Nov 2020 09:18:14 -0600

I'm getting these warnings from idnits:

  -- Unexpected draft version: The latest known version of
     draft-bonaventure-iccrg-schedulers is -00, but you're referring to -01.

  -- Unexpected draft version: The latest known version of
     draft-ietf-quic-datagram is -00, but you're referring to -01.

Oddly, the version numbers are coming from I-D.whatever references
with no version numbers, so whatever is adding version numbers added
these, but the -01 versions of these drafts do exist in the
datatracker.

Best,

Spencer

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Nov 2020 17:41:09 +0100

I’m sure Henrik will answer this, but the underlying problem appears to be that idnits is an amazing, organically grown piece of bash, awk, sed, wget, and spit holding all that together.  It is a strong candidate for a rewrite, and I’m not sure now how that will happen.

Grüße, Carsten

PS.:
Trivia question:  What is
UUOUUUUUUOOUUNUOUUUSUUUUUNUUUUUUUUIUUUUUUUUUUUUUUUUUUUUUUUUUOUUU
and why is there only one S in that line?

> On 2020-11-20, at 16:18, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> Oddly, the version numbers are coming from I-D.whatever references with no version numbers, so whatever is adding version numbers added these, but the -01 versions of these drafts do exist in the datatracker. 
> Best,
> Spencer
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 20 Nov 2020 17:55:01 +0100

>      draft-ietf-quic-datagram is -00, but you're referring to -01.

$ curl -I https://tools.ietf.org/draft/draft-ietf-quic-datagram/state
HTTP/1.1 200 OK
Date: Fri, 20 Nov 2020 16:51:59 GMT
Server: Apache/2.2.22 (Debian)
Last-Modified: Sun, 22 Mar 2020 09:30:27 GMT

Hmm.  This may be one of those “the script didn’t run” cases.

Grüße, Carsten

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 23 Nov 2020 15:31:15 +0100

> I’m sure Henrik will answer this, but the underlying problem appears to be that idnits is an amazing, organically grown piece of bash, awk, sed, wget, and spit holding all that together.  It is a s…

I expect to have that done before the end of the year.

	Henrik