Subject: [Tools-discuss] Diacritics in bibtex export

From: Cenk Gündoğan <[email-masked]>
Date: Fri, 11 Dec 2020 10:42:40 +0100

Hello all,

not sure, if here is the correct place to report this, but I'll give it
a try. We noticed that the bibtex export of RFC8724 [1,2] contains
diacritics for the name of one of the authors.  The RFC itself contains
the ascii-only name.

Since bibtex is quite picky (without explicitly activating utf8 support
for the whole LaTeX document), a typical compilation just fails.  Fixing
the entry locally is not really an option for us, since we use rsync to
fetch all I-D and RFC bibxml files to then generate the bibtex entries.

Is the meta info on this document really correct (containing the
diacritics)?  If yes, does someone has any recommendations or
suggestions (or experiences to share) on how to handle these cases?

Best,
Cenk

[1] https://datatracker.ietf.org/doc/rfc8724/
[2] https://datatracker.ietf.org/doc/rfc8724/bibtex

--
Cenk Gündoğan

Hamburg University of Applied Sciences
Dept. of Computer Science / Internet Technologies Group
Berliner Tor 7, 20099 Hamburg, Germany
Fon: +49 40 42875 - 8426
Mail: [email-masked]
Web: https://www.inet.haw-hamburg.de/

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 11 Dec 2020 10:48:26 +0100

> [2] https://datatracker.ietf.org/doc/rfc8724/bibtex

Do you need anything else than
\usepackage[utf8]{inputenc}
to make this work?

Grüße, Carsten

---

From: Lars Eggert <[email-masked]>
Date: Fri, 11 Dec 2020 11:49:35 +0200

Hi,

I wrote the bitex-generation of the datatracker, at lest initially.

> suggestions (or experiences to share) on how to handle these cases?

https://datatracker.ietf.org/doc/rfc8724/ shows that the author name really is Juan-Carlos Zúñiga, so the meta-data is correct.

Why is enabling UTF-8 for the latex document not the right option here?

Thanks,
Lars

---

From: Cenk Gündoğan <[email-masked]>
Date: Fri, 11 Dec 2020 11:26:07 +0100

Hello,

> Why is enabling UTF-8 for the latex document not the right option here?

That's probably the easiest way to go, then.  As Carsten pointed out,
enforcing utf8 with \usepackage[utf8]{inputenc} solves the compilation
problem.

I was actually quite surprised: initially, I thought the author entry
field of the bibxml data comes from the original document sources
(either uploaded plain text, or uploaded xml for xml2rfc).  Even if not,
I'd assumed that any other source should match with what is displayed in
the RFC document.  That's why I thought there might be an issue in the
meta data.

If everything is as expected, then I will move on with enforcing utf8
.. Thanks!

Cheers,
Cenk

>
> Thanks,
> Lars
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

--
Cenk Gündoğan