Subject: Re: [Tools-discuss] [xml2rfc] Failed decoding the uploaded file

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Dec 2020 01:55:01 +0100

On 2020-12-15, at 01:49, Robert Moskowitz <[email-masked]> wrote:
> 
> But I am getting the follow error from the txt file:

Don’t send the txt file with a v3 source.

(Another thing suggested by the submission interface that causes problems.)

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 14 Dec 2020 22:58:56 -0500

> (Another thing suggested by the submission interface that causes problems.)

I did not include the txt, only the xml and I was right that the problem 
was the author's name in the reference.

locally I get
R., Håstad

the submit generates:

R., HÃ¥stad

Not good. can we get this fixed and I will have to rev the draft just 
for this one error?

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 15 Dec 2020 16:12:09 +1100

> Not good. can we get this fixed and I will have to rev the draft just 

I opened https://trac.tools.ietf.org/tools/ietfdb/ticket/3151 a couple of days ago.  It's not consistently broken, but some outputs do break.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 15 Dec 2020 07:04:43 +0100

> I opened https://trac.tools.ietf.org/tools/ietfdb/ticket/3151 a couple of days ago.  It's not consistently broken, but some outputs do break.

...that might be a different problem.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 15 Dec 2020 09:29:12 +0100

> 
> Why would that matter? (unless there's a bug in xml2rfc...)

I have no idea how <?rfc include… is handled, so this was a shot in the dark.
> 
> FWIW, it *seems* to me that all is well, except that the text file
> 
>  https://www.ietf.org/archive/id/draft-ietf-hip-dex-22.txt
> 
> is served with incorrect HTTP header fields (as Martin correctly pointed
> out), while
> 
>  https://www.ietf.org/id/draft-ietf-hip-dex-22.txt
> 
> is ok.

Yep.  Should have checked with my local copy, which is also OK (rsync doesn’t break UTF-8).  Since the incorrect HTTP header is entirely an ietf.org infrastructure problem; I have CCed tools-discuss.

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Tue, 15 Dec 2020 09:34:28 +0100

> Yep.  Should have checked with my local copy, which is also OK (rsync doesn’t break UTF-8).  Since the incorrect HTTP header is entirely an ietf.org infrastructure problem; I have CCed tools-discus…

There's already a ticket (should have repeated that here):
<https://trac.tools.ietf.org/tools/ietfdb/ticket/3151>

Best regards, Julian

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 15 Dec 2020 15:51:09 +0100

> Not good. can we get this fixed and I will have to rev the draft just 

I suspect the file on disk on the ietf server is correct, and the issue is
that the mime-type indicated by the server is incorrect.

	Henrik

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 15 Dec 2020 10:18:20 -0500

> that the mime-type indicated by the server is incorrect.

I only submitted the xml, not the txt that my local xml2rfc built. It 
was that local txt that the upload barfed on with the illegal 
character.  What you have only is the base xml and the txt built by the 
online submission tool.