Subject: [Txauth] Fwd: New Version Notification for draft-richer-transactional-authz-03.txt

From: Justin Richer <[email-masked]>
Date: Fri, 1 Nov 2019 17:50:10 -0400

I’ve updated the XYZ draft. This brings it in line with what’s currently available on the website, https://oauth.xyz/ <https://oauth.xyz/>

 — Justin

> Begin forwarded message:
> 
> From: [email-masked]
> Subject: New Version Notification for draft-richer-transactional-authz-03.txt
> Date: November 1, 2019 at 4:14:20 PM EDT
> 
> 
> A new version of I-D, draft-richer-transactional-authz-03.txt
> has been successfully submitted by Justin Richer and posted to the
> IETF repository.
> 
> Name:		draft-richer-transactional-authz
> Revision:	03
> Title:		Transactional Authorization
> Document date:	2019-11-01
> Group:		Individual Submission
> Pages:		28
> URL:            https://www.ietf.org/internet-drafts/draft-richer-transactional-authz-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-richer-transactional-authz/
> Htmlized:       https://tools.ietf.org/html/draft-richer-transactional-authz-03
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-richer-transactional-authz
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-richer-transactional-authz-03
> 
> Abstract:
>   This document defines a mechanism for delegating authorization to a
>   piece of software, and conveying that delegation to the software.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: "Bron Gondwana" <[email-masked]>
Date: Mon, 04 Nov 2019 17:05:55 +1100

Thanks for doing this work Justin. I'm really disappointed that I won't be able to make it to the txauth session because I'm chairing two working groups through that entire timeslot :(

I was looking for something to replace the authentication which was proposed in the very first draft of JMAP core here:

https://www.ietf.org/archive/id/draft-jenkins-jmap-00.txt

I'm keen to get involved with txauth or whoever else and see if there's a way we can have the same flexible (and possibly even out-of-band) session setup and bootstrap system! I'll try to find you in Singapore and have a chat.

Cheers,

Bron.

On Sat, Nov 2, 2019, at 08:50, Justin Richer wrote:
> I’ve updated the XYZ draft. This brings it in line with what’s currently available on the website, https://oauth.xyz/
> 
>  — Justin
> 
>> Begin forwarded message:
>> 
>> *From: [email-masked]
>> *Subject: **New Version Notification for draft-richer-transactional-authz-03.txt*
>> *Date: *November 1, 2019 at 4:14:20 PM EDT
>> 
>> 
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
> 

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Justin Richer <[email-masked]>
Date: Mon, 4 Nov 2019 11:47:57 -0500

That is a very interesting draft that I hadn’t seen, thanks for passing it along. I think that does fit the same kind of model that XYZ is built around, with the client asking for something but having opportunities to step things up along the way. 

I look forward to your involvement with TXAuth wherever it lands, and perhaps we can grab some time for a side chat in Singapore as well.

 — Justin

> On Nov 4, 2019, at 1:05 AM, Bron Gondwana <[email-masked]> wrote:
> 
> https://www.ietf.org/archive/id/draft-jenkins-jmap-00.txt <https://www.ietf.org/archive/id/draft-jenkins-jmap-00.txt>
> 
>>> From: [email-masked] <mailto:[email-masked]>
>>> URL:            https://www.ietf.org/internet-drafts/draft-richer-transactional-authz-03.txt <https://www.ietf.org/internet-drafts/draft-richer-transactional-authz-03.txt>
>>> Status:         https://datatracker.ietf.org/doc/draft-richer-transactional-authz/ <https://datatracker.ietf.org/doc/draft-richer-transactional-authz/>
>>> Htmlized:       https://tools.ietf.org/html/draft-richer-transactional-authz-03 <https://tools.ietf.org/html/draft-richer-transactional-authz-03>
>>> Htmlized:       https://datatracker.ietf.org/doc/html/draft-richer-transactional-authz <https://datatracker.ietf.org/doc/html/draft-richer-transactional-authz>
>>> Diff:           https://www.ietf.org/rfcdiff?url2=draft-richer-transactional-authz-03 <https://www.ietf.org/rfcdiff?url2=draft-richer-transactional-authz-03>
>>> 
>>> Abstract:
>>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
>>> 
>>> The IETF Secretariat
>> 
>> -- 
>> Txauth mailing list
>> [email-masked]
>   [email-masked] <mailto:[email-masked]>
> 
> 
> -- 
> Txauth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>