Subject: Re: [Txauth] use case document?

From: Yaron Sheffer <[email-masked]>
Date: Sat, 01 Feb 2020 20:20:38 +0200

I support such a document in principle. I agree that having a list of use cases would help to scope the protocol document(s).

However I think now is not the right time, because a use case document is only useful in defining scope once it is more or less stable and enjoys rough consensus. We can only demonstrate consensus once we move past the BoF stage and into a WG. So I believe it only makes sense to produce the use case doc when we have a chartered WG.

Thanks,

                Yaron

From: Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Saturday, February 1, 2020 at 00:38
To: <[email-masked]>
Subject: [Txauth] use case document?

As I reflect on my conversations with Justin, a set of use cases would help guide us. We could then refer to a use case as why a feature is present and see how different features support (or don't support) different use cases.

We can also use the document to decide which use cases are in scope, or out of scope.

I'll put up my hand to edit. Who is interested in contributing?

/Dick

ᐧ

-- Txauth mailing list [email-masked] https://www.ietf.org/mailman/listinfo/txauth

---

From: Dick Hardt <[email-masked]>
Date: Sat, 1 Feb 2020 14:16:05 -0800

I was thinking a rough draft of a use case document would assist in teasing
out what is in scope and not for the WG.

I've been adding use cases to the XAuth ID to tease out what would be in
and out of scope.

It would also provide clarity on why this WG is different from the OAuth
WG.

On Sat, Feb 1, 2020 at 10:20 AM Yaron Sheffer <[email-masked]> wrote:

> I support such a document in principle. I agree that having a list of use
> cases would help to scope the protocol document(s).
>
>
>
> However I think now is not the right time, because a use case document is
> only useful in defining scope once it is more or less stable and enjoys
> rough consensus. We can only demonstrate consensus once we move past the
> BoF stage and into a WG. So I believe it only makes sense to produce the
> use case doc when we have a chartered WG.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *Txauth <[email-masked]> on behalf of Dick Hardt <
> [email-masked]>
> *Date: *Saturday, February 1, 2020 at 00:38
> *To: *<[email-masked]>
> *Subject: *[Txauth] use case document?
>
>
>
> As I reflect on my conversations with Justin, a set of use cases would
> help guide us. We could then refer to a use case as why a feature is
> present and see how different features support (or don't support) different
> use cases.
>
>
>
> -- Txauth mailing list [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>

---

From: Yaron Sheffer <[email-masked]>
Date: Sun, 02 Feb 2020 00:23:25 +0200

It’s hard to “tease out” what’s in scope, and in particular what’s *not* in scope, before you have a WG. I am worried about scope creep which is likely to happen once this is a WG and more people are involved. IMO the best way to avoid it is by only having this discussion once everybody is on board.

Thanks,

                Yaron

From: Dick Hardt <[email-masked]>
Date: Sunday, February 2, 2020 at 00:16
To: Yaron Sheffer <[email-masked]>
Cc: <[email-masked]>
Subject: Re: [Txauth] use case document?

I was thinking a rough draft of a use case document would assist in teasing out what is in scope and not for the WG.

I've been adding use cases to the XAuth ID to tease out what would be in and out of scope.

It would also provide clarity on why this WG is different from the OAuth WG.  

Thanks,

                Yaron

/Dick

Error! Filename not specified.ᐧ

---

From: Dick Hardt <[email-masked]>
Date: Sat, 1 Feb 2020 14:24:15 -0800

Works for me.

On Sat, Feb 1, 2020 at 2:23 PM Yaron Sheffer <[email-masked]> wrote:

> It’s hard to “tease out” what’s in scope, and in particular what’s **not**
> in scope, before you have a WG. I am worried about scope creep which is
> likely to happen once this is a WG and more people are involved. IMO the
> best way to avoid it is by only having this discussion once everybody is on
> board.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *Dick Hardt <[email-masked]>
> *Date: *Sunday, February 2, 2020 at 00:16
> *To: *Yaron Sheffer <[email-masked]>
> *Cc: *<[email-masked]>
> *Subject: *Re: [Txauth] use case document?
>
>
>
> I was thinking a rough draft of a use case document would assist in
> teasing out what is in scope and not for the WG.
>
>
>
> *Error! Filename not specified.*ᐧ
>

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Mon, 3 Feb 2020 21:04:00 +0000

I don’t follow the logic of deferring this, since the charter defines the scope of the working group. We’re all comparing the charter drafts against our use cases anyway; doing that out in the open seems less likely to lead to arguments down the road over whether something falls within the scope laid out in the charter.

For what it’s worth, Justin put this together back in August: https://mailarchive.ietf.org/arch/msg/oauth/v8TdkruCzwH43FMKS598IC2Sheo

–
Annabelle Richard Backman
AWS Identity

From: Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Saturday, February 1, 2020 at 2:25 PM
To: Yaron Sheffer <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Txauth] use case document?

Works for me.

On Sat, Feb 1, 2020 at 2:23 PM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
It’s hard to “tease out” what’s in scope, and in particular what’s *not* in scope, before you have a WG. I am worried about scope creep which is likely to happen once this is a WG and more people are involved. IMO the best way to avoid it is by only having this discussion once everybody is on board.

Thanks,
                Yaron

From: Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Sunday, February 2, 2020 at 00:16
To: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Txauth] use case document?

On Sat, Feb 1, 2020 at 10:20 AM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
I support such a document in principle. I agree that having a list of use cases would help to scope the protocol document(s).

Thanks,
                Yaron

From: Txauth <[email-masked]<mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Saturday, February 1, 2020 at 00:38
To: <[email-masked]<mailto:[email-masked]>>
Subject: [Txauth] use case document?

/Dick
Error! Filename not specified.ᐧ
-- Txauth mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/txauth

---

From: Mike Jones <[email-masked]>
Date: Mon, 3 Feb 2020 22:01:25 +0000

I agree. I'd rather see use cases sooner than later.

-- Mike
________________________________
From: Txauth <[email-masked]> on behalf of Richard Backman, Annabelle <richanna=[email-masked]>
Sent: Monday, February 3, 2020 9:04:00 PM
To: Dick Hardt <[email-masked]>; Yaron Sheffer <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: [EXTERNAL] Re: [Txauth] use case document?

For what it’s worth, Justin put this together back in August: https://mailarchive.ietf.org/arch/msg/oauth/v8TdkruCzwH43FMKS598IC2Sheo<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Foauth%2Fv8TdkruCzwH43FMKS598IC2Sheo&data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce3e2d46999344f80a61508d7a8ec9e24%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637163606550459264&sdata=ju8pbqh1wxW9AlA3sBuB34Tj21XJQL7H5X83UbI5HvA%3D&reserved=0>

–

AWS Identity

Works for me.

Thanks,

                Yaron

Thanks,

                Yaron

/Dick

-- Txauth mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/txauth<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce3e2d46999344f80a61508d7a8ec9e24%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637163606550464263&sdata=%2BhlMRgQRBpF8j%2BsNbJOewdHxQyNWY6TU2LqG5RcEu88%3D&reserved=0>

---

From: Justin Richer <[email-masked]>
Date: Tue, 4 Feb 2020 11:17:07 -0500

I’m fine with use cases as input to work, but they should always be taken as non-binding and non-normative. In other words, they’re a great way for us to write something down and say “yeah that makes sense for something for us to work on”. But I don’t think it makes sense as a way to enforce direction or decision within the group (ie, “that’s not in the use cases document, we’re not going to talk about it”), or as a formal output of the document. 

Therefore if it’s an openly accessible and editable document that people can put things in, I think it’s a helpful tool. The moment it becomes burdensome to update and continue use, we need to question whether we should keep doing it.

 — Justin

> On Feb 3, 2020, at 5:01 PM, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> For what it’s worth, Justin put this together back in August: https://mailarchive.ietf.org/arch/msg/oauth/v8TdkruCzwH43FMKS598IC2Sheo <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Foauth%2Fv8TdkruCzwH43FMKS598IC2Sheo&data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce3e2d46999344f80a61508d7a8ec9e24%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637163606550459264&sdata=ju8pbqh1wxW9AlA3sBuB34Tj21XJQL7H5X83UbI5HvA%3D&reserved=0>
>  
> – 
> On Sat, Feb 1, 2020 at 2:23 PM Yaron Sheffer <[email-masked] <mailto:[email-masked]>> wrote:
> From: Dick Hardt <[email-masked] <mailto:[email-masked]>>
> To: Yaron Sheffer <[email-masked] <mailto:[email-masked]>>
> Cc: <[email-masked] <mailto:[email-masked]>>
> On Sat, Feb 1, 2020 at 10:20 AM Yaron Sheffer <[email-masked] <mailto:[email-masked]>> wrote:
> From: Txauth <[email-masked] <mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked] <mailto:[email-masked]>>
> To: <[email-masked] <mailto:[email-masked]>>
> -- Txauth mailing list [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/txauth <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce3e2d46999344f80a61508d7a8ec9e24%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637163606550464263&sdata=%2BhlMRgQRBpF8j%2BsNbJOewdHxQyNWY6TU2LqG5RcEu88%3D&reserved=0>-- 
> Txauth mailing list
> [email-masked]

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Tue, 4 Feb 2020 18:57:32 +0200

I believe the way to use this document is to inform decisions around the
scope of the charter.
Once the WG is formed this will be a useful reference for evaluating design
decisions but could just as easily be left to go stale as the point of
reference for the WG on issues of scope will be the charter itself.

On Tue, 4 Feb 2020 at 18:17, Justin Richer <[email-masked]> wrote:

> I’m fine with use cases as input to work, but they should always be taken
> as non-binding and non-normative. In other words, they’re a great way for
> us to write something down and say “yeah that makes sense for something for
> us to work on”. But I don’t think it makes sense as a way to enforce
> direction or decision within the group (ie, “that’s not in the use cases
> document, we’re not going to talk about it”), or as a formal output of the
> document.
>
> Therefore if it’s an openly accessible and editable document that people
> can put things in, I think it’s a helpful tool. The moment it becomes
> burdensome to update and continue use, we need to question whether we
> should keep doing it.
>
>  — Justin
>
> On Feb 3, 2020, at 5:01 PM, Mike Jones <
> Michael.Jones=[email-masked]> wrote:
>
> ------------------------------
> *From:* Txauth <[email-masked]> on behalf of Richard Backman,
> Annabelle <richanna=[email-masked]>
> *Sent:* Monday, February 3, 2020 9:04:00 PM
> *To:* Dick Hardt <[email-masked]>; Yaron Sheffer <
> [email-masked]>
> *Cc:* [email-masked] <[email-masked]>
> *Subject:* [EXTERNAL] Re: [Txauth] use case document?
>
> I don’t follow the logic of deferring this, since the charter defines the
> scope of the working group. We’re all comparing the charter drafts against
> our use cases anyway; doing that out in the open seems less likely to lead
> to arguments down the road over whether something falls within the scope
> laid out in the charter.
>
>
> For what it’s worth, Justin put this together back in August:
> https://mailarchive.ietf.org/arch/msg/oauth/v8TdkruCzwH43FMKS598IC2Sheo
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Foauth%2Fv8TdkruCzwH43FMKS598IC2Sheo&data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce3e2d46999344f80a61508d7a8ec9e24%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637163606550459264&sdata=ju8pbqh1wxW9AlA3sBuB34Tj21XJQL7H5X83UbI5HvA%3D&reserved=0>
>
>
> –
> *Date: *Saturday, February 1, 2020 at 2:25 PM
> *Cc: *"[email-masked]" <[email-masked]>
> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7Ce3e2d46999344f80a61508d7a8ec9e24%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637163606550464263&sdata=%2BhlMRgQRBpF8j%2BsNbJOewdHxQyNWY6TU2LqG5RcEu88%3D&reserved=0>
>
> --
> Txauth mailing list
> [email-masked]
> --

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 04 Feb 2020 18:42:54 +0200

Once this is a working group, we will need to make decisions on scope: what goes into the base document, what we might want as extensions, and what the WG doesn’t want to work on in the near term.

If we have a use case document, that would be the natural place to have these discussions – you clarify each particular use case and make sure everybody agrees on what it means, and then the group decides which bucket to put it in: base document, extension, defer. Otherwise I’m not sure what the document is intended to achieve.

Thanks,

                Yaron

From: Justin Richer <[email-masked]>
Date: Tuesday, February 4, 2020 at 18:17
To: Mike Jones <Michael.Jones=[email-masked]>
Cc: Dick Hardt <[email-masked]>, Yaron Sheffer <[email-masked]>, "Richard Backman, Annabelle" <richanna=[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Txauth] use case document?

 — Justin

-- Mike

– 

AWS Identity

Works for me.

Thanks,

                Yaron

Thanks,

                Yaron

/Dick

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Wed, 5 Feb 2020 10:49:30 +0200

It's my understanding that the scope needs to be decided before we have a
WG (i.e. defined in the charter).

On Wed, 5 Feb 2020 at 01:06, Yaron Sheffer <[email-masked]> wrote:

> Once this is a working group, we will need to make decisions on scope:
> what goes into the base document, what we might want as extensions, and
> what the WG doesn’t want to work on in the near term.
>
>
>
> If we have a use case document, that would be the natural place to have
> these discussions – you clarify each particular use case and make sure
> everybody agrees on what it means, and then the group decides which bucket
> to put it in: base document, extension, defer. Otherwise I’m not sure what
> the document is intended to achieve.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *Justin Richer <[email-masked]>
> *Date: *Tuesday, February 4, 2020 at 18:17
> *To: *Mike Jones <Michael.Jones=[email-masked]>
> *Cc: *Dick Hardt <[email-masked]>, Yaron Sheffer <
> [email-masked]>, "Richard Backman, Annabelle" <richanna=
> [email-masked]>, "[email-masked]" <[email-masked]>
> yaronf.ietf@gmail..com <[email-masked]>>
> [email-masked] <dick.hardt@gmail..com>>

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 05 Feb 2020 11:55:17 -0800

Yes, but it’s on us to decide at what level of granularity. Typically a use case document would go deeper that what you would expect in a WG charter.

Thanks,

                Yaron

From: Adrian Hope-Bailie <[email-masked]>
Date: Wednesday, February 5, 2020 at 00:49
To: Yaron Sheffer <[email-masked]>
Cc: Justin Richer <[email-masked]>, Mike Jones <Michael.Jones=[email-masked]>, "Richard Backman, Annabelle" <richanna=[email-masked]>, "[email-masked]" <[email-masked]>, Dick Hardt <[email-masked]>
Subject: Re: [Txauth] use case document?

It's my understanding that the scope needs to be decided before we have a WG (i.e. defined in the charter).

Thanks,

                Yaron

 — Justin

-- Mike

To: Dick Hardt <[email-masked]>; Yaron Sheffer <yaronf.ietf@gmail..com>

– 

AWS Identity

Works for me.

Thanks,

                Yaron

Thanks,

                Yaron

/Dick

---

From: Dick Hardt <[email-masked]>
Date: Wed, 5 Feb 2020 14:06:26 -0800

I proposed a use case document so that there is a common understand of what
the WG is working to solve. In my discussions online with Justin, it is
clear that he and I don't share a common set of requirements for this WG,
and I suspect that is the case for many.

First, I don't think there is a common understanding of all the use cases
that OAuth 2.0 and OpenID Connect are solving today.

Second, in the latest charter we have "new use cases not enabled by OAuth
2.0.", which is somewhat based on a number of those use cases that were
presented in the BoF in Singapore, but in ad hoc discussions, I think there
are many use cases that people desire to be solved, but are not widely
understood.

In my opinion, the use case document acts as the WGs requirements. Without
it, there are disagreements in the IDs because participants are wanting to
solve different use cases, but they don't know they have different use
cases, so the disagreements surface in the ID. Sometimes those
disagreements are resolved in a side meeting, but the knowledge is not
captured and the "why" fades away.

I'd advocate that if someone is wanting a feature, there needs to a a use
case the WG has agreed to that requires the feature. If the use case is not
in the use case document, it needs to be written up and adopted by the WG.

While this adds some overhead to the process, I think it will assist in in
alignment on the rest of the work products.

I don't want this WG to be Perl6. =)

ᐧ

On Wed, Feb 5, 2020 at 11:55 AM Yaron Sheffer <[email-masked]> wrote:

> Yes, but it’s on us to decide at what level of granularity. Typically a
> use case document would go deeper that what you would expect in a WG
> charter.
>
>
>
> Thanks,
>
>                 Yaron
>
>
>
> *From: *Adrian Hope-Bailie <[email-masked]>
> *Date: *Wednesday, February 5, 2020 at 00:49
> *Cc: *Justin Richer <[email-masked]>, Mike Jones <Michael.Jones=
> [email-masked]>, "Richard Backman, Annabelle" <richanna=
> [email-masked]>, "[email-masked]" <[email-masked]>, Dick
> Hardt <[email-masked]>

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Thu, 6 Feb 2020 10:14:04 +0200

Agree on the the purpose of the document.

My concern, and this is not unique to IETF, is that the desire to tightly
define the scope in the charter of the WG means participants are compelled
to already design solutions and use these to frame the scope. The effect is
to charter a WG that is already bound to a particular solution.

I would be very supportive of coming to consensus on a set of use cases as
a better way of agreeing on scope and basing the charter off of this shared
understanding.

My point is that following the formation of the WG I don't expect us to be
bound by the use case document but rather the charter, which, as has been
pointed out already, may be less specific.

E.g. we may add use cases post chartering that the WG considers important
IF they fit within the scope as defined in the charter.

TL;DR: let's build a use case document. We are keen to contribute the cases
that are important to us

On Thu, Feb 6, 2020 at 00:06 Dick Hardt <[email-masked]> wrote:

>
> I proposed a use case document so that there is a common understand of
> what the WG is working to solve. In my discussions online with Justin, it
> is clear that he and I don't share a common set of requirements for this
> WG, and I suspect that is the case for many.
>
Sent from a mobile device, please excuse any typos

---

From: Mike Jones <[email-masked]>
Date: Thu, 6 Feb 2020 10:04:48 +0000

+1

From: Dick Hardt <[email-masked]>
Sent: Wednesday, February 5, 2020 2:06 PM
To: Yaron Sheffer <[email-masked]>
Cc: Adrian Hope-Bailie <[email-masked]>; Justin Richer <[email-masked]>; Mike Jones <[email-masked]>; Richard Backman, Annabelle <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [Txauth] use case document?

I proposed a use case document so that there is a common understand of what the WG is working to solve. In my discussions online with Justin, it is clear that he and I don't share a common set of requirements for this WG, and I suspect that is the case for many.

First, I don't think there is a common understanding of all the use cases that OAuth 2.0 and OpenID Connect are solving today.

Second, in the latest charter we have "new use cases not enabled by OAuth 2.0.", which is somewhat based on a number of those use cases that were presented in the BoF in Singapore, but in ad hoc discussions, I think there are many use cases that people desire to be solved, but are not widely understood.

In my opinion, the use case document acts as the WGs requirements. Without it, there are disagreements in the IDs because participants are wanting to solve different use cases, but they don't know they have different use cases, so the disagreements surface in the ID. Sometimes those disagreements are resolved in a side meeting, but the knowledge is not captured and the "why" fades away.

I'd advocate that if someone is wanting a feature, there needs to a a use case the WG has agreed to that requires the feature. If the use case is not in the use case document, it needs to be written up and adopted by the WG.

While this adds some overhead to the process, I think it will assist in in alignment on the rest of the work products.

ᐧ

On Wed, Feb 5, 2020 at 11:55 AM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
Yes, but it’s on us to decide at what level of granularity. Typically a use case document would go deeper that what you would expect in a WG charter.

Thanks,
                Yaron

From: Adrian Hope-Bailie <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 5, 2020 at 00:49
To: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Cc: Justin Richer <[email-masked]<mailto:[email-masked]>>, Mike Jones <Michael.Jones=[email-masked]<mailto:[email-masked]>>, "Richard Backman, Annabelle" <richanna=[email-masked]<mailto:40amazon.com@dmarc..ietf.org>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Dick Hardt <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Txauth] use case document?

On Wed, 5 Feb 2020 at 01:06, Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
Once this is a working group, we will need to make decisions on scope: what goes into the base document, what we might want as extensions, and what the WG doesn’t want to work on in the near term.

If we have a use case document, that would be the natural place to have these discussions – you clarify each particular use case and make sure everybody agrees on what it means, and then the group decides which bucket to put it in: base document, extension, defer. Otherwise I’m not sure what the document is intended to achieve..

Thanks,
                Yaron

From: Justin Richer <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, February 4, 2020 at 18:17
To: Mike Jones <Michael.Jones=[email-masked]<mailto:[email-masked]>>
Cc: Dick Hardt <[email-masked]<mailto:[email-masked]>>, Yaron Sheffer <[email-masked]<mailto:[email-masked]>>, "Richard Backman, Annabelle" <richanna=[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Txauth] use case document?

 — Justin

On Feb 3, 2020, at 5:01 PM, Mike Jones <Michael.Jones=[email-masked]<mailto:Michael.Jones=[email-masked]>> wrote:

I agree. I'd rather see use cases sooner than later.
-- Mike
________________________________
From: Txauth <[email-masked]<mailto:[email-masked]>> on behalf of Richard Backman, Annabelle <richanna=[email-masked]<mailto:richanna=[email-masked]>>
Sent: Monday, February 3, 2020 9:04:00 PM
To: Dick Hardt <[email-masked]<mailto:[email-masked]>>; Yaron Sheffer <yaronf.ietf@gmail..com<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] Re: [Txauth] use case document?

For what it’s worth, Justin put this together back in August: https://mailarchive.ietf.org/arch/msg/oauth/v8TdkruCzwH43FMKS598IC2Sheo<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmailarchive.ietf.org%2Farch%2Fmsg%2Foauth%2Fv8TdkruCzwH43FMKS598IC2Sheo&data=02%7C01%7CMichael.Jones%40microsoft.com%7C3b6db8ece2294978163408d7aa87ba2b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637165372257997050&sdata=49TiEcD7uzLY5FzOGvbo3v6uJqMRBdSjH99ilofSws4%3D&reserved=0>

–

Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Works for me.

On Sat, Feb 1, 2020 at 2:23 PM Yaron Sheffer <[email-masked]<mailto:[email-masked]>> wrote:
It’s hard to “tease out” what’s in scope, and in particular what’s *not* in scope, before you have a WG. I am worried about scope creep which is likely to happen once this is a WG and more people are involved.. IMO the best way to avoid it is by only having this discussion once everybody is on board.

Thanks,
                Yaron

Thanks,
                Yaron

From: Txauth <[email-masked]<mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked]<mailto:dick.hardt@gmail..com>>
Date: Saturday, February 1, 2020 at 00:38
To: <[email-masked]<mailto:[email-masked]>>
Subject: [Txauth] use case document?

/Dick
Error! Filename not specified..ᐧ
-- Txauth mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/txauth<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7C3b6db8ece2294978163408d7aa87ba2b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637165372258007041&sdata=lQqB9kaGzok6zJ8jsh4rdhmog7Sftw9JZnRomyyNjnI%3D&reserved=0>
--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7C3b6db8ece2294978163408d7aa87ba2b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637165372258017045&sdata=CHBdL3FpJhs%2BW07wLzCrCQEwjFD0DRR1Yn24%2B14yHRk%3D&reserved=0>

--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftxauth&data=02%7C01%7CMichael.Jones%40microsoft.com%7C3b6db8ece2294978163408d7aa87ba2b%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637165372258027040&sdata=wuLBTXkZf%2B4%2FWX6hAmPYgXYtq2MN%2Fwpb75RXFxDuyQU%3D&reserved=0>

---

From: Dick Hardt <[email-masked]>
Date: Thu, 6 Feb 2020 07:57:47 -0800

On Thu, Feb 6, 2020 at 12:14 AM Adrian Hope-Bailie <[email-masked]>
wrote:

> <snip>

Agreed. Thank you for stating what I was trying to say more clearly!

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 06 Feb 2020 08:56:00 -0800

I believe we all agree that we can start working on use cases for clarity now, but that the time to nail down a precise protocol scope is only after the WG has been chartered.

From: Dick Hardt <[email-masked]>
Date: Thursday, February 6, 2020 at 07:58
To: Adrian Hope-Bailie <[email-masked]>
Cc: Justin Richer <[email-masked]>, Mike Jones <Michael.Jones=[email-masked]>, "Richard Backman, Annabelle" <richanna=[email-masked]>, Yaron Sheffer <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Txauth] use case document?

On Thu, Feb 6, 2020 at 12:14 AM Adrian Hope-Bailie <[email-masked]> wrote:

<snip>

My point is that following the formation of the WG I don't expect us to be bound by the use case document but rather the charter, which, as has been pointed out already, may be less specific.

E.g. we may add use cases post chartering that the WG considers important IF they fit within the scope as defined in the charter.

---

From: Justin Richer <[email-masked]>
Date: Thu, 6 Feb 2020 14:43:05 -0500

But before the WG can be chartered, we need a full WG charter. So comments and suggestions on the charter text (on the other thread) would still be helpful!

 — Justin

> On Feb 6, 2020, at 11:56 AM, Yaron Sheffer <[email-masked]> wrote:
> 
> On Thu, Feb 6, 2020 at 12:14 AM Adrian Hope-Bailie <[email-masked] <mailto:[email-masked]>> wrote:
>> <snip>
>>

---

From: Dick Hardt <[email-masked]>
Date: Thu, 6 Feb 2020 12:27:55 -0800

Would you update with the latest comments and post? Unless I missed it, 3.5
was the latest. :)

On Thu, Feb 6, 2020 at 11:43 AM Justin Richer <[email-masked]> wrote:

> But before the WG can be chartered, we need a full WG charter. So comments
> and suggestions on the charter text (on the other thread) would still be
> helpful!
>
>  — Justin
>
> I believe we all agree that we can start working on use cases for clarity
> now, but that the time to nail down a precise protocol scope is only after
> the WG has been chartered.
>
> *Date: *Thursday, February 6, 2020 at 07:58
> *To: *Adrian Hope-Bailie <[email-masked]>
> *Cc: *Justin Richer <[email-masked]>, Mike Jones <
> Michael.Jones=[email-masked]>, "Richard Backman,
> Annabelle" <richanna=[email-masked]>, Yaron Sheffer <
> [email-masked]>, "[email-masked]" <[email-masked]>