Subject: [Txauth] alignment on Justin's use of "transactional" adjective

From: Fabien Imbault <[email-masked]>
Date: Thu, 23 Apr 2020 16:06:44 +0200

+1 to NAP proposed by Mike.

With that I'll rest easy (in software and elsewhere) ;-)

NAuth would do too (N for negociated)?

Fabien

---

From: Justin Richer <[email-masked]>
Date: Thu, 23 Apr 2020 10:27:27 -0400

I’d be a little of the “N” coming off as “negative” or “not”. As in, this is “not auth”. :P

 — Justin

> On Apr 23, 2020, at 10:06 AM, Fabien Imbault <[email-masked]> wrote:
> 
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth

---

From: Fabien Imbault <[email-masked]>
Date: Thu, 23 Apr 2020 16:54:09 +0200

Yes indeed, it would happen.
ah... naming things...

---

From: "Amanjeev Sethi" <[email-masked]>
Date: Thu, 23 Apr 2020 11:57:30 -0400

Late to the party. 

Reading Justin's docs, the term "intent-based" stands out to me. I do not have any issues with "transaction". But a few more could be -

- Intent Driven Auth (IDAuth)
- Client Intent Origin Auth (CIOAuth)
- Client Intent Driven Auth (CIDAuth)
- Transaction and Intent Driven Yield Auth (TIDYAuth)
- Transaction and Intent Driven Extension Auth (TIDEAuth)
- Transaction and Intent-Driven Extension Auth (TIEAuth)

AJ

---

From: Fabien Imbault <[email-masked]>
Date: Fri, 24 Apr 2020 01:27:02 +0200

Maybe :

Transactional -> Negociated
Tx -> Ng
TxAuth -> NgAuth (which should also be fine with people that prefered
"nextgen").

 ?

Le jeu. 23 avr. 2020 à 16:54, Fabien Imbault <[email-masked]> a

---

From: Vijay IETF <[email-masked]>
Date: Fri, 1 May 2020 01:44:52 +0530

Late to the party. Catching up.
+1 for NgAuth (for its new meaning, not for what I suggested earlier)
+1 for IdAuth (gives some clues that Identity is innate to authorization)

+2 for TxAuth (I really don't see why it is so bad. In fact the
"transaction" is what drew me to this group)

Cheers!