Subject: Re: [Txauth] Name criteria

From: Mike Jones <[email-masked]>
Date: Tue, 28 Apr 2020 01:57:57 +0000

I agree with Justin that the “short” criteria is overly restrictive.  Remember too, that many protocols have a short and a long name, but some don’t.  Some common ones with both long and short names are:
              Internet Protocol (IP)
              Transmission Control Protocol (TCP)
An example without a short name is:
              OpenID Connect
An example that effectively only has a short name is:
              SCIM

All of these kinds of reasonable names should be eligible for consideration, not all of which are short.

                                                       -- Mike

From: Txauth <[email-masked]> On Behalf Of Justin Richer
Sent: Monday, April 27, 2020 6:37 PM
To: Dick Hardt <[email-masked]>
Cc: [email-masked]
Subject: Re: [Txauth] Name criteria

I think the 6-character length requirement is more under “desirable” than “required”. Shorter names are often better, but that doesn’t make a longer name off limits for consideration.

 — Justin

On Apr 27, 2020, at 7:19 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

Riffing on the work done to name Perl6, here are the name criteria I propose:

Required:

  1.  No confusion with another protocol or major software project
  2.  no existing registered trademarks in related classes
  3.  Less than 1M results in Google
  4.  Short (<=6 chars)
  5.  Descriptive of protocol (this criteria is subjective)
Desirable:

  1.  Straightforward to pronounce
  2.  Easy to spell
  3.  Easy to read

--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth

---

From: Dick Hardt <[email-masked]>
Date: Mon, 27 Apr 2020 20:56:55 -0700

I pick 6 chars since all the protocols I could think of were <= 6 chars in
their short form, but I'm fine just stack ranking them.

Would we agree that all other things being equal, shorter is better?

The related dimension would be number of syllables. A smaller number of
syllables makes it easier to say.

... and to argue with Mike ... because it is fun ... :)

The short form for OpenID Connect is OIDC ... and the previous version is
just OpenID ... and while rarely used, SCIM is System for Cross-domain
Identity Management (which as we all know was made up to match the acronym
which originally was Simple Cloud Identity Management)

TCP/IP is the common term used for the wire transport. (6 chars)

On Mon, Apr 27, 2020 at 6:57 PM Mike Jones <[email-masked]>
wrote:

> I agree with Justin that the “short” criteria is overly restrictive.
> Remember too, that many protocols have a short and a long name, but some
> don’t.  Some common ones with both long and short names are:
>
>               Internet Protocol (IP)
>
> All of these kinds of reasonable names should be eligible for
> consideration, not all of which are short.
>
>
>
>                                                        -- Mike
>
>
>
> *From:* Txauth <[email-masked]> *On Behalf Of *Justin Richer
> *Sent:* Monday, April 27, 2020 6:37 PM
> *To:* Dick Hardt <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Txauth] Name criteria
>
>
>
> I think the 6-character length requirement is more under “desirable” than
> “required”. Shorter names are often better, but that doesn’t make a longer
> name off limits for consideration.
>
>
>
>  — Justin
>
>
>
> On Apr 27, 2020, at 7:19 PM, Dick Hardt <[email-masked]> wrote:
>
>
>
> [email-masked]

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 28 Apr 2020 16:29:27 +0300

Please add to point #1: No confusion … or an IETF/IRTF WG.

Now you guys can go back to counting letters 😊

From: Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Tuesday, April 28, 2020 at 06:57
To: Mike Jones <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Justin Richer <[email-masked]>
Subject: Re: [Txauth] Name criteria

I pick 6 chars since all the protocols I could think of were <= 6 chars in their short form, but I'm fine just stack ranking them.

The related dimension would be number of syllables. A smaller number of syllables makes it easier to say.

The short form for OpenID Connect is OIDC ... and the previous version is just OpenID ... and while rarely used, SCIM is System for Cross-domain Identity Management (which as we all know was made up to match the acronym which originally was Simple Cloud Identity Management)

 

On Mon, Apr 27, 2020 at 6:57 PM Mike Jones <[email-masked]> wrote:

              Internet Protocol (IP)

              OpenID Connect

              SCIM

                                                       -- Mike

Cc: txauth@ietf..org

 — Justin

Required:

No confusion with another protocol or major software project
no existing registered trademarks in related classes
Less than 1M results in Google
Short (<=6 chars)
Descriptive of protocol (this criteria is subjective)
Desirable:

Straightforward to pronounce
Easy to spell 
Easy to read

-- Txauth mailing list [email-masked] https://www.ietf.org/mailman/listinfo/txauth

---

From: Mike Jones <[email-masked]>
Date: Tue, 28 Apr 2020 15:54:17 +0000

Arguing with Dick in reply (because it’s fun ;-) )…

“Facebook Connect” is the descriptive name of a successful well-known protocol with no short name.  (“OIDC” is not used in any of the OpenID Connect specs either.)  My point is not to exclude consideration of names without a short form.

And it would be a safe bet that you had to look up the bacronym for “SCIM”, because it doesn’t exactly roll off the tongue!

                                                       Cheers,
                                                       -- Mike

From: Yaron Sheffer <[email-masked]>
Sent: Tuesday, April 28, 2020 6:29 AM
To: Dick Hardt <[email-masked]>; Mike Jones <[email-masked]>
Cc: [email-masked]; Justin Richer <[email-masked]>
Subject: Re: [Txauth] Name criteria

From: Txauth <[email-masked]<mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, April 28, 2020 at 06:57
To: Mike Jones <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Justin Richer <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Txauth] Name criteria

On Mon, Apr 27, 2020 at 6:57 PM Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

                                                       -- Mike

From: Txauth <[email-masked]<mailto:[email-masked]>> On Behalf Of Justin Richer
Sent: Monday, April 27, 2020 6:37 PM
To: Dick Hardt <[email-masked]<mailto:[email-masked]>>
Cc: txauth@ietf..org<mailto:[email-masked]>
Subject: Re: [Txauth] Name criteria

 — Justin

Required:

-- Txauth mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/txauth

---

From: Dick Hardt <[email-masked]>
Date: Tue, 28 Apr 2020 10:04:39 -0700

Revised criteria:

Required:

   1. No confusion with another protocol, major software project, or
   IETF/IRTF WG name
   2. no existing registered trademarks in related classes
   3. Less than 1M results in Google
   4. Descriptive of protocol (this criteria is subjective)

Desirable:

   4. Shortish

And to continue my arguing with Mike ... :)

Facebook Connect has a registered trademark in its name, and while I did
have to look up the current SCIM words, I knew the original! :)

On Tue, Apr 28, 2020 at 8:54 AM Mike Jones <[email-masked]>
wrote:

> “Facebook Connect” is the descriptive name of a successful well-known
> protocol with no short name.  (“OIDC” is not used in any of the OpenID
> Connect specs either.)  My point is not to exclude consideration of names
> without a short form.
>
>
>
> And it would be a safe bet that you had to look up the bacronym for
> “SCIM”, because it doesn’t exactly roll off the tongue!
>
>
>
>                                                        Cheers,
>
>                                                        -- Mike
>
>
>
> *From:* Yaron Sheffer <[email-masked]>
> *Sent:* Tuesday, April 28, 2020 6:29 AM
> *To:* Dick Hardt <[email-masked]>; Mike Jones <
> [email-masked]>
> *Cc:* [email-masked]; Justin Richer <[email-masked]>
> *From: *Txauth <[email-masked]> on behalf of Dick Hardt <
> [email-masked]>
> *Date: *Tuesday, April 28, 2020 at 06:57
> *To: *Mike Jones <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, Justin Richer <[email-masked]>
> *Subject: *Re: [Txauth] Name criteria
>
>
>
> *Cc:* txauth@ietf..org <[email-masked]>
> -- Txauth mailing list [email-masked]
ᐧ

---

From: Daniel Fett <[email-masked]>
Date: Tue, 28 Apr 2020 19:09:19 +0200

>  1. Straightforward to pronounce
5. Not a negatively connotated word in another language

-Daniel

---

From: Dick Hardt <[email-masked]>
Date: Tue, 28 Apr 2020 10:54:09 -0700

Daniel: I'm in favor of the intent of your suggestion -- but curious which
languages we would test that in. Doing it for all languages is impractical.
A negative connotation may also be a locale rather than language specific.
For example, a fag in the UK (a cigarette) is very different than a fag in
the US/Canada (offensive term for a homosexual man).
ᐧ

---

From: "Amanjeev Sethi" <[email-masked]>
Date: Tue, 28 Apr 2020 13:58:00 -0400

Does no one think that "intent driven" can be used for creating a name?

On Tue, Apr 28, 2020, at 1:54 PM, Dick Hardt wrote:
> Daniel: I'm in favor of the intent of your suggestion -- but curious which languages we would test that in. Doing it for all languages is impractical. A negative connotation may also be a locale rather than language specific. For example, a fag in the UK (a cigarette) is very different than a fag in the US/Canada (offensive term for a homosexual man).
> ᐧ
> 
>>>  1. No confusion with another protocol, major software project, or IETF/IRTF WG name

---

From: Daniel Fett <[email-masked]>
Date: Tue, 28 Apr 2020 20:01:26 +0200

Am 28.04.20 um 19:54 schrieb Dick Hardt:
> Daniel: I'm in favor of the intent of your suggestion -- but curious
> which languages we would test that in. Doing it for all languages is
> impractical. A negative connotation may also be a locale rather than
> language specific. For example, a fag in the UK (a cigarette) is very
> different than a fag in the US/Canada (offensive term for a homosexual
> man).

If it is in the Urban Dictionary, it is probably a bad choice ;-)

No, seriously, I guess we can just google for "<x> definition", "<x>
translation" and see what comes up.

-Daniel

---

From: Dick Hardt <[email-masked]>
Date: Tue, 28 Apr 2020 11:11:30 -0700

But which languages are we checking? There are alot in the world. The
phonetics of the name could be offensive -- ie it could be an offensive
word when said in China or Japan. I don't know how to use google to
search phonetics.
ᐧ

---

From: Justin Richer <[email-masked]>
Date: Tue, 28 Apr 2020 14:28:48 -0400

I think that both “intent driven” and “intent registration” are good starting points, as that’s one of several key aspects to this proposed solution space. The flexibility of the interaction (and non-reliance on web browsers for it) is another important aspect.

So interactive intent of some flavor might be an inspiration.

 — Justin

> On Apr 28, 2020, at 1:58 PM, Amanjeev Sethi <[email-masked]> wrote:
> 
>> On Tue, Apr 28, 2020 at 10:09 AM Daniel Fett <[email-masked] <mailto:[email-masked]>> wrote:
>>> No confusion with another protocol, major software project, or IETF/IRTF WG name
>>> Shortish
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
>> -- 
>> Txauth mailing list
>> [email-masked]
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 28 Apr 2020 21:31:02 +0300

If someone in the working group finds it offensive, it is. Not very scientific but IMO good enough.

From: Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Tuesday, April 28, 2020 at 21:12
To: Daniel Fett <[email-masked]>
Cc: <[email-masked]>
Subject: Re: [Txauth] Name criteria

But which languages are we checking? There are alot in the world. The phonetics of the name could be offensive -- ie it could be an offensive word when said in China or Japan. I don't know how to use google to search phonetics. 

ᐧ

Daniel: I'm in favor of the intent of your suggestion -- but curious which languages we would test that in. Doing it for all languages is impractical. A negative connotation may also be a locale rather than language specific.. For example, a fag in the UK (a cigarette) is very different than a fag in the US/Canada (offensive term for a homosexual man).

No, seriously, I guess we can just google for "<x> definition", "<x> translation" and see what comes up. 

-Daniel

---

From: Dick Hardt <[email-masked]>
Date: Tue, 28 Apr 2020 11:33:35 -0700

Works for me.

Revised criteria:

Required:

   5. Not offensive to a member of the mail list.

Desirable:

On Tue, Apr 28, 2020 at 11:31 AM Yaron Sheffer <[email-masked]>
wrote:

> *Date: *Tuesday, April 28, 2020 at 21:12
> *To: *Daniel Fett <[email-masked]>
> *Cc: *<[email-masked]>
> A negative connotation may also be a locale rather than language specific..

---

From: Justin Richer <[email-masked]>
Date: Wed, 29 Apr 2020 11:39:47 -0400

+1. We should avoid things that we are aware are offensive somewhere. Our knowledge will not be universal, but having the “Federation Under Cryptographic Keys” protocol would be a bad call. :)

 — Justin

> On Apr 28, 2020, at 2:31 PM, Yaron Sheffer <[email-masked]> wrote:
> 
> From: Txauth <[email-masked] <mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked] <mailto:[email-masked]>>
> To: Daniel Fett <[email-masked] <mailto:[email-masked]>>
> Cc: <[email-masked] <mailto:[email-masked]>>
> On Tue, Apr 28, 2020 at 11:01 AM Daniel Fett <[email-masked] <mailto:[email-masked]>> wrote:
> -- Txauth mailing list [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>-- 
> Txauth mailing list

---

From: Vijay IETF <[email-masked]>
Date: Fri, 1 May 2020 02:15:01 +0530

You meant "Federation Using Cryptographic Keys" of course. Why still carry
the remnants of the king?
Goes well with "Information Technology". I like it :-)

On Wed, 29 Apr 2020 at 21:10, Justin Richer <[email-masked]> wrote:

> +1. We should avoid things that we are *aware* are offensive somewhere.
> Our knowledge will not be universal, but having the “Federation Under
> Cryptographic Keys” protocol would be a bad call. :)
>
>  — Justin
>