Subject: Re: [Txauth] WG name: TxAuth? XAuth? Something else?

From: Mike Jones <[email-masked]>
Date: Mon, 13 Apr 2020 23:37:50 +0000

The normal computer science use of the term “transaction” involves a proposed state change that either commits or aborts atomically.  That doesn’t match your description of the term below.  It also doesn’t match the RFC 4949<https://tools.ietf.org/html/rfc4949> definition of the term (which does match my paraphrase above).  It reads:

   $ transaction
      1. (I) A unit of interaction between an external entity and a
      system, or between components within a system, that involves a
      series of system actions or events.

      2. (O) "A discrete event between user and systems that supports a
      business or programmatic purpose." [M0404<https://tools.ietf.org/html/rfc4949#ref-M0404>]

      Tutorial: To maintain secure state, transactions need to be
      processed coherently and reliably. Usually, they need to be
      designed to be atomic, consistent, isolated, and durable [Gray<https://tools.ietf.org/html/rfc4949#ref-Gray>]:
      -  "Atomic": All actions and events that comprise the transaction
         are guaranteed to be completed successfully, or else the result
         is as if none at all were executed.
      -  "Consistent": The transaction satisfies correctness constraints
         defined for the data that is being processed.
      -  "Isolated": If two transactions are performed concurrently,
         they do not interfere with each other, and it appears as though
         the system performs one at a time.
      -  "Durable": System state and transaction semantics survive
         system failures.

We shouldn’t try to invent a new meaning for the well-established computer science term “transaction” in this working group.

                                                       -- Mike

P.S.  On a personal note, I really continue to miss Jim Gray.

From: Justin Richer <[email-masked]>
Sent: Monday, April 13, 2020 4:27 PM
To: Mike Jones <[email-masked]>
Cc: Vijay IETF <[email-masked]>; Matthew A. Miller <[email-masked]>; Lee McGovern <[email-masked]>; Amanjeev Sethi <[email-masked]>; [email-masked]
Subject: Re: [Txauth] WG name: TxAuth? XAuth? Something else?

On Apr 13, 2020, at 6:25 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:

Because the proposed starting points and likely outcomes aren’t transactional, I believe we shouldn’t confuse people by calling it Transactional Authorization or using the abbreviation “Tx”.

I’m not sure what you mean. XYZ, as a starting point, is transactional by design. I have given several talks on this topic, which you have attended. And in fact I would argue that the entire intent-registration pattern, upon which both proposals are predicated, is transactional in nature as well. As Dick was kind enough to pull the definition earlier in this thread, let me restate that definition:

              a communicative action or activity involving two parties or things that reciprocally affect or influence each other

The entire act of getting the delegation to occur is a transaction between the client and the AS (or equivalent component). The client begins the transaction by talking to the AS, the AS continues the transaction by optionally getting the user involved, and the client continues the transaction when the interaction portion is completed, and so on. While this is intentionally built into XYZ, I would argue that even XAuth has this feature.

So with that in mind, I don’t think it’s misleading or confusing at all. I’m not sure why people keep referring to it as “incorrect”.

Yes, there are other definitions of “transaction” that do not apply — words have more than one definition, and that happens.

Since you asked, I will gladly offer my specific thoughts on your suggestions.

I haven’t heard responses to any of these brainstormed names yet:

  *   Disaggregated Authorization (DisAuth)
  *   Componentized Authorization (CompAuth)

Neither of these capture what’s different about this. The components are largely the same as they were in OAuth 2, UMA, OIDC, SAML, and related protocols. The componentization isn’t the new thing here, so I don’t think these are that good a fit.

  *
  *   Build-Your-Own Authorization (BYOAuth)
  *   Do-It-Yourself Authorization (DIYAuth)

These aren’t really what we’re after at all. In fact, the proposed charter is specifically about building a protocol instead of a framework, so either of these are very misleading.

  *
  *   Refactored Authorization (ReAuth or RefAuth)

This doesn’t offer any description of what’s gone on here. Refactored from what? Additionally  I don’t believe this name flows naturally from the proposed shortenings.  “ReAuth” sounds like “ReAuthorization” and/or “ReAuthentication”, where as “RefAuth” sounds like it should stand for “reference” instead of “refactored”.

  *

To those I’ll now add:

  *   Alternative Authorization Protocol (AAP)
  *   Alternative Authorization (AltAuth)
  *   Reimagined Authorization (ReAuth)

All of these are problematic for the same reason that “NewAuth” or “NgAuth” are. They just say “it’s new” and don’t say anything about it. And if we’re successful, it won’t be “new" while people are still using it.

  *
  *   Back-end Based Authorization (BBAuth)

This is a start in concept, as it starts to talk about what’s different, but “BBAuth” is already something — one of the predecessors of OAuth 1.0 was “BBAuth” from Flickr (later Yahoo). Also, note that in this historical context, the expansion is “Browser Based Auth”, which could happen here again. As one of the key aspects of what people are interested is decoupling from the browser, we don’t want to have echos of that, even if the name weren’t already historically taken.

  *

And for fun, there’s still:

  *   Dismembered Authorization
Plus:

  *   ZZAuth – The Protocol

Please, no.

Surely others must have other good ideas than don’t use the misleading term “Transactional” or its abbreviation “Tx”.

Again, as above, this is not misleading. That said, if there’s a better idea, I’m open to it. But for all of the reasons I keep repeating now, TxAuth is decent and I haven’t seen a better one.

Thanks,

 — Justin

                                                       Cheers,
                                                       -- Mike

From: Txauth <[email-masked]<mailto:[email-masked]>> On Behalf Of Justin Richer
Sent: Monday, April 13, 2020 11:43 AM
To: Vijay IETF <[email-masked]<mailto:[email-masked]>>
Cc: Matthew A. Miller <[email-masked]<mailto:[email-masked]>>; Lee McGovern <[email-masked]<mailto:[email-masked]>>; Amanjeev Sethi <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Txauth] WG name: TxAuth? XAuth? Something else?

I appreciate the brainstorming of names here.

I dislike names like “NgAuth” or “YAAP” or the like because they rely on this being “new” and it’s only “new” right now. If we’re successful and people are still talking about it in ten years then it won’t be new anymore and the name will just seem absurd.

While we’re at it, we really can’t use “XAuth” because it’s already been something for 30 years: the X11 authentication command: https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html

My project’s name “XYZ” would also be a bad name for a lasting protocol, as it’s too generic on its own.

I still argue that we should call the protocol and the working group TxAuth. Not only do I think the underlying “transactional authorization” aspect is a key difference from what’s come before (the nature of which I’ve described many, many times on this list), if you go and search for the term “txauth” you end up back at this mailing list and the posts that people have made about it.

 — Justin

On Apr 10, 2020, at 9:22 AM, Vijay IETF <[email-masked]<mailto:[email-masked]>> wrote:

Assuming we are still at it...

NgAuth (Next Gen Auth).

On Tue, 24 Mar 2020 at 19:00, Amanjeev Sethi <[email-masked]<mailto:[email-masked]>> wrote:
TOI (as in french you): TxAuth's OAuth's Improvement

On Tue, Mar 24, 2020, at 4:25 AM, Lee McGovern wrote:
> YAAP
>
> Yet another authX protocol
>
>
> -----Original Message-----
> From: Txauth <[email-masked]<mailto:[email-masked]>> On Behalf Of Matthew A. Miller
> Sent: Monday, March 23, 2020 3:06 PM
> To: [email-masked]<mailto:[email-masked]>
> Subject: Re: [Txauth] WG name: TxAuth? XAuth? Something else?
>
> On 20/03/23 13:49, Brian Campbell wrote:
> > YAAAAS - Yet Another Authorization And Authentication Specification
> >
>
> +1
>
>
> - m&m
>
> Matthew A. Miller
>
> > On Mon, Mar 23, 2020 at 1:39 PM Mike Jones
> > <Michael.Jones=40microsoft.com<http://40microsoft.com/>@dmarc..ietf.org<http://ietf.org/>
> > <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
> >
> >     In brainstorming mode…____
> >
> >       * Disaggregated Authorization (DisAuth)____
> >       * Componentized Authorization (CompAuth)____
> >       * Build-Your-Own Authorization (BYOAuth)____
> >       * Do-It-Yourself Authorization (DIYAuth)____
> >       * Refactored Authorization (ReAuth or RefAuth)____
> >
> >     __ __
> >
> >     And for fun…____
> >
> >       * Dismembered Authorization____
> >
> >     __ __
> >
> >                                                            -- Mike____
> >
> >     __ __
> >
> >     *From:* Txauth <[email-masked]<mailto:[email-masked]>
> >     <mailto:[email-masked]<mailto:[email-masked]>>> *On Behalf Of *David Skaife
> >     *Sent:* Saturday, March 21, 2020 11:22 AM
> >     *To:* Justin Richer <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> >     *Cc:* Yaron Sheffer <[email-masked]<mailto:[email-masked]>
> >     <mailto:[email-masked]<mailto:[email-masked]>>>; [email-masked]<mailto:[email-masked]>
> >     <mailto:[email-masked]<mailto:[email-masked]>>; Dick Hardt <[email-masked]<mailto:[email-masked]>
> >     <mailto:[email-masked]<mailto:[email-masked]>>>
> >     *Subject:* Re: [Txauth] WG name: TxAuth? XAuth? Something
> > else?____
> >
> >     __ __
> >
> >     I think we're saying the same thing with regards to the working
> >     group name - I was saying it *isn't* particularly important in
> >     comparison to the name of the protocol (which obviously is very
> >     important).____
> >
> >     __ __
> >
> >     On Sat, Mar 21, 2020 at 6:18 PM Justin Richer <[email-masked]<mailto:[email-masked]>
> >     <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
> >
> >         I disagree on the working group name being super important.
> >         Nobody knows that the OAuth WG is actually named “The Web
> >         Authorization Protocol Working Group”, and nobody cares.____
> >
> >         __ __
> >
> >         My proposal is that we name the protocol we work on “TxAuth”
> >         (and keep the mailing list), and that we name the working group
> >         something like “Next Generation Web Authorization Protocol” to
> >         say what we’re doing.____
> >
> >         __ __
> >
> >          -- Justin____
> >
> >
> >
> >         ____
> >
> >             On Mar 21, 2020, at 2:08 PM, David Skaife
> >             <[email-masked]<mailto:[email-masked]>
> >             <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
> >
> >             __ __
> >
> >             Just to throw in another suggestion, to address Yaron's
> >             point about some people mistakenly thinking that "Auth"
> >             stands for authentication rather than authorization, how
> >             about naming the working group *AuthZ*____
> >
> >             Nice and simple, and it makes it clear what the group is
> >             focused on.
> >
> >             I think the name of the actual protocol that we produce is
> >             far, far more important that the name of the working group -
> >             and the name of that protocol doesn't need to correlate to
> >             the WG name. Also, we have much more time before we need to
> >             decide on the name of that protocol, even if the
> >             initial draft documents that we produce end up using a
> >             placeholder name.____
> >
> >             __ __
> >
> >             On Sat, Mar 21, 2020 at 5:44 PM Justin Richer
> >             <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
> >
> >                 As you can see in the email you replied to, that is not
> >                 even close to what I said. I believe it is a
> >                 transaction, and therefore, I do not agree that it’s not
> >                 a transaction.____
> >
> >                 __ __
> >
> >                 But if we take “Transactional” out of the WG title, I
> >                 won’t be offended. If we just call it “TxAuth” without
> >                 expansion, then that’s fine.____
> >
> >                 __ __
> >
> >                 I do not like calling it “XAuth”. The term “TAuth" was
> >                 floated during naming the list, but rejected because
> >                 (among other reasons) it would likely be awkwardly
> >                 pronounced as “towth” or something. TxAuth reads as “Tee
> >                 - ex - oth” more naturally, which was the intent. ____
> >
> >                 __ __
> >
> >                 So how about we take a page from the OAuth working group
> >                 and name it:____
> >
> >                 __ __
> >
> >                 TxAuth - Next Generation Web Authorization Protocol
> >                 Working Group____
> >
> >                 __ __
> >
> >                 __ __
> >
> >                  — Justin____
> >
> >
> >
> >                 ____
> >
> >                     On Mar 21, 2020, at 1:15 PM, Dick Hardt
> >                     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> >                     wrote:____
> >
> >                     __ __
> >
> >                     To clarify -- you agree it is not a transaction, and
> >                     we will take the word transaction out of the WG
> >                     title?____
> >
> >                     __ __
> >
> >                     On Fri, Mar 20, 2020 at 5:53 PM Justin Richer
> >                     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> > wrote:____
> >
> >                         Dick, thanks for pulling the definitions
> > up:____
> >
> >                         __ __
> >
> >                         > a communicative action or activity involving
> >                         two parties or things that reciprocally affect
> >                         or influence each other____
> >
> >                         __ __
> >
> >                         This is the kind of thing that I had in mind.
> >                         The client and the AS are in a conversation over
> >                         time that each one contributes to and each
> >                         changes. ____
> >
> >                         __ __
> >
> >                         Also — we can just as easily decide that
> >                         “TxAuth” doesn’t stand for “Transactional Auth”
> >                         much the same way we decided that the “O” in
> >                         “OAuth” doesn’t stand for “Open” anymore. ____
> >
> >                         __ __
> >
> >                         None of the arguments below in favor of XAuth
> >                         have made me like that name better. If it’s just
> >                         a “placeholder” name, then why come up with
> >                         something new?____
> >
> >                         __ __
> >
> >                          — Justin____
> >
> >
> >
> >                         ____
> >
> >                             On Mar 20, 2020, at 3:32 PM, Dick Hardt
> >                             <[email-masked]<mailto:[email-masked]>
> >                             <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
> >
> >                             __ __
> >
> >                             __ __
> >
> >                             __ __
> >
> >                             __ __
> >
> >                             not a transaction - there are multiple
> >                             transactions____
> >
> >                             __ __
> >
> >                             backchannel innovation is combination of
> >                             here is who I am, and here is what I want to
> >                             do____
> >
> >                             __ __
> >
> >                             __ __
> >
> >                             childhood trauma therapy group____
> >
> >                             __ __
> >
> >                             __ __
> >
> >                             __ __
> >
> >                             On Mon, Mar 16, 2020 at 6:56 PM Justin
> >                             Richer <[email-masked]<mailto:[email-masked]>
> >                             <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
> >
> >                                 Yes, naming things is hard — but I still
> >                                 believe in the name TxAuth. We’re moving
> >                                 beyond OAuth, and taking the process of
> >                                 getting an authorization delegated to
> >                                 the client software as a multi-step,
> >                                 multi-party transaction is, I believe,
> >                                 the key insight that’s letting us move
> >                                 beyond OAuth’s limitations here. It’s
> >                                 not just about going to the AS first —
> >                                 we had that in OAuth 1 and we’re
> >                                 patching that into OAuth 2 with PAR.. I
> >                                 really think it’s about the transaction
> >                                 at the core.. ____
> >
> >                             __ __
> >
> >                             OAuth 2.0 had multi-step, multi-party.
> >                             TxAuth extends that.____
> >
> >                             __ __
> >
> >                             I think the big shift is going to the AS.
> >                             This enables the request to be richer with
> >                             JSON, instead of name/value pairs parameters
> >                             in a URI. It allows the client and AS to
> >                             negotiate, and to short circuit having to
> >                             redirect the user to the AS. PAR does some
> >                             of this, but it is constrained by having to
> >                             do it in the OAuth 2.0 context.____
> >
> >                             __ __
> >
> >                             My concern is that the protocol is MUCH MORE
> >                             than a transaction. While the initial
> >                             interaction between client, AS, user and RO
> >                             is a transaction. The protocol also covers
> >                             the client and RS interactions. The access
> >                             token refreshes. Access token revocation.
> >                             Access token introspection. As described in
> >                             the charter, there is a whole lifecycle,
> >                             that consists of multiple
> > transactions.____
> >
> >                             __ __
> >
> >                             From
> > https://www.merriam-webster.com/dictionary/transaction:____
> >
> >                             __ __
> >
> >
> >                                 Definition of /transaction/____
> >
> >                             *1a**: *something transacted
> >                             <https://www.merriam-webster.com/dictionary/transacted>/especially/ *: *an
> >                             exchange or transfer
> >                             <https://www.merriam-webster.com/dictionary/transfer> of
> >                             goods, services, or
> >                             fundselectronic /transactions/____
> >
> >                             *b: transactions*/ plural/ *: *the often
> >                             published record of the meeting of a society
> >                             or association____
> >
> >                             *2a**: *an act, process, or instance
> >                             of transacting
> >
> > <https://www.merriam-webster.com/dictionary/transacting>____
> >
> >                             *b**: *a communicative action or activity
> >                             involving two parties or things that
> >                             reciprocally affect or influence each
> > other____
> >
> >                             __ __
> >
> >                             Calling the protocol a transaction will
> >                             confusing to people.____
> >
> >                              ____
> >
> >                                 __ __
> >
> >                                 Having come of age in the 1990’s, I have
> >                                 particular dislike for XAuth. It sounds
> >                                 too “X-TREME” and “X-CITING”, and if you
> >                                 read either of those with a growling
> >                                 yell in your head then you know exactly
> >                                 what I’m talking about.____
> >
> >                             __ __
> >
> >                             In case you are confused, this is not a
> >                             childhood trauma support group.  :)____
> >
> >                             __ __
> >
> >                             Unlike "X-TREME" or "X-CITING", XAuth is
> >                             using the "X" as a placeholder. X-Men, Xbox,
> >                             X-Factor, X-files. ____
> >
> >                             __ __
> >
> >
> > https://www.businessinsider.com/the-indisputable-power-of-brand-x-2012
> > -4____
> >
> >                             __ __
> >
> >
> > https://english.stackexchange.com/questions/358181/whats-the-purpose-o
> > f-using-letter-x-or-x-as-a-suffix-in-brand-names____
> >
> >                             __ __
> >
> >                              ____
> >
> >                                 And to Dick’s rationale for the name
> >                                 below, I absolutely do NOT see this work
> >                                 as “OAuth with all the extra features”.
> >                                 I think that does a disservice to the
> >                                 kind of change we have an opportunity to
> >                                 make here. ____
> >
> >                             __ __
> >
> >                             From the charter ____
> >
> >                             __ __
> >
> >                                 "It will expand upon the uses cases
> >                                 currently supported by OAuth 2.0 and
> >                                 OpenID Connect (itself an extension of
> >                                 OAuth 2.0)"____
> >
> >                             __ __
> >
> >                             Which sounds pretty similar to “OAuth with
> >                             all the extra features”____
> >
> >                             __ __
> >
> >                             While I think XAuth captures what we are
> >                             doing, a placeholder name would be
> >                             preferable to an incorrect descriptive name
> >                             such as TxAuth.____
> >
> >                             __ __
> >
> >                             For example, XYZ is a good placeholder name.
> >                             Or XYZAuth. Let's not mislead people.____
> >
> >                              ____
> >
> >                                 __ __
> >
> >                                  — Justin____
> >
> >
> >
> >                                 ____
> >
> >                                     On Mar 16, 2020, at 7:04 PM, Dick
> >                                     Hardt <[email-masked]<mailto:[email-masked]>
> >                                     <mailto:[email-masked]<mailto:[email-masked]>>>
> >                                     wrote:____
> >
> >                                     __ __
> >
> >                                     Hello everyone____
> >
> >                                     __ __
> >
> >                                     I prompted a thread around the name
> >                                     of the protocol a while back:____
> >
> >                                     __ __
> >
> >
> > https://mailarchive.ietf.org/arch/msg/txauth/ZVQVbHt4ADqehKrBDXOrTr_s_
> > wc/____
> >
> >                                     __ __
> >
> >                                     As Justin stated "naming is
> > hard"____
> >
> >                                     __ __
> >
> >                                     Wearing my marketing hat I want to
> >                                     ensure that the name will be
> >                                     perceived properly in the broader
> >                                     community.____
> >
> >                                     __ __
> >
> >                                     A recent example that comes to mind
> >                                     are the privacy related works on the
> >                                     browser storage API. Given that
> >                                     name, one would think that it is
> >                                     local storage. It is actually about
> >                                     browser cookies.____
> >
> >                                     __ __
> >
> >                                     Justin discussed his reasons for
> >                                     TxAuth in the thread above (and I'm
> >                                     sure in other places)____
> >
> >                                     __ __
> >
> >                                     I chose XAuth in my draft to reflect
> >                                     the eXtensibility goal that we have
> >                                     over OAuth -- and XAuth is OAuth but
> >                                     with an X to reflect all the extra
> >                                     features. =)____
> >
> >                                     __ __
> >
> >                                     Other suggestions?____
> >
> >                                     __ __
> >
> >                                     This will be an agenda item in the
> >                                     BoF -- but the name will NOT be an
> >                                     open discussion item -- we will
> >                                     summarize what has been discussed on
> >                                     the list and perhaps do a poll of
> >                                     options presented unless consensus
> >                                     is obvious from this thread.____
> >
> >                                     __ __
> >
> >                                     /Dick____
> >
> >                                     __ __
> >
> >                                     __ __
> >
> >                                     __ __
> >
> >                                     __ __
> >
> >                                     __ __
> >
> >                                     ᐧ____
> >
> >                                 __ __
> >
> >                         __ __
> >
> >                 __ __
> >
> >                 --
> >                 Txauth mailing list
> >                 [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> >                 https://www.ietf.org/mailman/listinfo/txauth____
> >
> >         __ __
> >
> >     --
> >     Txauth mailing list
> >     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> >     https://www.ietf.org/mailman/listinfo/txauth
> >
> >
> >
> > --
> > <https://www.pingidentity.com<https://www.pingidentity.com/>>Ping Identity <https://www.pingidentity.com<https://www.pingidentity.com/>>
> > Brian Campbell
> > Distinguished Engineer
> > [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> > w: +1 720.317.2061
> > c: +1 303.918..9415
> >
> > Connect with us:    Glassdoor logo
> > <https://www.glassdoor.com/Overview/Working-at-Ping-Identity-EI_IE3809
> > 07.11,24.htm> LinkedIn logo <https://www.linkedin.com/company/21870>
> > twitter logo
> > <https://twitter.com/pingidentity>  facebook logo
> > <https://www.facebook.com/pingidentitypage> youtube logo
> > <https://www.youtube.com/user/PingIdentityTV> Blog logo
> > <https://www.pingidentity.com/en/blog.html>
> >
> > <https://www.google.com/url?q=https://www.pingidentity.com/content/dam
> > /ping-6-2-assets/Assets/faqs/en/consumer-attitudes-post-breach-era-337
> > 5.pdf?id%3Db6322a80-f285-11e3-ac10-0800200c9a66&source=gmail&ust=15416
> > 93608526000&usg=AFQjCNGBl5cPHCUAVKGZ_NnpuFj5PHGSUQ><https://www.pingid<https://www.pingid/>
> > entity.com/en/events/d/identify-2019.html<http://entity.com/en/events/d/identify-2019.html>><https://www.pingidentity.co<https://www.pingidentity.co/>
> > m/content/dam/ping-6-2-assets/Assets/Misc/en/3464-consumersurvey-execs
> > ummary.pdf><https://www.pingidentity.com/en/events/e/rsa.html><https:/
> > /www.pingidentity.com/en/events/e/rsa.html<http://www.pingidentity.com/en/events/e/rsa.html>><https://www.pingidentity.c<https://www.pingidentity.c/>
> > om/en/lp/e/enabling-work-from-home-with-MFA.html>
> >
> > /If you’re not a current customer, click here
> > <https://www.pingidentity.com/en/lp/e/work-from-home-sso-mfa.html?utm_
> > source=Email&utm_campaign=WF-COVID19-New-EMSIG> for a more relevant
> > offer./
> >
> > /CONFIDENTIALITY NOTICE: This email may contain confidential and
> > privileged material for the sole use of the intended recipient(s). Any
> > review, use, distribution or disclosure by others is strictly
> > prohibited..  If you have received this communication in error, please
> > notify the sender immediately by e-mail and delete the message and any
> > file attachments from your computer. Thank you./
> >
>
> --
> Txauth mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth
>
>
> This e-mail, including attachments, is intended for the person(s) or
> company named and may contain confidential and/or legally privileged
> information.
>
> Unauthorized disclosure, copying or use of this information may be
> unlawful and is prohibited. If you are not the intended recipient,
> please delete this message and notify the sender.
> All incoming and outgoing e-mail messages are stored in the Swiss Re
> Electronic Message Repository.
> If you do not wish the retention of potentially private e-mails by
> Swiss Re, we strongly advise you not to use the Swiss Re e-mail account
> for any private, non-business related communications.
> --
> Txauth mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth
>

--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth
--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth

---

From: Justin Richer <[email-masked]>
Date: Mon, 13 Apr 2020 21:24:51 -0400

Mike, thanks for pulling up the definition. I agree we don’t want to redefine a well-used term, but I disagree that this is any attempt to redefine the well-used term here; but instead I see us applying it in a way that is consistent with the design goals of at least one of the input documents (XYZ) and I would argue with the core tenets of the solution space that we’re looking into. 

While the definition that I quoted from Dick below is the best fit, I still think that the units below are also appropriate. You begin the transaction when the client starts things off. The transaction ends when the token is issued. The token is the result of the transaction. While it’s not a perfect 1:1 mapping, since we’re talking about a multi-party protocol and not the fundamental definition here, 

And I think with all of this argument it’s important to point out that I’ve been using an adjective form the whole time: Transactional Authorization. It’s an authorization that has aspects and components and artifacts of a transaction. That doesn’t mean that this protocol is a transaction in every aspect. Nor is it, I would argue, authorization in every aspect. Just like “identity” covers many, many things, so do these terms, and I think we’re honestly hitting enough of them for it to make sense, still.

I’m still fine with a *better* name if there is one to be had. Naming things is hard.

For some context, these are a few of the names that Roman and I tossed around when we came up with TxAuth for the list name six months ago:

	TRAP: Transaction Authorization Protocol

	TRADE: Transaction Authorization and Delegation

I’m not a big fan of either of those because I’m not big on cute and pronounceable acronyms, personally. I could live with “TRADE” though if there was a groundswell for it.

 — Justin

> On Apr 13, 2020, at 7:37 PM, Mike Jones <[email-masked]> wrote:
> 
> The normal computer science use of the term “transaction” involves a proposed state change that either commits or aborts atomically.  That doesn’t match your description of the term below.  It also doesn’t match the RFC 4949 <https://tools.ietf.org/html/rfc4949> definition of the term (which does match my paraphrase above).  It reads:
>  
>    $ transaction
>       business or programmatic purpose." [M0404 <https://tools.ietf.org/html/rfc4949#ref-M0404>]
>  
>       designed to be atomic, consistent, isolated, and durable [Gray <https://tools.ietf.org/html/rfc4949#ref-Gray>]:
> On Apr 13, 2020, at 6:25 PM, Mike Jones <[email-masked] <mailto:[email-masked]>> wrote:
>  
> Disaggregated Authorization (DisAuth)
> Componentized Authorization (CompAuth)
>  
> Build-Your-Own Authorization (BYOAuth)
> Do-It-Yourself Authorization (DIYAuth)
>  
> Refactored Authorization (ReAuth or RefAuth)
>  
> Alternative Authorization Protocol (AAP)
> Alternative Authorization (AltAuth)
> Reimagined Authorization (ReAuth)
>  
> Back-end Based Authorization (BBAuth)
>  
> Dismembered Authorization
> Plus:
> ZZAuth – The Protocol
>  
> Please, no.
> 
> 
>  
> From: Txauth <[email-masked] <mailto:[email-masked]>> On Behalf Of Justin Richer
> To: Vijay IETF <[email-masked] <mailto:[email-masked]>>
> Cc: Matthew A. Miller <[email-masked] <mailto:[email-masked]>>; Lee McGovern <[email-masked] <mailto:[email-masked]>>; Amanjeev Sethi <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> While we’re at it, we really can’t use “XAuth” because it’s already been something for 30 years: the X11 authentication command: https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html <https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html>
>  
> On Apr 10, 2020, at 9:22 AM, Vijay IETF <[email-masked] <mailto:[email-masked]>> wrote:
>  
> On Tue, 24 Mar 2020 at 19:00, Amanjeev Sethi <[email-masked] <mailto:[email-masked]>> wrote:
> > From: Txauth <[email-masked] <mailto:[email-masked]>> On Behalf Of Matthew A. Miller
> > To: [email-masked] <mailto:[email-masked]>
> > > <Michael.Jones=40microsoft.com <http://40microsoft.com/>@dmarc..ietf.org <http://ietf.org/>
> > > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
> > > 
> > >     *From:* Txauth <[email-masked] <mailto:[email-masked]>
> > >     <mailto:[email-masked] <mailto:[email-masked]>>> *On Behalf Of *David Skaife
> > >     *To:* Justin Richer <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
> > >     *Cc:* Yaron Sheffer <[email-masked] <mailto:[email-masked]>
> > >     <mailto:[email-masked] <mailto:[email-masked]>>>; [email-masked] <mailto:[email-masked]>
> > >     <mailto:[email-masked] <mailto:[email-masked]>>; Dick Hardt <[email-masked] <mailto:[email-masked]>
> > >     <mailto:[email-masked] <mailto:[email-masked]>>>
> > >     On Sat, Mar 21, 2020 at 6:18 PM Justin Richer <[email-masked] <mailto:[email-masked]>
> > >     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > > 
> > >             <[email-masked] <mailto:[email-masked]>
> > >             <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > > 
> > >             __ __
> > > 
> > >             <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > > 
> > >                     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
> > >                     wrote:____
> > > 
> > >                     __ __
> > > 
> > >                     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> 
> > > wrote:____
> > > 
> > >                             <[email-masked] <mailto:[email-masked]>
> > >                             <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > > 
> > >                             __ __
> > > 
> > >                             __ __
> > > 
> > >                             __ __
> > > 
> > >                             __ __
> > > 
> > >                             Richer <[email-masked] <mailto:[email-masked]>
> > >                             <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > > 
> > > https://www.merriam-webster.com/dictionary/transaction:____ <https://www.merriam-webster.com/dictionary/transaction:____>
> > > 
> > >                             __ __
> > > 
> > > 
> > >                             <https://www.merriam-webster.com/dictionary/transacted <https://www.merriam-webster.com/dictionary/transacted>>/especially/ *: *an
> > >                             exchange or transfer
> > >                             <https://www.merriam-webster.com/dictionary/transfer <https://www.merriam-webster.com/dictionary/transfer>> of
> > >                             goods, services, or
> > > <https://www.merriam-webster.com/dictionary/transacting <https://www.merriam-webster.com/dictionary/transacting>>____
> > > 
> > > https://www.businessinsider.com/the-indisputable-power-of-brand-x-2012 <https://www.businessinsider.com/the-indisputable-power-of-brand-x-2012>
> > > -4____
> > > 
> > >                             __ __
> > > 
> > >                             
> > > https://english.stackexchange.com/questions/358181/whats-the-purpose-o <https://english.stackexchange.com/questions/358181/whats-the-purpose-o>
> > >                                     Hardt <[email-masked] <mailto:[email-masked]>
> > >                                     <mailto:[email-masked] <mailto:[email-masked]>>>
> > >                                     wrote:____
> > > 
> > >                                     __ __
> > > 
> > >                                     Hello everyone____
> > > 
> > >                                     __ __
> > > 
> > > https://mailarchive.ietf.org/arch/msg/txauth/ZVQVbHt4ADqehKrBDXOrTr_s_ <https://mailarchive.ietf.org/arch/msg/txauth/ZVQVbHt4ADqehKrBDXOrTr_s_>
> > > wc/____
> > > 
> > >                                     __ __
> > > 
> > >                 [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
> > >                 https://www.ietf.org/mailman/listinfo/txauth____ <https://www.ietf.org/mailman/listinfo/txauth____>
> > > 
> > >         __ __
> > > 
> > >     -- 
> > >     Txauth mailing list
> > >     [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
> > >     https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
> > > 
> > > 
> > > 
> > > -- 
> > > <https://www.pingidentity.com <https://www.pingidentity.com/>>Ping Identity <https://www.pingidentity.com <https://www.pingidentity.com/>>          
> > > Brian Campbell      
> > > Distinguished Engineer      
> > > [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>      
> > > w: +1 720.317.2061  
> > > c: +1 303.918..9415 
> > > 
> > > <https://www.glassdoor.com/Overview/Working-at-Ping-Identity-EI_IE3809 <https://www.glassdoor.com/Overview/Working-at-Ping-Identity-EI_IE3809>
> > > 07.11,24.htm> LinkedIn logo <https://www.linkedin.com/company/21870 <https://www.linkedin.com/company/21870>>
> > > twitter logo
> > > <https://twitter.com/pingidentity <https://twitter.com/pingidentity>>  facebook logo
> > > <https://www.facebook.com/pingidentitypage <https://www.facebook.com/pingidentitypage>> youtube logo
> > > <https://www.youtube.com/user/PingIdentityTV <https://www.youtube.com/user/PingIdentityTV>> Blog logo
> > > <https://www.pingidentity.com/en/blog.html <https://www.pingidentity.com/en/blog.html>> 
> > > 
> > > <https://www.google.com/url?q=https://www.pingidentity.com/content/dam <https://www.google.com/url?q=https://www.pingidentity.com/content/dam>
> > > 93608526000&usg=AFQjCNGBl5cPHCUAVKGZ_NnpuFj5PHGSUQ><https://www.pingid <https://www.pingid/>
> > > entity.com/en/events/d/identify-2019.html <http://entity.com/en/events/d/identify-2019.html>><https://www.pingidentity.co <https://www.pingidentity.co/>
> > > ummary.pdf><https://www.pingidentity.com/en/events/e/rsa.html <https://www.pingidentity.com/en/events/e/rsa.html>><https:/
> > > /www.pingidentity.com/en/events/e/rsa.html <http://www.pingidentity.com/en/events/e/rsa.html>><https://www.pingidentity.c <https://www.pingidentity.c/>
> > > <https://www.pingidentity.com/en/lp/e/work-from-home-sso-mfa.html?utm_ <https://www.pingidentity.com/en/lp/e/work-from-home-sso-mfa.html?utm_>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
> > 
> > 
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
> >
> 
> -- 
> Txauth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
> -- 
> Txauth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>

---

From: George Fletcher <[email-masked]>
Date: Tue, 14 Apr 2020 11:51:30 -0400

Personally I like TRADE as the words clearly identify what the protocol 
is about. For me, the protocol is about establishing Authorization and 
Delegation for use in multiple transactions over time.

---

From: George Fletcher <[email-masked]>
Date: Tue, 14 Apr 2020 11:51:30 -0400

---

From: "Hjelm, Bjorn" <[email-masked]>
Date: Tue, 14 Apr 2020 09:39:28 -0700

I agree with George.

+1 on TRADE.

BR,
Bjorn

On Tue, Apr 14, 2020 at 8:54 AM George Fletcher <gffletch=
[email-masked]> wrote:

> Personally I like TRADE as the words clearly identify what the protocol is
> about. For me, the protocol is about establishing Authorization and
> On Apr 13, 2020, at 7:37 PM, Mike Jones <[email-masked]> <[email-masked]> wrote:
>
> The normal computer science use of the term “transaction” involves a proposed state change that either commits or aborts atomically.  That doesn’t match your description of the term below.  It also doesn’t match the RFC 4949 <https://tools.ietf.org/html/rfc4949> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc4949&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=acQQVtWuiF90a6IeEaPpypr2KgkzQ_OsZd1uJz25x-Y&e=> definition of the term (which does match my paraphrase above).  It reads:
>
>    $ transaction
>       business or programmatic purpose." [M0404 <https://tools.ietf.org/html/rfc4949#ref-M0404> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc4949-23ref-2DM0404&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=xSzZJWqz-GDfujPKmm6ET3EYZCN9JjsIpdNrt8iKaBM&e=>]
>
>       designed to be atomic, consistent, isolated, and durable [Gray <https://tools.ietf.org/html/rfc4949#ref-Gray> <https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_rfc4949-23ref-2DGray&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=ZVWvI_c8Y_eKlw3xgNEYIDFz2zW0Em2JkcBNzQEoM-A&e=>]:
> From: Justin Richer <[email-masked]> <[email-masked]>
> To: Mike Jones <[email-masked]> <[email-masked]>
> Cc: Vijay IETF <[email-masked]> <[email-masked]>; Matthew A. Miller <[email-masked]> <[email-masked]>; Lee McGovern <[email-masked]> <[email-masked]>; Amanjeev Sethi <[email-masked]> <[email-masked]>; [email-masked]
> On Apr 13, 2020, at 6:25 PM, Mike Jones <[email-masked] <mailto:[email-masked]> <[email-masked]>> wrote:
>
> From: Txauth <[email-masked] <mailto:[email-masked]> <[email-masked]>> On Behalf Of Justin Richer
> To: Vijay IETF <[email-masked] <mailto:[email-masked]> <[email-masked]>>
> Cc: Matthew A. Miller <[email-masked] <mailto:[email-masked]> <[email-masked]>>; Lee McGovern <[email-masked] <mailto:[email-masked]> <[email-masked]>>; Amanjeev Sethi <[email-masked] <mailto:[email-masked]> <[email-masked]>>; [email-masked] <mailto:[email-masked]> <[email-masked]>
> While we’re at it, we really can’t use “XAuth” because it’s already been something for 30 years: the X11 authentication command: https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.x.org_archive_X11R6.8.1_doc_xauth.1.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=1gmbjbcrtgN1swzoEC0sUNzMABzm9tkT41nsOQhI5Ko&e=> <https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.x.org_archive_X11R6.8.1_doc_xauth.1.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=1gmbjbcrtgN1swzoEC0sUNzMABzm9tkT41nsOQhI5Ko&e=>
>
> On Apr 10, 2020, at 9:22 AM, Vijay IETF <[email-masked] <mailto:[email-masked]> <[email-masked]>> wrote:
>
> On Tue, 24 Mar 2020 at 19:00, Amanjeev Sethi <[email-masked] <mailto:[email-masked]> <[email-masked]>> wrote:
> From: Txauth <[email-masked] <mailto:[email-masked]> <[email-masked]>> On Behalf Of Matthew A. Miller
> To: [email-masked] <mailto:[email-masked]> <[email-masked]>
> <Michael.Jones=40microsoft.com <http://40microsoft.com/> <https://urldefense.proofpoint.com/v2/url?u=http-3A__40microsoft.com_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=HCm31NqQeBW4INnGAVDHzkOwaHnnCbne7nsodOJcE_M&e=>@dmarc..ietf.org <http://ietf.org/> <https://urldefense.proofpoint.com/v2/url?u=http-3A__ietf.org_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=ieX_BYgQAogrrJagnKYotjN09O3gcPaS6sl5HTbK0_M&e=>
> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> wrote:
>
>     *From:* Txauth <[email-masked] <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> *On Behalf Of *David Skaife
>     *To:* Justin Richer <[email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>>
>     *Cc:* Yaron Sheffer <[email-masked] <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>>; [email-masked] <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>; Dick Hardt <[email-masked] <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>>
>     On Sat, Mar 21, 2020 at 6:18 PM Justin Richer <[email-masked] <mailto:[email-masked]> <[email-masked]>
>     <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> wrote:____
>
>             <[email-masked] <mailto:[email-masked]> <[email-masked]>
>             <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> wrote:____
>
>             __ __
>
>             <[email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> wrote:____
>
>                     <[email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>>
>                     wrote:____
>
>                     __ __
>
>                     <[email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>>
> wrote:____
>
>                             <[email-masked] <mailto:[email-masked]> <[email-masked]>
>                             <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> wrote:____
>
>                             __ __
>
>                             __ __
>
>                             __ __
>
>                             __ __
>
>                             Richer <[email-masked] <mailto:[email-masked]> <[email-masked]>
>                             <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>> wrote:____
>
>                             Fromhttps://www.merriam-webster.com/dictionary/transaction:____ <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transaction-3A-5F-5F-5F-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=nz6Gz8WFw38zUsCS_w02CfiUi7mBm86aJ-bLnJzLdN8&e=> <https://www.merriam-webster.com/dictionary/transaction:____> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transaction-3A-5F-5F-5F-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=nz6Gz8WFw38zUsCS_w02CfiUi7mBm86aJ-bLnJzLdN8&e=>
>
>                             __ __
>
>
>                             <https://www.merriam-webster.com/dictionary/transacted <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transacted&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=spmihilWxBYFWUv1trDL4vorFkuoOnzCLqbmFNyfMkc&e=> <https://www.merriam-webster.com/dictionary/transacted> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transacted&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=spmihilWxBYFWUv1trDL4vorFkuoOnzCLqbmFNyfMkc&e=>>/especially/ *: *an
>                             exchange or transfer
>                             <https://www.merriam-webster.com/dictionary/transfer <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transfer&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=W8CxpwlWUUXhxH501dQCvJL9w-gWfwV1ikecqmnwBlQ&e=> <https://www.merriam-webster.com/dictionary/transfer> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transfer&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=W8CxpwlWUUXhxH501dQCvJL9w-gWfwV1ikecqmnwBlQ&e=>> of
>                             goods, services, or
> <https://www.merriam-webster.com/dictionary/transacting <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transacting&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=tM9boW3q4Us8SfbPHzue1H6Woo6goEKg7TQfBkXyxx8&e=> <https://www.merriam-webster.com/dictionary/transacting> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.merriam-2Dwebster.com_dictionary_transacting&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=tM9boW3q4Us8SfbPHzue1H6Woo6goEKg7TQfBkXyxx8&e=>>____
>
>                             https://www.businessinsider.com/the-indisputable-power-of-brand-x-2012 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.businessinsider.com_the-2Dindisputable-2Dpower-2Dof-2Dbrand-2Dx-2D2012&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=5KZ_url4T2GsjTJ8spFYd8kYjVmDqVTwuqyaaJX06Bs&e=> <https://www.businessinsider.com/the-indisputable-power-of-brand-x-2012> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.businessinsider.com_the-2Dindisputable-2Dpower-2Dof-2Dbrand-2Dx-2D2012&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=5KZ_url4T2GsjTJ8spFYd8kYjVmDqVTwuqyaaJX06Bs&e=>
> -4____
>
>                             __ __
>
>                             https://english.stackexchange.com/questions/358181/whats-the-purpose-o <https://urldefense.proofpoint.com/v2/url?u=https-3A__english.stackexchange.com_questions_358181_whats-2Dthe-2Dpurpose-2Do&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=_0dOKI_ogKc8_Zyvp3IstYRTOdfUh2lIlwwP7SOXqmU&e=> <https://english.stackexchange.com/questions/358181/whats-the-purpose-o> <https://urldefense.proofpoint.com/v2/url?u=https-3A__english.stackexchange.com_questions_358181_whats-2Dthe-2Dpurpose-2Do&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=_0dOKI_ogKc8_Zyvp3IstYRTOdfUh2lIlwwP7SOXqmU&e=>
>                                     Hardt <[email-masked] <mailto:[email-masked]> <[email-masked]>
>                                     <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>>
>                                     wrote:____
>
>                                     __ __
>
>                                     Hello everyone____
>
>                                     __ __
>
>                                     https://mailarchive.ietf.org/arch/msg/txauth/ZVQVbHt4ADqehKrBDXOrTr_s_ <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_txauth_ZVQVbHt4ADqehKrBDXOrTr-5Fs-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=XX_5DnaMWn2qeohSRoLmcd0QlSRhCgbv5plYyyFysSQ&e=> <https://mailarchive.ietf.org/arch/msg/txauth/ZVQVbHt4ADqehKrBDXOrTr_s_> <https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.org_arch_msg_txauth_ZVQVbHt4ADqehKrBDXOrTr-5Fs-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=XX_5DnaMWn2qeohSRoLmcd0QlSRhCgbv5plYyyFysSQ&e=>
> wc/____
>
>                                     __ __
>
>                 [email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>
>                 https://www.ietf.org/mailman/listinfo/txauth____ <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth-5F-5F-5F-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=Bq6jWkB6HUphc3HuxrMFo9uXNKZFvWzg8rvTXEjzuk0&e=> <https://www.ietf.org/mailman/listinfo/txauth____> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth-5F-5F-5F-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=Bq6jWkB6HUphc3HuxrMFo9uXNKZFvWzg8rvTXEjzuk0&e=>
>
>         __ __
>
>     --
>     Txauth mailing list
>     [email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>
>     https://www.ietf.org/mailman/listinfo/txauth <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=> <https://www.ietf.org/mailman/listinfo/txauth> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=>
>
>
>
> --
> <https://www.pingidentity.com <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=oOVyJBpiEvKZp5UanZGkwF8Nq8s5Ze9HCdkXg94a7MY&e=> <https://www.pingidentity.com/> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=GKd4CWKgfkengEh4RWwqZYdzu_en608EGqXK7r3PGK0&e=>>Ping Identity <https://www.pingidentity.com <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=oOVyJBpiEvKZp5UanZGkwF8Nq8s5Ze9HCdkXg94a7MY&e=> <https://www.pingidentity.com/> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=GKd4CWKgfkengEh4RWwqZYdzu_en608EGqXK7r3PGK0&e=>>
> Brian Campbell
> Distinguished Engineer      [email-masked] <mailto:[email-masked]> <[email-masked]> <mailto:[email-masked] <[email-masked]> <mailto:[email-masked]> <[email-masked]>>
> w: +1 720.317.2061
> c: +1 303.918..9415
>
> <https://www.glassdoor.com/Overview/Working-at-Ping-Identity-EI_IE3809 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.glassdoor.com_Overview_Working-2Dat-2DPing-2DIdentity-2DEI-5FIE3809&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=ZsHBwIlL-N3eUnZ2z-EF2olryREV3Glxn0Sok13y6kw&e=> <https://www.glassdoor.com/Overview/Working-at-Ping-Identity-EI_IE3809> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.glassdoor.com_Overview_Working-2Dat-2DPing-2DIdentity-2DEI-5FIE3809&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=ZsHBwIlL-N3eUnZ2z-EF2olryREV3Glxn0Sok13y6kw&e=>
> 07.11,24.htm> LinkedIn logo <https://www.linkedin.com/company/21870 <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.linkedin.com_company_21870&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=G4TBWhlYbmPt7oHWG8RECFIUOqh-SRbOdvgjl2OfgAA&e=> <https://www.linkedin.com/company/21870> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.linkedin.com_company_21870&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=G4TBWhlYbmPt7oHWG8RECFIUOqh-SRbOdvgjl2OfgAA&e=>>
> twitter logo
> <https://twitter.com/pingidentity <https://urldefense.proofpoint.com/v2/url?u=https-3A__twitter.com_pingidentity&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=sh0idDPJKU8aHIR1-Z4TiBEP-2sDkFzOUum_25vuD0Q&e=> <https://twitter.com/pingidentity> <https://urldefense.proofpoint.com/v2/url?u=https-3A__twitter.com_pingidentity&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=sh0idDPJKU8aHIR1-Z4TiBEP-2sDkFzOUum_25vuD0Q&e=>>  facebook logo
> <https://www.facebook.com/pingidentitypage <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.facebook.com_pingidentitypage&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=V7WYktNDGEfGjOyKo6aQLyMEn_p3osqDaAt0LmDqom8&e=> <https://www.facebook.com/pingidentitypage> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.facebook.com_pingidentitypage&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=V7WYktNDGEfGjOyKo6aQLyMEn_p3osqDaAt0LmDqom8&e=>> youtube logo
> <https://www.youtube.com/user/PingIdentityTV <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.youtube.com_user_PingIdentityTV&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=_Si8bVlA4C6DIM-dhm5JprYQaQd1Yzas8vIsFS3CjnA&e=> <https://www.youtube.com/user/PingIdentityTV> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.youtube.com_user_PingIdentityTV&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=_Si8bVlA4C6DIM-dhm5JprYQaQd1Yzas8vIsFS3CjnA&e=>> Blog logo
> <https://www.pingidentity.com/en/blog.html <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_en_blog.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=-jqImBzR2kH9wDhs8sJNOkt03Bjz1rlU3_k36kZ38tw&e=> <https://www.pingidentity.com/en/blog.html> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_en_blog.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=-jqImBzR2kH9wDhs8sJNOkt03Bjz1rlU3_k36kZ38tw&e=>>
>
> <https://www.google.com/url?q=https://www.pingidentity.com/content/dam <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.google.com_url-3Fq-3Dhttps-3A__www.pingidentity.com_content_dam&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=oZ5SnDZofi-WZPIcj8EnfmIp-HLgoTrEMNHXmUEF6GM&e=> <https://www.google.com/url?q=https://www.pingidentity.com/content/dam> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.google.com_url-3Fq-3Dhttps-3A__www.pingidentity.com_content_dam&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=oZ5SnDZofi-WZPIcj8EnfmIp-HLgoTrEMNHXmUEF6GM&e=>
> 93608526000&usg=AFQjCNGBl5cPHCUAVKGZ_NnpuFj5PHGSUQ><https://www.pingid <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingid&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=ZQih6HPuSqTdGFI00ZOo2ZMszect2bkMg2PpNE4ePA4&e=> <https://www.pingid/> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingid_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vRbyOKGMyWmnkwaIecnT3Zp2TxeJ-NVxTvpsPKkDT3E&e=>entity.com/en/events/d/identify-2019.html <http://entity.com/en/events/d/identify-2019.html> <https://urldefense.proofpoint.com/v2/url?u=http-3A__entity.com_en_events_d_identify-2D2019.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=ZbOFzwM29qH5dRc4Ji9ViMlv742nGAXT5KLfVPpKoe4&e=>><https://www.pingidentity.co <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.co&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=mx8zZEdR28kkBvpTlX8mDNUcdy1lD_y9z0F9pLvxN2s&e=> <https://www.pingidentity.co/> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.co_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=1Md-GlKoPqumVgqc4uC3ZaAwCVjBXDbv0Fa6t4NPMTM&e=>
> ummary.pdf><https://www.pingidentity.com/en/events/e/rsa.html <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_en_events_e_rsa.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=2XDi3g9TtwmNDIJe5LCTEZBEfBbDx8l06MP97959sgk&e=> <https://www.pingidentity.com/en/events/e/rsa.html> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_en_events_e_rsa.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=2XDi3g9TtwmNDIJe5LCTEZBEfBbDx8l06MP97959sgk&e=>><https:/
> /www.pingidentity.com/en/events/e/rsa.html <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.pingidentity.com_en_events_e_rsa.html&d=DwQDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=dv907uxEiR-SLAQ42N3TbfQDQeV34-URVnlI0B0rOgw&e=> <http://www.pingidentity.com/en/events/e/rsa.html> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.pingidentity.com_en_events_e_rsa.html&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=dv907uxEiR-SLAQ42N3TbfQDQeV34-URVnlI0B0rOgw&e=>><https://www.pingidentity.c <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.c&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=l7kzCrcW47bLbdddl-wuSUAixeynEuTGYEiHbMFs9qQ&e=> <https://www.pingidentity.c/> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.c_&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=U7uRBQlpTnhfveD8OVt6bYkq4-ONTvpHiNFjyr1Qsn8&e=>
> <https://www.pingidentity.com/en/lp/e/work-from-home-sso-mfa.html?utm_ <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_en_lp_e_work-2Dfrom-2Dhome-2Dsso-2Dmfa.html-3Futm-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=33xLordCb07tWqWKZaIp5wJ2YuDRioTpUGdbUTp_O20&e=> <https://www.pingidentity.com/en/lp/e/work-from-home-sso-mfa.html?utm_> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.pingidentity.com_en_lp_e_work-2Dfrom-2Dhome-2Dsso-2Dmfa.html-3Futm-5F&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=33xLordCb07tWqWKZaIp5wJ2YuDRioTpUGdbUTp_O20&e=>
> Txauth mailing [email-masked] <mailto:[email-masked]> <[email-masked]>https://www.ietf.org/mailman/listinfo/txauth <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=> <https://www.ietf.org/mailman/listinfo/txauth> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=>
>
>
> Txauth mailing [email-masked] <mailto:[email-masked]> <[email-masked]>https://www.ietf.org/mailman/listinfo/txauth <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=> <https://www.ietf.org/mailman/listinfo/txauth> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=>
>
> --
> Txauth mailing [email-masked] <mailto:[email-masked]> <[email-masked]>https://www.ietf.org/mailman/listinfo/txauth <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=> <https://www.ietf.org/mailman/listinfo/txauth> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=>
> --
> Txauth mailing [email-masked] <mailto:[email-masked]> <[email-masked]>https://www.ietf.org/mailman/listinfo/txauth <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=> <https://www.ietf.org/mailman/listinfo/txauth> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwMDaQ&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=>
>
>
>
> --
> Txauth mailing list
> [email-masked]
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=W_Q2MG_IzJTOtRDBy8OdiRE3BsSrQARNXZSjAULS4mY&s=vyXsPYffs_iIIks8NKDn0R1e1ojhksAN5tDC6L-g_-Y&e=
>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 21 Apr 2020 17:43:20 -0700

Some responses on the definition of Transaction, and my summary as chair on
where we are ...

On Mon, Apr 13, 2020 at 4:38 PM Mike Jones <Michael.Jones=
[email-masked]> wrote:

>
>
>
> We shouldn’t try to invent a new meaning for the well-established computer
> science term “transaction” in this working group.
>

I think we would all agree that we should not be reinventing what a word
means. Justin: would you not agree with this?

>  As Dick was kind enough to pull the definition earlier in this thread,
> let me restate that definition:
>
>
>
>               *a communicative action or activity involving two parties
> or things that reciprocally affect or influence each other*
>

Assuming you still agree with this as the definition of a transaction, then
the charter is in conflict:

1)

... support authorizations scoped as narrowly as a single transaction ...

implies that the protocol is *for* authorization of a transaction, rather
than *being* a transaction

2)

The delegation process will be acted upon by multiple parties in the
protocol ...

indicates that there are more than two parties, in conflict with the
definition

3) It is not clear to me how this part of the definition

... reciprocally affect or influence each other

Is part of the charter.

>
>
> So with that in mind, I don’t think it’s misleading or confusing at all.
> I’m not sure why people keep referring to it as “incorrect”.
>
<snip>

>    - ZZAuth – The Protocol

This comes across as an emotional response rather than a reasoned response.

>
>
> Surely others must have other good ideas than don’t use the misleading
> term “Transactional” or its abbreviation “Tx”.
>
>
>
>
>
> Again, as above, this is not misleading. That said, if there’s a better
> idea, I’m open to it.
>

Do you think it is your decision what the name is, or the group?

> But for all of the reasons I keep repeating now, TxAuth is decent and I
> haven’t seen a better one.
>
>
>

 Given the numerous alternative name proposals, and pushback on on
"transaction" being in the name, I don't think there is consensus on TxAuth
being the name

---

From: Dick Hardt <[email-masked]>
Date: Tue, 21 Apr 2020 17:57:44 -0700

On Mon, Apr 13, 2020 at 4:38 PM Mike Jones <Michael.Jones=
[email-masked]> wrote:

> The normal computer science use of the term “transaction” involves a
> proposed state change that either commits or aborts atomically.  That
> doesn’t match your description of the term below.  It also doesn’t match
> the RFC 4949 <https://tools.ietf.org/html/rfc4949> definition of the term
> (which does match my paraphrase above).  It reads:
>
>
>
>    $ transaction
>
>       business or programmatic purpose." [M0404
> <https://tools.ietf.org/html/rfc4949#ref-M0404>]
>
>
>
>       designed to be atomic, consistent, isolated, and durable [Gray
> <https://tools.ietf.org/html/rfc4949#ref-Gray>]:
>
> *From:* Justin Richer <[email-masked]>
> *Sent:* Monday, April 13, 2020 4:27 PM
> *To:* Mike Jones <[email-masked]>
> *Cc:* Vijay IETF <[email-masked]>; Matthew A. Miller <
> [email-masked]>; Lee McGovern <[email-masked]>;
> Amanjeev Sethi <[email-masked]>; [email-masked]
> *Subject:* Re: [Txauth] WG name: TxAuth? XAuth? Something else?
>
>
>
> On Apr 13, 2020, at 6:25 PM, Mike Jones <[email-masked]>
> wrote:
>
>
>
> Because the proposed starting points and likely outcomes aren’t
> transactional, I believe we shouldn’t confuse people by calling it
> Transactional Authorization or using the abbreviation “Tx”.
>
>
>
> I’m not sure what you mean. XYZ, as a starting point, is transactional by
> design. I have given several talks on this topic, which you have attended.
> And in fact I would argue that the entire intent-registration pattern, upon
> which both proposals are predicated, is transactional in nature as well. As
> Dick was kind enough to pull the definition earlier in this thread, let me
> restate that definition:
>
>
>
> The entire act of getting the delegation to occur is a transaction between
> the client and the AS (or equivalent component). The client begins the
> transaction by talking to the AS, the AS continues the transaction by
> optionally getting the user involved, and the client continues the
> transaction when the interaction portion is completed, and so on. While
> this is intentionally built into XYZ, I would argue that even XAuth has
> this feature.
>
>
>
> Yes, there are other definitions of “transaction” that do not apply —
> words have more than one definition, and that happens.
>
>
>
>    - Disaggregated Authorization (DisAuth)
>    - Componentized Authorization (CompAuth)
>
>
>
> Neither of these capture what’s different about this. The components are
> largely the same as they were in OAuth 2, UMA, OIDC, SAML, and related
> protocols. The componentization isn’t the new thing here, so I don’t think
> these are that good a fit.
>
>
>
>
>    -
>    - Build-Your-Own Authorization (BYOAuth)
>    - Do-It-Yourself Authorization (DIYAuth)
>
>
>
> These aren’t really what we’re after at all. In fact, the proposed charter
> is specifically about building a protocol instead of a framework, so either
> of these are very misleading.
>
>
>
>
>    -
>    - Refactored Authorization (ReAuth or RefAuth)
>
>
>
> This doesn’t offer any description of what’s gone on here. Refactored from
> what? Additionally  I don’t believe this name flows naturally from the
> proposed shortenings.  “ReAuth” sounds like “ReAuthorization” and/or
> “ReAuthentication”, where as “RefAuth” sounds like it should stand for
> “reference” instead of “refactored”.
>
>
>
>
>    -
>
>
>
> To those I’ll now add:
>
>    - Alternative Authorization Protocol (AAP)
>    - Alternative Authorization (AltAuth)
>    - Reimagined Authorization (ReAuth)
>
>
>
> All of these are problematic for the same reason that “NewAuth” or
> “NgAuth” are. They just say “it’s new” and don’t say anything about it. And
> if we’re successful, it won’t be “new" while people are still using it.
>
>
>
>
>    -
>    - Back-end Based Authorization (BBAuth)
>
>
>
> This is a start in concept, as it starts to talk about what’s different,
> but “BBAuth” is already something — one of the predecessors of OAuth 1.0
> was “BBAuth” from Flickr (later Yahoo). Also, note that in this historical
> context, the expansion is “Browser Based Auth”, which could happen here
> again. As one of the key aspects of what people are interested is
> decoupling from the browser, we don’t want to have echos of that, even if
> the name weren’t already historically taken.
>
>
>
>
>    -
>
>
>
>    - Dismembered Authorization
>
> Plus:
>
>    - ZZAuth – The Protocol
>
>
>
> Please, no.
>
>
>
>
>
> idea, I’m open to it. But for all of the reasons I keep repeating now,
> TxAuth is decent and I haven’t seen a better one.
>
>
>
> Thanks,
>
>
>
>  — Justin
>
>
>
>                                                        Cheers,
>
>                                                        -- Mike
>
>
>
> *From:* Txauth <[email-masked]> *On Behalf Of *Justin Richer
> *Sent:* Monday, April 13, 2020 11:43 AM
> *To:* Vijay IETF <[email-masked]>
> *Cc:* Matthew A. Miller <[email-masked]>; Lee McGovern <
> [email-masked]>; Amanjeev Sethi <[email-masked]>;
> [email-masked]
> *Subject:* Re: [Txauth] WG name: TxAuth? XAuth? Something else?
>
>
>
> I dislike names like “NgAuth” or “YAAP” or the like because they rely on
> this being “new” and it’s only “new” right now. If we’re successful and
> people are still talking about it in ten years then it won’t be new anymore
> and the name will just seem absurd.
>
>
>
> While we’re at it, we really can’t use “XAuth” because it’s already been
> something for 30 years: the X11 authentication command:
> https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html
>
>
>
> I still argue that we should call the protocol and the working group
> *TxAuth*. Not only do I think the underlying “transactional
> authorization” aspect is a key difference from what’s come before (the
> nature of which I’ve described many, many times on this list), if you go
> and search for the term “txauth” you end up back at this mailing list and
> the posts that people have made about it.
>
>
>
>  — Justin
>
>
>
>
> On Apr 10, 2020, at 9:22 AM, Vijay IETF <[email-masked]> wrote:
>
>
>
> On Tue, 24 Mar 2020 at 19:00, Amanjeev Sethi <[email-masked]> wrote:
>
> > From: Txauth <[email-masked]> On Behalf Of Matthew A. Miller
> > To: [email-masked]
> > > <Michael.Jones=40microsoft.com@dmarc..ietf.org
> > > <mailto:[email-masked]>> wrote:
> > >
> > >     *From:* Txauth <[email-masked]
> > >     <mailto:[email-masked]>> *On Behalf Of *David Skaife
> > >     *To:* Justin Richer <[email-masked] <mailto:[email-masked]>>
> > >     *Cc:* Yaron Sheffer <[email-masked]
> > >     <mailto:[email-masked]>>; [email-masked]
> > >     <mailto:[email-masked]>; Dick Hardt <[email-masked]
> > >     <mailto:[email-masked]>>
> > >     On Sat, Mar 21, 2020 at 6:18 PM Justin Richer <[email-masked]
> > >     <mailto:[email-masked]>> wrote:____
> > >
> > >             <[email-masked]
> > >             <mailto:[email-masked]>> wrote:____
> > >
> > >             __ __
> > >
> > >             <[email-masked] <mailto:[email-masked]>> wrote:____
> > >
> > >                     <[email-masked] <mailto:[email-masked]
> >>
> > >                     wrote:____
> > >
> > >                     __ __
> > >
> > >                     <[email-masked] <mailto:[email-masked]>>
> > > wrote:____
> > >
> > >                             <[email-masked]
> > >                             <mailto:[email-masked]>> wrote:____
> > >
> > >                             __ __
> > >
> > >                             __ __
> > >
> > >                             __ __
> > >
> > >                             __ __
> > >
> > >                             Richer <[email-masked]
> > >                             <mailto:[email-masked]>> wrote:____
> > >
> > >                             <
> https://www.merriam-webster.com/dictionary/transacted>/especially/ *: *an
> > >                             exchange or transfer
> > >                             <
> https://www.merriam-webster.com/dictionary/transfer> of
> > >                             goods, services, or
> > >                                     Hardt <[email-masked]
> > >                                     <mailto:[email-masked]>>
> > >                                     wrote:____
> > >
> > >                                     __ __
> > >
> > >                                     Hello everyone____
> > >
> > >                                     __ __
> > >
> > > <https://www.pingidentity.com>Ping Identity <
> https://www.pingidentity.com>
> > > Brian Campbell
> > > Distinguished Engineer
> > > [email-masked] <mailto:[email-masked]>
> > > w: +1 720.317.2061
> > > c: +1 303.918..9415
> > >
> > > 93608526000&usg=AFQjCNGBl5cPHCUAVKGZ_NnpuFj5PHGSUQ><https://www.pingid
> > > entity.com/en/events/d/identify-2019.html><https://www.pingidentity.co
> > > /www.pingidentity.com/en/events/e/rsa.html><https://www.pingidentity.c

---

From: Dick Hardt <[email-masked]>
Date: Tue, 21 Apr 2020 18:01:16 -0700

> transaction when the interaction portion is completed, and so on.
>

An important part of the protocol is how the client presents authorization
to the RS, which one could consider a transaction (and is called as much in
the charter)

---

From: Dick Hardt <[email-masked]>
Date: Tue, 21 Apr 2020 18:04:22 -0700

George: I think your application of "transaction" is different from what
Justin is intending.

>From Justin:

And I think with all of this argument it’s important to point out that I’ve
been using an adjective form the whole time: Transactional Authorization.
It’s an authorization that has aspects and components and artifacts of a
transaction.