Subject: [Txauth] alignment on Justin's use of "transactional" adjective

From: Dick Hardt <[email-masked]>
Date: Tue, 21 Apr 2020 18:12:38 -0700

With the recent threads on the name, I'm going to make a push to get
consensus. While there are many of you that don't care, there are also many
that do care (myself included)

There have been a number of people (including myself) concerned with the
protocol being called a transaction, there may be others (besides Justin)
that are aligned with Justin's definition that have not felt a need to say
anything.

So let's get some feedback:

Transactional Authorization. It’s an authorization that has aspects and
components and artifacts of a transaction.

If you are aligned using "transactional", please respond with a +1

If you are not aligned, please respond with a -1

If you don't care, don't bother responding. :)

---

From: Bjorn Hjelm <[email-masked]>
Date: Tue, 21 Apr 2020 22:39:03 -0400

-1

BR,
Bjorn

> On Apr 21, 2020, at 6:12 PM, Dick Hardt <[email-masked]> wrote:
>
> 
> With the recent threads on the name, I'm going to make a push to get consensus. While there are many of you that don't care, there are also many that do care (myself included)
>
> There have been a number of people (including myself) concerned with the protocol being called a transaction, there may be others (besides Justin) that are aligned with Justin's definition that have not felt a need to say anything.
>
> Transactional Authorization. It’s an authorization that has aspects and components and artifacts of a transaction.
>
> --
> Txauth mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_txauth&d=DwICAg&c=udBTRvFvXC5Dhqg7UHpJlPps3mZ3LRxpb6__0PomBTQ&r=NMZJHCV8pjvGIH2fTx9z6l7g7-V-a2xW7ISf9uHdz0A&m=vdAGFttu3V1hEtN1ahva3y1obz200Ppyo4LnH2CxJRQ&s=sGY-CVADXCELX9ksUxU8QdEatELK5-LrOjzXNvQFHPM&e=

---

From: Justin Richer <[email-masked]>
Date: Wed, 22 Apr 2020 10:39:35 -0400

+1 to transactional … but that’s no surprise.

As I’ve said before, I think it captures the nature of the kind of protocol we’re after, and this nature exists in both of the proposed input documents. There’s a setup, a process, and a conclusion. It’s atomic in that you either get a token or you get an error. It’s multi-party, and different parties can alter and contribute to the state while the transaction is in progress but not after it’s been concluded. There’s a flow of information with a specific result.

I’m really against the “Yet Another” name family for the reasons Yaron suggested. I think it’s a joke, and a cruel one at that.

I’ve already responded to Mike’s list of proposed adjectives in detail as to why they aren’t "more accurate” as he claims on this thread.

 — Justin

> On Apr 21, 2020, at 9:12 PM, Dick Hardt <[email-masked]> wrote:
> 
> https://www.ietf.org/mailman/listinfo/txauth

---

From: Dmitri Zagidulin <[email-masked]>
Date: Wed, 22 Apr 2020 10:47:30 -0400

+1 to transactional.

---

From: Brian Campbell <[email-masked]>
Date: Wed, 22 Apr 2020 14:56:16 -0600

When I made the suggestion of YAAAAS
<https://mailarchive.ietf.org/arch/msg/txauth/nWWTvIyIpBzu0FM5EEFXzcvWsig/>
(for Yet Another Authorization And Authentication Specification) it was
indeed intended to be humorous. But not in an unkind way. The "Yet Another"
part certainly doesn't shy away from the reality that there are other
specifications in the space but it was mostly a vehicle to get to the
YAAAAS acronym. It's a common spelling of and nod to the first part of the
popular phrase "yas queen"
<https://www.yourtango.com/2018314692/what-does-yas-queen-mean-simple-guide-slang-internet-term-everyones-using>,
which has largely positive meaning. I suppose that could be criticized as
cultural appropriation but kinda feel like it's been so widely appropriated
already that it's fair use at this point.

On Wed, Apr 22, 2020 at 8:39 AM Justin Richer <[email-masked]> wrote:
<snip>

> I’m really against the “Yet Another” name family for the reasons Yaron
> suggested. I think it’s a joke, and a cruel one at that.
>
 <snip>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: Vittorio Bertocci <[email-masked]>
Date: Wed, 22 Apr 2020 21:33:51 +0000

FWIW, I never saw the proposal as a joke, and definitely not cruel- it’s humorous for sure, but in the insider joke way that is typical of computer science.
There are plenty of very successful endeavors and technologies listed in https://en.wikipedia.org/wiki/Yet_another that back that point IMO, without the need to go all the way back to the 70’s.

From: Txauth <[email-masked]> on behalf of Brian Campbell <bcampbell=[email-masked]>
Date: Wednesday, April 22, 2020 at 13:56
To: Justin Richer <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Dick Hardt <[email-masked]>
Subject: Re: [Txauth] alignment on Justin's use of "transactional" adjective

When I made the suggestion of YAAAAS<https://mailarchive.ietf.org/arch/msg/txauth/nWWTvIyIpBzu0FM5EEFXzcvWsig/> (for Yet Another Authorization And Authentication Specification) it was indeed intended to be humorous. But not in an unkind way. The "Yet Another" part certainly doesn't shy away from the reality that there are other specifications in the space but it was mostly a vehicle to get to the YAAAAS acronym. It's a common spelling of and nod to the first part of the popular phrase "yas queen"<https://www.yourtango.com/2018314692/what-does-yas-queen-mean-simple-guide-slang-internet-term-everyones-using>, which has largely positive meaning. I suppose that could be criticized as cultural appropriation but kinda feel like it's been so widely appropriated already that it's fair use at this point.

On Wed, Apr 22, 2020 at 8:39 AM Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:
<snip>
I’m really against the “Yet Another” name family for the reasons Yaron suggested. I think it’s a joke, and a cruel one at that.
 <snip>

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Justin Richer <[email-masked]>
Date: Wed, 22 Apr 2020 17:48:33 -0400

I found the suggestion wholly dismissive of the effort and work that’s gone into this to date, and will go into it going forward.

From the wikipedia page you linked, this is used to indicate the “name of a computer program <https://en.wikipedia.org/wiki/Computer_program>, organisation, or event that is confessedly unoriginal.”

In other words, nothing new or interesting to see here. Considering that the suggestion came from someone who has stated publicly that they don’t see the value in this work at all, I took it largely as jab, whether it was intended as one or not.

I understand that it was intended to be humorous and I get the intended joke, but I still don’t like the joke. Even with the best of intentions, I really don’t like how the name feels. It reeks of “oh here we go again, why are we doing this, aren't we just idiots or something??”

 — Justin

> On Apr 22, 2020, at 5:33 PM, Vittorio Bertocci <[email-masked]> wrote:
> 
> There are plenty of very successful endeavors and technologies listed in https://en.wikipedia.org/wiki/Yet_another <https://en.wikipedia.org/wiki/Yet_another> that back that point IMO, without the need to go all the way back to the 70’s.
>  
> When I made the suggestion of YAAAAS <https://mailarchive.ietf.org/arch/msg/txauth/nWWTvIyIpBzu0FM5EEFXzcvWsig/> (for Yet Another Authorization And Authentication Specification) it was indeed intended to be humorous. But not in an unkind way. The "Yet Another" part certainly doesn't shy away from the reality that there are other specifications in the space but it was mostly a vehicle to get to the YAAAAS acronym. It's a common spelling of and nod to the first part of the popular phrase "yas queen" <https://www.yourtango.com/2018314692/what-does-yas-queen-mean-simple-guide-slang-internet-term-everyones-using>, which has largely positive meaning. I suppose that could be criticized as cultural appropriation but kinda feel like it's been so widely appropriated already that it's fair use at this point.
>  
> On Wed, Apr 22, 2020 at 8:39 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
> <snip>

---

From: David Waite <[email-masked]>
Date: Wed, 22 Apr 2020 21:12:31 -0600

-1 to transactional, due to the confusion it will cause by its use as part of a different technical process. In addition to not involving three-phase commits or the like, the protocol does not complete after initial authentication/authorization - gathered information and consent may be leveraged to mint additional refreshed authorization tokens.

IMHO, better terms would revolve around the aspects of intermediation/arbitration by the AS-equivalent.

-DW

> On Apr 22, 2020, at 8:39 AM, Justin Richer <[email-masked]> wrote:
>

---

From: Dick Hardt <[email-masked]>
Date: Thu, 23 Apr 2020 18:09:34 -0700

<chair hat>

Justin: Brian was pretty clear earlier in this thread what his intentions
were with the suggestion. Let's take him at his word.

Your response below did not add to the conversation, and potentially
alienated a valued member of the community.

/Dick

On Wed, Apr 22, 2020 at 2:48 PM Justin Richer <[email-masked]> wrote:

> I found the suggestion wholly dismissive of the effort and work that’s
> gone into this to date, and will go into it going forward.
>
> From the wikipedia page you linked, this is used to indicate the “name of
> a computer program <https://en.wikipedia.org/wiki/Computer_program>,
> organisation, or event that is *confessedly unoriginal*.”
>
> In other words, nothing new or interesting to see here. Considering that
> the suggestion came from someone who has stated publicly that they don’t
> see the value in this work at all, I took it largely as jab, whether it was
> intended as one or not.
>
> I understand that it was intended to be humorous and I get the intended
> joke, but I still don’t like the joke. Even with the best of intentions, I
> really don’t like how the name feels. It reeks of “oh here we go again, why
> are we doing this, aren't we just idiots or something??”
>
>  — Justin
>
> FWIW, I never saw the proposal as a joke, and definitely not cruel- it’s
> humorous for sure, but in the insider joke way that is typical of computer
> science.
> There are plenty of very successful endeavors and technologies listed in
> https://en.wikipedia.org/wiki/Yet_another that back that point IMO,
> without the need to go all the way back to the 70’s.
>
> *From: *Txauth <[email-masked]> on behalf of Brian Campbell <
> bcampbell=[email-masked]>
> *Date: *Wednesday, April 22, 2020 at 13:56
> *To: *Justin Richer <[email-masked]>
> *Cc: *"[email-masked]" <[email-masked]>, Dick Hardt <
> [email-masked]>
> *Subject: *Re: [Txauth] alignment on Justin's use of "transactional"
> adjective
>
> *CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly prohibited..
> If you have received this communication in error, please notify the sender
> immediately by e-mail and delete the message and any file attachments from
> your computer. Thank you.*
>
>
> --
> Txauth mailing list
> [email-masked]
ᐧ

---

From: Dick Hardt <[email-masked]>
Date: Thu, 23 Apr 2020 18:09:42 -0700

Twice as many people are -1 than +1 for "transactional" which indicates to
me we need a different name.

I'll propose a process in a new thread.
ᐧ