Subject: [Txauth] Name criteria

From: Dick Hardt <[email-masked]>
Date: Mon, 27 Apr 2020 16:19:14 -0700

Riffing on the work done to name Perl6, here are the name criteria I
propose:

Required:

   1. No confusion with another protocol or major software project
   2. no existing registered trademarks in related classes
   3. Less than 1M results in Google
   4. Short (<=6 chars)
   5. Descriptive of protocol (this criteria is subjective)

Desirable:

   1. Straightforward to pronounce
   2. Easy to spell
   3. Easy to read

---

From: Justin Richer <[email-masked]>
Date: Mon, 27 Apr 2020 21:37:19 -0400

I think the 6-character length requirement is more under “desirable” than “required”. Shorter names are often better, but that doesn’t make a longer name off limits for consideration. 

 — Justin

> On Apr 27, 2020, at 7:19 PM, Dick Hardt <[email-masked]> wrote:
> 
> Riffing on the work done to name Perl6, here are the name criteria I propose:
> 
> Required:
> No confusion with another protocol or major software project
> no existing registered trademarks in related classes
> Less than 1M results in Google
> Short (<=6 chars)
> Descriptive of protocol (this criteria is subjective)
> Desirable:
> Straightforward to pronounce
> Easy to spell 
> Easy to read
> 
> 
> 
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth