Subject: Re: [Txauth] Name criteria

From: Hankins Parichabutr <[email-masked]>
Date: Tue, 28 Apr 2020 15:42:22 -0400

@Amanjeev beat me to this...

I'm also wondering whether "intent" and/or "delegation" are useful to the
naming:
+ Intent-based
+ Intentional authorization
+ Intentional delegation

Regards,
Hankins Parichabutr
. . . . . . . . . . . . . . . . . . . . .

On Tue, Apr 28, 2020 at 2:29 PM <[email-masked]> wrote:

> Send Txauth mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/txauth
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Txauth digest..."
> Today's Topics:
>
>    1. Re: Name criteria (Amanjeev Sethi)
>    2. Re: Name criteria (Daniel Fett)
>    3. Re: Name criteria (Dick Hardt)
>    4. Re: Name criteria (Justin Richer)
>
>
>
> ---------- Forwarded message ----------
> From: Amanjeev Sethi <[email-masked]>
> To: Dick Hardt <[email-masked]>, Daniel Fett <[email-masked]>
> Cc: [email-masked]
> Bcc:
> Date: Tue, 28 Apr 2020 13:58:00 -0400
> Subject: Re: [Txauth] Name criteria
> Does no one think that "intent driven" can be used for creating a name?
>
> On Tue, Apr 28, 2020, at 1:54 PM, Dick Hardt wrote:
>
> Daniel: I'm in favor of the intent of your suggestion -- but curious which
> languages we would test that in. Doing it for all languages is impractical.
> A negative connotation may also be a locale rather than language specific.
> For example, a fag in the UK (a cigarette) is very different than a fag in
> the US/Canada (offensive term for a homosexual man).
> ᐧ
>
> On Tue, Apr 28, 2020 at 10:09 AM Daniel Fett <[email-masked]> wrote:
>
> Am 28.04.20 um 19:04 schrieb Dick Hardt:
>
> Revised criteria:
>
> Required:
>
>    1. No confusion with another protocol, major software project, or
>    IETF/IRTF WG name
>    2. no existing registered trademarks in related classes
>    3. Less than 1M results in Google
>    4. Descriptive of protocol (this criteria is subjective)
>
> Desirable:
>
>    1. Straightforward to pronounce
>    2. Easy to spell
>    3. Easy to read
>    4. Shortish
>
> 5. Not a negatively connotated word in another language
>
> -Daniel
> --
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
> --
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
>
>
>
>
> ---------- Forwarded message ----------
> From: Daniel Fett <[email-masked]>
> To: Dick Hardt <[email-masked]>
> Cc: [email-masked]
> Bcc:
> Date: Tue, 28 Apr 2020 20:01:26 +0200
> Subject: Re: [Txauth] Name criteria
> Am 28.04.20 um 19:54 schrieb Dick Hardt:
>
> Daniel: I'm in favor of the intent of your suggestion -- but curious which
> languages we would test that in. Doing it for all languages is impractical.
> A negative connotation may also be a locale rather than language specific.
> For example, a fag in the UK (a cigarette) is very different than a fag in
> the US/Canada (offensive term for a homosexual man).
>
> If it is in the Urban Dictionary, it is probably a bad choice ;-)
>
> No, seriously, I guess we can just google for "<x> definition", "<x>
> translation" and see what comes up.
>
> -Daniel
>
>
>
>
> ---------- Forwarded message ----------
> From: Dick Hardt <[email-masked]>
> To: Daniel Fett <[email-masked]>
> Cc: [email-masked]
> Bcc:
> Date: Tue, 28 Apr 2020 11:11:30 -0700
> Subject: Re: [Txauth] Name criteria
> But which languages are we checking? There are alot in the world. The
> phonetics of the name could be offensive -- ie it could be an offensive
> word when said in China or Japan. I don't know how to use google to
> search phonetics.
> ᐧ
>
> On Tue, Apr 28, 2020 at 11:01 AM Daniel Fett <[email-masked]> wrote:
>
>> Am 28.04.20 um 19:54 schrieb Dick Hardt:
>>
>> Daniel: I'm in favor of the intent of your suggestion -- but curious
>> which languages we would test that in. Doing it for all languages is
>> impractical. A negative connotation may also be a locale rather than
>> language specific.. For example, a fag in the UK (a cigarette) is very
>> different than a fag in the US/Canada (offensive term for a homosexual man).
>>
>> If it is in the Urban Dictionary, it is probably a bad choice ;-)
>>
>> No, seriously, I guess we can just google for "<x> definition", "<x>
>> translation" and see what comes up.
>>
>> -Daniel
>>
>>
>
>
> ---------- Forwarded message ----------
> From: Justin Richer <[email-masked]>
> To: Amanjeev Sethi <[email-masked]>
> Cc: Dick Hardt <[email-masked]>, Daniel Fett <[email-masked]>,
> [email-masked]
> Bcc:
> Date: Tue, 28 Apr 2020 14:28:48 -0400
> Subject: Re: [Txauth] Name criteria
> I think that both “intent driven” and “intent registration” are good
> starting points, as that’s one of several key aspects to this proposed
> solution space. The flexibility of the interaction (and non-reliance on web
> browsers for it) is another important aspect.
>
> So interactive intent of some flavor might be an inspiration.
>
>  — Justin
>
> On Apr 28, 2020, at 1:58 PM, Amanjeev Sethi <[email-masked]> wrote:
>
> Does no one think that "intent driven" can be used for creating a name?
>
> On Tue, Apr 28, 2020, at 1:54 PM, Dick Hardt wrote:
>
> Daniel: I'm in favor of the intent of your suggestion -- but curious which
> languages we would test that in. Doing it for all languages is impractical.
> A negative connotation may also be a locale rather than language specific.
> For example, a fag in the UK (a cigarette) is very different than a fag in
> the US/Canada (offensive term for a homosexual man).
> ᐧ
>
> On Tue, Apr 28, 2020 at 10:09 AM Daniel Fett <[email-masked]> wrote:
>
> Am 28.04.20 um 19:04 schrieb Dick Hardt:
>
> Revised criteria:
>
> Required:
>
>    1. No confusion with another protocol, major software project, or
>    IETF/IRTF WG name
>    2. no existing registered trademarks in related classes
>    3. Less than 1M results in Google
>    4. Descriptive of protocol (this criteria is subjective)
>
> Desirable:
>
>    1. Straightforward to pronounce
>    2. Easy to spell
>    3. Easy to read
>    4. Shortish
>
> 5. Not a negatively connotated word in another language
>
> -Daniel
> --
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
> --
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
>
> --
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
>
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 28 Apr 2020 12:46:19 -0700

Any other feedback on the criteria?

I'll start a separate thread for brainstorming names
ᐧ

On Tue, Apr 28, 2020 at 12:44 PM Hankins Parichabutr <
[email-masked]> wrote:

>> language specific. For example, a fag in the UK (a cigarette) is very
>> Am 28.04..20 um 19:04 schrieb Dick Hardt:
>>
>> Revised criteria:
>>
>> Required:
>>
>>> language specific... For example, a fag in the UK (a cigarette) is very
>> impractical.. A negative connotation may also be a locale rather than
>> language specific. For example, a fag in the UK (a cigarette) is very