Subject: Re: [Txauth] alignment on Justin's use of "transactional" adjective

From: Mike Jones <[email-masked]>
Date: Wed, 22 Apr 2020 22:55:52 +0000

Then perhaps a few accurate and descriptive protocol names that we could consider would be:

              Multi-Step Authorization Protocol (MSAP)
              Multi-Phase Authorization Protocol (MPAP)

                                                          -- Mike

From: Txauth <[email-masked]> On Behalf Of Dick Hardt
Sent: Wednesday, April 22, 2020 3:44 PM
To: Mike Varley <[email-masked]>
Cc: [email-masked]
Subject: Re: [Txauth] alignment on Justin's use of "transactional" adjective

On Wed, Apr 22, 2020 at 5:55 AM Mike Varley <[email-masked]<mailto:[email-masked]>> wrote:
... the intent of the protocol, which to my mind can be summarized as:
There is a pre-flight setup transaction required by clients to authorization servers before the OAuth request/response (transaction) process can begin
<snip>

This is also what I think it the major change to the protocol.

/Dick

---

From: Justin Richer <[email-masked]>
Date: Wed, 22 Apr 2020 20:18:41 -0400

Phased Auth — PhAuth.

 — Justin

> On Apr 22, 2020, at 6:55 PM, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> From: Txauth <[email-masked] <mailto:[email-masked]>> On Behalf Of Dick Hardt
> To: Mike Varley <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> On Wed, Apr 22, 2020 at 5:55 AM Mike Varley <[email-masked] <mailto:[email-masked]>> wrote:
> -- 
> Txauth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>

---

From: Mike Varley <[email-masked]>
Date: Thu, 23 Apr 2020 11:56:35 +0000

+1 to these.

I prefer ‘multi-step’ or ‘multi-stage’ over ‘phase’ for no particular reason, and I will concede there maybe confusion with multi-step authentication.

Negotiated Authorization Protocol? NAP?

MV

On Apr 22, 2020, at 6:55 PM, Mike Jones <[email-masked]> wrote:

                                                          -- Mike

/Dick

This email and any attachments are for the sole use of the intended recipients and may be privileged, confidential or otherwise exempt from disclosure under law. Any distribution, printing or other use by anyone other than the intended recipient is prohibited. If you are not an intended recipient, please contact the sender immediately, and permanently delete this email and its attachments.

---

From: Dick Hardt <[email-masked]>
Date: Thu, 23 Apr 2020 18:09:25 -0700

PAuth

Phased
Pre-flight

or what comes after OAuth (P comes after O)

On Wed, Apr 22, 2020 at 5:18 PM Justin Richer <[email-masked]> wrote:

> Phased Auth — PhAuth.
>
>  — Justin
>
> On Apr 22, 2020, at 6:55 PM, Mike Jones <
> Michael.Jones=[email-masked]> wrote:
>
> *From:* Txauth <[email-masked]> *On Behalf Of *Dick Hardt
> *Sent:* Wednesday, April 22, 2020 3:44 PM
> *To:* Mike Varley <[email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [Txauth] alignment on Justin's use of "transactional"
> adjective
>
>
>
> On Wed, Apr 22, 2020 at 5:55 AM Mike Varley <[email-masked]>
> wrote:
>
> There is a pre-flight setup transaction required by clients to
> authorization servers before the OAuth request/response (transaction)
> process can begin
>
> <snip>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
>
> --
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
ᐧ

---

From: Daniel Fett <[email-masked]>
Date: Fri, 24 Apr 2020 10:20:08 +0200

AuthFlow / FlowAuth?

-Daniel

Am 23.04.20 um 02:18 schrieb Justin Richer:
> Phased Auth — PhAuth.
>
>  — Justin
>
>> On Apr 22, 2020, at 6:55 PM, Mike Jones
>> <Michael.Jones=[email-masked]
>> <mailto:Michael.Jones=[email-masked]>> wrote:
>>
>> *From:* Txauth <[email-masked]
>> <mailto:[email-masked]>> *On Behalf Of *Dick Hardt
>> *To:* Mike Varley <[email-masked]
>> <mailto:[email-masked]>>
>> *Cc:* [email-masked] <mailto:[email-masked]>
>> On Wed, Apr 22, 2020 at 5:55 AM Mike Varley
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     authorization servers before the OAuth request/response
>>     (transaction) process can begin
>>
>> <snip>
>>