Subject: Re: #1028 orig-date (was: Ticket status, USEFOR)

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 11 Aug 2005 13:34:34 +0200

Seems like a good idea, and uncontroversial.
I've changed status to "text accepted".

--On onsdag, juli 20, 2005 08:19:34 +0200 Frank Ellermann 
<[email-masked]> wrote:

>
> Harald Tveit Alvestrand wrote:
>
>> 1028 USEFOR 3.1.2 Date: What zones should be on the MUST
>> accept list?  "Document updated"
>
> Yes, but it shouldn't say "from" instead of "orig-date" ;-)
>
> And IIRC we wanted to mention 2.2 _and_ 2.1 in 3.1.2, not
> only 2.2, because the "forget obs-" info is in 2.1, and
> the "but accept GMT" part of 3.1.2 needs this 2.1 detail.
>
> How about adding an example below the <orig-date> syntax ?
>
>| This is an example for the deprecated GMT syntax, GMT is
>| interpreted as +0000, compare [RFC2822] chapter 4.3:
>|
>|      Date: Wed, 20 Jul 2005, 22:33:44 GMT
>
>                          Bye, Frank
>
>
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 11 Aug 2005 13:56:53 +0200

I don't see any strong push to change injection-date into a component of 
injection-info. So I'm closing this ticket with "no change required".

For USEFOR, it's late...

                    Harald

--On fredag, juli 22, 2005 22:57:47 +0200 Frank Ellermann 
<[email-masked]> wrote:

>
> Russ Allbery wrote:
>
>>> Having it as a "posting-date" parameter of Injection-Info
>>> was discussed by the WG, and rejected
>
> That's clear.
>
>> The intention is for every news server to parse this field
>> instead of Date.  Given that, it should be easy to parse.
>> MIME-style parameters are not.
>
> Dito, same reason.  How about this:
>
> ~~~ old ~~~
> injection-date = "Injection-Date:" SP date-time CRLF
>
> injection-info = "Injection-Info:" SP [CFWS] path-identity
>                  *( [CFWS] ";" [CFWS] inj-info-param )
>                  [CFWS] CRLF
> ~~~ new ~~~
> injection-info = "Injection-Info:" SP *WSP path-identity
>                  1*WSP datetime
>                  *( ";" [CFWS] inj-info-param [CFWS] ) CRLF
> ~~~ end ~~~
>
> The added <date-time> ends with [CFWS], therefore I could join
> the two [CFWS] before semicolon or CRLF into one [CFWS] behind
> <inj-info-param>.
>
> And I got rid of the first [CFWS] before the <path-identity>.
>
> It won't work with Charles' concept of a "reinjection" keeping
> the old <injection-date>, if that's critical forget it, please.
>
>                           Bye, Frank
>
>
>