Subject: #1093 Email addresses: Poll results, sort of final

From: Harald Tveit Alvestrand <[email-masked]>
Date: Tue, 09 Aug 2005 15:26:20 +0200

I think enough time has passed....

1) news@ and usenet@ for all path-identities in the Path: or
  Injection-info: headers
  Alternatives, plese pick one:

  1A) All identities that look like domain-names MUST support
  1B) All identities that look like domain-names SHOULD support
	Frank Ellermann
  1C) Some identities MUST support
      ("at least one of the <path-identity>s inserted by
      themselves" is one example of "some")
	Charles Lindsey (preferred)
  1D) Some identities SHOULD support
	Richard Clayton (second)
	Charles Lindsey (second)
  1E) No requirement
	Richard Clayton (preferred)
	Russ Allbery
	Bruce Lilly
	Forrest J. Cavalier (wants 2)
	Ralph Babel
	Dan Schlitt
	Eivind Tagseth
  1F) None of the above
	Forrest J. Cavalier (wants 2)
	John Stanley

Conclusion: 2 people support some form of mandate in USEPRO.
6 people support not making any mandate in USEPRO (one of which has said 
that he thinks it's a good idea for USEAGE), and one person would prefer no 
mandate, but could live with a SHOULD mandate.

2) abuse@ for injecting agents as identified in Path:, for the
   case where Injection-info doesn't contain "mail-complaints-to"
   Alternatives, please pick one:

  2A) All identities MUST support abuse@identity
	Charles Lindsey (one alternative of 2)
  2B) All identities SHOULD support
	Richard Clayton (preferred)
	Frank Ellermann (wants 2)
	Charles Lindsey (one alternative of 2)
  2C) No requirement
	Russ Allbery
	Bruce Lilly
	Forrest J. Cavalier (wants 2)
	Ralph Babel
	Dan Schlitt
	Eivind Takseth
  2D) Top level domain corresponding to identity MUST support
	Frank Ellermann (wants 2)
  2E) Top level domain corresponding to identity SHOULD support
	Richard Clayton (could live with)
  2F) None of the above
	Forrest J. Cavalier (wants 2)
	John Stanley

Counting as above, 3 people support some form of mandate.
6 people do not support any form of mandate.

---

From: Bruce Lilly <[email-masked]>
Date: Tue, 9 Aug 2005 22:55:28 -0400

>   1A) All identities that look like domain-names MUST support
[...]
> 	Charles Lindsey (preferred)
[...]

> Conclusion: 2 people support some form of mandate in USEPRO.

I see only one (unless you're counting some of the "None of the above"
respondents).

> that he thinks it's a good idea for USEAGE),

I see 7 in the "no requirement" category alone; surely that means "not making
any mandate".

> and one person would prefer no  

There's no such thing as "a SHOULD mandate"; "SHOULD" is a recommendation
(indeed it explicitly carries the same meaning as RECOMMENDED).  The BCP 14
mandates (as in mandatory, are REQUIRED, MUST, SHALL, MUST NOT, and SHALL
NOT).

> 	Charles Lindsey (one alternative of 2)
[...]
> 	Frank Ellermann (wants 2)
[...]
> Counting as above, 3 people support some form of mandate.

I see only 2, both of whom also want no mandate.

> 6 people do not support any form of mandate.

I count 7.

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 10 Aug 2005 08:13:07 +0200

--On tirsdag, august 09, 2005 22:55:28 -0400 Bruce Lilly <[email-masked]> 
wrote:

> (indeed it explicitly carries the same meaning as RECOMMENDED).  The BCP
> 14 mandates (as in mandatory, are REQUIRED, MUST, SHALL, MUST NOT, and
> SHALL NOT).

Bruce (and John):

For your info - RFC 2119 refers to MUST, SHOLD and MAY as "requirement 
levels".

The "american heritage dictionary of the English language" defines 
"mandate" (definition one) as "an authoritative command or instruction". 
SHOULD is an authoritative instruction too, but a more complex one.

I could have used a word that you would not have found fault with. I 
didn't. I'm unlikely to use "mandate" again in this context.

Neither of your chairs is a native English speaker. Live with it.

                     Harald