Subject: Re: USEFOR cite by reference vs. rewriting syntax

From: Bruce Lilly <[email-masked]>
Date: Wed, 3 Aug 2005 20:48:57 -0400

On Fri July 29 2005 12:54, Frank Ellermann wrote:
> 
> Bruce Lilly wrote:
> 
> >>>> The long-term roadmap is to fix the <msg-id> in a 2822bis
> 
> > a) it's not broken
> 
> Of course it is, you claimed that it "invented" <id-left> and
> <id-right> especially because <local-part> and <domain> don't
> work in news.  Obviously they failed to get it right, so now
> we do it, where's the problem ?

Usenetters requested elimination of CFWS (but no other changes) to
accommodate news software.  That change was made to the syntax (but
no change to semantics of the RHS) accordingly.

> NetNews always was a proper subset, and it always will be, crap
> like length 250 (instead of 320) for the <msg-id> and no ">"
> and the magic SP won't make it in 2822bis, it's just too silly.

Given the fact that a domain name can be up to 255 octets, limiting
a msg-id (domain name plus local-part plus '<', '@', and '>') simply
isn't rational.

-------
> > a roadmap should be specified
> 
> The roadmap is clear:  msg-id = "<" id-local "@" id-domain ">"
> It updates "<" unique "@" full_domain_name ">" and other old
> or incompatible constructs like "<" id-left "@" id-right ">".
[...]

Tilting at windmills didn't work well for Don Quixote.  Good luck.

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 12 Aug 2005 06:27:14 +0200

Bruce Lilly wrote:

> Usenetters requested elimination of CFWS (but no other
> changes) to accommodate news software.  That change was made
> to the syntax (but no change to semantics of the RHS)
> accordingly.

Apparently they forgot the other issues, NO-WS-CTL and ">" and
some kind of "canonical" <msg-id>.  So now we fix that back to
VCHAR modulo some details as it always was, still is, and will
be for the foreseeable future (as far as NNTP is concerned).

> Given the fact that a domain name can be up to 255 octets,
> limiting a msg-id (domain name plus local-part plus '<', '@',
> and '>') simply isn't rational.

I could justify 322, and a limit is rational.  By some accident
we inherit 250.  It's ugly like hell, but replacing it by 322
if that breaks existing software everywhere makes no sense.

We discussed this already in the past years, so let's agree to
disagree about the ugly limit (of course we do agree that it's
ugly).

> Tilting at windmills didn't work well for Don Quixote.

Except from the stolen RfC 2822 names I'm happy with the fixed
syntax.  Syntactically Charles' and my version are identical -
we didn't talk for months about it without any results.

One minor difference, his version allows [] as RHS (an empty
domain-literal), my version wants non-empty domain-literals.

The real problem is of course that I in fact want <id-domain>,
where Charles allows random strings, a real domain-literal is
never empty.
                            Bye, Frank

---

From: Bruce Lilly <[email-masked]>
Date: Sun, 14 Aug 2005 09:29:39 -0400

On Fri August 12 2005 00:27, Frank Ellermann wrote:
> some kind of "canonical" <msg-id>.

Then please explain (in a form suitable for an implementation note)
precisely why such changes are necessary (or specifically which
existing (not hypothetical) brain-dead implementations get handling
of msg-ids wrong, and why we shouldn't simply treat such brain-dead
implementations as non-conforming and move on).

> I could justify 322, and a limit is rational.

There is an inherent limit of 997 octets imposed by lack of folding.

> By some accident 
> we inherit 250.

No consensus work from which to "inherit" that. It's not in 724, 733,
822, 850, 1036, or 2822.

> It's ugly like hell, but replacing it by 322 

If you can prove that it "breaks existing software everywhere", i.e.
that there is not one implementation that can handle >= 251 octets
for a msg-id, I'll agree.
 
> we didn't talk for months about it without any results.

Neither you nor Charles has addressed how gateways are going to
handle the differences from RFC 2822 that you wish to impose.
That is necessary before locking down any such proposal.

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 15 Aug 2005 23:03:25 +0200

Bruce Lilly wrote:

> please explain (in a form suitable for an implementation
> note) precisely why such changes are necessary (or
> specifically which existing (not hypothetical) brain-dead
> implementations get handling of msg-ids wrong

I've already proposed pure ABNF, it's IMHO obvious.  For
the limit 250 we'll have a reference to the NNTP standard.
That also explains other details like VCHAR excl. ">", and
why there can't be different Message-IDs with the same
semantics.

Charles' version needs more prose because it isn't obvious
for some details:  What's an <id-right>, why can't I just
use whatever I like, what's a collision, how can I calculate
the probability, what's a name space owner, can I cancel
abuses of my name space, can I sue the offending party, is
software using random IDs broken by design, can I sue the
vendor, etc.  BTW, I'd say "yes" for the last four points.

[Your point about gateways addressed in a reply to Harald]

                           Bye, Frank

---

From: Bruce Lilly <[email-masked]>
Date: Tue, 16 Aug 2005 20:49:33 -0400

On Mon August 15 2005 17:03, Frank Ellermann wrote:
> I've already proposed pure ABNF, it's IMHO obvious.

Changed ABNF doesn't explain *why*, *who*, or *how* to get to convergence
with other Internet Message Format applications.

> For 

NNTP (RFC 977) has a limit of ca. 500 octets.  Lower than the 997 octets
imposed by 2822, but not hopelessly irrationally low (i.e. it's not lower
than the longest legal domain name).  250 is hopelessly irrational; do you
suppose that no DNS experts will notice the problem during IETF Last Call?

> why there can't be different Message-IDs with the same

No, RFC 977 says none of those things.

---

From: Russ Allbery <[email-masked]>
Date: Tue, 16 Aug 2005 17:58:32 -0700

Bruce Lilly <[email-masked]> writes:

> imposed by 2822, but not hopelessly irrationally low (i.e. it's not
> lower than the longest legal domain name).  250 is hopelessly
> irrational; do you suppose that no DNS experts will notice the problem
> during IETF Last Call?

The NNTP draft currently sitting in the RFC Editor's queue imposes a limit
of 250 characters.  Neither two IETF Last Calls nor an IESG review turned
up any objections.  Please see the extensive previous discussion in this
list that was behind the original decision.  Yes, it's an arbitrary
number; it's also a *safe* arbitrary number already imposed by deployed
software that poses no difficulties in practice.

>> That also explains other details like VCHAR excl. ">", and why there
>> can't be different Message-IDs with the same semantics.

> No, RFC 977 says none of those things.

I assure you that RFC 977 will be obsoleted by the time USEFOR manages to
publish.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

---

From: Henry Spencer <[email-masked]>
Date: Tue, 16 Aug 2005 22:21:04 -0400 (EDT)

On Tue, 16 Aug 2005, Bruce Lilly wrote:
> ...250 is hopelessly irrational...

The rational (unfortunate, but rational) reasons for that limit have been
explained to you repeatedly, the first time on 25 Feb 2003.

                                                          Henry Spencer
                                                       [email-masked]

---

From: "Charles Lindsey" <[email-masked]>
Date: Wed, 17 Aug 2005 14:45:55 GMT

>implementations as non-conforming and move on).

I am not aware of ANY widely deployed news-servers that would operate with
<msg-id>s exactly as defined in RFC 2822. So if you want to characterize
all the people who have implemented such servers over the years (and
expended much time and effort in making them work efficiently) as
"brain-dead", then go ahead.

Or could you please fine ONE example of a news-server that could so cope,
or ONE competent and experienced implementer who would be prepared to
write such a server?

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5