Subject: Re: ABNF

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 3 Jan 2006 15:04:05 GMT

In <[email-masked]> Frank Ellermann <[email-masked]> writes:

>Charles Lindsey wrote:

>> if you look at draft-ietf-usefor-article-13, you will see
>> that is exactly what was done (non-normatively, of course),

>Yes, I liked that, but a later consensus (?) was to drop it.

I don't recall that it was ever discussed. Anyway it is there if we want
to continue to use it (or something like it). There should certainly be a
collected syntax of some sort, but it needn't go to that extent if people
prefer it shorter.

> <host-value> 
>> The syntax using the ":" was taken from the presently used
>> NNTP-Posting-Host header, which <host-value> is intended to
>> replace.

>Okay.  But note that colon is a 2045 <tspecial>, so there will
>a major difference for "FQDN or IPv4 only" vs. "FQDN:IPv4", in
>the latter case the <host-value> MUST be in a <quoted-string>.

>With square brackets for all IP literals (as in 2821) or at the
>very minimum for IPv6 and beyond (as in STD 66) we could avoid
>all potential IPv6 trouble:

OK, that is a good point. I would be happy with

   posting-host = news.foo.example[123.456.123.456]

(not lack of whitespace after "example" - you would need to quote it
then). But then you also have to decide whether you want

   posting-host = [123.456.123.456]
as well as the present
   posting-host = 123.456.123.456

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 03 Jan 2006 20:44:39 +0100

Charles Lindsey wrote:

> I would be happy with
> (not lack of whitespace after "example" - you would need to
> quote it then). But then you also have to decide whether you
> want
 
>    posting-host = 123.456.123.456

The former as in 2821 (IPs always in square brackets).
Quoted, because square brackets are also <tspecials> :-(

It's a new <parameter> in a new header field, if the present
NNTP-Hosting-Host header field is a bit different that's no
real issue.

The real question is, is the colon confusing in conjunction
with IPv6 ?  If *not* let's just use the 4234-beautified ABNF
as proposed in "ISSUE: host-value", otherwise the same as is.

BTW, while you discuss control FWS vs. 1*WSP with Russ, the -06
syntax is actually:

    verb *( [FWS} argument )

If we'd stick to FWS that should be at least:

    verb *( FWS argument )

Or  verb *( 1*WSP argument )  without folding.  Your proposal
to add a note "detailed control commands are specified in
[USEPRO]" (or something in that direction) is a good idea.  A
real example plus pointer to USEPRO could have the same effect.

                          Bye, Frank

---

From: "Charles Lindsey" <[email-masked]>
Date: Wed, 4 Jan 2006 11:39:48 GMT

>Quoted, because square brackets are also <tspecials> :-(

OK. If you have to quote it anyway because of the [...], then you might as
well leave it with the ":" we have at present.

>as proposed in "ISSUE: host-value", otherwise the same as is.

It is not ambiguous since an Ipv6Address cannot begin with a ":". I tried
to construct an ambiguity supposing that ICANN might have invented a TLD
"beef", but I could not do it even then. So let it be.

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 04 Jan 2006 14:44:20 +0100

Charles Lindsey wrote:

> not ambiguous since an Ipv6Address cannot begin with a
> ":". I tried to construct an ambiguity supposing that
> ICANN might have invented a TLD "beef", but I could not
> do it even then.

Okay, I tried an.example.de:be:af:: (existing <h16> ccTLDs)

It should be clear that that's an.example.de [be:af::] and
not an.example. [de:be:af::] with a trailing dot...

> So let it be

...ACK.  Let's add a note "colon => quoted because of 2045".

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 04 Jan 2006 15:27:42 +0100

Charles Lindsey wrote:

> an Ipv6Address cannot begin with a ":"

JFTR, it can begin with two colons ::ad:be:ef resulting
in say posting-host = "an.example.de:::ad:be:ef"