Subject: Imroved <toplabel> idea (was: RFC 4408 <draft-schlitt-spf-classic-02.txt> -- AUTH48 changes)

From: Frank Ellermann <[email-masked]>
Date: Sun, 02 Apr 2006 01:33:08 +0200

(About the <toplabel> thread in SPF-discuss)  Wait a moment...

>>> toplabel =
>>>       ( *alphanum alpha *alphanum ) /
>>>       ( 1*alphanum "-" *( alphanum / "-" ) alphanum )

...it's simple to add the "no single alpha" case to this beast:

| toplabel =
|       ( alpha 1*alphanum ) / ( 1*digit alpha *alphanum ) /
|       ( 1*alphanum "-" *( alphanum / "-" ) alphanum )

I'll propose that for USEFOR, it's clearer than the convoluted
syntax based on <label>.  It's also unambiguous for a parser -
credits to Matthew.van.Eerde, copy to USEFOR.

                              Bye, Frank

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 3 Apr 2006 10:08:10 GMT

>...it's simple to add the "no single alpha" case to this beast:

What's the point? It resolves no ambiguities/whatever for our use. Is
there some rule somewhere disallowing single alphas at TLDs in the DNS? It
is really not our job to define the rules for domain names. There is
already enough confusion out there already without us adding to it.

I grant you that your syntax is neat and does the job, but it is really
someone else's job to fix it.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5