Subject: Possible typos

From: Julien ÉLIE <[email-masked]>
Date: Tue, 7 Apr 2009 21:09:41 +0200

Hi,

Here are a few remarks to improve the document.

In 2:

    Transports for Netnews articles MUST treat news articles as uninterpreted
    sequences of octets, excluding the values 0 (which may not occur in Netnews
    articles) and 13 and 10 (which MUST only appear in Netnews articles as a pair
    in that order and which together denote a line separator).

Wouldn't it be better to write %x00, %x0D and %x0A?
"and 13 and 10" -> not ", 13 and 10"?

In 3.3:

    Such a history database would grow without bound, however, so it is common
    and permitted to optimize based on the Injection-Date or Date header field
    of an article as follows.

"to optimize it"?  (I do not know whether "it" is mandatory or not in English there.)

In 3.6, the Injector-Info: header is mentioned.  Isn't it Injection-Info: instead?

In 3.9:

    the leftmost unapproved newsgroup is is the leftmost moderated newsgroup
    in that field

Only one "is".

    Any Path header field MUST either be removed or truncated to only those entries
    following its "POSTED" <diag-keyword>, if any.

Is it clear enough?  "following" and not "preceding"?  It depends on the direction
we read the Path: header :)

In 3.10.2:

    there is no one "official" gateway

Is "one" correct here?  (Probably yes, but better ask.)

What if Original-Sender already exists?  Is it renamed to X-Original-Sender (as 3.10.4
seems to suggest)?

-- 
Julien ÉLIE

« C'est souvent la femme qui nous inspire les grandes choses
  qu'elles nous empêchent d'accomplir. » (Alexandre Dumas Fils)

---

From: "Charles Lindsey" <[email-masked]>
Date: Wed, 8 Apr 2009 11:55:00 GMT

>"and 13 and 10" -> not ", 13 and 10"?

I think I agree.

>"to optimize it"?  (I do not know whether "it" is mandatory or not in English there.)

Yes, I spotted that one and it grated a bit. The "it" is not mandatory,
but I agree it would read better with it in.

>In 3.6, the Injector-Info: header is mentioned.  Isn't it Injection-Info:

Yes. Many many drafts ago, the term _was_ Injector-Info, and this one seems
to have been overlooked.

>Only one "is".

+1

>we read the Path: header :)

Since the Path header is generated right to left, this confusion will
always be there, but I think "following" is correct, and I think that is
the usage elsewhere in the drafts.

>Is "one" correct here?  (Probably yes, but better ask.)

Yes, that is correct.

>What if Original-Sender already exists?  Is it renamed to X-Original-Sender (as 3.10.4

The re-re-sender needs to use his imagination! It is not actually
forbidden to have two Original-Senders, and he could add a comment if he
was that fussy. But I don't think we really care, so leave it be.

Those are my comments. I presume Russ will adopt them as he sees fit.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131            Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Julien ÉLIE <[email-masked]>
Date: Wed, 8 Apr 2009 20:24:29 +0200

Hi,

Other typos:

In 4.3:
    The content of the application/news-groupinfo body part is defined as:

It is application/news-checkgroups!

In both 4.3 and 5.2.1.1, could it be said that in the examples, spaces
are used in newsgroups descriptions but that they are in fact tabs?

In 5.2.3, as for a checkgroups control message:

    It requests a news server update its valid newsgroup list for that hierarchy
    to include the groups specified, remove any groups not specified, and update
    group descriptions to match those given in the checkgroups control message.

Could it be said "and update group descriptions as well as moderation status to match
those..."?

In 5.3:

    The cancel control message requests that a target article be withdrawn
    from circulation and access.

In order to be consistent with the previous paragraphs, "that" should not be added
here after "requests" :)
The same goes in 5.4 for the Supersedes: header field and 5.5 for sendme.  Whence maybe
"that" should be added in 5.2.1, 5.2.2 and 5.2.3 instead?  (It is a very minor remark.)

By the way, why does "Supersedes" always begin with a capital?
When we do not speak about the header, it should be a lower-case letter shouldn't it?
For instance in 3.4, "which cancels or Supersedes another article".

In 6.1:

    Cancel control messages are not required to have the same Newsgroups
    header field as the messages they are cancelling and, since they are
    sometimes processed before the original message is received, it may not
    be possible to check that they do.

"to check what they do"?  "to check that"?

-- 
Julien ÉLIE

« Quand je raconterai mon odyssée, personne ne me croira ! » (Astérix)