Subject: [Editorial Errata Reported] RFC5536 (1979)

From: RFC Errata System <[email-masked]>
Date: Mon, 28 Dec 2009 04:10:50 -0800 (PST)

The following errata report has been submitted for RFC5536,
"Netnews Article Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5536&eid=1979

--------------------------------------
Type: Editorial
Reported by: Alfred Hoenes <[email-masked]>

Section: 3.2.7

Original Text
-------------
... in the 2nd paragraph:

   However, software that predates this standard does not use this
|  header, and therefore agents MUST accept articles without the
   Injection-Date header field.

Corrected Text
--------------
   However, software that predates this standard does not use this
|  header field, and therefore agents MUST accept articles without the
   Injection-Date header field.

Notes
-----
Rationale:
  The whole RFC is precise in its use of the IETF standard terminology
  as explained in Section 2.1.  This phrase is an exception; here as
  well "header" should be "header field".

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5536 (draft-ietf-usefor-usefor-12)
--------------------------------------
Title               : Netnews Article Format
Publication Date    : November 2009
Author(s)           : K. Murchison, Ed., C. Lindsey, D. Kohn
Category            : PROPOSED STANDARD
Source              : Usenet Article Standard Update
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Julien ÉLIE <[email-masked]>
Date: Mon, 28 Dec 2009 20:11:49 +0100

Hi Alfred,

>  well "header" should be "header field".

Is it really the case?

Section 2.1 of RFC 5536:

   This document follows the
   terminology in Section 2 of [RFC5322] in using the terms "line",
   "header field", "header field name", "header field body"

Section 2 of RFC 5322:

   Header fields are lines beginning with a field name, followed by a
   colon (":"), followed by a field body, and terminated by CRLF.

But a header field body in RFC 5536 seems to refer to what follows the
first SP of a header field body in RFC 5322.
See Section 2.2 of RFC 5536:

   o  All agents MUST generate header fields so that at least one space
      immediately follows the ':' separating the header field name and
      the header field body

It is not the IETF standard terminology you mention in your rationale.

Hmm...  And I now wonder how the wording you suggest in your erratum 1980
for RFC 5537 should be like...
For instance, Section 5.3 of RFC 5537:

    The syntax of its Control header field is:

         control-command     =/ Cancel-command
         Cancel-command      = "cancel" Cancel-arguments
         Cancel-arguments    = 1*WSP msg-id

And Section 3.2.3 of RFC 5536 gives:

   control         =  "Control:" SP *WSP control-command *WSP CRLF
   control-command =  verb *( 1*WSP argument )
   verb            =  token
   argument        =  1*( %x21-7E )

So in RFC 5537, it is not really the header field.  And not really
the header field body.  So the fix in erratum 1980 might not be correct...
Maybe it is better to leave the global "header field" terminology...

-- 
Julien ÉLIE

« Ne parlez jamais de vous, ni en bien, car on ne vous
  croirait pas, ni en mal car on ne vous croirait que trop. » (Confucius)