Subject: RE: Webdav issue: UNLOCK_BY_NON_LOCK_OWNERS

From: "Jason Crawford" <[email-masked]>
Date: Sun, 19 Aug 2001 12:19:46 -0400

<<
The other issue, Geoff, is that people are using LOCK as a poor person's
CHECKOUT, also assuming that LOCK's won't timeout.
I agree.

<<
  The RFC2518 revision
should clearly state that LOCKs aren't to be used for this purpose.
???? - I assume the purpose of locking is to avoid lost updates.  What is
the distinction between a "poor man's CHECKOUT"  and "avoidance of the lost
update problem"?   In the absense of actual versioning, aren't they the
same?

J.

---

From: "Eric Sedlar" <[email-masked]>
Date: Tue, 21 Aug 2001 10:32:49 -0700

Well, checkout doesn't allow things to timeout, nor can you grab
a resource checked out into another workspace the way you can grab
somebody else's lock.

> -----Original Message-----
> From: Jason Crawford [mailto:[email-masked]]
> Sent: Sunday, August 19, 2001 9:20 AM
> To: Eric Sedlar
> Cc: Webdav WG
> Subject: RE: Webdav issue: UNLOCK_BY_NON_LOCK_OWNERS
> 
> 
> 
> <<