Subject: RE: rfc2518 issue: LOCK_NULL_STATUS_CREATION

From: "Jason Crawford" <[email-masked]>
Date: Tue, 14 Aug 2001 14:01:41 -0400

I'm marking the following issue:

What status code should be returned when a lock null resource is created ?
200 OK or 201 Created? A related issue is what status code should be
returned by a PUT or MKCOL on a lock-null resource? MKCOL is defined to be
201, PUT could be 200 or 201 (201 seems like a slightly better choice).

...as resolved by our apparent consensus on the addition of the following
wording for a status code for LOCK requests...

201 (Created) - The lock request succeeded by creating a new resource
and the value of the lockdiscovery property is included in the body.

Discussion in the thread that includes the following posting by Stefan...

http://lists.w3.org/Archives/Public/w3c-dist-auth/2001JulSep/0129.html

------------------------------------------
Phone: 914-784-7569,   [email-masked]

---

From: "Tim Ellison" <[email-masked]>
Date: Wed, 15 Aug 2001 09:21:40 +0100

BTW: Jim W. objected when I made this suggestion a couple of months ago.
(http://lists.w3.org/Archives/Public/w3c-dist-auth/2001AprJun/0302.html)

He is, of course, free to change his mind<g>

Regards,
Tim

Jason wrote:
> What status code should be returned when a lock null
> resource is created ? 200 OK or 201 Created? A related
> issue is what status code should be returned by a PUT
> or MKCOL on a lock-null resource? MKCOL is defined to
> be 201, PUT could be 200 or 201 (201 seems like a
> slightly better choice).
>
> ...as resolved by our apparent consensus on the addition
> of the following wording for a status code for LOCK requests...
>
> 201 (Created) - The lock request succeeded by creating a
> new resource and the value of the lockdiscovery property
> is included in the body.
>
>

---

From: "Clemm, Geoff" <[email-masked]>
Date: Wed, 15 Aug 2001 09:56:16 -0400

Note that Jim's objection was not in the new context,
in which the LOCK on an unmapped URL creates a regular
resource.  I am sure Jim will withdraw his
objection in this new context (:-).

Cheers,
Geoff

-----Original Message-----
From: Tim Ellison [mailto:[email-masked]]
Sent: Wednesday, August 15, 2001 4:22 AM
To: [email-masked]
Subject: RE: rfc2518 issue: LOCK_NULL_STATUS_CREATION

Regards,
Tim

---

From: "Jason Crawford" <[email-masked]>
Date: Wed, 15 Aug 2001 10:30:09 -0400

Tim,

Actually Jim wasn't disagree'ing with you on what we propose here.  He was
additionally proposing that the first PUT after the resource is created
*also* return 201.    I don't think that issue is on the issues list.   If
Jim advocates it again, we can put it on the list.

---

From: "Tim Ellison" <[email-masked]>
Date: Thu, 16 Aug 2001 09:55:36 +0100

> additionally proposing that the first PUT after the resource is created
*also*
> return 201.    I don't think that issue is on the issues list.   If Jim
advocates it again,
> we can put it on the list.

I'd object to such a proposition since it contradicts a RFC2616 SHOULD
requirement for modifying an exiting resource with PUT.

Regards,
Tim