Subject: RE: rfc2518 issue: LOCK_REFRESH_BY_METHODS

From: "Jason Crawford" <[email-masked]>
Date: Sat, 18 Aug 2001 15:05:17 -0400

Again.  I'd like at least one more supportive comment before I file this
one as resolved.    Please pipe up.  :-)

-----------------------------------------------------------------------------------------------------------

I'd just delete the paragraph in 9.8 that states:

   The timeout counter SHOULD be restarted any time an owner of the lock
   sends a method to any member of the lock, including unsupported
   methods, or methods which are unsuccessful.  However the lock MUST be
   refreshed if a refresh LOCK method is successfully received.

The last sentence is redundant, since it is already specified in the
LOCK semantics.

Cheers,
Geoff

---

From: "Eric Sedlar" <[email-masked]>
Date: Tue, 21 Aug 2001 08:46:32 -0700

I agree with the current consensus that LOCKs should not be
refreshed on other methods.  We don't do that.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jason Crawford
> Sent: Saturday, August 18, 2001 12:05 PM
> To: WebDAV (E-mail)
> Subject: RE: rfc2518 issue: LOCK_REFRESH_BY_METHODS
> 
> 
> 
> 
> 
> ------------------------------------------------------------------
> -----------------------------------------
> 
> 
>