Subject: RE: Notes from DAV meeting

From: "Hall, Shaun" <[email-masked]>
Date: Wed, 15 Aug 2001 16:02:36 +0100

> -----Original Message-----
> From: Clemm, Geoff [mailto:[email-masked]]
> Sent: 15 August 2001 14:56
> To: Webdav WG
> Subject: RE: Notes from DAV meeting
> 
> 
>    From: Hall, Shaun [mailto:[email-masked]]
> 
> I agree with all of Shaun's comments, except for:
> 
>    > - Lock Permissions -
>    > Consensus around: Users other than lock creators MAY be able to
>    > UNLOCK a resource by discovering and using the correct lock
>    > token.
> 
>    Assuming your are referring to "ordinary" users i.e. not say when
>    an Administrator removes a lock because an employee has left the
>    company sort of thing:
> 
>    I strongly disagree with this. It should not be allowed at all.
> 
> I strongly agree with the consensus opinion.
> 
> A client holding a lock already has to deal with locks being lost
> through timeouts.  Allowing another client to effectively force the
> timeout is a valuable feature that does not increase the complexity of
> the locking client.  A server can use access control to control what
> users have permission to force the timeout.
> 
>    I know locks can disappear at any time, but it could cause problems
>    for example ...
> 
> Any such problem already occurs because of timeouts, so 
> clients have to
> deal with all these situations anyway.  Allowing a client to force
> a timeout decreases the need to have an automatic server timeout,
> and therefore this capability will actually decrease the number of
> unnecessary timeouts (since the server can be written to assume that
> timeouts will be forced by clients that need them).

Supposing the server only supported infinite timed locks (which is allowed)
and therefore lost locks through timeouts are not an issue. You've just
bypassed the lock mechanism as we know it. In my crude example, what is the
original lock creator suppose to do ?

> Cheers,
> Geoff

Regards

Shaun Hall
Xerox Europe

---

From: "Lisa Dusseault" <[email-masked]>
Date: Wed, 15 Aug 2001 09:09:47 -0700

> original lock creator suppose to do ?

If the server only supports infinite timed locks, it's also free to prevent
anybody but the original lock creator to use the associated lock token.

This proposed clarification doesn't force anything on server implementors
that they don't like.  It only makes clients have to be more robust in the
face of locks disappearing.

lisa