Subject: Implementing WebDAV for different WebDAV clients

From: "Hanmay Udgiri" <[email-masked]>
Date: Tue, 20 May 2008 23:13:08 +0530

Hi
I am looking to implementing WebDAV which supports multiple WebDAV clients.
Which is the good practice to go for implementation.
I am using tomcat for deploying my application.
Currently we are supporting WebDAV for windows through IE.
We are planning to support WebDAV clients like Xythos and Mac OS finder etc

-- 
Thanks and Regards
Hanmayya Udgiri

---

From: Werner Baumann <[email-masked]>
Date: Tue, 20 May 2008 22:21:27 +0200

> We are planning to support WebDAV clients like Xythos and Mac OS finder etc
Why not just start supporting the standards?
If there should be problems with certain clients, you may decide whether 
to help debugging the clients or provide a workaround.

Still better: why don't you take an existing server. Or help make it better?

As developer of a WebDAV-client I am fed up with broken servers. Just 
had to answer an help-request, because they can't even implement HEAD 
according to the standards.

You are using tomcat. What is wrong with Jigsaw 
(http://www.w3.org/Jigsaw/)? Can you improve it?

Cheers
Werner