Subject: Fwd: New Version Notification for draft-sanchez-webdav-current-principal-00

From: Wilfredo Sánchez Vega <[email-masked]>
Date: Tue, 13 May 2008 17:56:42 -0700

Cyrus and I have submitted a draft for a property that lets a  
client determine which principal the server thinks the client is using  
in a request.

	-wsv

Begin forwarded message:

> From: IETF I-D Submission Tool <[email-masked]>
> Date: May 13, 2008 4:34:47 PM PDT
> To: [email-masked]
> Cc: [email-masked]
> Subject: New Version Notification for  draft-sanchez-webdav-current- 
> principal-00
>
>
> A new version of I-D, draft-sanchez-webdav-current-principal-00.txt  
> has been successfuly submitted by Wilfredo Sanchez and posted to the  
> IETF repository.
>
> Filename:	 draft-sanchez-webdav-current-principal
> Revision:	 00
> Title:		 WebDAV Current Principal Extension
> Creation_date:	 2008-05-13
> WG ID:		 Independent Submission
> Number_of_pages: 6
>
> Abstract:
> This specification defines a new WebDAV property that allows clients
> to quickly determine the principal corresponding to the current
> authenticated user.
>
>
>
> The IETF Secretariat.

---

From: Julian Reschke <[email-masked]>
Date: Wed, 14 May 2008 16:08:48 +0200

Wilfredo Sánchez Vega wrote:
> 
>   Cyrus and I have submitted a draft for a property that lets a client 
> determine which principal the server thinks the client is using in a 
> request.
 > ...

Looks good so far.

Nit:

  "Definition:

       <!ELEMENT current-user-principal-resource (DAV:unauthenticated |
                                                  DAV:href)>
       DAV:href value: a URL to a principal resource" -- 
<http://www3.tools.ietf.org/html/draft-sanchez-webdav-current-principal-00#section-3>

Not sure why you use the DAV: prefix for the child elements here, this 
seems to be inconsistent.

I'd also recommend making the DTD fragments valid, for example:

       <!ELEMENT current-user-principal-resource (unauthenticated |
                                                  href)>
       <!-- href value: a URL of a principal resource -->

BR, Julian