Subject: safeness of SEARCH method, Re: Last Call: draft-reschke-webdav-search (Web Distributed Authoring and Versioning (WebDAV) SEARCH) to Proposed Standard

From: Julian Reschke <[email-masked]>
Date: Sat, 02 Aug 2008 10:05:50 +0200

Hi,

here's a LC comment by myself: the specification should state that 
SEARCH is a safe method (see 
<http://greenbytes.de/tech/webdav/rfc2616.html#rfc.section.9.1.1>).

BR, Julian

---

From: Julian Reschke <[email-masked]>
Date: Sun, 03 Aug 2008 18:28:53 +0200

> <http://greenbytes.de/tech/webdav/rfc2616.html#rfc.section.9.1.1>).

Fixed in -latest, adding:

"SEARCH is a safe method; it does not have any significance other than 
executing a query and returning a query result (see [RFC2616], Section 
9.1.1)."

(<http://greenbytes.de/tech/webdav/draft-reschke-webdav-search-latest.html#rfc.section.2.1>).

BR, Julian