Subject: "Starts with" comparison in search

From: Cyrus Daboo <[email-masked]>
Date: Mon, 11 Aug 2008 10:35:20 -0400

Hi,
Is it too late to consider adding a "startswith" comparison operation to 
the basicsearch grammar in the SEARCH extension? I think that is a key 
string match operation to have in addition to "contains".

-- 
Cyrus Daboo

---

From: Julian Reschke <[email-masked]>
Date: Mon, 11 Aug 2008 17:00:33 +0200

> string match operation to have in addition to "contains".

Hi Cyrus,

are we talking about properties, or about content?

For properties, you can use DAV:like, with something like "prefix%" (see 
<http://greenbytes.de/tech/webdav/draft-reschke-webdav-search-17.html#rfc.section.5.15>).

BR, Julian

---

From: Cyrus Daboo <[email-masked]>
Date: Mon, 11 Aug 2008 11:08:55 -0400

Hi Julian,

> <http://greenbytes.de/tech/webdav/draft-reschke-webdav-search-17.html#rfc

Ah yes. That is probably sufficient for the vast majority of use cases I 
can think of.

-- 
Cyrus Daboo

---

From: "John Barone" <[email-masked]>
Date: Mon, 11 Aug 2008 08:36:24 -0700

+1   would be nice

-John 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Cyrus Daboo
Sent: Monday, August 11, 2008 7:35 AM
To: [email-masked]; [email-masked]
Subject: "Starts with" comparison in search

Hi,

--
Cyrus Daboo

This email and any attachments may contain confidential and proprietary
information of Blackboard that is for the sole use of the intended
recipient.  If you are not the intended recipient, disclosure, copying,
re-distribution or other use of any of this information is strictly
prohibited.  Please immediately notify the sender and delete this
transmission if you received this email in error.

---

From: "John Barone" <[email-masked]>
Date: Mon, 11 Aug 2008 08:37:41 -0700

Err... True.  Disregard my +1

-John 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Cyrus Daboo
Sent: Monday, August 11, 2008 8:09 AM
To: Julian Reschke
Cc: [email-masked]; [email-masked]
Subject: Re: "Starts with" comparison in search

Hi Julian,

--On August 11, 2008 5:00:33 PM +0200 Julian Reschke
<[email-masked]> wrote:

> <http://greenbytes.de/tech/webdav/draft-reschke-webdav-search-17.html#
> rfc
> .section.5.15>).

--
Cyrus Daboo