Subject: How to make Windows display the storage size and free space correctly

From: "Xia, Arandar" <[email-masked]>
Date: Fri, 8 Jan 2010 17:22:43 +0800

Hi,
I have a question about WebDAV (mod_dav).
If I map a network drive to a WebDAV server from Windows XP, there will be a drive standing for the WebDAV server in "My Computer". And the total size and free space of this drive will be displayed if choosing to show detailed information or right clicking for its attributes.
Currently, the total size and free space of the WebDAV server are same as the system disk (C disk).
How to make the total size and free space of the WebDAV server be shown correctly as what I want? What properties should be responded to the client for this purpose?
Could anybody help me!?

//Zeyi

---

From: Werner Baumann <[email-masked]>
Date: Sat, 9 Jan 2010 09:39:02 +0100

It is defined in Proposed Standard RFC 4331, Quota and Size Properties
for Distributed Authoring and Versioning (DAV) Collections. But I doubt
that there are many servers that support it. Apache/mod_dav/mod_davfs
does not. Some German providers (1und1) use their own non-standard
method. I heard rumors about Austrian Telecom WebDAV-servers that
support it.
I don't not whether Window's WebDAV-client supports it. I only know of
my own client (davfs2, only available for GNU/Linux) which supports it.
But I never saw any positive response from a server.

Werner

---

From: Joe Feise <[email-masked]>
Date: Sat, 09 Jan 2010 07:07:44 -0800

Werner Baumann wrote on 01/09/10 00:39:

> does not.

There are patches to provide quota support to Apache/mod_dav:
http://osdir.com/ml/apache.mod-dav.general/2007-02/msg00000.html

-Joe

---

From: "Xia, Arandar" <[email-masked]>
Date: Mon, 11 Jan 2010 10:18:12 +0800

I have modified my mod_dav to support quota-available-bytes and quota-used-bytes, but Windows (XP and Vista) still does not show the correct size information.
Does anyone know whether Mini-Redirector (WebDAV client of Windows) support these two properties of WebDAV.