Subject: [wpkops] X.509 defintions

From: Tony Rutkowski <[email-masked]>
Date: Sat, 07 Sep 2013 07:54:50 +0200

WARNING: contains banned part

Subject: X.509 defintions
From: Tony Rutkowski <[email-masked]>
To: [email-masked]
Date: Sat, 07 Sep 2013 07:54:50 +0200

Hi All,

As most of you know, the intergovernmental
organization ITU-T has a nearly defunct group
dealing with security, and a subgroup Q11/17
dealing with some of its legacy specs like X.509.
Every now an then, someone makes a proposal.
My perennial suggestion is that they grace
the actual industry concerning what they are
doing.

Here a definitional change is being proposed
by email, and a text has been produced that
is attached.  Some of these changes involve
efforts to promote new uses for some of the
legacy ITU-T specs, but may have secondary
effects on the industry that sometimes refers
to the legacy specs generically.

Since the ITU-T is an intergovernmental body,
you can always feed views through the governmental
representative or via the IETF liaison.

--tony

-------- Original Message --------
Subject: 	[T17Q11] X.509 defintions
Date: 	Fri, 6 Sep 2013 11:41:46 +0200
From: 	Erik Andersen <[email-masked]>
To: 	Directory list <[email-masked]>, 
<[email-masked]>

The ITU-T editing is currently reviewing the editing of the 7^th edition 
(2012) of X.509 and found a couple of definition where they not 
completely happy with the English frasing:

I have tentatively responded as follows:

1.Can the following definition be edited as shown below.

**

*3.5.28 end-entity attribute certificate revocation list (EARL)*: A 
revocation list containing a list of attribute certificates issued to 
holders *_who_* that are not also AAs that and *_who_* are no longer 
considered valid by the certificate issuer.

I would  rather change it to: A revocation list containing a list of 
*_end-entity _*attribute certificates issued to holders that are not 
also AAs that are no longer considered valid by the *_issuing attribute 
authority_*certificate issuer.

2.Can the following definition be edited as shown below.

*3.5.31 end-entity public-key certificate revocation list (EPRL)*: A 
revocation list containing a list of public-key certificates issued to 
subjects that are not also CAs, *_and _*that are no longer considered 
valid by the certificate issuer.

I would rather change it to: A revocation list containing a list of 
*_end-entity _*public-key certificatesissued to subjects that are not 
also CAs, that are no longer considered valid by the *_issuing 
certification authority_*certificate issuer.

Could all you clever people out there see if you are happy with my 
suggestion?

Kind regards,

Erik

---

From: Tony Rutkowski <[email-masked]>
Date: Sat, 07 Sep 2013 08:05:45 +0200

Subject: two more ITU-T PKI items
From: Tony Rutkowski <[email-masked]>
To: [email-masked]
Date: Sat, 07 Sep 2013 08:05:45 +0200

These two PKI related ITU-T SG17
work items laid dormant as abstruse
projects proposed a year ago, and then
suddenly sprung alive this week with text
that came from unknown sources.

The broad scope and prescriptive nature
of this material is a bit disconcerting.
Some awareness of the CA industry
seems warranted.

--tony