Subject: [wpkops] draft-housley-web-pki-problems-00

From: Russ Housley <[email-masked]>
Date: Tue, 7 Jul 2015 09:48:50 -0400

I want to make people on this list aware of this draft that was posted yesterday.

Stephen Farrell suggested that this list might be a good place to discuss it.

Russ

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 7 Jul 2015 11:11:11 -0400

Good idea, I forwarded it on some CA lists as well.

One omission I think needs to be called out is that the WebPKI scope is
limited to server authentication. While I don't think that the draft should
consider client auth in detail, it is something that should be pointed out
as a shortcoming.

I think that the main reason we haven't got client auth working on a large
scale is that the administration and usability issues that impact the Web
Server PKI are even more severe for client PKI.

My Mesh project is an attempt to address those issues.