Subject: [xml2rfc] ID Nits incompatible with submission version of ID Nits

From: Anders Rundgren <[email-masked]>
Date: Mon, 16 Sep 2019 08:19:05 +0200

When clicking on [Nits] in https://tools.ietf.org/html/draft-rundgren-json-canonicalization-scheme-09
I get:
https://tools.ietf.org/idnits?url=https://tools.ietf.org/id/draft-rundgren-json-canonicalization-scheme-09.txt
This version of idnits (2.16.02) produces incorrect/different information which did not show up when I submitted the I-D in XML V3 using the Web tool:

"== Missing Reference: 'RFC7638' is mentioned on line 495, but not defined"

There are no missing references.  Apparently, a SHOULD is missing in:
https://tools.ietf.org/html/rfc7991#section-2.42

"  ** There are 55 instances of too long lines in the document, the longest one being 141 characters in excess of 72"

There is no line with 141 characters in excess of 72.  Unicode issue?
However, there is though a bunch of lines that are exactly 73 characters long due to a change in "auto undent" which apparently has been removed in the XML V3 RfcMarkup renderer.

thanx
Anders

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 16 Sep 2019 10:34:04 +0200

> https://tools.ietf.org/html/rfc7991#section-2.42

Heh.  Right, you used "Informal References" instead of "Informative References".
Good one.

> There is no line with 141 characters in excess of 72.  Unicode issue?

Quite possibly, yes.

> However, there is though a bunch of lines that are exactly 73
> characters long due to a change in "auto undent" which apparently has
> been removed in the XML V3 RfcMarkup renderer.

Yes, the v3 renderer does not shift too long artwork left, which the v2
did.

	Henrik

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Sep 2019 10:36:27 +0200

On 16.09.2019 08:19, Anders Rundgren wrote:
> ...
> ...

Could you please elaborate...?

Best regards, Julian

---

From: Anders Rundgren <[email-masked]>
Date: Mon, 16 Sep 2019 10:50:39 +0200

> Could you please elaborate...?

Henrik provided that in a previous mail.

It is nit-picking but it was non-obvious for me as non-experienced RFC author.
Or is it rather idnits that is nit-picking? :-)

Regards
Anders

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Sep 2019 11:46:48 +0200

> Or is it rather idnits that is nit-picking? :-)

RFC 7991 defines the vocabulary. RFC and ID requirements on the
*contents* (like boilerplate or references) do not belong there.

Best regards, Julian

---

From: Julian Reschke <[email-masked]>
Date: Mon, 16 Sep 2019 12:25:37 +0200

> Heh.  Right, you used "Informal References" instead of "Informative References".

I'd say it's a very misleading warning then.

Best regards, Julian