Subject: [xml2rfc] new build errors

From: Niels ten Oever <[email-masked]>
Date: Mon, 9 Sep 2019 22:07:21 +0200

Hi all,

I caught another weird one that I did not know how to handle, especially since I did not change much in the draft. 

Any advice would be much appreciated! 

Attached the markdown file just in case.

Cheers,

Niels

$ make
xml2rfc draft-political.xml --html
Traceback (most recent call last):
  File "/usr/bin/xml2rfc", line 11, in <module>
    load_entry_point('xml2rfc==2.25.0', 'console_scripts', 'xml2rfc')()
  File "/usr/lib/python3/dist-packages/xml2rfc/run.py", line 482, in main
    htmlwriter.write(filename)
  File "/usr/lib/python3/dist-packages/xml2rfc/writers/base.py", line 1430, in write
    self._build_document()
  File "/usr/lib/python3/dist-packages/xml2rfc/writers/base.py", line 1376, in _build_document
    self.write_reference_list(references[0])
  File "/usr/lib/python3/dist-packages/xml2rfc/writers/legacy_html.py", line 569, in write_reference_list
    initials, surname = short_author_name_parts(author)
  File "/usr/lib/python3/dist-packages/xml2rfc/util/name.py", line 26, in short_author_name_parts
    initials = get_initials(a)
  File "/usr/lib/python3/dist-packages/xml2rfc/util/name.py", line 22, in get_initials
    initials = initials.split('.')[0]
AttributeError: 'NoneType' object has no attribute 'split'
make: *** [Makefile:12: draft-political.html] Error 1

-- 
Niels ten Oever
Researcher and PhD Candidate
Datactive Research Group
University of Amsterdam

PGP fingerprint	   2458 0B70 5C4A FD8A 9488  
                   643A 0ED8 3F3A 468A C8B3

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 10 Sep 2019 18:23:25 +0200

I thought the issues might have been due to python and other software version issues on my machine, but I got a similar output on https://xml2rfc.tools.ietf.org/ :

  Parsing file INPUT
  Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
  Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
  Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
  Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629.dtd
  Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-xhtml.ent
  Resolving entity... /usr/local/lib/python2.7/dist-packages/xml2rfc/templates/rfc2629-other.ent
Traceback (most recent call last):
  File "/usr/local/bin/xml2rfc", line 11, in <module>
    sys.exit(main())
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/run.py", line 496, in main
    htmlwriter.write(filename)
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1431, in write
    self._build_document()
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/base.py", line 1377, in _build_document
    self.write_reference_list(references[0])
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/writers/legacy_html.py", line 570, in write_reference_list
    initials, surname = short_author_name_parts(author)
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/util/name.py", line 26, in short_author_name_parts
    initials = get_initials(a)
  File "/usr/local/lib/python2.7/dist-packages/xml2rfc/util/name.py", line 22, in get_initials
    initials = initials.split('.')[0]
AttributeError: 'NoneType' object has no attribute 'split'

Also attached XML FYI.

Any hints would ve very welcome!

Best,

Niels

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 10 Sep 2019 18:55:54 +0200

Hi Niels,

This is a bug.  I'll debug and fix.

	Henrik

On 2019-09-10 18:23, Niels ten Oever wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 10 Sep 2019 19:03:27 +0200

Thanks a lot! Am actually happily surprised it's not me :))

Let me know if I can be of any help!

Best,

Niels