Subject: [xml2rfc] txt to xml

From: Randy Bush <[email-masked]>
Date: Mon, 02 Sep 2019 19:43:05 -0700

is there a hack to turn a draft.txt into draft.xml?

randy, still googling

---

From: Randy Bush <[email-masked]>
Date: Mon, 02 Sep 2019 20:03:46 -0700

and https://xml2rfc.tools.ietf.org/ yields

Traceback (most recent call last):
  File "/usr/local/bin/id2xml", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3250, in <module>
    @_call_aside
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3234, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 3263, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 585, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 598, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/local/lib/python2.7/dist-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'id2xml==1.4.5.dev0' distribution was not found and is required by the application

---

From: Julian Reschke <[email-masked]>
Date: Tue, 3 Sep 2019 06:30:14 +0200

> pkg_resources.DistributionNotFound: The 'id2xml==1.4.5.dev0' distribution was not found and is required by the application

You can try a local install:

   pip install id2xml

This got me version 1.4.4, which might explain what's wrong on the web
page...

Best regards, Julian

PS: if you need the XML for a past RFC, let me know; I might have it.

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 3 Sep 2019 08:38:27 +0200

Hi Randy,

Yes, id2xml is the answer to your previous question.

As for the traceback below: Uh, oh!  Ok, fixed.  Thanks for the alert!

Best regards,

	Henrik

On 2019-09-03 05:03, Randy Bush wrote:
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
>