Subject: [xml2rfc] references for NIST

From: Robert Moskowitz <[email-masked]>
Date: Sun, 1 Sep 2019 22:10:52 -0400

Are there references for NIST FIPS202 and SP800-185?

I went browsing https://xml2rfc.tools.ietf.org/ and did not find much of 
anything for NIST docs.  (NIST-500?).

Right now I am having to include:

<reference anchor="NIST.FIPS.202" 
target="http://nvlpubs.nist.gov/nistpubs/FIPS/NIST.FIPS.202.pdf">
     <front>
     <title>SHA-3 Standard:  Permutation-Based Hash and 
Extendable-Output Functions</title>
     <author initials="M." surname="Dworkin" fullname="Morris J. Dworkin">
     <organization>National Institute of Standards and 
Technology</organization>
     </author>
     <date month="August" year="2015"/>
     </front>
     <seriesInfo name="FIPS" value="PUB 202"/>
     <seriesInfo name="DOI" value="10.6028/nist.fips.202"/>
</reference>
<reference anchor="NIST.SP.800_185" 
target="http://nvlpubs.nist.gov/nistpubs/SpecialPublications/NIST.SP.800-185.pdf">
     <front>
     <title>SHA-3 Derived Functions: cSHAKE, KMAC, TupleHash and 
ParallelHash</title>
     <author initials="J." surname="Kelsey" fullname="John Kelsey">
     <organization>National Institute of Standards and 
Technology</organization>
     </author>
     <author initials="S." surname="Change" fullname="Shu-jen Change">
     <organization>National Institute of Standards and 
Technology</organization>
     </author>
     <author initials="R." surname="Perlner" fullname="Ray Perlner">
     <organization>National Institute of Standards and 
Technology</organization>
     </author>
     <date month="December" year="2016"/>
     </front>
     <seriesInfo name="Special Publication" value="SP 800-185"/>
     <seriesInfo name="DOI" value="10.6028/nist.sp.800-185"/>
</reference>

thanks

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 2 Sep 2019 09:47:07 +0200

> On Sep 2, 2019, at 04:10, Robert Moskowitz <[email-masked]> wrote:
> 

These have DOIs.  So in kramdown-rfc, you could reference these as

{{!NIST.FIPS.202=DOI.10.6028/nist.fips.202}} and {{?NIST.SP.800_185=DOI.10.6028/nist.sp.800-185}} (where ! is for normative and ? is for informative).  You can of course also put these into the YAML prefix.

With stand_alone: yes, kramdown-rfc does the external loading.  With stand_alone: no (i.e., load the references from XML), kramdown-rfc generates this XML for the above input:

In the document subset:

<!ENTITY DOI.10.6028_nist.fips.202 SYSTEM "https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202">
<!ENTITY DOI.10.6028_nist.sp.800-185 SYSTEM "https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.sp.800-185.xml?anchor=NIST.SP.800_185">

In the references section, normative part:
&DOI.10.6028_nist.fips.202;
In the references section, informative part:
&DOI.10.6028_nist.sp.800-185;

In the (no longer so self-explanatory :-) text:
<xref target="NIST.FIPS.202"/> and <xref target="NIST.SP.800_185"/> (where ! is for normative and ? is for informative).  You can of course also put these into the YAML prefix.

Grüße, Carsten

> 
> I went browsing https://xml2rfc.tools.ietf.org/ and did not find much of anything for NIST docs.  (NIST-500?).
> 
> <reference anchor="NIST.FIPS.202" target="http://nvlpubs.nist.gov/nistpubs/FIPS/NIST.FIPS.202.pdf">
>     <front>
>     <title>SHA-3 Standard:  Permutation-Based Hash and Extendable-Output Functions</title>
>     <organization>National Institute of Standards and Technology</organization>
>     </author>
> <reference anchor="NIST.SP.800_185" target="http://nvlpubs.nist.gov/nistpubs/SpecialPublications/NIST.SP.800-185.pdf">
>     <front>
>     <title>SHA-3 Derived Functions: cSHAKE, KMAC, TupleHash and ParallelHash</title>
>     <organization>National Institute of Standards and Technology</organization>
>     </author>
>     <organization>National Institute of Standards and Technology</organization>
>     </author>
>     <organization>National Institute of Standards and Technology</organization>
>     </author>
> _______________________________________________
> xml2rfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/xml2rfc
> 
>

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 07:27:54 -0400

> <xref target="NIST.FIPS.202"/> and <xref target="NIST.SP.800_185"/> (where ! is for normative and ? is for informative).  You can of course also put these into the YAML prefix.

Now I am trying to translate this into what I do in xml for rfcs.

In the body I have:

<xref target="RFC7748">RFC 7748</xref>

And it the reference section:

<?rfc include="reference.RFC.7748.xml"?>

So I guessed:

<xref target="DOI.10.6028_nist.sp.800-185">NIST SP 800-185</xref>

<?doi include="DOI.10.6028_nist.sp.800-185"?>

But that did not work.

I then tried ?rfc rather than ?doi and got the same error:

Error: Unable to parse the XML document: 
draft-moskowitz-hip-new-crypto-00.xml
  draft-moskowitz-hip-new-crypto-00.xml: Line 320: Unable to resolve 
external request: "DOI.10.6028_nist.sp.800-185"

Note that for rfcs and drafts, I do not need any entity includes in the 
document subset..

thanks

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Sep 2019 13:37:10 +0200

On 02.09.2019 13:27, Robert Moskowitz wrote:
>> {{!NIST.FIPS.202=DOI.10.6028/nist.fips.202}} and
>> {{?NIST.SP.800_185=DOI.10.6028/nist.sp.800-185}} (where ! is for
>> normative and ? is for informative).  You can of course also put these
>> into the YAML prefix.
>>
>> With stand_alone: yes, kramdown-rfc does the external loading.  With
>> stand_alone: no (i.e., load the references from XML), kramdown-rfc
>> generates this XML for the above input:
>>
>> In the document subset:
>>
>> <!ENTITY DOI.10.6028_nist.fips.202 SYSTEM
>> "https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202">
>>
>> <!ENTITY DOI.10.6028_nist.sp.800-185 SYSTEM
>> "https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.sp.800-185.xml?anchor=NIST.SP.800_185">
>>
>>
>> <xref target="NIST.FIPS.202"/> and <xref target="NIST.SP.800_185"/>
>> (where ! is for normative and ? is for informative).  You can of
>> course also put these into the YAML prefix.
>>
>>
>
> ...

The *rfc* include directive takes a URI, just see those that Carsten posted.

Best regards, Julian

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 08:05:03 -0400

> The *rfc* include directive takes a URI, just see those that Carsten 

Hmm.  I am missing what the URI is in what Carsten posted.

I tried

reference.DOI.10.6028

Is in

     <?rfc include="reference.DOI.10.6028"?>

But that is not it.

Line 310: Unable to resolve external request: "reference.DOI.10.6028"

With RFCs, I can access the listing by browsing to:

https://xml2rfc.tools.ietf.org/public/rfc/bibxml/

I cannot do that with

https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/

I get "Invalid DOI or type"

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 2 Sep 2019 14:11:02 +0200

Hi Bob,

> anything for NIST docs.  (NIST-500?).

Based on your input below, I've just added (with minor tweaks) these to
the reference library on xml2rfc.tools.ietf.org, in the bibxml2 directory:

	reference.NIST.FIPS.202.xml
	reference.NIST.SP.800-185.xml

Best regards,

	Henrik

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Sep 2019 14:19:43 +0200

> I get "Invalid DOI or type"

<?rfc
include="https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202"?>

<?rfc
include="https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.sp.800-185.xml?anchor=NIST.SP.800_185"?>

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 2 Sep 2019 14:23:05 +0200

> 	reference.NIST.SP.800-185.xml

Give a man a fish…

        <?rfc include="reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202”?>

Note that the text from the “reference. to the ? is the DOI and the text from the ?anchor= to the “ is the anchor name that you use with target= in <xref.
(You get to choose anchor names with DOI and IANA references only, currently.)

Now, of course, the DOI-generated reference could be as broken as the DOI owner wants, but this should help people who want to build RFCs with references outside the IETF (almost all of which now have DOIs) directly from XML.

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 09:05:32 -0400

>> 	reference.NIST.SP.800-185.xml

I like the occasional fish.

Is Henrik's tweak the way for all such references?  Do I need to get a 
new version of xml2rfc for the tweak,

or is Carsten's reply the general way for all such references that have 
a DOI?

>          <?rfc include="reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202”?>

I am getting the errorr:

  <string>: Line 181: IDREF attribute target references an unknown ID 
"NIST.SP.800-185"

With:

<xref target="NIST.SP.800-185">NIST SP 800-185</xref>

     <?rfc 
include="reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185”?>

> Now, of course, the DOI-generated reference could be as broken as the DOI owner wants, but this should help people who want to build RFCs with references outside the IETF (almost all of which now h…

Is there a way to textually see the xml that the DOI owner built?

thanks

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 2 Sep 2019 15:28:52 +0200

Hi Robert,

On 2019-09-02 15:05, Robert Moskowitz wrote:
> Is Henrik's tweak the way for all such references?

Both work.  Carsten's depend on what's in the DOI database, which means that
manually putting a reference in place may give more complete information in
some cases.

> Do I need to get a new version of xml2rfc for the tweak,

Nope, it should be ready to use the same way you use other references
pulled from the xml2rfc.tools.ietf.org reference library.

> or is Carsten's reply the general way for all such references that have 

Carsten's approach is good, and of course immediately available without
manual intervention if a DOI is available.  I think it's to some extent
a matter of preference.

> Is there a way to textually see the xml that the DOI owner built?

This is built from the DOI owner's provided information by a script on the
tools server (written by Tony? or Carsten?):

http://xml2rfc.tools.ietf.org/public/rfc/bibxml-doi/reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202

Best regards,

	Henrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 2 Sep 2019 15:31:25 +0200

> On Sep 2, 2019, at 15:05, Robert Moskowitz <[email-masked]> wrote:
> 
> 
> 
> Is Henrik's tweak the way for all such references?  Do I need to get a new version of xml2rfc for the tweak,

Henrik only gave you those two fish.

> or is Carsten's reply the general way for all such references that have a DOI?
> 
> 

Yes.

(Please fix the closing double quote character smartly auto-broken by my mailer, though.)

> 
> I am getting the errorr:
> 
>  <string>: Line 181: IDREF attribute target references an unknown ID "NIST.SP.800-185"
> 
> With:
> 
>     <?rfc include="reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185”?>

Is that still the double quote character?
I don’t see anything else wrong here.

> Is there a way to textually see the xml that the DOI owner built?

I usually work with JSON:

$ curl -LHAccept:application/citeproc+json http://doi.org/10.6028/NIST.SP.800-185

{“institution":{"name":"National Institute of Standards and Technology","place":["Gaithersburg, MD"],"department":["Information Technology Laboratory"],"acronym":["NIST"]},"indexed":{"date-parts":[[2019,6,22]],"date-time":"2019-06-22T11:03:11Z","timestamp":1561201391547},"publisher-location":"Gaithersburg, MD","reference-count":0,"publisher":"National Institute of Standards and Technology","funder":[{"DOI":"10.13039\/100007764r","name":"Information Technology Laboratory","doi-asserted-by":"publisher","award":[]}],"content-domain":{"domain":[],"crossmark-restriction":false},"DOI":"10.6028\/nist.sp.800-185","type":"report","created":{"date-parts":[[2016,12,22]],"date-time":"2016-12-22T18:52:43Z","timestamp":1482432763000},"source":"Crossref","is-referenced-by-count":4,"title":"SHA-3 derived functions: cSHAKE, KMAC, TupleHash and ParallelHash","prefix":"10.6028","author":[{"given":"John","family":"Kelsey","sequence":"first","affiliation":[]},{"given":"Shu-jen","family":"Change","sequence":"additional","affiliation":[]},{"given":"Ray","family":"Perlner","sequence":"additional","affiliation":[]}],"member":"4068","published-online":{"date-parts":[[2016,12]]},"container-title":[],"original-title":[],"deposited":{"date-parts":[[2018,3,6]],"date-time":"2018-03-06T10:06:39Z","timestamp":1520330799000},"score":1.0,"subtitle":[],"short-title":[],"issued":{"date-parts":[[2016,12]]},"references-count":0,"URL":"http:\/\/dx.doi.org\/10.6028\/NIST.SP.800-185","relation":{}}

or use some JSON pretty printer such as jq with that:

$ curl -LHAccept:application/citeproc+json http://doi.org/10.6028/NIST.SP.800-185 | jq

{
  "institution": {
    "name": "National Institute of Standards and Technology",
    "place": [
      "Gaithersburg, MD"
    ],
    "department": [
      "Information Technology Laboratory"
    ],
    "acronym": [
      "NIST"
    ]
  },
  "indexed": {
    "date-parts": [
      [
        2019,
        6,
        22
      ]
    ],
    "date-time": "2019-06-22T11:03:11Z",
    "timestamp": 1561201391547
  },
  "publisher-location": "Gaithersburg, MD",
  "reference-count": 0,
  "publisher": "National Institute of Standards and Technology",
  "funder": [
    {
      "DOI": "10.13039/100007764r",
      "name": "Information Technology Laboratory",
      "doi-asserted-by": "publisher",
      "award": []
    }
  ],
  "content-domain": {
    "domain": [],
    "crossmark-restriction": false
  },
  "DOI": "10.6028/nist.sp.800-185",
  "type": "report",
  "created": {
    "date-parts": [
      [
        2016,
        12,
        22
      ]
    ],
    "date-time": "2016-12-22T18:52:43Z",
    "timestamp": 1482432763000
  },
  "source": "Crossref",
  "is-referenced-by-count": 4,
  "title": "SHA-3 derived functions: cSHAKE, KMAC, TupleHash and ParallelHash",
  "prefix": "10.6028",
  "author": [
    {
      "given": "John",
      "family": "Kelsey",
      "sequence": "first",
      "affiliation": []
    },
    {
      "given": "Shu-jen",
      "family": "Change",
      "sequence": "additional",
      "affiliation": []
    },
    {
      "given": "Ray",
      "family": "Perlner",
      "sequence": "additional",
      "affiliation": []
    }
  ],
  "member": "4068",
  "published-online": {
    "date-parts": [
      [
        2016,
        12
      ]
    ]
  },
  "container-title": [],
  "original-title": [],
  "deposited": {
    "date-parts": [
      [
        2018,
        3,
        6
      ]
    ],
    "date-time": "2018-03-06T10:06:39Z",
    "timestamp": 1520330799000
  },
  "score": 1,
  "subtitle": [],
  "short-title": [],
  "issued": {
    "date-parts": [
      [
        2016,
        12
      ]
    ]
  },
  "references-count": 0,
  "URL": "http://dx.doi.org/10.6028/NIST.SP.800-185",
  "relation": {}
}

You can see the bibxml that the doilit tool generates from that:

$ doilit -x=NIST.SP.800-185 10.6028/NIST.SP.800-185
<reference anchor=“NIST.SP.800-185" >
  <front>
    <title>SHA-3 derived functions: cSHAKE, KMAC, TupleHash and ParallelHash</title>
    <author initials="J." surname="Kelsey" fullname="John Kelsey">
      <organization></organization>
    </author>
    <author initials="S." surname="Change" fullname="Shu-jen Change">
      <organization></organization>
    </author>
    <author initials="R." surname="Perlner" fullname="Ray Perlner">
      <organization></organization>
    </author>
    <date year="2016" month="December"/>
  </front>
  <seriesInfo name="National Institute of Standards and Technology" value="report"/>
  <seriesInfo name="DOI" value="10.6028/nist.sp.800-185"/>
</reference>

(Assuming you have installed kramdown-rfc, whose doilit tool the bibxml web service uses.)
Or right from the bibxml web service:

$ curl https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/nist.sp.800-185.xml?anchor=NIST.SP.800-185
<reference anchor=‘NIST.SP.800-185' >
  <front>
    <title>SHA-3 derived functions: cSHAKE, KMAC, TupleHash and ParallelHash</title>
    <author initials="J." surname="Kelsey" fullname="John Kelsey">
      <organization></organization>
    </author>
    <author initials="S." surname="Change" fullname="Shu-jen Change">
      <organization></organization>
    </author>
    <author initials="R." surname="Perlner" fullname="Ray Perlner">
      <organization></organization>
    </author>
    <date year="2016" month="December"/>
  </front>
  <seriesInfo name="National Institute of Standards and Technology" value="report"/>
  <seriesInfo name="DOI" value="10.6028/nist.sp.800-185"/>
</reference>

(You can look at that URL in the browser, too, but many browsers need a “view source” here.)

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 10:44:12 -0400

> I don’t see anything else wrong here.

The way I am reading the error (compared to my earlier errors), the 
problem is with the anchor=

It does not like my xref target, and I can't see the difference. Both 
say NIST.SP.800-185

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Sep 2019 17:00:39 +0200

On 02.09.2019 15:05, Robert Moskowitz wrote:
>> include="reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202”?>
>
> I am getting the errorr:
>

You might need a new version of xml2rfc (I believe there was a problem
with the cache not using the query parm in the key).

Or try:

   xml2rfc --clear-cache

Best regards, Julian

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 11:29:58 -0400

> with the cache not using the query parm in the key).

I am running the current version

$ xml2rfc --version
xml2rfc 2.25.0

and

$ xml2rfc --clear-cache
$ xml2rfc draft-moskowitz-hip-new-crypto-00.xml
Error: Unable to validate the XML document: 
draft-moskowitz-hip-new-crypto-00.xml
  <string>: Line 181: IDREF attribute target references an unknown ID 
"NIST.SP.800-185"

Now what to try?

Perhaps I need to be using python3?  :)

I was told on the Fedora list to run

python3 -m pip install --user xml2rfc

Should I?

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 2 Sep 2019 17:34:06 +0200

Send XML.

Grüße, Carsten

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 11:53:18 -0400

> Grüße, Carsten
Here it is.

It is still very drafty on content,,,

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Sep 2019 18:41:59 +0200

rfc2629.xslt reports:

> WARNING: unmatched quote in: reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185▒ (at line 307)

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 2 Sep 2019 19:02:05 +0200

Yes, there is a double quote problem in the line:

Sorry about that.  If I fix that to

	<?rfc include="reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185"?>

I get the next error:

 draft-moskowitz-hip-new-crypto-00.xml: Line 311: Unable to resolve external request: "reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185"

Which is weird because I can resolve

$ curl https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185

(And, also,         
<?rfc include="reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202"?>
works.)

There must be something broken with the PI style of referencing in xml2rfc that works with the Entity style (which is the only one I use now and then).

Henrik: Any idea?  Any sensitivity of the code that adds bibxml7?

Grüße, Carsten

> On Sep 2, 2019, at 17:53, Robert Moskowitz <[email-masked]> wrote:
> 
> 
> 
> <draft-moskowitz-hip-new-crypto-00.xml>

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Sep 2019 19:06:00 +0200

> Henrik: Any idea?  Any sensitivity of the code that adds bibxml7?

Using the full URI should work...

Best regards, Julian

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 14:57:22 -0400

> Sorry about that.  If I fix that to

ARGH!!!  I hate that. I have trouble see the difference, some cut and 
paste did me in...

>   draft-moskowitz-hip-new-crypto-00.xml: Line 311: Unable to resolve external request: "reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185"

Yes, why once " is fixed do we get this error.

> Henrik: Any idea?  Any sensitivity of the code that adds bibxml7?

Weird.   I am heading for the airport (been visiting family in Virginia 
Beach), don't know how much more I will get done today.

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 14:57:58 -0400

On 9/2/19 1:06 PM, Julian Reschke wrote:
>> include="reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185"?>
>>
>> I get the next error:
>>
>>   draft-moskowitz-hip-new-crypto-00.xml: Line 311: Unable to resolve 
>> external request: 
>> "reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185"
>>
>> $ curl 
>> https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185
>>
>> (And, also,
>> <?rfc 
>> include="reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202"?>
>> works.)
>>
>> There must be something broken with the PI style of referencing in 
>> xml2rfc that works with the Entity style (which is the only one I use 
>> now and then).
>>

And should not be required.

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Sep 2019 21:32:17 +0200

> And should not be required.

I have to disagree with that. These are heuristics in URI resolution. Do
not rely on it. If you know the URI, use it. If only to avoid
unnecessary round trips.

Best regards, Julian

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 2 Sep 2019 16:09:28 -0400

> $ curl https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185

     <?rfc 
include="https://xml2rfc.tools.ietf.org/public/rfc/bibxml7/reference.DOI.10.6028/NIST.SP.800-185.xml?anchor=NIST.SP.800-185"?>

Works, but IMHO, the full URI should not be needed.

<?rfc 

Did not work for me:

Error: Unable to parse the XML document: 
draft-moskowitz-hip-new-crypto-00.xml
  draft-moskowitz-hip-new-crypto-00.xml: Line 346: Unable to resolve 
external request: 
"reference.DOI.10.6028/nist.fips.202.xml?anchor=NIST.FIPS.202"