Subject: AgentX Charter/Milestone Update

From: [email-masked]
Date: 18 Apr 2001 11:54:23 -0700

Hi,

The items/dates below are what I recommend we submit to the IESG and IETF Secretariat for our current work-plan.  Please post any suggested revisions or comments by the end of the day this coming Friday (4/20).  I will then submit this update (as may be revised via the list) and will post the implementation report format to the list on Monday (4/23).

Apr 01 - Implementation reports formally solicited (Apr 23)
Apr 01 - Interoperability reports formally solicited (Apr 30)
May 01 - Implmentation and interoperability reports summarized
         (by WG Chair) and assessed via WG e-mail discussion (May 31)
Jun 01 - All open issues resolved (Jun 30)
Jul 01 - Modifications (if any) to documents (RFC2741 and RFC2742) completed (Jul 15)
Jul 01 - Decision to advance or recycle made by WG and handed off to IESG for action (Jul 31)
Aug 01 - Shutdown WG or re-charter 

Cordially,

BobN
WG Chair

---

From: Wes Hardaker <[email-masked]>
Date: 18 Apr 2001 15:20:55 -0700

>>>>> On 18 Apr 2001 11:54:23 -0700, [email-masked] said:

bob> Jun 01 - All open issues resolved (Jun 30)

There might be a few issues that need to be thought about and
discarded or acted upon.  Specifically, it is not possible to
implement certain MIBs inside a strict AgentX subagent implementation.
Examples are the DISMAN-EVENT-MIB (needs access to authentication
information and bi-directional requests) and the SNMPCONF-PM-MIB (has
(will have) a "capabilities" table which is similar in nature to the
sysORTable (but different, of course) and no way of registering
entries to it easily via agentx, unless they change their indexing to
avoid illegal information duplications [which I've requested to them
that they do]).

Makes me think that we should either support another set of protocol
operations, or leave room for extensibility in some way that can be
defined by future specification documents that want to mention how to
implement "something" otherwise impossible under the AgentX protocol.

-- 
"Ninjas aren't dangerous.  They're more afraid of you than you are of them."

---

From: Bob Natale <[email-masked]>
Date: Thu, 19 Apr 2001 03:02:28 -0400

At 4/18/2001:06:20 PM, Wes Hardaker wrote:

Hi Wes,

>discarded or acted upon.

Agreed..."resolved" was not meant to imply any particular
outcome -- hopefully all of them will be thought about,
some may result in modifications to the specs (if any of
those mods are significant/substantial, we might have to
recycle as a result), some may be discarded (WG consensus
is that they are not relevant to or acceptable for AgentX),
and some might be tabled for consideration as part of a
re-chartering of the WG, etc.

>Specifically, it is not possible to implement certain MIBs inside
>a strict AgentX subagent implementation.

The stated goals for the protocol acknowledged this.  The
existing RFCs and their corresponding implementations should
be assessed for advancement, at this time, on the basis of
their pre-existing requirements and objectives.

>avoid illegal information duplications [which I've requested to them

Understood.  The authentication issues *should* be
resolvable within the existing AgentX context, I believe.
For some of the others, it may be best (in certain cases)
if MIB designers think in terms of AgentX at the outset
and, for some, it may be that only a new set of goals
for a re-chartered AgentX WG will suffice.

>implement "something" otherwise impossible under the AgentX protocol.

Ok...sounds like proposed new work for the re-chartering
discussion.

Thanks,

BobN

---

From: Dave Shield <[email-masked]>
Date: Thu, 19 Apr 2001 11:30:19 +0100

> Apr 01 - Interoperability reports formally solicited (Apr 30)

I presume these will include details of the appropriate formats
as promised in the advance notice earlier this month ?

Dave

---

From: Bob Natale <[email-masked]>
Date: Fri, 20 Apr 2001 01:13:26 -0400

At 4/19/2001:06:30 AM, Dave Shield wrote:

Hi Dave,

>as promised in the advance notice earlier this month ?

Precisely.

Cheers,

BobN