Subject: Fwd: Timeout during a commit-set operation

From: Randy Presuhn <[email-masked]>
Date: Thu, 5 Apr 2001 12:01:02 -0700 (PDT)

Hi -

I'm forwarding a posting to the agentx mailing list.
I've added this subscriber's alternate address to the
agentx "posters" list.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

|Received: from babbler.bmc.com (babbler.bmc.com [172.17.0.116])
|	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id FAA17096
|	for <[email-masked]>; Thu, 5 Apr 2001 05:36:08 -0700 (PDT)
|Received: from fw-us-hou-9.bmc.com (localhost [127.0.0.1])
|	by babbler.bmc.com (8.10.2/8.10.2) with SMTP id f35Cdvj07621
|	for <[email-masked]>; Thu, 5 Apr 2001 07:39:57 -0500 (CDT)
|Received: from netmail2.alcatel.com ([128.251.168.51]) by fw-us-hou-9.bmc.com; Thu, 05 Apr 2001 07:37:06 +0000 (CST)
|Received: from postal.adn.alcatel.com (workstation.alcatel.com [198.205.33.79] (may be forged))
|	by netmail2.alcatel.com (8.9.1/8.9.1) with ESMTP id HAA15354
|	for <[email-masked]>; Thu, 5 Apr 2001 07:35:50 -0500 (CDT)
|Received: from usa.alcatel.com ([198.205.41.133]) by postal.adn.alcatel.com
|          (Netscape Messaging Server 3.6)  with ESMTP id AAA3F16;
|          Thu, 5 Apr 2001 08:48:31 -0400
|Sender: [email-masked]
|Message-ID: <[email-masked]>
|Date: Thu, 05 Apr 2001 08:32:32 -0400
|From: Ken Andrews <[email-masked]>
|Organization: Alcatel
|X-Mailer: Mozilla 4.61 [en] (X11; U; SunOS 5.7 sun4u)
|X-Accept-Language: en
|MIME-Version: 1.0
|To: AgentX <[email-masked]>
|Subject: Timeout during a commit-set operation
|Content-Type: text/plain; charset=us-ascii
|Content-Transfer-Encoding: 7bit
|
|Hello,
|
|We are implementing a core router using agentX to connect a SNMPv3
|Master Agent with 20 or so sub-agents.
|
|One of the situations that I'm seeing is occasionally one of the 
|sub-agents fails to respond to a commit-set.  After its timeout 
|period the Master Agent sends the SNMP manager a get response with
|an error code 15 (Undo Failed) and sends the sub-agent a cleanup.
|
|RFC 2741 sec 7.2.5.1 states that the action of a master agent on
|a timeout is implementation specific but I think that in the case
|of a commit failure it needs to be more clear.
|
|As far as I can tell the best thing to do is to send the cleanup
|and hope that the sub-agent can deal with it.
|
|regards,
|Ken
|
|-- 
|Ken Andrews [email-masked]
|New Office #  703-679-6476
|New Fax #     703-679-6450
|We all ride the same road
|

---

From: "Ayers, Mike" <[email-masked]>
Date: Thu, 5 Apr 2001 14:13:57 -0500

> |an error code 15 (Undo Failed) and sends the sub-agent a cleanup.

	I don't think that this is correct.  According to 7.2.5.1, the
return code should be genErr due to the timeout.  Next, 7.2.5.5 states that
the master should sent an agentx-UndoSet-PDU to any subagent which has been
sent an agentx-CommitSet-PDU, which would include the timed out subagent.

> |of a commit failure it needs to be more clear.

	That implementation specific behavior, I believe, generally refers
to whether or not the master agent will terminate the AgentX session due to
a timeout.  While it is required to terminate a session after three
consecutive timeouts, the master may choose to do so after only one timeout.

> |and hope that the sub-agent can deal with it.

	Agreed - provided you mean "send the undo".

/|/|ike