Subject: Fwd: Re: AgentX implementation reports requested

From: Randy Presuhn <[email-masked]>
Date: Mon, 14 May 2001 09:25:18 -0700 (PDT)

Hi -

I'm forwarding a non-subscriber post to the agentx list.
I've added [email-masked] to the "posters" list.

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.

 -------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id MAA06067
> 	for <[email-masked]>; Fri, 11 May 2001 12:40:53 -0700 (PDT)
> Received: from fw-us-hou-9.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with SMTP id f4BJfnZ03000
> 	for <[email-masked]>; Fri, 11 May 2001 14:41:49 -0500 (CDT)
> Received: from milu.ipn.pt ([194.79.82.125]) by fw-us-hou-9.bmc.com; Fri, 11 May 2001 14:42:01 +0000 (CST)
> Received: from ipn.pt ([195.23.8.89])
> 	by milu.ipn.pt (8.9.3/8.9.3) with ESMTP id UAA17324;
> 	Fri, 11 May 2001 20:49:13 +0100 (PST)
> Message-ID: <[email-masked]>
> Date: Fri, 11 May 2001 20:51:30 +0100
> From: Pedro Pereira <[email-masked]>
> Organization: WIT-Software
> X-Mailer: Mozilla 4.5 [en] (WinNT; I)
> X-Accept-Language: en
> MIME-Version: 1.0
> To: [email-masked]
> CC: [email-masked]
> Subject: Re: AgentX implementation reports requested
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 
>                             AgentX Implementation Report
> 
> Report date:          May 11,
> 2001_______________________________________
> 
> Submitted by:         Pedro Pereira_____________________________________
> 
> Organization:         University of Coimbra_____________________________
> 
> E-mail address:       [email-masked] _________________________________ 
> 
> Implementation name:  J.AgentX _________________________________________
> 
> Implementation type:  _X_ Master and/or _X_ Sub-Agent and/or _X_ Toolkit
> 
> Runtime platform(s):  Any platform supporting Java 1.2 or later ________
> 
> Reported version id:  1.0 ______________________________________________
> 
> If Master Agent, did you implement:
> 
> SNMPv1 support in master agent:   _X_ Yes  ___ No
>    Comments:
> 
> SNMPv2c support in master agent:  ___ Yes  _X_ No
>    Comments:
> 
> SNMPv3 support in master agent:   ___ Yes  _X_ No
>    Comments:
> 
> If Sub-Agent, what MIB(s) did you implement: JamesMIB
>    Comments: The Master Agent also supports MIB-II.system, MIB-II.snmp
> and MIB-II.agentx
>    (Please identify each specific MIB.)
> 
> If Toolkit, please identify:
> 
> Development languages supported: Java 1.2 or later
>    Comments:
> 
> Development platforms supported: Any platform supporting Java 1.2 or
> later
>    Comments: 
> 
> Runtime platforms supported: Any platform supporting Java 1.2 or later
>    Comments: Functional tests were performed in Linux ReadHat 6.0
> (i386), 
> Win9x, WinNT, Win2000 and Sun Solaris 2.6 (sparc)
> 
> For all implementations:  Did you implement the following PDU types:
> 
> agentx-Open-PDU:             _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Close-PDU:            _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Register-PDU:         _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Unregister-PDU:       _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Get-PDU:              _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-GetNext-PDU:          _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-GetBulk-PDU:          ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> agentx-TestSet-PDU:          _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Commit-PDU:           _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Set-PDU:              _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-UndoSet-PDU:          _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-CleanupSet-PDU:       _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Notify-PDU:           _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Ping-PDU:             _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> agentx-IndexAllocate-PDU:    ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> agentx-IndexDeallocate-PDU:  ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> agentx-AddAgentCaps-PDU:     ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> agentx-RemoveAgentCaps-PDU:  ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> agentx-Response-PDU:         _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> Does this implementation have interoperability experience with at least
> one
> other independent implementation with respect to:
> 
> Registration operations:         _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> Registration priorities:         _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> Index allocation operations:     ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> Index deallocation operations:   ___ Yes  _X_ No, but plan to within ___
> months
>    Comments:
> 
> Multiple sub-agent connections:  _X_ Yes  ___ No, but plan to within ___
> months
>    Comments:
> 
> Connecting sub-agent(s) to multiple master agents:  ___ Yes  _X_ No, but
> plan to within ___ months
>    Comments:
> 
> Detecting loss of connection of sub-agent(s):       ___ Yes  _X_ No, but
> plan to within ___ months
>    Comments:
> 
> Detecting loss of connection with master agent(s):  ___ Yes  _X_ No, but
> plan to within ___ months
>    Comments:
> 
> What transport mappings did you implement:
> 
> TCP/IP on port 705:                           _X_ Yes  ___ No, but plan
> to within ___ months
>    Comments:
> 
> UNIX Domain Sockets on "/var/agentx/master":  ___ Yes  _X_ No, but plan
> to within ___ months
>    Comments:
> 
> UNIX Domain Sockets on other endpoints:       ___ Yes  _X_ No, but plan
> to within ___ months
>    Comments:
> 
> Other(s): UPD, JavaSpaces                     _X_ Yes  ___ No, but plan
> to within ___ months
>    Comments: We support UDP, although a connectionless protocol, because
> we find it usefull in 
> situations where using TCP can be awkward. JavaSpaces is also supported
> for integration with Mobile Agents. Notice that our Master Agent can
> support simultaneas SubAgents using different communication protocols.  
> 
> Did you implement the AgentX MIB (RFC2742):   _X_ Yes  ___ No, but plan
> to within ___ months
>    Comments:
> 
> Did you satisfy the agentxMIBCompliance
>            MODULE-COMPLIANCE requirements::   _X_ Yes  ___ No, but plan
> to within ___ months
>    Comments:
> 
> Did you implement the MIB as an integral part of the master agent:  _X_
> Yes ___ No
>    Comments: Considering "the MIB" as the "AgentX MIB"
> 
> Did you implement the MIB in an AgentX sub-agent:                   ___
> Yes _X_ No
>    Comments: I don't think it makes much sense implementing the AgentX
> MIB in a SubAgent.
> 
> Please record any other comments or notes you deem useful for the
> record:
>    Comments: The J.AgentX project is a public Java based implementation
> of the AgentX protocol.
> It's a rather simple and powerful implementation, comprising a Master
> Agent and Subagent API. 
> Source code and documentation are available at the J.AgentX home page:
> http://www.dei.uc.pt/agentx
> Any questions please submit to [email-masked]
>

---

From: "Ayers, Mike" <[email-masked]>
Date: Wed, 30 May 2001 12:19:37 -0500

With apologies for lateness...

Report date:          ____25May01_______________________________________

Submitted by:         ____Mike_Ayers____________________________________

Organization:         ____BMC_Software__________________________________

E-mail address:       [email-masked] 

Implementation name:  ____SNMP_Library__________________________________

Runtime platform(s):  ____Windows_NT/2K,_HPUX,_AIX,_Solaris,____________
                      ________Compaq_TRU-64_Unix(formerly_OSF/1)________

Reported version id:  ____3.3___________________________________________

SNMPv3 support in master agent:   ___ Yes  _X_ No
   Comments:  Will be supported in next release

If Sub-Agent, what MIB(s) did you implement: only sample MIBs were
implemented as separate subagents.  Master agent is implemented with a
monolithic subagent which
   Comments:
   (Please identify each specific MIB.)

Development languages supported:  C, C++
   Comments:

Development platforms supported:  Windows NT/2K, HPUX, AIX, Solaris, TRU-64
   Comments:

Runtime platforms supported:  Windows NT/2K, HPUX, AIX, Solaris, TRU-64
   Comments:

agentx-Open-PDU:             _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Close-PDU:            _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Register-PDU:         _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Unregister-PDU:       _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Get-PDU:              _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-GetNext-PDU:          _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-GetBulk-PDU:          _X_ Yes  ___ No, but plan to within ___ months
   Comments:  Not tested

agentx-TestSet-PDU:          _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Commit-PDU:           _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Set-PDU:              _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-UndoSet-PDU:          _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-CleanupSet-PDU:       _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Notify-PDU:           _X_ Yes  ___ No, but plan to within ___ months
   Comments:

agentx-Ping-PDU:             _X_ Yes  ___ No, but plan to within ___ months
   Comments:  Not tested

agentx-IndexAllocate-PDU:    ___ Yes  _X_ No, but plan to within _?_ months
   Comments:

agentx-IndexDeallocate-PDU:  ___ Yes  _X_ No, but plan to within _?_ months
   Comments:

agentx-AddAgentCaps-PDU:     ___ Yes  _X_ No, but plan to within _?_ months
   Comments:

agentx-RemoveAgentCaps-PDU:  ___ Yes  _X_ No, but plan to within _?_ months
   Comments:

agentx-Response-PDU:         _X_ Yes  ___ No, but plan to within ___ months
   Comments:

Does this implementation have interoperability experience with at least one
other independent implementation with respect to:

Index allocation operations:     ___ Yes  _X_ No, but plan to within _?_
months
   Comments:

Index deallocation operations:   ___ Yes  _X_ No, but plan to within _?_
months
   Comments:

Connecting sub-agent(s) to multiple master agents:  _X_ Yes  ___ No, but
plan to within ___ months
   Comments:

Detecting loss of connection of sub-agent(s):       _X_ Yes  ___ No, but
plan to within ___ months
   Comments:

Detecting loss of connection with master agent(s):  ___ Yes  _X_ No, but
plan to within _3_ months
   Comments:

TCP/IP on port 705:                           _X_ Yes  ___ No, but plan to
within ___ months
   Comments:

UNIX Domain Sockets on "/var/agentx/master":  _X_ Yes  ___ No, but plan to
within ___ months
   Comments:

UNIX Domain Sockets on other endpoints:       _X_ Yes  ___ No, but plan to
within ___ months
   Comments:

Other(s):                                     _X_ Yes  ___ No, but plan to
within ___ months
   Comments: TCP connections on any port
   (Please indicate at least type(s) and connection specifics.)

Did you implement the AgentX MIB (RFC2742):   ___ Yes  _X_ No, but plan to
within ___ months
   Comments:

Did you satisfy the agentxMIBCompliance
           MODULE-COMPLIANCE requirements::   ___ Yes  _X_ No, but plan to
within ___ months
   Comments: No MIB

Did you implement the MIB as an integral part of the master agent:  _X_ Yes
___ No
   Comments: No MIB

Did you implement the MIB in an AgentX sub-agent:                   _X_ Yes
___ No
   Comments: No MIB

Please record any other comments or notes you deem useful for the record:
   Comments:

---

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Thu, 31 May 2001 08:50:06 -0400

Hi Mike,

> 	With apologies for lateness...

Thanks for the report.

For the record, after receiving the main batch of
implementation reports (including several off-list),
there were two known implementations who had not
reported.  I contacted both orgs directly to ask
whether they intended to submit a report because
I did not want to proceed w/o them only to receive
them after the summary was produced.  One of the
orgs informed me that they did not intend to submit
an implementation report...with that, Mike's report
wraps up the set of implementations I am aware of,
so I will proceed with the next step(s) now and will
publish the draft summary implementation report to
the WG for review over the coming weekend.

Thanks,

BobN