Subject: Timeout during COMMIT SET phase?

From: [email-masked] (Frank Fock)
Date: Thu, 19 Jul 2001 09:14:57 +0200

Hi,

As far as I know, the AgentX protocol does not define
behavior of the master/subagent when a timeout occurs
during the COMMIT phase of a SET request.

It is my understanding that the master answers the SNMP
SET request with a "general error" when it detects that
the subagent does not respond within the corresponding
session/region timeout. But then the subagent will never
enter the CLEANUP phase for that request. That is a
problem because the subagent may have locked the MIB
object for concurrent access and may also have allocated
some resources.

Should the master send a CLEANUP PDU even if
the subagent timed out?

Or should  the subagent detect that the master agent
timed out the SET request and start its CLEANUP phase
independently?

Thanks for any clarification,
Frank Fock

---

From: "Holstein, Bert" <[email-masked]>
Date: Thu, 19 Jul 2001 11:25:47 +0200

Hi,

If the master should send anything at all (I think
it should), then it seems to me that the RFC wants it
to be an agentx-UndoSet-PDU (instead of the mentioned
agentx-CleanupSet-PDU).
Reading rfc 2741, especially section 7.2.5.5., having the 
master send an SNMP response PDU's error set to genErr
would also be my choice. However... some clarification
is welcomed indeed.

Bert Holstein

> -----Original Message-----
> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Thursday, July 19, 2001 9:15 AM
> To:	[email-masked]'
> Subject:	Timeout during COMMIT SET phase?
> 
> Hi,
>