Subject: Fwd:hi, this is vishnu from india about agentx

From: Randy Presuhn <[email-masked]>
Date: Tue, 16 Oct 2001 08:45:49 -0700 (PDT)

Hi -

I'm forwarding a non-subscriber posting to the AgentX
mailing list.  Subscription instructions are available at
http://www.ietf.org/html.charters/agentx-charter.html

 ------------------------------------------------------
 Randy Presuhn          BMC Software, Inc.  1-3141
 [email-masked]  2141 North First Street
 Tel: +1 408 546-1006   San José, California 95131  USA
 ------------------------------------------------------
 My opinions and BMC's are independent variables.
 ------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id HAA28955
> 	for <[email-masked]>; Tue, 16 Oct 2001 07:16:08 -0700 (PDT)
> Received: from mx-us-hou-1-int.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with ESMTP id f9GEFeB08654
> 	for <[email-masked]>; Tue, 16 Oct 2001 09:15:40 -0500 (CDT)
> Received: from hotmail.com (unknown [64.4.21.173])
> 	by mx-us-hou-1-int.bmc.com (Postfix) with SMTP id 4534820F01A
> 	for <[email-masked]>; Tue, 16 Oct 2001 09:09:11 -0500 (CDT)
> Received: from mail pickup service by hotmail.com with Microsoft SMTPSVC;
> 	 Tue, 16 Oct 2001 07:17:22 -0700
> Received: from 203.195.146.249 by lw14fd.law14.hotmail.msn.com with HTTP;
> 	Tue, 16 Oct 2001 14:17:21 GMT
> X-Originating-IP: [203.195.146.249]
> From: "vishnu varma chiluvuri" <[email-masked]>
> To: [email-masked]
> Subject: hi, this is vishnu from india about agentx
> Date: Tue, 16 Oct 2001 14:17:21 +0000
> Mime-Version: 1.0
> Content-Type: text/plain; format=flowed
> Message-ID: <[email-masked]>
> X-OriginalArrivalTime: 16 Oct 2001 14:17:22.0062 (UTC) FILETIME=[45717AE0:01C1564D]
> 
> hi Mr dorothy,
> 
> i am vishnu from india. i am working on snmp agentx protocol.i have one 
> question. plese give some infomation on this. In router generaly there are 
> the cards of same type having separate processor on each card. cards are 
> absolutely same but we do not know how many cards will be there in each 
> router. because no of cards vary depends on the user requirements. when 
> developing the subagent we make subagent for the card. but we never see 
> interms of no of cards becuase this no will change. can we use same subagent 
> software for any new card we are adding ?
> 
> how mibs will be regiesterd? i want to eliminate the contexts usage. how to 
> design a mib so that any no of cards can share that mib by registering the 
> mib. plese provide some inofmaion on this. i will wait for your reply. 
> thanking you.
> 
> with regards
> vishnu
> 
> _________________________________________________________________
> Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
> 
>

---

From: Randy Presuhn <[email-masked]>
Date: Tue, 16 Oct 2001 10:13:17 -0700 (PDT)

Hi -

> Message-ID: <[email-masked]>
...
> software for any new card we are adding ?

Probably.  This is a fairly common use of subagent technology.

> mib. plese provide some inofmaion on this. i will wait for your reply. 
...

The indexing structure of the mibs will provide the answer.
If there are "scalar" objects in the MIBs, and you need to
support multiple indexes, you're stuck with multiple contexts.
Otherwise, each card would just register the table regions
corresponding to its interfaces or whatever.  If the mib's
index structure is not sufficient to uniquely identify each
instance that has to be managed, you're have to fall back
on multiple contexts.