Subject: RE: AgentX Implementation Report from iReasoning Networks

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Thu, 12 Dec 2002 10:44:57 -0500

Hi Robin,

Thank you very much for submitting your
AgentX implementation report.  I see that
Dave has maintained his customary level
of exemplary responsiveness and has already
posted the report on the AgentX web site:

   www.scguild.com/agentx/

Yours is the 14th AgentX implementation
report submitted to the WG (including 3
anonymous reports, but excluding some
known commercial implementations for
which reports were not submitted).

I will update the summary report to
reflect your report content in the next
several days and ask Dave to post it on
the web site.

Cheers,

BobN

> -----Original Message-----
> From: ireasoning info [mailto:[email-masked]]
> Sent: Wednesday, December 11, 2002 10:48 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: AgentX Implementation Report from iReasoning Networks
> 
> 
> Hi Bob,
> 
> Here is the AgentX Implementation Report from iReasoning 
> Networks. Please review it and post it on
> Agentx Working Group homepage. Thanks!
> 
> Best Regards,
> 
> Robin Lin
> iReasoning Networks
> http://www.ireasoning.com
>

---

From: [email-masked] (Frank Fock)
Date: Fri, 13 Dec 2002 00:02:01 +0100

Hi Bob,

Reading your email I rembered that I tried
some time ago to get the info about AgentX++
updated on www.scguild.com/agentx/

May be my email got lost... ;-(

Anyway, could you please update the text with:

Contact: [email-masked]
URL: http://www.agentpp.com
Status: 

  * C++ API based on AGENT++/SNMP++ that
    supports AgentX master and subagents.

  * Supports SNMPv1/v2c/v3 and at least the
    following operating systems:
    Solaris 7/8, HPUX 11, Cygwin, Linux,
    Windows NT/2000/XP

  * Free for non-commercial use. Source code.

  * AgentX++ implements all features of the AgentX
    protocol, including but not limited to the following:

    - UNIX domain socket connections on UNIX systems
    - TCP connections on UNIX and Windows NT
    - Non-default contexts
    - Shared tables, including INDEX allocation
    - Uses AgentX GETBULK
    - AgentX request timeout handling
    - AgentX MIB
    - Atomic SET requests across multiple subagents
    - Seamless adding and dropping of connections and sessions

  * AgenPro a powerful fully customizable code generator with
    open source code generation backend and round-trip engineering
    support is also available with code generation templates for
    AgentX++.

  * Existing AGENT++ agents may be migrated to
    an AgentX master or subagent without changing
    the management instrumentation.

  Any comments, suggestions, and bug reports are
  highly appreciated.

--

Many thanks,
Frank

P.S.: Are my observations right, that the interest in
AgentX has strongly grown within the past six months?

---

From: David Keeney <[email-masked]>
Date: Thu, 12 Dec 2002 21:22:03 -0500

Frank,   I updated your listing on the AgentX website as you requested.

www.scguild.com/agentx/

Does anyone else have updates?

David Keeney
Software Contractors' Guild
http://www.scguild.com
===================================
At 12:02 AM 12/13/2002 +0100, you wrote:
>>>Here is the AgentX Implementation Report from iReasoning Networks. 
>>>Please review it and post it on