Subject: [conex] draft agenda posted

From: marcelo bagnulo braun <[email-masked]>
Date: Tue, 08 Nov 2011 22:45:58 +0100

see it at:

http://www.ietf.org/proceedings/82/agenda/conex.txt

regards, marcelo

---

From: <[email-masked]>
Date: Wed, 9 Nov 2011 09:11:41 +0000

http://tools.ietf.org/id/draft-briscoe-conex-initial-deploy-00.txt 

Bob,
thanks for the draft, think it's important to have started this. some comments.

I think you could start at S4. the earlier sections stop the reader getting rapidly to the main bit of the doc.

You start by saying that the initial step is a ledbat source is conex enabled; the second step is the network becomes conex-enabled. personally i wouldn't call this "unilateral deploymet by a single network" (scope of draft in S1). Talk of this ledbat-conex source somewhat disappears later on. if this is the deployment path, it also raises the question of what's the deployment incentive for ledbat, is this clear-cut?

I attempted to re-draw figure 1, see below, see if you think it's clearer.

I think it would be clearer if the conex-ISP just ran the network - dividing into core and access seems unnecessary detail [at least until the basic deployment scenario is clear]

I think the initial deployment step is where the ISP runs the network & a data centre - the DC has conex-enabled conex sources (which are trusted about their conex markings, since they're under ISP's control). you need to mention how other traffic is handled. a step beyond the initial one is where other senders are conex-enabled, but not trusted (i wouldn't include them on fig 1) - only at that stage might ledbat become relevant.

I think the scenario is that the DC-ISP offers a premium service to content providers, which internally it implements using conex.

anyway, i think the WG should decide whether the initial deployment case is via ledbat or a conex-core also running a DC. or via mobile network or internal to data centre.

thanks,
phil

----
                      <----     Single ISP operates    ----> 
                       data centre & core & access networks
                               all are ConEx-enabled

                                      _________      _______      ____
                                     | CORE    |    |ACCESS |    |HOME|
                                     | NETWORK      |NETWORK|    |NET |
                       _________     |         |    |       |    |    |
                      | ISP's   |    |         |    |       |    |    |
                      | data    |    |         |    |       |    |    |
                      | centre  |    |         |    |       |    |    |
                      |         |    |         |    |       |    |    |
                      | +-------+    +-------+ |    |       |    |    |
                      | |trusted|    | ConEx | |    |       |    |    |
                      | | ConEx | => |       | |    |       |    |    |
                      | |sender |    |monitor| | => |       | => |    |
                      | +-------+    +-------+ |    |       |    |    |
                      |         |    |         |    |       |    |    |
                      |_________|    |         |    |       |    |    |
 _________                           |         |    |       |    |    |
| ConEx-  |     ___                  |         |    |       |    |    |
|enabled  |    |   |                 | CORE    |    |ACCESS |    |HOME|
| CDN     |    |   |                 | NETWORK |    |NETWORK|    |NET |
|         |    | I |                 |         |    |       |    |    |
| +-------+    |   |                 |         |    |       |    |    |
| | Non-  |    | N |                 +-------+ |    |       |    |    |
| |trusted|    |   |                 | Non-  | |    |       |    |    |
| | ConEx | => |==>| ==============> | ConEx | | => |       | => |    |
| |sender |    |   |                 |policer| |    |       |    |    |
| +-------+    | T |                 +-------+ |    |       |    |    |
|_________|    |   |                 |         |    |       |    |    |
               | E |                 |         |    |       |    |    |
               |   |                 |         |    |       |    |    |
 _________     | R |                 |         |    |       |    |    |
|'legacy' |    |   |                 |         |    |       |    |    |
|         |    | N |                 |         |    |       |    |    |
| +-------+    |   |                 +-------+ |    +-----+ |    |    |
| | Non-  |    | E |                 | ConEx | |    |ConEx| |    |    |
| | ConEx | => |==>| ==============> |       | | => |     | | => |    |
| |sender |    |   |                 |policer| |    |audit| |    |    |
| +-------+    | T |                 +-------+ |    +-----+ |    |    |
|         |    |   |                 |         |    |       |    |    |
|_________|    |___|                 |         |    |       |    |    |
                                     |         |    |       |    |    |
                                     |_________|    |_______|    |____|

Philip Eardley   
Research and Technology Strategy

This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you. We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000