Subject: Re: [conex] Ben Campbell's Discuss on draft-ietf-conex-mobile-05: (with DISCUSS and COMMENT)

From: Martin Stiemerling <[email-masked]>
Date: Thu, 1 Oct 2015 11:14:54 +0200

Hi Ben,

Am 30.09.15 um 23:16 schrieb Ben Campbell:

>
>
> ----------------------------------------------------------------------
> DISCUSS:
> ----------------------------------------------------------------------
>
> The security considerations section seems substantially incomplete. The
> phrase "include, but are not limited to" seems to indicate that people
> thought there were additional considerations. Please write them down, or
> explain why there really aren't additional considerations.

A bit more text can help here, though a number of threats might be 
obvious by now or might depend on the "version" of the mobile network.

However, I let the authors to get more text and suggestions to you.

>
>
> ----------------------------------------------------------------------
> COMMENT:
> ----------------------------------------------------------------------
>
> There is an IPR declaration that lists this as an "associated draft". I'm
> not sure what to make of that, but it was not mentioned in the shepherd
> review.

The IPR you are mention (https://datatracker.ietf.org/ipr/1922/) is sort 
of a spread shot across all conex documents. The shepherd write-up 
should have mentioned it, indeed.

However, the WG did and does know about this IPR. Use this as anchor in 
the mail archive if you are looking for it:
https://mailarchive.ietf.org/arch/msg/conex/cDSGuMhPDwMPOZH8YJGdVEi0yuk

>
> This reads much like an advocacy white paper. There's useful information
> in it, but I would have preferred less of the marketing tone. But that's
> just me, and I don't expect that to change this late in the process.

ok, thanks.

   Martin

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 16 Oct 2015 11:11:58 +0000

Hi Ben,

thanks for the review.

In general, you are right -- there are additional security considerations that could be mentioned more explicitly. Most of them apply to ConEx in general, regardless of the deployment scenario.

I am not sure whether you were on  the attached e-mail thread discussing this in the context of the security directorate review.

We will add something along those lines to the security considerations sections (there are other nits that warrant another rev).

The mentioned IPR applies all ConEx documents, and the WG is aware of that.

Best regards,
Dirk

-----Original Message-----
From: Ben Campbell [mailto:[email-masked]] 
Sent: Mittwoch, 30. September 2015 23:16
To: The IESG
Cc: [email-masked]; [email-masked]; [email-masked]; Mirja Kuehlewind; [email-masked]
Subject: Ben Campbell's Discuss on draft-ietf-conex-mobile-05: (with DISCUSS and COMMENT)

Ben Campbell has entered the following ballot position for
draft-ietf-conex-mobile-05: Discuss

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-conex-mobile/

The security considerations section seems substantially incomplete. The phrase "include, but are not limited to" seems to indicate that people thought there were additional considerations. Please write them down, or explain why there really aren't additional considerations.

There is an IPR declaration that lists this as an "associated draft". I'm not sure what to make of that, but it was not mentioned in the shepherd review.

This reads much like an advocacy white paper. There's useful information in it, but I would have preferred less of the marketing tone. But that's just me, and I don't expect that to change this late in the process.

Subject: RE: secdir review of draft-ietf-conex-mobile-05
From: Dirk Kutscher <[email-masked]>
To: "Xialiang (Frank)" <[email-masked]>
Cc: secdir <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Fri, 11 Sep 2015 09:48:48 +0000

Hi Frank,

In general, the ConEx-related risks regarding manipulating congestion notification/exposure can apply to mobile networks, too.

What could perhaps be said is that mobile networks (UMTS, LTE) employ a virtual-circuit-like bearer model for the access, i.e., users in a cell can generally not see other users’ traffic – so that would rule out some threats. Also, authentication is part of the bearer establishment, so the network generally knows the user and device identity.

Now, assuming that mobile networks can be subject to passive monitoring, one could claim that this would enable attackers to collect information about a user’s congestion contribution (also over time), but that threat seems less critical (compared to exposing the payload itself).

Best regards,

Dirk

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Freitag, 11. September 2015 11:20
To: Dirk Kutscher
Cc: secdir; [email-masked]; [email-masked]
Subject: Re: secdir review of draft-ietf-conex-mobile-05

Hi Dirk,

Thank you for quick response.

I reviewed the drafts you mentioned below. I agree that they already discussed the general security issues I am concerned, especially in the draft-conex-abstract-mech-13 and its reference.

So, in general, my concerns are addressed. But I still have a little bit doubts about possibly new security issues for the use cases of using ConEx protocol over the mobile communication networks. I am not an expert in this area, can you clarify me?

Thanks!

B.R.

Frank

发件人: Dirk Kutscher [mailto:[email-masked]]
发送时间: 2015年9月11日 16:52
收件人: Xialiang (Frank); secdir; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
主题: RE: secdir review of draft-ietf-conex-mobile-05

Hi Frank,

thanks for the review.

The security issues you mentioned would apply to ConEx in general. The corresponding documents are discussing potential security issues:

https://tools.ietf.org/html/draft-ietf-conex-abstract-mech-13#page-24 (also see the references)

https://tools.ietf.org/html/draft-ietf-conex-destopt-09#page-10

https://tools.ietf.org/html/draft-ietf-conex-tcp-modifications-04#page-11

We’d therefore rather not duplicate that discussion in conex-mobile.

Regarding the security risks you mentioned, I’d say it is questionable whether ConEx introduces additional issues for confidentiality (compared to IP alone).

Thanks,

Dirk

From: Xialiang (Frank) [mailto:[email-masked]]
Sent: Freitag, 11. September 2015 02:49
To: secdir; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: secdir review of draft-ietf-conex-mobile-05

Hi,

I have reviewed this document as part of the security directorate's ongoing effort to review all IETF documents being processed by the IESG.  These comments were written primarily for the benefit of the security area directors.  Document editors and WG chairs should treat these comments just like any other last call comment.

This memo describes a mobile communications use case for congestion exposure (ConEx) with a particular focus on those mobile communication networks that are architecturally similar to the 3GPP Evolved Packet System (EPS).

I have the following comments:

l  1. It should be helpful to consider the communication security between the ConEx senders and receivers such as the Confidentiality, data integrity and peer entity authentication in the security considerations part. Because in general, the corresponding risks are still possible to exist.

l  2. The authentication mechanism among all the elements of ConEx solution should also be considered to handle the condition of faked messages or invalid peer elements.

Recommendation:  Ready With Issues

B.R.

Frank