Subject: [core] Unicast NON congestion control

From: "Angelo P. Castellani" <[email-masked]>
Date: Fri, 11 Mar 2011 12:55:09 +0100

Looking at Sec. 4.5 of coap-04, I can't find any explicit text about
limiting unicast NON messages to avoid congestion.

This seems relevant to me especially when CoAP servers send observe-01
notifications as NON and I have not found any text about congestion
control in observe-01.

Using aggregate congestion control defined in Sec. 3.2 of
congestion-control-01 seems a good starting point to me.

Best,
Angelo

---

From: Zach Shelby <[email-masked]>
Date: Fri, 11 Mar 2011 14:06:50 +0200

Hi Angelo,

> congestion-control-01 seems a good starting point to me.

That is exactly the intention, and congestion-control-01 is referenced in the document. However the WG decided (in Maastricht I think) not to introduce aggregate congestion control into the base document yet, as more work is needed to analyze this still. In other words, we need to roll up our sleeves and get some measurement/deployment results :-) 

Section 4.5 currently reads:

"4.5.  Congestion Control

   Basic congestion control for CoAP is provided by the exponential
   back-off mechanism in 
Section 4.1
.  Further congestion control
   optimizations are being considered and tested for CoAP
   [
I-D.eggert-core-congestion-control
].
"

Zach

> 
> Best,
> Angelo
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

-- 
Zach Shelby, Chief Nerd, Sensinode Ltd.
http://zachshelby.org  - My blog "On the Internet of Things"
http://6lowpan.net - My book "6LoWPAN: The Wireless Embedded Internet"
Mobile: +358 40 7796297

---

From: "Angelo P. Castellani" <[email-masked]>
Date: Fri, 11 Mar 2011 15:59:28 +0100

Probably an useful clarification to that section could be added saying
that some conservative policy to limit the output message rate is
currently needed, while an optimized aggregate congestion control is
being considered (congestion-control-01).

Best,
Angelo