Subject: [core] I-D Action:draft-ietf-core-block-02.txt

From: [email-masked]
Date: Mon, 14 Mar 2011 14:30:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Constrained RESTful Environments Working Group of the IETF.

	Title           : Blockwise transfers in CoAP
	Author(s)       : Z. Shelby, C. Bormann
	Filename        : draft-ietf-core-block-02.txt
	Pages           : 22
	Date            : 2011-03-14

CoAP is a RESTful transfer protocol for constrained nodes and
networks.  CoAP is based on datagram transport, which limits the
maximum size of resource representations that can be transferred
without too much fragmentation.  The Block option provides a minimal
way to transfer larger representations in a block-wise fashion.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-core-block-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Likepeng <[email-masked]>
Date: Fri, 18 Mar 2011 05:27:44 +0000

Thanks for the update to address my comments. I have one more comment to Block draft. See also Ticket #130.

I am not sure about the mapping of HTTP response code 408 with CoAP response code 4.08. In HTTP, 408 means "Request Timeout". In CoAP Block, 4.08 means "Request Entity Incomplete". From the text cited below, it seems that CoAP 4.08 should also be changed to "Request Timeout", instead of "Request Entity Incomplete". 

1. Cited from section 3.1: any HTTP 408 status code that indicates that the HTTP server became impatient with the resulting transfer can then be mapped into a CoAP 4.08 response code.

2. Cited from section 3.1: If the HTTP client is too slow delivering a request body on a PUT or POST, the CoAP server might time out and return a 4.08 response code, which in turn maps well to an HTTP 408 status code.

3. Cited from section 4: 4.08 Request Entity Incomplete.

Kepeng Li
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2011年3月15日 5:30
收件人: [email-masked]
抄送: [email-masked]
主题: [core] I-D Action:draft-ietf-core-block-02.txt

CoAP is a RESTful transfer protocol for constrained nodes and networks.  CoAP is based on datagram transport, which limits the maximum size of resource representations that can be transferred without too much fragmentation.  The Block option provides a minimal way to transfer larger representations in a block-wise fashion.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.

---

From: Likepeng <[email-masked]>
Date: Fri, 18 Mar 2011 08:26:07 +0000

Editorial comment: (See also Ticket #131)

In CoAP-05, 2.00 response code is removed, and changed to 2.05. But in the block draft examples, 2.00 is still used. It needs to be changed as well.

Kepeng Li