Subject: [core] retransmission timer in CoAP

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sat, 26 Mar 2011 17:36:16 +0100

During a discussion around CON/ACK, the method for computing the retransmission timers came up.

For information, ISA100.11a settled for following RFC 2988. The main discussion, in fact, is what the initial value should be.

The point is that in a large deployment, the latency can grow very high and if the default is small, that means that many devices have to be reconfigured.

OTOH, in a small deployment, a too large default can  more easily be fixed because that represents few devices.

I understand that this comes from experience, that the recommendation is to be conservative; and that a few seconds is in fact, very optimistic.

What do you think?

Pascal Thubert
IPv6 Engineering
Product Development
[email-masked] <mailto:[email-masked]> 
Phone: +33 4 9723 2634
Mobile: +33 6 1998 2985

Cisco Systems France
Village d'Entreprises Green Side
400 Avenue de Roumanille 
Batiment T 3 
06410 
BIOT - SOPHIA ANTIPOLIS
France
Cisco.com <http://www.cisco.com/global/FR/> 

 Think before you print.

Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc Michel Givone, For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html <http://www.cisco.com/web/about/doing_business/legal/cri/index.html>

---

From: "Noriyuki SATO" <[email-masked]>
Date: Thu, 31 Mar 2011 22:15:41 +0900

Hi,
I agree with Pascal. Thinking sleeping router to apply to core environment, timeout time should be larger as usual.
Some scalability mechanism like Jacobson (TCP's time out mechanism) will solve it. I agree with applying RFC2988 as Pascal indicated.

---
OKI Electric Industry Co., Ltd.
Noriyuki Sato ([email-masked])
Tel +81-6-6260-0700
Fax +81-6-6260-0770

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Pascal Thubert (pthubert)
> Sent: Sunday, March 27, 2011 1:36 AM
> To: core WG
> Subject: [core] retransmission timer in CoAP
> 
> For information, ISA100.11a settled for following RFC 2988. The main discussion,
> in fact, is what the initial value should be.
> 
> 
> 
> The point is that in a large deployment, the latency can grow very high and
> if the default is small, that means that many devices have to be reconfigured.
> 
> 
> 
> I understand that this comes from experience, that the recommendation is to
> be conservative; and that a few seconds is in fact, very optimistic.
> 
> 
> 
> What do you think?
> 
> 
> 
> 
> Pascal Thubert
> IPv6 Engineering
> Product Development
> Description: Think before you print.Think before you print.
> 
> Cisco Systems France, Société à responsabiité limitée, Rue Camille Desmoulins
> – Imm Atlantis Zac Forum Seine Ilot 7 92130 Issy les Moulineaux, Au capital
> de 91.470 €, 349 166 561 RCS Nanterre, Directeur de la publication: Jean-Luc
> Michel Givone, For corporate legal information go to:
> http://www.cisco.com/web/about/doing_business/legal/cri/index.html
> <http://www.cisco.com/web/about/doing_business/legal/cri/index.html>
> 
> 
> 
>