Subject: [core] #131: [Block] 2.00 Response Code

From: "core issue tracker" <[email-masked]>
Date: Fri, 18 Mar 2011 08:24:33 -0000

#131: [Block] 2.00 Response Code

 In CoAP-05, 2.00 response code is removed, and changed to 2.05. But in the
 block draft examples, 2.00 is still used. It needs to be changed as well.

 Kepeng Li

-- 
---------------------------------+------------------------------------------
 Reporter:  likepeng@…           |       Owner:     
     Type:  protocol defect      |      Status:  new
 Priority:  minor                |   Milestone:     
Component:  block                |     Version:     
 Severity:  -                    |    Keywords:     
---------------------------------+------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/131>
core <http://tools.ietf.org/core/>

---

From: "core issue tracker" <[email-masked]>
Date: Fri, 18 Mar 2011 09:05:25 -0000

Changes (by cabo@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Fixed in [278]:

 Fix #131 in block -03.
 Thanks Kepeng!

-- 
---------------------------------+------------------------------------------
 Reporter:  likepeng@…           |        Owner:        
     Type:  protocol defect      |       Status:  closed
 Priority:  minor                |    Milestone:        
Component:  block                |      Version:        
 Severity:  -                    |   Resolution:  fixed 
 Keywords:                       |  
---------------------------------+------------------------------------------

Ticket URL: </ticket/131#comment:1>
core <http://tools.ietf.org/core/>

---

From: Guido Moritz <[email-masked]>
Date: Fri, 18 Mar 2011 11:52:56 +0100

Sorry, but I have in mind that we agreed in the Webex to replace 2.00 for GET with a new code (i.e. 2.05), but to leave 2.00 as generic success response code for GET and POST? Am I wrong here? The reason was for example to allow a POST response to carry payload which does not fit in the existing response code semantics.

Guido

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] Im Auftrag von
> core issue tracker
> Gesendet: Freitag, 18. März 2011 09:25
> An: [email-masked]
> Cc: [email-masked]
> Betreff: [core] #131: [Block] 2.00 Response Code
> 
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 18 Mar 2011 12:32:56 +0100

> Sorry, but I have in mind that we agreed in the Webex to replace 2.00 for GET with a new code (i.e. 2.05), but to leave 2.00 as generic success response code for GET and POST? Am I wrong here? The…

Good point.  There is still an outstanding addition to the protocol to actually allow payloads with PUT/POST responses; with these, we would then define the appropriate response codes (see section 5.5). (2.00 is free right now because we were trying to have x.00 be the "generic" response codes, i.e. ones that a client implementation would use upon getting a response code it does not understand.  Is that the right code for "I have a body in this response for you"?  I think we also need to say what this body then represents.)
This addition also requires corresponding changes/additions to -block to allow blockwise transfer of these bodies, as you have pointed out.

Sorry, we didn't manage to do all of this in a consistent way in time for the Prague I-D deadline.
We probably can hijack this ticket to remind us of this outstanding addition.

Gruesse, Carsten

---

From: Guido Moritz <[email-masked]>
Date: Fri, 18 Mar 2011 14:34:23 +0100

> 2.00 is free right now
> because we were trying to have x.00 be the "generic" response codes, i.e.
> ones that a client implementation would use upon getting a response code
it
> does not understand.
A client can use response codes? This is new for me.

Is that the right code for "I have a body in this
> response for you"?  I think we also need to say what this body then
> represents.)
> Von: Carsten Bormann [mailto:[email-masked]]
> Gesendet: Freitag, 18. März 2011 12:33
> An: Guido Moritz
> Cc: 'core'
> Betreff: Re: [core] #131: [Block] 2.00 Response Code
> 
> > Sorry, but I have in mind that we agreed in the Webex to replace 2.00
for
> GET with a new code (i.e. 2.05), but to leave 2.00 as generic success
response
> code for GET and POST? Am I wrong here? The reason was for example to
> allow a POST response to carry payload which does not fit in the existing
> response code semantics.
> 
> Good point.  There is still an outstanding addition to the protocol to
actually
> allow payloads with PUT/POST responses; with these, we would then define
> the appropriate response codes (see section 5.5). (2.00 is free right now
> because we were trying to have x.00 be the "generic" response codes, i.e.
> ones that a client implementation would use upon getting a response code
it
> does not understand.  Is that the right code for "I have a body in this
> response for you"?  I think we also need to say what this body then
> represents.)
> This addition also requires corresponding changes/additions to -block to
> allow blockwise transfer of these bodies, as you have pointed out.
> 
> Sorry, we didn't manage to do all of this in a consistent way in time for
the
> Prague I-D deadline.

---

From: Guido Moritz <[email-masked]>
Date: Fri, 18 Mar 2011 14:36:41 +0100

Sorry, the first mail was sent out to fast.

it

> response for you"?  I think we also need to say what this body then
It would be OK for me to use 2.05 for this, but it has to be allowed to be
used by POST and not by GET exclusively.

> We probably can hijack this ticket to remind us of this outstanding
addition.
Having a ticket to keep this in mind would be great.

Guido

for
response
actually
it
the