Subject: Re: [core] #117: Block Response Code Mapping

From: "core issue tracker" <[email-masked]>
Date: Wed, 09 Mar 2011 20:09:56 -0000

#117: Block Response Code Mapping

Changes (by cabo@…):

  * owner:  => cabo@…
  * status:  new => assigned

Comment:

 There is some text in section 3.3 of draft-hartke-core-coap-http-00.txt --
 do we need anything beyond that?

-- 
---------------------------------+------------------------------------------
 Reporter:  likepeng@…           |       Owner:  cabo@…      
     Type:  protocol defect      |      Status:  assigned    
 Priority:  minor                |   Milestone:              
Component:  block                |     Version:              
 Severity:  Active WG Document   |    Keywords:              
---------------------------------+------------------------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/core/trac/ticket/117#comment:1>
core <http://tools.ietf.org/core/>

---

From: Likepeng <[email-masked]>
Date: Thu, 10 Mar 2011 01:16:14 +0000

My original proposal is to map 4.08 "Request Entity Incomplete" into a HTTP response code, like what we did in CoAP-04, for example, CoAP 4.13 "Request Entity too Large" is mapped to HTTP 413 " Request Entity too Large ".

But I checked the HTTP response code, 408 is " Request Timeout ". It is totally different from the meaning here. Maybe we should choose another response code other than 4.08, and add one sentence to say, there is no mapped response code in HTTP? 

I don't think section 3.3 in draft-hartke-core-coap-http-00.txt is relevant to my comment.

Thanks,
Kepeng 
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表 core issue tracker
发送时间: 2011年3月10日 4:10
收件人: [email-masked]
抄送: [email-masked]
主题: Re: [core] #117: Block Response Code Mapping

Changes (by cabo@…):

  * owner:  => cabo@…

Comment:

_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: "core issue tracker" <[email-masked]>
Date: Sat, 12 Mar 2011 20:47:18 -0000

Changes (by cabo@…):

  * status:  assigned => closed
  * resolution:  => fixed

Comment:

 (Additional subsection in block-02.)

-- 
---------------------------------+------------------------------------------
 Reporter:  likepeng@…           |        Owner:  cabo@…      
     Type:  protocol defect      |       Status:  closed      
 Priority:  minor                |    Milestone:              
Component:  block                |      Version:              
 Severity:  Active WG Document   |   Resolution:  fixed       
 Keywords:                       |  
---------------------------------+------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/117#comment:2>
core <http://tools.ietf.org/core/>