Subject: [core] Comments to draft-castellani-core-http-coap-mapping-01

From: Likepeng <[email-masked]>
Date: Wed, 30 Mar 2011 11:21:13 +0000

Hi Angelo and Salvatore,

I have reviewed the draft, and have the following comments:
(1) Section 2.2: It is not clear about the three proxy models: Forward Proxy, Reverse Proxy, Transparent. In the draft, there are definitions about these three models, but how to use it is not clearly defined. More detailed explanation will be helpful.
(2) Section 2.4.1: It is mentioned about lifetime for observation. In fact, lifetime was removed from Observe draft. So, this needs to be changed accordingly.
(3) In the draft, it is mentioned about the establishment of observation using HTTP/COAP Proxy. Maybe it is also helpful to add another section to explain how to use CoAP/HTTP proxy for Block wise transfers, for example, the use of Range header.
(4) This draft needs to be merged with draft-hartke-core-coap-http-00, and also some texts can be taken from CoAP-05.

Thanks,
Kind Regards
Kepeng

---

From: "Angelo P. Castellani" <[email-masked]>
Date: Wed, 30 Mar 2011 14:45:54 +0200

Thanks Kepeng for the comments.

Please consider that our draft was based upon coap-04 and
observe-01... Now needs some updates as you noted.

2011/3/30 Likepeng <[email-masked]>:
> (1) Section 2.2: It is not clear about the three proxy models: Forward
> Proxy, Reverse Proxy, Transparent. In the draft, there are definitions about
> these three models, but how to use it is not clearly defined. More detailed
> explanation will be helpful.

We were planning to do so, but we waited for some comments before
expanding that section and go over with more text.

> (2) Section 2.4.1: It is mentioned about lifetime for observation. In fact,
> lifetime was removed from Observe draft. So, this needs to be changed
> accordingly.

We plan to to do this in the next revision, as said before.

> (3) In the draft, it is mentioned about the establishment of observation
> using HTTP/COAP Proxy. Maybe it is also helpful to add another section to
> explain how to use CoAP/HTTP proxy for Block wise transfers, for example,
> the use of Range header.

Sure that is TBD and we will be probably merging with Klaus on this section.

> (4) This draft needs to be merged with draft-hartke-core-coap-http-00, and
> also some texts can be taken from CoAP-05.

Yes, as said.

Best,
Angelo