Subject: [core] Comments to draft-rahman-core-groupcomm-04

From: Likepeng <[email-masked]>
Date: Wed, 30 Mar 2011 11:53:39 +0000

Hi Akbar, and all,

I reviewed the group communication draft and have the following comments:

(1) Section 4, Application Group Management, the draft proposes to add two Options: Group Join and Group Leave to CoAP, but which method will be used? Post or Put?

(2) Section 6, Usually, we use CoAP to send request from proxy to CoAP node to retrieve something or update something, but this draft introduces another message direction, from CoAP node to proxy. How can the constrained CoAP node initiate the request?  Is the request indicated by a user?

(3) Section 3.1.5.2, it is mentioned about the MGET and MPUT. I am not sure why we need that. If requester wants to send multiple Get/Put for multiple reciepient, it can just send requests separately. We don't need to define other similar methods.

(4) Section 3.1.3, Group Discovery, this is a difficult part for constrained CoAP node to support. It will be easier for the proxy or group manager to discover the CoAP nodes, and add them to the group or remove them from the group.

(5) In general, I think the main task of group communication will be done by the HTTP/CoAP proxy. Group communication can be explained in the CoAP/HTTP mapping draft. It is not clear to me what should be standardized for group communication. It is better to leave this to HTTP/CoAP Proxy implementation to achieve.

Thanks,

Kind Regards

Kepeng

---

From: Kerry Lynn <[email-masked]>
Date: Wed, 30 Mar 2011 08:50:02 -0400

Comments inline...

2011/3/30 Likepeng <[email-masked]>

> (1) Section 4, Application Group Management, the draft proposes to add two
> Options: Group Join and Group Leave to CoAP, but which method will be used?
> Post or Put?
>
> (2) Section 6, Usually, we use CoAP to send request from proxy to CoAP
> node to retrieve something or update something, but this draft introduces
> another message direction, from CoAP node to proxy. How can the constrained
> CoAP node initiate the request?  Is the request indicated by a user?
>
> (3) Section 3.1.5.2, it is mentioned about the MGET and MPUT. I am not sure
> why we need that. If requester wants to send multiple Get/Put for multiple
> reciepient, it can just send requests separately. We don't need to define
> other similar methods.
>
MGET and MPUT are just mnemonics.  They stand for "GET request sent to a
multicast address"
and "PUT request sent to a multicast address", respectively.  We aren't
suggesting new methods.
This is in contrast to group comms that use serial unicasting.

> (4) Section 3.1.3, Group Discovery, this is a difficult part for
> constrained CoAP node to support. It will be easier for the proxy or group
> manager to discover the CoAP nodes, and add them to the group or remove them
> from the group.
>
Vendors should not be prevented from implementing DNS responders
on constrained devices if they choose to do so.  But a more likely
client for DNS-SD is a management console or more functional
device.  DNS-SD is proposed as a way to limit discovery traffic on
constrained data links in large installations.

> (5) In general, I think the main task of group communication will be done
> by the HTTP/CoAP proxy. Group communication can be explained in the
> CoAP/HTTP mapping draft. It is not clear to me what should be standardized
> for group communication. It is better to leave this to HTTP/CoAP Proxy
> implementation to achieve.
>
> No, this is simply one aspect of group comms.  We cannot predict, a priori,
how a capability will be used.  Only that it cannot be used if we don't
specify it.

Regards, -K-

>
>
> Thanks,
>
> Kind Regards
>
> Kepeng
>
>
>
>
>
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>
>