Subject: Re: [core] #107: Remove Max-Age from requests

From: "core issue tracker" <[email-masked]>
Date: Wed, 09 Mar 2011 12:23:34 -0000

#107: Remove Max-Age from requests

Changes (by hartke@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Done in coap-05.

-- 
----------------------------+-----------------------------------------------
 Reporter:  hartke@…        |        Owner:  hartke@…      
     Type:  task            |       Status:  closed        
 Priority:  minor           |    Milestone:                
Component:  coap            |      Version:                
 Severity:  -               |   Resolution:  fixed         
 Keywords:                  |  
----------------------------+-----------------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/core/trac/ticket/107#comment:1>
core <http://tools.ietf.org/core/>

---

From: "Angelo P. Castellani" <[email-masked]>
Date: Wed, 9 Mar 2011 14:51:23 +0100

On Mon, Mar 7, 2011 at 10:09, Matthieu VIAL
<[email-masked]> wrote:
> We could also resurrect the Max-Age option in a request to let a client
> control the maximum time between 2 notifications even if there is no
> change of state.

Is it possible with the current definition of Max-Age in coap-05?

Best,
Angelo

On Wed, Mar 9, 2011 at 13:23, core issue tracker
<[email-masked]> wrote:
> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

---

From: Klaus Hartke <[email-masked]>
Date: Wed, 9 Mar 2011 14:57:31 +0100

Angelo P. Castellani wrote:
> Matthieu VIAL wrote:

coap-05 now defines that Max-Age has no meaning in a request, i.e. a
client shouldn't include this option and a server must ignore it.

We can always define a meaning for Max-Age in requests in -observe, or
resurrect it in -coap if necessary.

But I'm not sure if we should couple Max-Age too tightly to
observation relationship maintenance.

Klaus