Subject: [core] CoMI draft

From: peter van der Stok <[email-masked]>
Date: Fri, 08 Nov 2013 19:44:03 +0100

> Dear CoRE wg,
> 
> Unfortunately I was unable to present our CoMI draft during the CoRE wg 
> meeting.
> Attached you will find the 3 slides and the draft.
> 
> Question to you: We propose 4 payload formats and want to reduce that 
> to one.
> Do you have a reasoned preference for either CBOR or EXI?
> 
> Our plans are to make a version-02 that incorporates the excellent
> comments by Juergen Schoenwalder.
> 
> In the next version-03 we want to address the security aspects and 
> compare what
> CoAP can deliver with the SNMPv3 security provisioning.
> 
> Looking forward to your reaction,
> 
> Peter + Bert
> 
> 

-- 
Peter van der Stok
vanderstok consultancy
mailto: [email-masked]
www: www.vanderstok.org
tel NL: +31(0)492474673     F: +33(0)966015248

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 12 Nov 2013 10:10:04 -0500

Hi Peter + Bert,

Thanks for the good draft.  One question.  In your slides, it said:

> Integrate SNMP + CoAP to reduce code complexity and stack size

Do you see that this integration as absolutely necessary.  Or can sometimes CoAP itself (i.e. without SNMP) provide an adequate interface?  As you know, for example, we provide an example of a CoAP method to configure Endpoint group addresses in

http://tools.ietf.org/html/draft-ietf-core-groupcomm-16#section-2.6.2

I am just trying to understand the implications of "Integrate SNMP + CoAP".

Thanks,

Akbar

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of peter van der Stok
Sent: Friday, November 08, 2013 1:44 PM
To: Core
Subject: [core] CoMI draft

> Dear CoRE wg,
> 
> Unfortunately I was unable to present our CoMI draft during the CoRE 
> wg meeting.
> compare what CoAP can deliver with the SNMPv3 security provisioning.
>

---

From: peter van der Stok <[email-masked]>
Date: Tue, 12 Nov 2013 16:23:20 +0100

Hi Akbar

thanks for the question.
Actually I meant integrating the functionality of CoAP and SNMP, and use 
the CoAP protocol to attain this integration.

Hope this is clearer.

Peter

Rahman, Akbar schreef op 2013-11-12 16:10:
> Do you see that this integration as absolutely necessary.  Or can
> sometimes CoAP itself (i.e. without SNMP) provide an adequate
> interface?  As you know, for example, we provide an example of a CoAP
> method to configure Endpoint group addresses in
>

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 12 Nov 2013 10:39:18 -0500

Stated another way, do you mean use CoAP to read/write MIBs?

-----Original Message-----
From: peter van der Stok [mailto:[email-masked]] 
Sent: Tuesday, November 12, 2013 10:23 AM
To: Rahman, Akbar
Cc: [email-masked]; Core
Subject: RE: [core] CoMI draft

Hi Akbar

thanks for the question.
Actually I meant integrating the functionality of CoAP and SNMP, and use the CoAP protocol to attain this integration.

Hope this is clearer.

Peter

---

From: Zach Shelby <[email-masked]>
Date: Tue, 12 Nov 2013 10:34:35 -0800

Akbar,

I think the point of Peter's draft is to enable access to MiBs purely using CoAP in a restful way. I think the CoMI draft is a good step in that direction as it allows access to MiBs as they are written now. Of course in parallel to that, if a device (like a border router or gateway e.g.) did support SNMP, the same MiBs could be accessible also via that.

Zach

On Nov 12, 2013, at 7:39 AM, "Rahman, Akbar" <[email-masked]> wrote:

> _______________________________________________
> core mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/core
>

Zach Shelby
Director of Technology
ARM Internet of Things BU
www.arm.com
mobile: +1 (408) 203-9434
Skype: zdshelby
LinkedIn: fi.linkedin.com/in/zachshelby/

-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium.  Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No:  2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No:  2548782

---

From: "Rahman, Akbar" <[email-masked]>
Date: Tue, 12 Nov 2013 15:34:56 -0500

Thanks, Zach.  Got it and +1.

-----Original Message-----
From: Zach Shelby [mailto:[email-masked]] 
Sent: Tuesday, November 12, 2013 1:35 PM
To: Rahman, Akbar
Cc: [email-masked]; Core
Subject: Re: [core] CoMI draft

Akbar,

I think the point of Peter's draft is to enable access to MiBs purely
using CoAP in a restful way. I think the CoMI draft is a good step in
that direction as it allows access to MiBs as they are written now. Of
course in parallel to that, if a device (like a border router or gateway
e.g.) did support SNMP, the same MiBs could be accessible also via that.

Zach

On Nov 12, 2013, at 7:39 AM, "Rahman, Akbar"
<[email-masked]> wrote:

> Actually I meant integrating the functionality of CoAP and SNMP, and
use the CoAP protocol to attain this integration.

>>> Question to you: We propose 4 payload formats and want to reduce 
>>> that to one.

Zach Shelby
Director of Technology

-- IMPORTANT NOTICE: The contents of this email and any attachments are
confidential and may also be privileged. If you are not the intended
recipient, please notify the sender immediately and do not disclose the
contents to any other person, use it for any purpose, or store or copy
the information in any medium.  Thank you.

ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ,
Registered in England & Wales, Company No:  2557590 ARM Holdings plc,
Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in
England & Wales, Company No:  2548782

---

From: peter van der Stok <[email-masked]>
Date: Wed, 13 Nov 2013 10:15:06 +0100

Let me confirm the correctness of Zach's description

Peter