Subject: [core] WG interest in Sleepy Node topic

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 7 Nov 2013 21:36:32 -0500

Hi All,

Once again we ran out of time on the agenda to discuss the WG interest
on the topic of Sleepy Nodes

http://www.ietf.org/id/draft-rahman-core-sleepy-nodes-do-we-need-00.txt

However, Carsten did suggest that we carry the discussion that we would
have had in the meeting forward to the WG list.  The key questions that
we need WG feedback on are:

1.       Does the WG want to keep discussing Sleepy Nodes in CORE?  The
Sleepy Node support could be in:

a.       CoAP Protocol

b.      CORE Link Format

c.       CORE Resource Directory

d.      Etc.

2.       Sub-Question:

a.       Does the WG want to see some immediate development of the
Mirror Server concept (which seems to have near unanimous support and is
well correlated to Sleepy Node support)?

Any and all comments are appreciated!  Please write back even if you
answered earlier Emails on this topic as we need to gauge WG interest.

Thanks,

Akbar

---

From: "weigengyu" <[email-masked]>
Date: Fri, 8 Nov 2013 16:01:43 +0800

Hi，Akbar，

I believe that sleepy node will affects the CoAP performance and functionalities when CoAP runs in smart phone. 
Smart phones of IOS’s, Android and WP have sleep mode, 
and that affects the existing mobile internet applications and mobile networks.

Samrt phones are ever used as SINK in sensor network, as a hub for merging data and processing, 
and as a proxy for accessing the Internet through Gprs, 3G or 4G in M2M networks. 

Smart phone plays a very important role in the applicatoins, the same as CoRE applications, that were developed two or three years ago. 
The typical cenario is that sensors send data to smart phone(s) and then the smart phone, as a proxy, delivers data to the service center in the Internet.
When the smart phone falls into sleep mode,  communications are affected apparently. 
Whereas PADs, notebooks are considered to replace the smart phone, as you know, all these mobile quipements have the sleep mode for sustaining a longer battery life.  

So, in CoRE like enviroments, we need to take care of sleep node.  

regards, 

Gengyu 

Network Technology Center
School of Computer
Beijing University of Posts & Telecommunications

From: Rahman, Akbar 
Sent: Friday, November 08, 2013 10:36 AM
To: Core 
Subject: [core] WG interest in Sleepy Node topic

Hi All,

Once again we ran out of time on the agenda to discuss the WG interest on the topic of Sleepy Nodes

 

However, Carsten did suggest that we carry the discussion that we would have had in the meeting forward to the WG list.  The key questions that we need WG feedback on are:

1.       Does the WG want to keep discussing Sleepy Nodes in CORE?  The Sleepy Node support could be in:

a.       CoAP Protocol

b.      CORE Link Format

d.      Etc.

2.       Sub-Question:

a.       Does the WG want to see some immediate development of the Mirror Server concept (which seems to have near unanimous support and is well correlated to Sleepy Node support)?

Any and all comments are appreciated!  Please write back even if you answered earlier Emails on this topic as we need to gauge WG interest.

Thanks,

Akbar

--------------------------------------------------------------------------------
_______________________________________________
core mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/core

---

From: Thomas Fossati <[email-masked]>
Date: Fri, 8 Nov 2013 09:48:14 +0000

Hi Akbar,

> the topic of Sleepy Nodes

yes, I'm sorry about that.

> However, Carsten did suggest that we carry the discussion that we would have
> had in the meeting forward to the WG list.  The key questions that we need
> WG feedback on are:
>

IMHO if we want to safely stay within the CoRE scope, we should keep
sleepy/intermittent handling at the CoAP protocol and Link Format
level (with RD used as a backup/complement to base Link Format
discovery).  So, to me this should be a.+b. with optional c.
And this is completely possible -- as documented in the Publish I-D.

> 2.       Sub-Question:
>
> a.       Does the WG want to see some immediate development of the Mirror
> Server concept (which seems to have near unanimous support and is well
> correlated to Sleepy Node support)?

No, for two reasons:
1) before adopting any solution I think we should look at the
different proposals on the table (there are quite a few) and be able
to match them against real use cases so to decide what is the best fit
for the case (or even better, for a non-trivial subset of cases);
2) I think Mirror belongs to the layer just above CoAP and L-F, and so
possibly out of CoRE scope.

Cheers (and thanks again for keeping the discussion alive).

---

From: "Dijk, Esko" <[email-masked]>
Date: Fri, 8 Nov 2013 15:36:45 +0000

> 1. Does the WG want to keep discussing Sleepy Nodes in CORE?
Yes, let's continue to use the mailing list and CoRE I-Ds for this.

> 2. Does the WG want to see some immediate development of the Mirror Server concept
First thing to do is check how well it satisfies the requirements, compared to other methods. For that, we need requirements. For the requirements, we need use cases! See http://tools.ietf.org/html/draft-dijk-core-sleepy-reqs-00#section-3 for an initial set of building control use cases.

I'm open to receive any other use cases; we could publish these on the mailing list and collect them from there.

Esko

From: [email-masked] [mailto:[email-masked]] On Behalf Of Rahman, Akbar
Sent: Friday, November 08, 2013 03:37
To: Core
Subject: [core] WG interest in Sleepy Node topic

Hi All,

a.       CoAP Protocol

b.      CORE Link Format

d.      Etc.

2.       Sub-Question:

Thanks,

Akbar

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.

---

From: Abhijan Bhattacharyya <[email-masked]>
Date: Sat, 9 Nov 2013 02:30:32 +0530

Hi Akbar,
Its a yes from my side in favour of supporting sleepy nodes in CoRE.
One of the many reasons why we have started advocating for CoAP to our customers, compared to any other competing technologies, is the assumption that support for sleepy nodes is very much there in CoAP's road map. If we deviate then probably CoAP will lose an edge as there are competing solutions which already incorporate support for sleepy-node-state-machine at the application layer.
Another point I would like to make is: The probable intention behind confining the sleep-management considerations within the Layer-2, etc.  is probably to make the application more agnostic about the lower-part of the stack. In an ideal world we would like to do that. But when we are in the constrained world of IoT/M2M (or whatever you call it) probably we cannot have that much liberty.   

The mirror server may not always be a practicable solution. We need other proposals.

Regards
Abhijan Bhattacharyya
Associate Consultant
Scientist, Innovation Lab, Kolkata, India
Tata Consultancy Services Limited
Mailto: [email-masked]
Website: http://www.tcs.com
____________________________________________
Experience certainty.	IT Services
Business Solutions
Consulting
____________________________________________

From: Rahman, Akbar <[email-masked]>
Date: Fri, Nov 8, 2013 at 8:06 AM
Subject: [core] WG interest in Sleepy Node topic
To: Core <[email-masked]>

Hi All,

 

a.       CoAP Protocol

b.      CORE Link Format

d.      Etc.

2.       Sub-Question:

 

 

Thanks,

Akbar

=====-----=====-----=====
Notice: The information contained in this e-mail
message and/or attachments to it may contain 
confidential or privileged information. If you are 
not the intended recipient, any dissemination, use, 
review, distribution, printing or copying of the 
information contained in this e-mail message 
and/or attachments to it are strictly prohibited. If 
you have received this communication in error, 
please notify us by reply e-mail or telephone and 
immediately and permanently delete the message 
and any attachments. Thank you

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 8 Nov 2013 17:25:47 -0800

On 08 Nov 2013, at 01:48, Thomas Fossati <[email-masked]> wrote:

> out of CoRE scope

At this stage of the discussion, I would be less concerned with the WG scope than with finding out what the industry actually needs to be standardized to foster interoperability.  If there are items within this set that are outside CoRE scope, we can always try to find a home for them, either by rechartering or by finding another WG.  But it is important to have a clear understanding of the items that we think need to be speced.  At a level a bit more specific than we have been discussing so far.

Grüße, Carsten