Subject: [core] Final comment from Thomas on groupcomm-17

From: "Rahman, Akbar" <[email-masked]>
Date: Wed, 18 Dec 2013 12:32:39 -0500

I'm resending this with a different title as I was told that my excessive capitalization in my previous Emails had caused problems with the mailing list servers.

-----Original Message-----
From: Rahman, Akbar 
Sent: Wednesday, December 18, 2013 12:25 PM
To: 'FOSSATI, Thomas (Thomas)'
Cc: [email-masked]; Dijk, Esko
Subject: RE: [core] WGLC comments for draft-ietf-core-groupcomm-17

Hi Thomas,

Thanks for the feedback.  So I think we have come to an agreement on all your items except for:

>>Section 2.10
>>
>>- shameless plug: the "Multipart Content-Format Encoding for CoAP" I-D 
>>could provide the aggregation format needed ;-)

>Multipart is recursive, so you could have an inner multipart which aggregates the per-response attributes (i.e. identifier/locator of the sender, CoAP payload), and an outer multipart providing the >list/set that gathers all the responses together.

Our proposal is that we can change the following in our Section 2.10 (Proxy Operation).  This would be similar to our Section 5.3.3 (Security Future Evolution).

FROM:
     "There is no default format defined in CoAP for aggregation of
      multiple responses into a single response."

TO:

     "There is no default format yet adopted in CoAP for aggregation of
      multiple responses into a single response.  However, some proposals are being considered such as fossati-core-multipar-ct."

Please tell us if you have any further comments.

/Akbar & Esko

---

From: "FOSSATI, Thomas (Thomas)" <[email-masked]>
Date: Wed, 18 Dec 2013 17:45:25 +0000

Hi Akbar,

On 18/12/2013 17:32, "Rahman, Akbar" <[email-masked]> wrote:
>Thanks for the feedback.  So I think we have come to an agreement on all
>your items

Yes, I think so.
I have stepped back from the "response suppression indicators in the API”
argument as I think it is something that we don’t need to have
immediately, and requires a bit more thinking and talking.

>except for:
>>Multipart is recursive, so you could have an inner multipart which
>>aggregates the per-response attributes (i.e. identifier/locator of the
>>sender, CoAP payload), and an outer multipart providing the >list/set
>>that gathers all the responses together.
>
>
>Our proposal is that we can change the following in our Section 2.10
>(Proxy Operation).  This would be similar to our Section 5.3.3 (Security
>Future Evolution).
>
>
>FROM:
>      multiple responses into a single response.  However, some proposals
>are being considered such as fossati-core-multipar-ct."

Excellent.

>Please tell us if you have any further comments.

Thanks again to you & Esko for the nice document and prompt feedback.

Cheers, Thomas.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 19 Dec 2013 07:25:15 +0100

On 18 Dec 2013, at 18:32, Rahman, Akbar <[email-masked]> wrote:

> such as fossati-core-multipar-ct

I'm not sure we are ready to propose one specific format for response
sets.  Just to demonstrate the potential variety, I have added another
proposal for a response set format to draft-bormann-coap-misc (section 4).

Grüße, Carsten

---

From: "Rahman, Akbar" <[email-masked]>
Date: Thu, 19 Dec 2013 10:37:52 -0500

Okay, I guess you are saying that we should have an adopted WG draft on the topic of aggregation format (as we now have more than 1 proposal) before we reference it.  That makes sense to me.

Best Regards,

Akbar

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Thursday, December 19, 2013 1:25 AM
To: Rahman, Akbar
Cc: FOSSATI, Thomas (Thomas); core ([email-masked])
Subject: Re: [core] Final comment from Thomas on groupcomm-17

> such as fossati-core-multipar-ct

I'm not sure we are ready to propose one specific format for response sets.  Just to demonstrate the potential variety, I have added another proposal for a response set format to draft-bormann-coap-misc (section 4).

Grüße, Carsten